rebuilt with ldc 1.31.0 [release 0.9.0-2mamba;Mon Mar 13 2023]
This commit is contained in:
parent
2e9b196434
commit
120d6ebc00
45
appstream-generator-0.9.0-undeaD-xml.patch
Normal file
45
appstream-generator-0.9.0-undeaD-xml.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
diff --git a/src/asgen/backends/rpmmd/rpmpkgindex.d b/src/asgen/backends/rpmmd/rpmpkgindex.d
|
||||||
|
index f336919..733e8f1 100644
|
||||||
|
--- a/src/asgen/backends/rpmmd/rpmpkgindex.d
|
||||||
|
+++ b/src/asgen/backends/rpmmd/rpmpkgindex.d
|
||||||
|
@@ -25,7 +25,7 @@ import std.array : appender, empty;
|
||||||
|
import std.string : format;
|
||||||
|
import std.algorithm : canFind, endsWith;
|
||||||
|
import std.conv : to;
|
||||||
|
-import std.xml;
|
||||||
|
+import undead.xml;
|
||||||
|
static import std.file;
|
||||||
|
|
||||||
|
import asgen.logging;
|
||||||
|
diff --git a/src/asgen/meson.build b/src/asgen/meson.build
|
||||||
|
index be49dba..d8a5b46 100644
|
||||||
|
--- a/src/asgen/meson.build
|
||||||
|
+++ b/src/asgen/meson.build
|
||||||
|
@@ -64,6 +64,7 @@ backend_sources = [
|
||||||
|
'backends/ubuntu/ubupkg.d',
|
||||||
|
'backends/ubuntu/ubupkgindex.d',
|
||||||
|
|
||||||
|
+ '../../undeaD-1.1.8/src/undead/xml.d',
|
||||||
|
'backends/rpmmd/package.d',
|
||||||
|
'backends/rpmmd/rpmpkg.d',
|
||||||
|
'backends/rpmmd/rpmpkgindex.d',
|
||||||
|
@@ -76,7 +77,8 @@ asgen_exe = executable('appstream-generator',
|
||||||
|
[asgen_sources,
|
||||||
|
backend_sources],
|
||||||
|
include_directories: [src_dir,
|
||||||
|
- gir_bind_dir],
|
||||||
|
+ gir_bind_dir,
|
||||||
|
+ '../../undeaD-1.1.8/src'],
|
||||||
|
dependencies: [glibd_dep,
|
||||||
|
appstream_dep,
|
||||||
|
ascompose_dep,
|
||||||
|
@@ -92,7 +94,8 @@ asgen_test_exe = executable('asgen_test',
|
||||||
|
[asgen_sources,
|
||||||
|
backend_sources],
|
||||||
|
include_directories: [src_dir,
|
||||||
|
- gir_bind_dir],
|
||||||
|
+ gir_bind_dir,
|
||||||
|
+ '../../undeaD-1.1.8/src'],
|
||||||
|
dependencies: [glibd_dep,
|
||||||
|
appstream_dep,
|
||||||
|
ascompose_dep,
|
@ -1,6 +1,6 @@
|
|||||||
Name: appstream-generator
|
Name: appstream-generator
|
||||||
Version: 0.9.0
|
Version: 0.9.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A fast AppStream metadata generator
|
Summary: A fast AppStream metadata generator
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,6 +8,8 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://github.com/ximion/appstream-generator
|
URL: https://github.com/ximion/appstream-generator
|
||||||
Source: https://github.com/ximion/appstream-generator.git/v%{version}/appstream-generator-%{version}.tar.bz2
|
Source: https://github.com/ximion/appstream-generator.git/v%{version}/appstream-generator-%{version}.tar.bz2
|
||||||
|
Source1: https://github.com/dlang/undeaD/archive/refs/tags/v1.1.8.tar.gz
|
||||||
|
Patch0: appstream-generator-0.9.0-undeaD-xml.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -22,7 +24,7 @@ BuildRequires: libldc-devel
|
|||||||
BuildRequires: liblmdb-devel
|
BuildRequires: liblmdb-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
BuildRequires: libldc-devel >= 1.29.0
|
BuildRequires: libldc-devel >= 1.31.0
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A fast AppStream metadata generator.
|
A fast AppStream metadata generator.
|
||||||
@ -30,7 +32,8 @@ A fast AppStream metadata generator.
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -a1
|
||||||
|
%patch0 -p1 -b .undeaD-xml
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson
|
%meson
|
||||||
@ -60,6 +63,9 @@ A fast AppStream metadata generator.
|
|||||||
%doc LICENSE
|
%doc LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 13 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0-2mamba
|
||||||
|
- rebuilt with ldc 1.31.0
|
||||||
|
|
||||||
* Sat Jan 28 2023 Automatic Build System <autodist@mambasoft.it> 0.9.0-1mamba
|
* Sat Jan 28 2023 Automatic Build System <autodist@mambasoft.it> 0.9.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user