try to fix icons by restoring default installation paths inernal to application dir [release 0.9.2-3mamba;Thu Aug 20 2015]
This commit is contained in:
parent
3dbc528bbe
commit
ad8e3d2fac
42
apper-0.9.1-no-popup-for-background-actions.patch
Normal file
42
apper-0.9.1-no-popup-for-background-actions.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From: Stephan Kulow <coolo@suse.de>
|
||||
Subject: Avoid popup message boxes for locked or masked PK
|
||||
|
||||
Index: apper-0.9.1/libapper/PkTransaction.cpp
|
||||
===================================================================
|
||||
--- apper-0.9.1.orig/libapper/PkTransaction.cpp
|
||||
+++ apper-0.9.1/libapper/PkTransaction.cpp
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <KService>
|
||||
#include <KPixmapSequence>
|
||||
#include <KPixmapSequenceOverlayPainter>
|
||||
+#include <KNotification>
|
||||
|
||||
#include <KDebug>
|
||||
|
||||
@@ -765,11 +766,26 @@ void PkTransaction::showSorry(const QStr
|
||||
{
|
||||
PkTransactionWidget *widget = qobject_cast<PkTransactionWidget *>(d->parentWindow);
|
||||
if (!widget || widget->isCancelVisible()) {
|
||||
+ // for background jobs like getupdates (triggered by a timer) we don't want a popup
|
||||
+ if (role() == Transaction::RoleGetUpdates) {
|
||||
+ KNotification *notify;
|
||||
+ notify = new KNotification("TransactionMessage", 0, KNotification::Persistent);
|
||||
+ notify->setComponentData(KComponentData("apperd"));
|
||||
+ notify->setTitle(title);
|
||||
+ if (details.isEmpty())
|
||||
+ notify->setText(description);
|
||||
+ else
|
||||
+ notify->setText(details);
|
||||
+
|
||||
+ notify->setPixmap(KIcon("dialog-warning").pixmap(KPK_ICON_SIZE, KPK_ICON_SIZE));
|
||||
+ notify->sendEvent();
|
||||
+ } else {
|
||||
if (details.isEmpty()) {
|
||||
KMessageBox::sorry(d->parentWindow, description, title);
|
||||
} else {
|
||||
KMessageBox::detailedSorry(d->parentWindow, description, details, title);
|
||||
}
|
||||
+ }
|
||||
} else {
|
||||
emit sorry(title, description, details);
|
||||
}
|
42
apper.spec
42
apper.spec
@ -1,7 +1,7 @@
|
||||
Name: apper
|
||||
Epoch: 1
|
||||
Version: 0.8.2
|
||||
Release: 1mamba
|
||||
Version: 0.9.2
|
||||
Release: 3mamba
|
||||
Summary: A KDE interface and plasmoid for PackageKit
|
||||
Group: Graphical Desktop/Applications/Administration
|
||||
Vendor: openmamba
|
||||
@ -12,6 +12,7 @@ Source: http://download.kde.org/stable/apper/%{version}/src/apper-%{versi
|
||||
Source1: 01-fedora-org.packagekit.updater.js
|
||||
Source2: apper-0.8.0-translations.tar.xz
|
||||
Patch0: apper-0.8.1-plasmoid-fix-icons.patch
|
||||
Patch1: apper-0.9.1-no-popup-for-background-actions.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -19,7 +20,7 @@ BuildRequires: kde-workspace-devel
|
||||
BuildRequires: kdelibs-devel
|
||||
BuildRequires: libQtDeclarative
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libpackagekit-qt2-devel
|
||||
BuildRequires: libpackagekitqt4-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
@ -39,6 +40,11 @@ Apper (aka KPackageKit) is the KDE interface for PackageKit.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
#rm -f plasmoid/package/contents/ui/main.qml.orig
|
||||
|
||||
#-a2
|
||||
#%patch0 -p1
|
||||
|
||||
@ -65,14 +71,14 @@ mv %{buildroot}%{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service \
|
||||
mv %{buildroot}%{_kde4_libdir}/apper/libapper.so %{buildroot}%{_kde4_libdir}/libapper.so
|
||||
rmdir %{buildroot}%{_kde4_libdir}/apper
|
||||
|
||||
# fwik icons are not seached for under /animations
|
||||
mv %{buildroot}%{_kde4_datadir}/apper/icons/hicolor/48x48/animations/*.png \
|
||||
%{buildroot}%{_kde4_datadir}/apper/icons/hicolor/48x48/actions/
|
||||
## fwik icons are not seached for under /animations
|
||||
#mv %{buildroot}%{_kde4_datadir}/apper/icons/hicolor/48x48/animations/*.png \
|
||||
# %{buildroot}%{_kde4_datadir}/apper/icons/hicolor/48x48/actions/
|
||||
|
||||
# install icons in system hicolor directory
|
||||
install -d -m0755 %{buildroot}%{_kde4_icondir}
|
||||
mv %{buildroot}%{_kde4_datadir}/apper/icons/hicolor \
|
||||
%{buildroot}%{_kde4_icondir}/hicolor
|
||||
## install icons in system hicolor directory
|
||||
#install -d -m0755 %{buildroot}%{_kde4_icondir}
|
||||
#mv %{buildroot}%{_kde4_datadir}/apper/icons/hicolor \
|
||||
# %{buildroot}%{_kde4_icondir}/hicolor
|
||||
|
||||
ln -s apper %{buildroot}%{_kde4_bindir}/kpackagekit
|
||||
|
||||
@ -137,9 +143,10 @@ exit 0
|
||||
%{_kde4_sharedir}/appdata/apper.appdata.xml
|
||||
%{_kde4_datadir}/plasma-desktop/updates/01-packagekit.updater.js
|
||||
%{_kde4_datadir}/apperd/apperd.notifyrc
|
||||
%{_kde4_icondir}/hicolor/*
|
||||
#%{_kde4_datadir}/apper/icons/hicolor/*/actions/*.png
|
||||
#%{_kde4_datadir}/apper/icons/hicolor/*/categories/*.png
|
||||
#%{_kde4_icondir}/hicolor/*
|
||||
%{_kde4_datadir}/apper/icons/hicolor/*/actions/*.png
|
||||
%{_kde4_datadir}/apper/icons/hicolor/*/animations/*.png
|
||||
%{_kde4_datadir}/apper/icons/hicolor/*/categories/*.png
|
||||
%dir %{_kde4_datadir}/plasma/plasmoids/org.packagekit.updater
|
||||
%dir %{_kde4_datadir}/plasma/plasmoids/org.packagekit.updater/contents
|
||||
%dir %{_kde4_datadir}/plasma/plasmoids/org.packagekit.updater/contents/ui
|
||||
@ -154,6 +161,15 @@ exit 0
|
||||
# TODO
|
||||
|
||||
%changelog
|
||||
* Thu Aug 20 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.2-3mamba
|
||||
- try to fix icons by restoring default installation paths inernal to application dir
|
||||
|
||||
* Sun Aug 16 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.2-2mamba
|
||||
- remove not working icons patch
|
||||
|
||||
* Fri Aug 14 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.2-1mamba
|
||||
- update to 0.9.2
|
||||
|
||||
* Thu Oct 16 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.2-1mamba
|
||||
- update to 0.8.2
|
||||
|
||||
|
Reference in New Issue
Block a user