238 lines
6.7 KiB
RPMSpec
238 lines
6.7 KiB
RPMSpec
Name: apparmor
|
|
Version: 4.0.3
|
|
Release: 1mamba
|
|
Summary: Mandatory Access Control (MAC) using Linux Security Module (LSM)
|
|
Group: System/Kernel and Hardware
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://gitlab.com/apparmor/apparmor
|
|
Source: https://gitlab.com/apparmor/apparmor/-/archive/v%{version}/apparmor-v%{version}.tar.bz2
|
|
License: GPL, LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libpam-devel
|
|
BuildRequires: libperl
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: libruby-devel
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description
|
|
Mandatory Access Control (MAC) using Linux Security Module (LSM).
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%package -n ruby-%{name}
|
|
Group: System/Libraries/Ruby
|
|
Summary: Ruby binding to %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n ruby-%{name}
|
|
This package contains the ruby binding to %{name}.
|
|
|
|
%package -n perl-%{name}
|
|
Group: System/Libraries/Perl
|
|
Summary: Perl binding to %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n perl-%{name}
|
|
This package contains the perl binding to %{name}.
|
|
|
|
%package -n python-%{name}-py3
|
|
Group: System/Libraries/Python
|
|
Summary: Python binding to %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n python-%{name}-py3
|
|
This package contains the python binding to %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n %{name}-v%{version}
|
|
#-D -T
|
|
#:<< __EOF
|
|
cd libraries/libapparmor
|
|
autoreconf -fi
|
|
|
|
%build
|
|
#:<< __EOF
|
|
cd libraries/libapparmor
|
|
|
|
%configure \
|
|
--with-perl \
|
|
--with-python \
|
|
--with-ruby
|
|
|
|
%make
|
|
|
|
cd ../..
|
|
|
|
make -C binutils
|
|
make -C parser
|
|
make -C profiles
|
|
make -C utils
|
|
make -C changehat/pam_apparmor SECDIR=%{_libdir}/security
|
|
make -C changehat/mod_apparmor
|
|
make -C utils/vim
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
install -d -m0755 %{buildroot}%{ruby_sitearch}
|
|
%makeinstall -C libraries/libapparmor
|
|
%makeinstall -C changehat/pam_apparmor \
|
|
SECDIR=%{buildroot}%{_libdir}/security
|
|
%makeinstall -C changehat/mod_apparmor
|
|
%makeinstall -C binutils SBINDIR=%{buildroot}%{_sbindir} \
|
|
USR_SBINDIR=%{buildroot}%{_bindir}
|
|
%makeinstall install-systemd -C parser \
|
|
SBINDIR=%{buildroot}%{_sbindir} USR_SBINDIR=%{buildroot}%{_bindir} \
|
|
APPARMOR_BIN_PREFIX=%{buildroot}%{_prefix}/lib/apparmor
|
|
%makeinstall -C profiles
|
|
%makeinstall -C utils SBINDIR=%{buildroot}%{_sbindir} \
|
|
BINDIR=%{buildroot}%{_bindir} \
|
|
VIM_INSTALL_PATH=%{buildroot}%{_datadir}/vim/vimfiles/syntax
|
|
|
|
rm -f %{buildroot}%{perl_archlib}/perllocal.pod
|
|
|
|
%find_lang %{name} --all-name || touch %{name}.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%preun
|
|
%systemd_preun %{name}
|
|
:
|
|
|
|
%post
|
|
%systemd_post %{name}
|
|
:
|
|
|
|
%postun
|
|
%systemd_postun %{name}
|
|
:
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%dir %{_sysconfdir}/apparmor
|
|
%config(noreplace) %{_sysconfdir}/apparmor/*.conf
|
|
%{_sysconfdir}/apparmor/severity.db
|
|
%dir %{_prefix}/lib/apparmor
|
|
%{_prefix}/lib/apparmor/*
|
|
%dir %{_sysconfdir}/apparmor.d
|
|
%{_sysconfdir}/apparmor.d/*
|
|
%{_sbindir}/apparmor_parser
|
|
#%{_sbindir}/rcapparmor
|
|
%{_bindir}/aa-*
|
|
%{_sbindir}/aa-*
|
|
%{_sbindir}/apparmor_status
|
|
%{_unitdir}/apparmor.service
|
|
%dir %{_datadir}/apparmor
|
|
%{_datadir}/apparmor/*
|
|
%{_datadir}/vim/vimfiles/syntax/apparmor.vim
|
|
%{_mandir}/man1/aa-*.1*
|
|
%{_mandir}/man2/aa_*.2*
|
|
%{_mandir}/man5/apparmor*.5*
|
|
%{_mandir}/man5/logprof.conf.5*
|
|
%{_mandir}/man7/apparmor*.7*
|
|
%{_mandir}/man8/aa-*.8*
|
|
%{_mandir}/man8/apparmor_*.8*
|
|
%{_mandir}/man8/mod_apparmor.8*
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libapparmor.so.*
|
|
%{_libdir}/security/pam_apparmor.so
|
|
%doc LICENSE
|
|
|
|
%files -n ruby-%{name}
|
|
%defattr(-,root,root)
|
|
%{ruby_sitearch}/LibAppArmor.so
|
|
|
|
%files -n perl-%{name}
|
|
%defattr(-,root,root)
|
|
%{perl_vendorarch}/*
|
|
|
|
%files -n python-%{name}-py3
|
|
%defattr(-,root,root)
|
|
%dir %{python3_sitelib}/apparmor-%{version}-py*.egg-info
|
|
%{python3_sitelib}/apparmor-%{version}-py*.egg-info/*
|
|
%dir %{python3_sitearch}/LibAppArmor-%{version}-py*.egg-info
|
|
%{python3_sitearch}/LibAppArmor-%{version}-py*.egg-info/*
|
|
%dir %{python3_sitearch}/LibAppArmor
|
|
%{python3_sitearch}/LibAppArmor/*
|
|
%dir %{python3_sitelib}/apparmor
|
|
%{python3_sitelib}/apparmor/*
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%{_includedir}/aalogparse/aalogparse.h
|
|
%{_includedir}/sys/apparmor.h
|
|
%{_includedir}/sys/apparmor_private.h
|
|
%{_libdir}/apache/mod_apparmor.so
|
|
%{_libdir}/libapparmor.a
|
|
%{_libdir}/libapparmor.so
|
|
%{_libdir}/pkgconfig/libapparmor.pc
|
|
%{_mandir}/man3/aa_*.3*
|
|
%doc README.md
|
|
|
|
%changelog
|
|
* Sun Aug 18 2024 Automatic Build System <autodist@openmamba.org> 4.0.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 31 2024 Automatic Build System <autodist@openmamba.org> 4.0.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jun 04 2024 Automatic Build System <autodist@openmamba.org> 4.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 07 2024 Automatic Build System <autodist@openmamba.org> 3.1.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 22 2023 Automatic Build System <autodist@mambasoft.it> 3.1.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jun 10 2023 Automatic Build System <autodist@mambasoft.it> 3.1.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 25 2023 Automatic Build System <autodist@mambasoft.it> 3.1.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 16 2023 Sdk Build System <sdk@mambasoft.it> 3.1.3-2mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Tue Feb 28 2023 Automatic Build System <autodist@mambasoft.it> 3.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 13 2022 Automatic Build System <autodist@mambasoft.it> 3.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 03 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-3mamba
|
|
- added subpackages for python and perl bindings
|
|
|
|
* Wed Nov 02 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-2mamba
|
|
- fix installation path of pam module
|
|
|
|
* Fri Sep 30 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-1mamba
|
|
- package created using the webbuild interface
|