rebuilt with nodejs 17.4.0 [release 2.6.4-2mamba;Sat Jan 29 2022]
This commit is contained in:
parent
35cf7de339
commit
126ec936bd
140
apm-2.6.4-nodejs-17.4.0.patch
Normal file
140
apm-2.6.4-nodejs-17.4.0.patch
Normal file
@ -0,0 +1,140 @@
|
|||||||
|
From 42134ae3278d93469e9b0f55f38c29cb91ec34f6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: sadick254 <sadickjunior@gmail.com>
|
||||||
|
Date: Thu, 8 Jul 2021 18:50:20 +0300
|
||||||
|
Subject: [PATCH] Bump first-mate
|
||||||
|
|
||||||
|
---
|
||||||
|
package-lock.json | 66 ++++++++++++++---------------------------------
|
||||||
|
package.json | 2 +-
|
||||||
|
2 files changed, 20 insertions(+), 48 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/package-lock.json b/package-lock.json
|
||||||
|
index 9531867e..ed666ae5 100644
|
||||||
|
--- a/package-lock.json
|
||||||
|
+++ b/package-lock.json
|
||||||
|
@@ -828,17 +828,17 @@
|
||||||
|
}
|
||||||
|
},
|
||||||
|
"ext": {
|
||||||
|
- "version": "1.2.1",
|
||||||
|
- "resolved": "https://registry.npmjs.org/ext/-/ext-1.2.1.tgz",
|
||||||
|
- "integrity": "sha512-x+OKKC57tNiLhDW26UmWtvQBpvO+2wxdC/A0jP7RkmjAc4gze9/U98hQyIYJUzo9A+o9ntMHpC+LH3pWMSbrVQ==",
|
||||||
|
+ "version": "1.4.0",
|
||||||
|
+ "resolved": "https://registry.npmjs.org/ext/-/ext-1.4.0.tgz",
|
||||||
|
+ "integrity": "sha512-Key5NIsUxdqKg3vIsdw9dSuXpPCQ297y6wBjL30edxwPgt2E44WcWBZey/ZvUc6sERLTxKdyCu4gZFmUbk1Q7A==",
|
||||||
|
"requires": {
|
||||||
|
"type": "^2.0.0"
|
||||||
|
},
|
||||||
|
"dependencies": {
|
||||||
|
"type": {
|
||||||
|
- "version": "2.0.0",
|
||||||
|
- "resolved": "https://registry.npmjs.org/type/-/type-2.0.0.tgz",
|
||||||
|
- "integrity": "sha512-KBt58xCHry4Cejnc2ISQAF7QY+ORngsWfxezO68+12hKV6lQY8P/psIkcbjeHWn7MqcgciWJyCCevFMJdIXpow=="
|
||||||
|
+ "version": "2.5.0",
|
||||||
|
+ "resolved": "https://registry.npmjs.org/type/-/type-2.5.0.tgz",
|
||||||
|
+ "integrity": "sha512-180WMDQaIMm3+7hGXWf12GtdniDEy7nYcyFMKJn/eZz/6tSLXrUN9V0wKSbMjej0I1WHWbpREDEKHtqPQa9NNw=="
|
||||||
|
}
|
||||||
|
}
|
||||||
|
},
|
||||||
|
@@ -922,45 +922,17 @@
|
||||||
|
}
|
||||||
|
},
|
||||||
|
"first-mate": {
|
||||||
|
- "version": "7.4.1",
|
||||||
|
- "resolved": "https://registry.npmjs.org/first-mate/-/first-mate-7.4.1.tgz",
|
||||||
|
- "integrity": "sha512-SEG5W0aajCvK/Ngoo3he3Ib4DsT+CRPhBAgSju5hksBLvvUfRWP7Jf3+HQ+CNTD4GZZqbDNOEJNOxbf35EblrQ==",
|
||||||
|
+ "version": "7.4.3",
|
||||||
|
+ "resolved": "https://registry.npmjs.org/first-mate/-/first-mate-7.4.3.tgz",
|
||||||
|
+ "integrity": "sha512-PtZUpaPmcV5KV4Rw5TfwczEnExN+X1o3Q/G82E4iRJ0tW91fm3Yi7pa5t4cBH8r3D6EyoBKvfpG2jKE+TZ0/nw==",
|
||||||
|
"requires": {
|
||||||
|
"emissary": "^1",
|
||||||
|
"event-kit": "^2.2.0",
|
||||||
|
"fs-plus": "^3.0.0",
|
||||||
|
"grim": "^2.0.1",
|
||||||
|
- "oniguruma": "7.2.1",
|
||||||
|
+ "oniguruma": "^7.2.3",
|
||||||
|
"season": "^6.0.2",
|
||||||
|
"underscore-plus": "^1"
|
||||||
|
- },
|
||||||
|
- "dependencies": {
|
||||||
|
- "async": {
|
||||||
|
- "version": "1.5.2",
|
||||||
|
- "resolved": "https://registry.npmjs.org/async/-/async-1.5.2.tgz",
|
||||||
|
- "integrity": "sha1-7GphrlZIDAw8skHJVhjiCJL5Zyo="
|
||||||
|
- },
|
||||||
|
- "fs-plus": {
|
||||||
|
- "version": "3.1.1",
|
||||||
|
- "resolved": "https://registry.npmjs.org/fs-plus/-/fs-plus-3.1.1.tgz",
|
||||||
|
- "integrity": "sha512-Se2PJdOWXqos1qVTkvqqjb0CSnfBnwwD+pq+z4ksT+e97mEShod/hrNg0TRCCsXPbJzcIq+NuzQhigunMWMJUA==",
|
||||||
|
- "requires": {
|
||||||
|
- "async": "^1.5.2",
|
||||||
|
- "mkdirp": "^0.5.1",
|
||||||
|
- "rimraf": "^2.5.2",
|
||||||
|
- "underscore-plus": "1.x"
|
||||||
|
- },
|
||||||
|
- "dependencies": {
|
||||||
|
- "rimraf": {
|
||||||
|
- "version": "2.7.1",
|
||||||
|
- "resolved": "https://registry.npmjs.org/rimraf/-/rimraf-2.7.1.tgz",
|
||||||
|
- "integrity": "sha512-uWjbaKIK3T1OSVptzX7Nl6PvQ3qAGtKEtVRjRuazjfL3Bx5eI409VZSqgND+4UNnmzLVdPj9FqFJNPqBZFve4w==",
|
||||||
|
- "requires": {
|
||||||
|
- "glob": "^7.1.3"
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
}
|
||||||
|
},
|
||||||
|
"forever-agent": {
|
||||||
|
@@ -1148,9 +1120,9 @@
|
||||||
|
"integrity": "sha512-6uHUhOPEBgQ24HM+r6b/QwWfZq+yiFcipKFrOFiBEnWdy5sdzYoi+pJeQaPI5qOLRFqWmAXUPQNsielzdLoecA=="
|
||||||
|
},
|
||||||
|
"grim": {
|
||||||
|
- "version": "2.0.2",
|
||||||
|
- "resolved": "https://registry.npmjs.org/grim/-/grim-2.0.2.tgz",
|
||||||
|
- "integrity": "sha512-Qj7hTJRfd87E/gUgfvM0YIH/g2UA2SV6niv6BYXk1o6w4mhgv+QyYM1EjOJQljvzgEj4SqSsRWldXIeKHz3e3Q==",
|
||||||
|
+ "version": "2.0.3",
|
||||||
|
+ "resolved": "https://registry.npmjs.org/grim/-/grim-2.0.3.tgz",
|
||||||
|
+ "integrity": "sha512-FM20Ump11qYLK9k9DbL8yzVpy+YBieya1JG15OeH8s+KbHq8kL4SdwRtURwIUHniSxb24EoBUpwKfFjGNVi4/Q==",
|
||||||
|
"requires": {
|
||||||
|
"event-kit": "^2.0.0"
|
||||||
|
}
|
||||||
|
@@ -1604,9 +1576,9 @@
|
||||||
|
}
|
||||||
|
},
|
||||||
|
"nan": {
|
||||||
|
- "version": "2.14.0",
|
||||||
|
- "resolved": "https://registry.npmjs.org/nan/-/nan-2.14.0.tgz",
|
||||||
|
- "integrity": "sha512-INOFj37C7k3AfaNTtX8RhsTw7qRy7eLET14cROi9+5HAVbbHuIWUHEauBv5qT4Av2tWasiTY1Jw6puUNqRJXQg=="
|
||||||
|
+ "version": "2.14.2",
|
||||||
|
+ "resolved": "https://registry.npmjs.org/nan/-/nan-2.14.2.tgz",
|
||||||
|
+ "integrity": "sha512-M2ufzIiINKCuDfBSAUr1vWQ+vuVcA9kqx8JJUsbQi6yf1uGRyb7HfpdfUr5qLXf3B/t8dPvcjhKMmlfnP47EzQ=="
|
||||||
|
},
|
||||||
|
"napi-build-utils": {
|
||||||
|
"version": "1.0.2",
|
||||||
|
@@ -4873,9 +4845,9 @@
|
||||||
|
}
|
||||||
|
},
|
||||||
|
"oniguruma": {
|
||||||
|
- "version": "7.2.1",
|
||||||
|
- "resolved": "https://registry.npmjs.org/oniguruma/-/oniguruma-7.2.1.tgz",
|
||||||
|
- "integrity": "sha512-WPS/e1uzhswPtJSe+Zls/kAj27+lEqZjCmRSjnYk/Z4L2Mu+lJC2JWtkZhPJe4kZeTQfz7ClcLyXlI4J68MG2w==",
|
||||||
|
+ "version": "7.2.3",
|
||||||
|
+ "resolved": "https://registry.npmjs.org/oniguruma/-/oniguruma-7.2.3.tgz",
|
||||||
|
+ "integrity": "sha512-PZZcE0yfg8Q1IvaJImh21RUTHl8ep0zwwyoE912KqlWVrsGByjjj29sdACcD1BFyX2bLkfuOJeP+POzAGVWtbA==",
|
||||||
|
"requires": {
|
||||||
|
"nan": "^2.14.0"
|
||||||
|
}
|
||||||
|
diff --git a/package.json b/package.json
|
||||||
|
index a75b3e6d..05a11a9c 100644
|
||||||
|
--- a/package.json
|
||||||
|
+++ b/package.json
|
||||||
|
@@ -31,7 +31,7 @@
|
||||||
|
"asar-require": "0.3.0",
|
||||||
|
"async": "^3.2.0",
|
||||||
|
"colors": "~1.4.0",
|
||||||
|
- "first-mate": "^7.4.1",
|
||||||
|
+ "first-mate": "^7.4.3",
|
||||||
|
"fs-plus": "3.x",
|
||||||
|
"git-utils": "^5.7.2",
|
||||||
|
"glob": "^7.1.6",
|
10
apm.spec
10
apm.spec
@ -1,6 +1,6 @@
|
|||||||
Name: apm
|
Name: apm
|
||||||
Version: 2.6.4
|
Version: 2.6.4
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Atom Package Manager
|
Summary: Atom Package Manager
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -9,6 +9,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://github.com/atom/apm
|
URL: https://github.com/atom/apm
|
||||||
Source: https://github.com/atom/apm.git/v%{version}/apm-%{version}.tar.bz2
|
Source: https://github.com/atom/apm.git/v%{version}/apm-%{version}.tar.bz2
|
||||||
Patch0: apm-2.6.1-no-scripts.patch
|
Patch0: apm-2.6.1-no-scripts.patch
|
||||||
|
Patch1: apm-2.6.4-nodejs-17.4.0.patch
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -18,7 +19,7 @@ BuildRequires: libsecret-devel
|
|||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: node-gyp
|
BuildRequires: node-gyp
|
||||||
BuildRequires: nodejs >= 16.0.0
|
BuildRequires: nodejs >= 17.4.0
|
||||||
Requires: nodejs
|
Requires: nodejs
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -33,8 +34,10 @@ Atom Package Manager - Discover and install Atom packages powered by atom.io.
|
|||||||
# From Arch Linux
|
# From Arch Linux
|
||||||
# Don't download binary Node
|
# Don't download binary Node
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1 -b .nodejs-17.4.0
|
||||||
rm BUNDLED_NODE_VERSION script/*
|
rm BUNDLED_NODE_VERSION script/*
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
npm install
|
npm install
|
||||||
@ -101,6 +104,9 @@ find %{buildroot}%{_prefix}/lib \
|
|||||||
%doc LICENSE.md
|
%doc LICENSE.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.4-2mamba
|
||||||
|
- rebuilt with nodejs 17.4.0
|
||||||
|
|
||||||
* Wed Jun 23 2021 Automatic Build System <autodist@mambasoft.it> 2.6.4-1mamba
|
* Wed Jun 23 2021 Automatic Build System <autodist@mambasoft.it> 2.6.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user