added tools subpackage; updated installation paths [release 2.4.58-3mamba;Fri Dec 29 2023]
This commit is contained in:
parent
be56f68b7d
commit
d19bc18517
10
apache-2.4.58-libxml2-2.12.3.patch
Normal file
10
apache-2.4.58-libxml2-2.12.3.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- httpd-2.4.58/modules/filters/mod_xml2enc.c.orig 2023-12-29 11:30:50.683697976 +0100
|
||||
+++ httpd-2.4.58/modules/filters/mod_xml2enc.c 2023-12-29 11:31:08.853733261 +0100
|
||||
@@ -35,6 +35,7 @@
|
||||
#endif
|
||||
|
||||
/* libxml2 */
|
||||
+#include <libxml/parser.h>
|
||||
#include <libxml/encoding.h>
|
||||
|
||||
#if defined(__clang__)
|
95
apache.spec
95
apache.spec
@ -6,7 +6,7 @@
|
||||
|
||||
Name: apache
|
||||
Version: 2.4.58
|
||||
Release: 1mamba
|
||||
Release: 3mamba
|
||||
Epoch: 1
|
||||
Summary: The Apache webserver
|
||||
Group: System/Servers
|
||||
@ -22,6 +22,7 @@ Source4: httpd-update_httpdconf.sh
|
||||
Source5: httpd.service
|
||||
Source6: apache-add-vhost
|
||||
Patch0: apache-2.4.50-openssl-3.0.0.patch
|
||||
Patch1: apache-2.4.58-libxml2-2.12.3.patch
|
||||
License: Apache License 2.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -47,6 +48,7 @@ BuildRequires: libz-devel
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
#BuildRequires: libdistcache-devel
|
||||
Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: httpd = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: apache-source < 1:2.4.50
|
||||
|
||||
@ -56,6 +58,14 @@ Apache is a powerful, full-featured, efficient, and freely-available Web server.
|
||||
Apache is also the most popular Web server on the Internet.
|
||||
The Apache/Perl integration project brings together the full power of the Perl programming language and the Apache HTTP server.
|
||||
|
||||
%package tools
|
||||
Group: System/Tools
|
||||
Summary: Tools provided with the Apache Web server
|
||||
|
||||
%description tools
|
||||
Apache is a powerful, full-featured, efficient, and freely-available Web server.
|
||||
This package contains the tools provided with Apache Web server.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Module development tools for apache
|
||||
@ -98,14 +108,15 @@ Apache module for launching a CGI script as another user.
|
||||
%setup -q -n httpd-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
#%patch 0 -p1
|
||||
%patch 1 -p1
|
||||
|
||||
cat >> config.layout << _EOF
|
||||
<Layout OPENMAMBA>
|
||||
prefix: %{_prefix}
|
||||
exec_prefix: %{_prefix}
|
||||
bindir: %{_bindir}
|
||||
sbindir: %{_sbindir}
|
||||
sbindir: %{_bindir}
|
||||
libdir: %{_libdir}
|
||||
libexecdir: %{_libdir}/apache
|
||||
mandir: %{_mandir}
|
||||
@ -127,6 +138,7 @@ _EOF
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--sbindir=%{_bindir} \
|
||||
--datadir=/var/www \
|
||||
--includedir=%{_includedir}/apache \
|
||||
--libexecdir=%{_libdir}/apache \
|
||||
@ -234,7 +246,7 @@ install -p -D -m 0644 %{S:2} %{buildroot}%{_sysconfdir}/sysconfig/httpd
|
||||
# logrotate stuff
|
||||
install -D -m 0644 %{S:3} %{buildroot}%{_sysconfdir}/logrotate.d/httpd
|
||||
|
||||
install -D -m 0755 %{S:6} %{buildroot}%{_sbindir}/apache-add-vhost
|
||||
install -D -m 0755 %{S:6} %{buildroot}%{_bindir}/apache-add-vhost
|
||||
|
||||
# create void log files
|
||||
> %{buildroot}/var/log/httpd/access_log
|
||||
@ -269,13 +281,13 @@ IncludeOptional %{_sysconfdir}/httpd/httpd.d/*.conf" >> \
|
||||
%{buildroot}%{_sysconfdir}/httpd/httpd.conf
|
||||
|
||||
# install httpd.conf conversion tool
|
||||
install -m 0755 %{S:4} %{buildroot}%{_sbindir}/update_httpdconf
|
||||
install -m 0755 %{S:4} %{buildroot}%{_bindir}/update_httpdconf
|
||||
|
||||
# systemd
|
||||
install -D -m0644 %{SOURCE5} %{buildroot}/lib/systemd/system/httpd.service
|
||||
install -D -m0644 %{SOURCE5} %{buildroot}%{_unitdir}/httpd.service
|
||||
|
||||
install -d -m0755 %{buildroot}%{_prefix}/lib/tmpfiles.d
|
||||
cat > %{buildroot}%{_prefix}/lib/tmpfiles.d/httpd.conf << _EOF
|
||||
install -d -m0755 %{buildroot}%{_tmpfilesdir}
|
||||
cat > %{buildroot}%{_tmpfilesdir}/httpd.conf << _EOF
|
||||
d /run/httpd 710 root apache
|
||||
d /run/httpd/htcacheclean 700 apache apache
|
||||
_EOF
|
||||
@ -391,28 +403,20 @@ exit 0
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/httpd
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/httpd
|
||||
%dir %{_sysconfdir}/httpd/httpd.d
|
||||
%{_bindir}/ab
|
||||
%{_bindir}/apxs
|
||||
%{_bindir}/dbmmanage
|
||||
%{_bindir}/htdbm
|
||||
%{_bindir}/htdigest
|
||||
%{_bindir}/htpasswd
|
||||
%{_bindir}/logresolve
|
||||
%{_bindir}/httxt2dbm
|
||||
%{_sbindir}/apachectl
|
||||
%{_sbindir}/checkgid
|
||||
%{_sbindir}/envvars
|
||||
%{_sbindir}/fcgistarter
|
||||
%{_sbindir}/httpd
|
||||
%{_sbindir}/rotatelogs
|
||||
%{_sbindir}/htcacheclean
|
||||
%{_sbindir}/update_httpdconf
|
||||
%{_sbindir}/apache-add-vhost
|
||||
/lib/systemd/system/httpd.service
|
||||
%{_bindir}/apachectl
|
||||
%{_bindir}/checkgid
|
||||
%{_bindir}/envvars
|
||||
%{_bindir}/fcgistarter
|
||||
%{_bindir}/httpd
|
||||
%{_bindir}/rotatelogs
|
||||
%{_bindir}/htcacheclean
|
||||
%{_bindir}/update_httpdconf
|
||||
%{_bindir}/apache-add-vhost
|
||||
%{_unitdir}/httpd.service
|
||||
%{_tmpfilesdir}/httpd.conf
|
||||
%dir %{_libdir}/apache
|
||||
%{_libdir}/apache/httpd.exp
|
||||
%{_libdir}/apache/mod_*.so
|
||||
%{_prefix}/lib/tmpfiles.d/httpd.conf
|
||||
%exclude %{_libdir}/apache/mod_suexec.so
|
||||
%{_prefix}/lib/apache/build/*
|
||||
/var/www/cgi-bin/*
|
||||
@ -424,15 +428,40 @@ exit 0
|
||||
%attr(0755,apache,apache) %dir /var/log/httpd
|
||||
%ghost /var/log/httpd/access_log
|
||||
%ghost /var/log/httpd/error_log
|
||||
%{_mandir}/man?/*
|
||||
%{_mandir}/man8/apachectl.8*
|
||||
%{_mandir}/man8/fcgistarter.8*
|
||||
%{_mandir}/man8/htcacheclean.8*
|
||||
%{_mandir}/man8/httpd.8*
|
||||
%{_mandir}/man8/rotatelogs.8*
|
||||
%{_mandir}/man8/suexec.8*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_sbindir}/envvars-std
|
||||
%{_bindir}/envvars-std
|
||||
%dir %{_includedir}/apache
|
||||
%{_includedir}/apache/*
|
||||
%dir %{_libdir}/apache
|
||||
|
||||
%files tools
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/ab
|
||||
%{_bindir}/apxs
|
||||
%{_bindir}/dbmmanage
|
||||
%{_bindir}/htdbm
|
||||
%{_bindir}/htdigest
|
||||
%{_bindir}/htpasswd
|
||||
%{_bindir}/logresolve
|
||||
%{_bindir}/httxt2dbm
|
||||
%{_mandir}/man1/ab.1*
|
||||
%{_mandir}/man1/apxs.1*
|
||||
%{_mandir}/man1/dbmmanage.1*
|
||||
%{_mandir}/man1/htdbm.1*
|
||||
%{_mandir}/man1/htdigest.1*
|
||||
%{_mandir}/man1/htpasswd.1*
|
||||
%{_mandir}/man1/httxt2dbm.1*
|
||||
%{_mandir}/man1/logresolve.1*
|
||||
%doc LICENSE
|
||||
|
||||
%files -n apache-manual
|
||||
%defattr(-,root,root)
|
||||
%dir /var/www/manual
|
||||
@ -440,10 +469,16 @@ exit 0
|
||||
|
||||
%files mod_suexec
|
||||
%defattr(-,root,root)
|
||||
%attr(4750,root,apache) %{_sbindir}/suexec
|
||||
%attr(4750,root,apache) %{_bindir}/suexec
|
||||
%{_libdir}/apache/mod_suexec.so
|
||||
|
||||
%changelog
|
||||
* Fri Dec 29 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.58-3mamba
|
||||
- added tools subpackage; updated installation paths
|
||||
|
||||
* Fri Dec 29 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.58-2mamba
|
||||
- add tools subpackage
|
||||
|
||||
* Thu Oct 19 2023 Automatic Build System <autodist@mambasoft.it> 2.4.58-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user