update to 1.4 [release 1.4-1mamba;Mon Feb 28 2011]

This commit is contained in:
gil 2024-01-05 20:28:00 +01:00
parent 8067e44241
commit 2ddab3696d
4 changed files with 584 additions and 0 deletions

View File

@ -1,2 +1,10 @@
# apache-commons-dbcp # apache-commons-dbcp
The DBCP package shall create and maintain a database connection pool
package written in the Java language to be distributed under the ASF
license. The package shall be available as a pseudo-JDBC driver and
via a DataSource interface. The package shall also support multiple
logins to multiple database systems, reclamation of stale or dead
connections, testing for valid connections, PreparedStatement
pooling, and other features.

View File

@ -0,0 +1,47 @@
--- build.xml 2010-02-07 17:59:19.000000000 +0100
+++ build.xml-gil 2011-02-28 01:28:17.000000000 +0100
@@ -37,7 +37,7 @@
<property name="user-propfile" value="${user.home}/build.properties"/>
<property file="${user-propfile}"/>
- <property name="commons-pool.jar" value="${basedir}/../pool/dist/commons-pool.jar"/>
+ <property name="commons-pool.jar" value="${basedir}/pool/dist/commons-pool.jar"/>
<!-- command line classpath, if any -->
<property name="cp" value=""/>
@@ -230,22 +230,23 @@
<target name="build-jar" depends="compile">
<mkdir dir="${dist.dir}"/>
- <jar jarfile="${dist.jar}">
- <fileset dir="${build.classes.dir}"/>
+ <jar jarfile="${dist.jar}"
+ compress="true"
+ index="false"
+ manifest="${build.classes.dir}/META-INF/MANIFEST.MF"
+ excludes="**/*.html">
+ <fileset dir="${build.classes.dir}">
+ <include name="org/apache/commons/dbcp/**"/>
+ <include name="META-INF/LICENSE.txt"/>
+ <include name="META-INF/NOTICE.txt"/>
+ <include name="META-INF/maven/commons-dbcp/commons-dbcp/pom.properties"/>
+ <include name="META-INF/maven/commons-dbcp/commons-dbcp/pom.xml"/>
+ </fileset>
<metainf dir="${basedir}" includes="LICENSE.txt,NOTICE.txt"/>
- <manifest>
- <attribute name="Built-By" value="${user.name}"/>
- <attribute name="Package" value="${package}"/>
- <attribute name="Extension-Name" value="${name}"/>
- <attribute name="Specification-Vendor" value="Apache Software Foundation"/>
- <attribute name="Specification-Title" value="${title}"/>
- <attribute name="Implementation-Version" value="${version}"/>
- <attribute name="Implementation-Vendor" value="Apache Software Foundation"/>
- </manifest>
</jar>
</target>
- <target name="build" depends="clean,build-jar,javadoc">
+ <target name="build" depends="build-jar,javadoc">
<copy todir="${dist.dir}" file="${basedir}/LICENSE.txt"/>
<copy todir="${dist.dir}" file="${basedir}/NOTICE.txt"/>
<copy todir="${dist.dir}" file="${basedir}/README.txt"/>

284
apache-commons-dbcp.spec Normal file
View File

@ -0,0 +1,284 @@
%define maven 0
%if %maven
%define target_dir target
%define api_dir %target_dir/site/apidocs
%else
%define target_dir dist
%define api_dir %target_dir/docs/api
%endif
Name: apache-commons-dbcp
Version: 1.4
Release: 1mamba
Summary: Apache Commons DBCP (Commons Database Connection Pooling)
Group: Development/Libraries/Java
Vendor: openmamba
Distribution: openmamba
Packager: gil <puntogil@libero.it>
URL: http://commons.apache.org/dbcp/
# https://issues.apache.org/jira/secure/attachment/12362389/patch.txt
# svn export http://svn.apache.org/repos/asf/commons/proper/dbcp/trunk commons-dbcp-1.3
# tar czf commons-dbcp-1.3-SNAPSHOT-svn-src.tar.gz commons-dbcp-1.3
Source0: http://www.apache.org/dist/commons/dbcp/source/commons-dbcp-1.4-src.tar.gz
# svn export -r '{2007-02-15}' http://svn.apache.org/repos/asf/commons/proper/commons-build/trunk/ jakarta-commons-build-dbcp
# tar czf jakarta-commons-build-dbcp.tar.gz jakarta-commons-build-dbcp
Source1: maven2-2.2.0-settings.xml
Source2: apache-commons-dbcp-1.4-autogeneratedfiles.tar.gz
Patch0: apache-commons-dbcp-1.3-build_xml.patch
License: Apache Software License Version 2.0
BuildRequires: apache-ant
BuildRequires: apache-commons-pool
BuildRequires: apache-geronimo-1.2-specs
%if %maven
BuildRequires: apache-maven2
BuildRequires: apache-maven2-ant-plugin
BuildRequires: apache-maven2-assembly-plugin
BuildRequires: apache-maven2-changes-plugin
BuildRequires: apache-maven2-checkstyle-plugin
BuildRequires: apache-maven2-compiler-plugin
BuildRequires: apache-maven2-install-plugin
BuildRequires: apache-maven2-jar-plugin
BuildRequires: apache-maven2-javadoc-plugin
BuildRequires: apache-maven2-pmd-plugin
#BuildRequires: felix-maven-bundle-plugin
#BuildRequires: mojo clirr-maven-plugin
#BuildRequires: mojo cobertura-maven-plugin
%endif
BuildRequires: jakarta-commons-collections
BuildRequires: jakarta-commons-collections-tomcat5
BuildRequires: jakarta-commons-logging
BuildRequires: java-backport-util-concurrent
BuildRequires: java-gcj-compat
BuildRequires: java-junit3
BuildRequires: jpackage-utils
BuildRequires: libtomcat5-common
BuildRequires: xerces-j2
BuildRequires: xml-commons-apis
Requires: apache-commons-pool
Requires: jakarta-commons-collections
BuildRoot: %{_tmppath}/%{name}-%{version}-root
#check_message:
# [echo] Could not find ${naming-java.jar}
%description
The DBCP package shall create and maintain a database connection pool
package written in the Java language to be distributed under the ASF
license. The package shall be available as a pseudo-JDBC driver and
via a DataSource interface. The package shall also support multiple
logins to multiple database systems, reclamation of stale or dead
connections, testing for valid connections, PreparedStatement
pooling, and other features.
%package javadoc
Group: Documentation
Summary: Javadoc for %{name}
%description javadoc
Apache Commons DBCP (Database Connection Pools) Package.
This package contains javadoc for %{name}
%package manual
Group: Documentation
Summary: Documents for %{name}
%description manual
Apache Commons DBCP (Database Connection Pools) Package.
This package contains documents for %{name}.
%package tomcat5
Group: Development/Libraries/Java
Summary: Pool dependency for Tomcat5
%description tomcat5
Apache Commons DBCP (Database Connection Pools) Package.
This package contains DBCP dependency for Tomcat5.
%prep
%setup -q -n commons-dbcp-%{version}-src
for j in $(find . -name "*.jar"); do
mv $j ${j}.no
done
%if %maven
mv build.xml build.xml-old
cp %{SOURCE1} settings.xml
mkdir -p .m2/repository/JPP/maven2
sed -i -e "s|<localRepository>__INTERNAL_REPO_PLACEHOLDER__</localRepository>|<localRepository>file://`pwd`/external_repo</localRepository>|g" settings.xml
sed -i -e "s|<url>__EXTERNAL_REPO_PLACEHOLDER__</url>|<url>file://`pwd`/.m2/repository</url>|g" settings.xml
%else
tar -xzf %{SOURCE2}
%patch0 -p0
%endif
cp %{S:2} tomcat5-build.xml
sed -i 's/\r//' LICENSE.txt
sed -i 's/\r//' NOTICE.txt
sed -i 's/\r//' README.txt
%build
export JAVA_HOME=/usr/lib/jvm/jdk-gcj
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
%if %maven
mkdir external_repo
ln -s %{_javadir} external_repo/JPP
mvn-jpp \
-e \
-s $(pwd)/settings.xml \
-Dmaven.test.failure.ignore=true \
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
ant:ant org.apache.felix:maven-bundle-plugin:ant install javadoc:javadoc
%else
export CLASSPATH=$(build-classpath pool/apache-commons-pool commons-collections \
xerces-j2 tomcat5/naming-factory tomcat5/naming-resources \
geronimo/jta-1.1-api geronimo/ejb-2.1-api geronimo/ejb-3.0-api \
backport-util-concurrent):$java_home/jre/lib/rt.jar
ant \
-Dbuild.sysclasspath=first \
-Dcommons-pool.jar=$(build-classpath pool/apache-commons-pool) \
-Dcommons-collections.jar=$(build-classpath commons-collections) \
-Djunit.jar=$(build-classpath junit-3.8.2) \
-Djndi.jar=$JAVA_HOME/jre/lib/rt.jar \
-Dsax2.jar=$(build-classpath xml-commons-jaxp-1.3-apis) \
-Djdbc20ext.jar=$JAVA_HOME/jre/lib/rt.jar \
-Dcommons-logging.jar=$(build-classpath commons-logging) \
-Dxerces.jar=$(build-classpath xerces-j2) \
-Dxml-apis.jar=$(build-classpath xml-commons-jaxp-1.3-apis) \
-Djta-spec.jar=$(build-classpath geronimo/jta-1.0.1B-api) \
-Djta-impl.jar=$(build-classpath geronimo/jta-1.1-api) \
-Dbackport-util-concurrent.jar=$(build-classpath backport-util-concurrent) \
-Dejb-spec.jar=$(build-classpath geronimo/ejb-2.1-api-1.1) \
-Dnaming-common.jar=$(build-classpath tomcat5/naming-resources) \
-Dnaming-java=$JAVA_HOME/jre/lib/rt.jar \
-Djava.io.tmpdir=. \
-Dname=commons-dbcp-%{version} \
build-jar javadoc
mkdir -p pool/dist/
ln -sf $(build-classpath pool/apache-commons-pool) pool/dist/commons-pool.jar
export CLASSPATH=$CLASSPATH:$(build-classpath junit-3.8.2)
ant \
-Djdbc20ext.jar=$JAVA_HOME/jre/lib/rt.jar \
-Djunit.jar=$(build-classpath junit-3.8.2) \
-Dcommons-pool.jar=$(build-classpath pool/apache-commons-pool) \
-Dcommons-logging.jar=$(build-classpath commons-logging) \
-Dxerces.jar=$(build-classpath xerces-j2) \
-Dxml-apis.jar=$(build-classpath xml-commons-jaxp-1.3-apis) \
-Djta-spec.jar=$(build-classpath geronimo/jta-1.0.1B-api) \
-Djta-impl.jar=$(build-classpath geronimo/jta-1.1-api) \
-Dbackport-util-concurrent.jar=$(build-classpath backport-util-concurrent) \
-Dejb-spec.jar=$(build-classpath geronimo/ejb-2.1-api) \
-Djta-impl.jar=$(build-classpath geronimo/jta-1.1-api) \
-Dnaming-common.jar=$(build-classpath tomcat5/naming-resources) \
-Dnaming-java=$JAVA_HOME/jre/lib/rt.jar \
-Dname=commons-dbcp-%{version} \
-Djava.io.tmpdir=. prepare dist
%endif
export CLASSPATH=$CLASSPATH:$(build-classpath commons-collections-tomcat5 pool/apache-commons-pool)
#ant -f tomcat5-build.xml
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
mkdir -p %{buildroot}%{_javadir}/dbcp
install -p -m 644 %target_dir/commons-dbcp-%{version}.jar \
%{buildroot}%{_javadir}/dbcp/%{name}-%{version}.jar
#install -p -m 644 pool-tomcat5/commons-dbcp-tomcat5.jar \
# %{buildroot}%{_javadir}/dbcp/%{name}-tomcat5-%{version}.jar
mkdir -p %{buildroot}%{_datadir}/maven2/poms
install -pm 644 pom.xml %{buildroot}%{_datadir}/maven2/poms/JPP.dbcp-commons-pool.pom
%add_to_maven_depmap org.apache.commons commons-dbcp %{version} JPP/dbcp commons-pool
%add_to_maven_depmap commons-dbcp commons-dbcp %{version} JPP/dbcp commons-pool
(
cd %{buildroot}%{_javadir}/dbcp
for jar in *-%{version}*; do
ln -sf ${jar} `echo $jar| sed "s|apache-||g"`
done
)
(
cd %{buildroot}%{_javadir}/dbcp
for jar in *-%{version}*; do
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
done
)
mkdir -p %{buildroot}%{_javadocdir}/%{name}-%{version}
cp -pr %api_dir/* %{buildroot}%{_javadocdir}/%{name}-%{version}
ln -s %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
#%{_bindir}/aot-compile-rpm
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
%update_maven_depmap
%postun
%update_maven_depmap
%files
%defattr(-,root,root)
%{_javadir}/dbcp/apache-commons-dbcp-%{version}.jar
%{_javadir}/dbcp/apache-commons-dbcp.jar
%{_javadir}/dbcp/commons-dbcp-%{version}.jar
%{_javadir}/dbcp/commons-dbcp.jar
%{_datadir}/maven2/poms
%{_mavendepmapfragdir}
%doc LICENSE.txt NOTICE.txt README.txt
%files javadoc
%defattr(-,root,root)
%{_javadocdir}/apache-commons-dbcp-%{version}
%{_javadocdir}/apache-commons-dbcp
%files manual
%defattr(-,root,root)
%doc doc
#%files tomcat5
#%defattr(-,root,root)
#%{_javadir}/dbcp/apache-commons-dbcp-tomcat5-%{version}.jar
#%{_javadir}/dbcp/apache-commons-dbcp-tomcat5.jar
#%{_javadir}/dbcp/commons-dbcp-tomcat5-%{version}.jar
#%{_javadir}/dbcp/commons-dbcp-tomcat5.jar
%changelog
* Mon Feb 28 2011 gil <puntogil@libero.it> 1.4-1mamba
- update to 1.4
* Mon Feb 28 2011 gil <puntogil@libero.it> 1.3-4mamba
- add OSGi Manifest and maven 2 pom
- rebuilt with java-gcj-compat and new apache-commons-pool support
* Wed Nov 10 2010 gil <puntogil@libero.it> 1.3-3mamba
- rebuilt devel
* Mon Jun 15 2009 gil <puntogil@libero.it> 1.3-2mamba
- rebuilt sun-java 6u20
* Thu Jun 11 2009 gil <puntogil@libero.it> 1.3-1mamba
- update to 1.3
- renamed to legacy apache-commons-dbcp (ex jakarta)
* Sun Mar 08 2009 gil <puntogil@libero.it> 1.2.2-1mamba
- package created by autospec

245
maven2-2.2.0-settings.xml Normal file
View File

@ -0,0 +1,245 @@
<!--
Licensed to the Apache Software Foundation (ASF) under one
or more contributor license agreements. See the NOTICE file
distributed with this work for additional information
regarding copyright ownership. The ASF licenses this file
to you under the Apache License, Version 2.0 (the
"License"); you may not use this file except in compliance
with the License. You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing,
software distributed under the License is distributed on an
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
KIND, either express or implied. See the License for the
specific language governing permissions and limitations
under the License.
-->
<!--
| This is the configuration file for Maven. It can be specified at two levels:
|
| 1. User Level. This settings.xml file provides configuration for a single user,
| and is normally provided in $HOME/.m2/settings.xml.
|
| NOTE: This location can be overridden with the system property:
|
| -Dorg.apache.maven.user-settings=/path/to/user/settings.xml
|
| 2. Global Level. This settings.xml file provides configuration for all maven
| users on a machine (assuming they're all using the same maven
| installation). It's normally provided in
| ${maven.home}/conf/settings.xml.
|
| NOTE: This location can be overridden with the system property:
|
| -Dorg.apache.maven.global-settings=/path/to/global/settings.xml
|
| The sections in this sample file are intended to give you a running start at
| getting the most out of your Maven installation. Where appropriate, the default
| values (values used when the setting is not specified) are provided.
|
|-->
<settings xmlns="http://maven.apache.org/settings/1.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
<!-- localRepository
| The path to the local repository maven will use to store artifacts.
|
| Default: ~/.m2/repository-->
<localRepository>__INTERNAL_REPO_PLACEHOLDER__</localRepository>
<!-- interactiveMode
| This will determine whether maven prompts you when it needs input. If set to false,
| maven will use a sensible default value, perhaps based on some other setting, for
| the parameter in question.
|
| Default: true
<interactiveMode>true</interactiveMode>
-->
<!-- offline
| Determines whether maven should attempt to connect to the network when executing a build.
| This will have an effect on artifact downloads, artifact deployment, and others.
|
| Default: false
<offline>false</offline>
-->
<!-- proxies
| This is a list of proxies which can be used on this machine to connect to the network.
| Unless otherwise specified (by system property or command-line switch), the first proxy
| specification in this list marked as active will be used.
|-->
<proxies>
<!-- proxy
| Specification for one proxy, to be used in connecting to the network.
|
<proxy>
<id>optional</id>
<active>true</active>
<protocol>http</protocol>
<username>proxyuser</username>
<password>proxypass</password>
<host>proxy.host.net</host>
<port>80</port>
<nonProxyHosts>local.net|some.host.com</nonProxyHosts>
</proxy>
-->
</proxies>
<!-- servers
| This is a list of authentication profiles, keyed by the server-id used within the system.
| Authentication profiles can be used whenever maven must make a connection to a remote server.
|-->
<servers>
<!-- server
| Specifies the authentication information to use when connecting to a particular server, identified by
| a unique name within the system (referred to by the 'id' attribute below).
|
| NOTE: You should either specify username/password OR privateKey/passphrase, since these pairings are
| used together.
|
<server>
<id>deploymentRepo</id>
<username>repouser</username>
<password>repopwd</password>
</server>
-->
<!-- Another sample, using keys to authenticate.
<server>
<id>siteServer</id>
<privateKey>/path/to/private/key</privateKey>
<passphrase>optional; leave empty if not used.</passphrase>
</server>
-->
</servers>
<!-- mirrors
| This is a list of mirrors to be used in downloading artifacts from remote repositories.
|
| It works like this: a POM may declare a repository to use in resolving certain artifacts.
| However, this repository may have problems with heavy traffic at times, so people have mirrored
| it to several places.
|
| That repository definition will have a unique id, so we can create a mirror reference for that
| repository, to be used as an alternate download site. The mirror site will be the preferred
| server for that repository.
|-->
<mirrors>
<!-- mirror
| Specifies a repository mirror site to use instead of a given repository. The repository that
| this mirror serves has an ID that matches the mirrorOf element of this mirror. IDs are used
| for inheritance and direct lookup purposes, and must be unique across the set of mirrors.
|
-->
<mirror>
<id>mirrorId</id>
<mirrorOf>repositoryId</mirrorOf>
<name>Human Readable Name for this Mirror.</name>
<url>__EXTERNAL_REPO_PLACEHOLDER__</url>
</mirror>
</mirrors>
<!-- profiles
| This is a list of profiles which can be activated in a variety of ways, and which can modify
| the build process. Profiles provided in the settings.xml are intended to provide local machine-
| specific paths and repository locations which allow the build to work in the local environment.
|
| For example, if you have an integration testing plugin - like cactus - that needs to know where
| your Tomcat instance is installed, you can provide a variable here such that the variable is
| dereferenced during the build process to configure the cactus plugin.
|
| As noted above, profiles can be activated in a variety of ways. One way - the activeProfiles
| section of this document (settings.xml) - will be discussed later. Another way essentially
| relies on the detection of a system property, either matching a particular value for the property,
| or merely testing its existence. Profiles can also be activated by JDK version prefix, where a
| value of '1.4' might activate a profile when the build is executed on a JDK version of '1.4.2_07'.
| Finally, the list of active profiles can be specified directly from the command line.
|
| NOTE: For profiles defined in the settings.xml, you are restricted to specifying only artifact
| repositories, plugin repositories, and free-form properties to be used as configuration
| variables for plugins in the POM.
|
|-->
<profiles>
<!-- profile
| Specifies a set of introductions to the build process, to be activated using one or more of the
| mechanisms described above. For inheritance purposes, and to activate profiles via <activatedProfiles/>
| or the command line, profiles have to have an ID that is unique.
|
| An encouraged best practice for profile identification is to use a consistent naming convention
| for profiles, such as 'env-dev', 'env-test', 'env-production', 'user-jdcasey', 'user-brett', etc.
| This will make it more intuitive to understand what the set of introduced profiles is attempting
| to accomplish, particularly when you only have a list of profile id's for debug.
|
| This profile example uses the JDK version to trigger activation, and provides a JDK-specific repo.
<profile>
<id>jdk-1.4</id>
<activation>
<jdk>1.4</jdk>
</activation>
<repositories>
<repository>
<id>jdk14</id>
<name>Repository for JDK 1.4 builds</name>
<url>http://www.myhost.com/maven/jdk14</url>
<layout>default</layout>
<snapshotPolicy>always</snapshotPolicy>
</repository>
</repositories>
</profile>
-->
<!--
| Here is another profile, activated by the system property 'target-env' with a value of 'dev',
| which provides a specific path to the Tomcat instance. To use this, your plugin configuration
| might hypothetically look like:
|
| ...
| <plugin>
| <groupId>org.myco.myplugins</groupId>
| <artifactId>myplugin</artifactId>
|
| <configuration>
| <tomcatLocation>${tomcatPath}</tomcatLocation>
| </configuration>
| </plugin>
| ...
|
| NOTE: If you just wanted to inject this configuration whenever someone set 'target-env' to
| anything, you could just leave off the <value/> inside the activation-property.
|
<profile>
<id>env-dev</id>
<activation>
<property>
<name>target-env</name>
<value>dev</value>
</property>
</activation>
<properties>
<tomcatPath>/path/to/tomcat/instance</tomcatPath>
</properties>
</profile>
-->
</profiles>
<!-- activeProfiles
| List of profiles that are active for all builds.
|
<activeProfiles>
<activeProfile>alwaysActiveProfile</activeProfile>
<activeProfile>anotherAlwaysActiveProfile</activeProfile>
</activeProfiles>
-->
</settings>