update to 1.0.15 [release 1.0.15-1mamba;Wed Mar 26 2014]
This commit is contained in:
parent
94e8354705
commit
ad6f4e1eee
10
README.md
10
README.md
@ -1,2 +1,12 @@
|
|||||||
# apache-commons-daemon
|
# apache-commons-daemon
|
||||||
|
|
||||||
|
The scope of this package is to define an API in line with the current
|
||||||
|
Java(tm) Platform APIs to support an alternative invocation mechanism
|
||||||
|
which could be used instead of the above mentioned public static void
|
||||||
|
main(String[]) method. This specification cover the behavior and life
|
||||||
|
cycle of what we define as Java(tm) daemons, or, in other words, non
|
||||||
|
interactive Java(tm) applications.
|
||||||
|
|
||||||
|
Daemon is made of 2 parts. One written in C that makes the interface to the
|
||||||
|
operating system and the other in Java that provides the Daemon API
|
||||||
|
|
||||||
|
32
apache-commons-daemon-1.0.4-add_OSGi_Manifest.patch
Normal file
32
apache-commons-daemon-1.0.4-add_OSGi_Manifest.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
--- build.xml 2010-10-19 20:05:34.000000000 +0200
|
||||||
|
+++ build.xml-gil 2010-12-12 06:29:33.000000000 +0100
|
||||||
|
@@ -292,22 +292,17 @@
|
||||||
|
tofile="${build.home}/classes/META-INF/LICENSE.txt"/>
|
||||||
|
<copy file="NOTICE.txt"
|
||||||
|
tofile="${build.home}/classes/META-INF/NOTICE.txt"/>
|
||||||
|
- <jar jarfile="${dist.home}/commons-${component.name}-${component.version}.jar">
|
||||||
|
- <manifest>
|
||||||
|
- <attribute name="Specification-Title" value="Commons Daemon"/>
|
||||||
|
- <attribute name="Specification-Version" value="${component.version}"/>
|
||||||
|
- <attribute name="Specification-Vendor" value="Apache Software Foundation"/>
|
||||||
|
- <attribute name="Implementation-Title" value="Commons Daemon"/>
|
||||||
|
- <attribute name="Implementation-Version" value="${component.version}"/>
|
||||||
|
- <attribute name="Implementation-Vendor" value="Apache Software Foundation"/>
|
||||||
|
- <attribute name="Implementation-Vendor-Id" value="org.apache"/>
|
||||||
|
- <attribute name="X-Compile-Source-JDK" value="${compile.source}"/>
|
||||||
|
- <attribute name="X-Compile-Target-JDK" value="${compile.target}"/>
|
||||||
|
- </manifest>
|
||||||
|
+ <jar jarfile="${dist.home}/commons-${component.name}-${component.version}.jar"
|
||||||
|
+ compress="true"
|
||||||
|
+ index="false"
|
||||||
|
+ manifest="${build.home}/classes/META-INF/MANIFEST.MF"
|
||||||
|
+ excludes="**/*.html">
|
||||||
|
<fileset dir="${build.home}/classes">
|
||||||
|
<include name="org/apache/commons/daemon/**"/>
|
||||||
|
<include name="META-INF/LICENSE.txt"/>
|
||||||
|
<include name="META-INF/NOTICE.txt"/>
|
||||||
|
+ <include name="META-INF/maven/commons-daemon/commons-daemon/pom.properties"/>
|
||||||
|
+ <include name="META-INF/maven/commons-daemon/commons-daemon/pom.xml"/>
|
||||||
|
</fileset>
|
||||||
|
</jar>
|
||||||
|
</target>
|
18
apache-commons-daemon-1.0.4-execve-path-warning.patch
Normal file
18
apache-commons-daemon-1.0.4-execve-path-warning.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
--- src/native/unix/native/jsvc-unix.c 2010-10-16 15:09:11.000000000 +0200
|
||||||
|
+++ src/native/unix/native/jsvc-unix.c-gil 2010-12-12 05:55:08.000000000 +0100
|
||||||
|
@@ -966,6 +966,15 @@
|
||||||
|
char *tmp = NULL;
|
||||||
|
char *p1 = NULL;
|
||||||
|
char *p2 = NULL;
|
||||||
|
+
|
||||||
|
+ /* We don't want to use a form of exec() that searches the
|
||||||
|
+ PATH, so require that argv[0] be either an absolute or
|
||||||
|
+ relative path. Error out if this isn't the case. */
|
||||||
|
+ tmp=strchr(oldpath,'/');
|
||||||
|
+ if (tmp==NULL) {
|
||||||
|
+ log_error("JSVC re-exec requires execution with an absolute or relative path");
|
||||||
|
+ return(1);
|
||||||
|
+ }
|
||||||
|
|
||||||
|
/*
|
||||||
|
* There is no need to change LD_LIBRARY_PATH
|
253
apache-commons-daemon.spec
Normal file
253
apache-commons-daemon.spec
Normal file
@ -0,0 +1,253 @@
|
|||||||
|
%define maven 0
|
||||||
|
%if %maven
|
||||||
|
%define target_dir target
|
||||||
|
%define api_dir %target_dir/site/apidocs
|
||||||
|
%else
|
||||||
|
%define target_dir dist
|
||||||
|
%define api_dir %target_dir/docs/api
|
||||||
|
%endif
|
||||||
|
Name: apache-commons-daemon
|
||||||
|
Version: 1.0.15
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Apache Commons Daemon Package
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: gil <puntogil@libero.it>
|
||||||
|
URL: http://commons.apache.org/daemon/
|
||||||
|
Source0: http://www.apache.org/dist/commons/daemon/source/commons-daemon-%{version}-src.tar.gz
|
||||||
|
Source1: maven2-2.2.0-settings.xml
|
||||||
|
Source2: commons-daemon-1.0.5-autogeneratedfiles.tar.gz
|
||||||
|
Patch0: apache-commons-daemon-1.0.4-execve-path-warning.patch
|
||||||
|
Patch1: apache-commons-daemon-1.0.4-add_OSGi_Manifest.patch
|
||||||
|
#Patch0: jakarta-commons-daemon-1.0.1-crosslink.patch
|
||||||
|
#Patch3: jakarta-commons-daemon-1.0.1-ia64-configure.patch
|
||||||
|
License: Apache Software License 2.0
|
||||||
|
BuildRequires: apache-ant
|
||||||
|
%if %maven
|
||||||
|
BuildRequires: apache-maven2
|
||||||
|
BuildRequires: apache-maven2-ant-plugin
|
||||||
|
BuildRequires: apache-maven2-antrun-plugin
|
||||||
|
BuildRequires: apache-maven2-assembly-plugin
|
||||||
|
BuildRequires: apache-maven2-compiler-plugin
|
||||||
|
BuildRequires: apache-maven2-idea-plugin
|
||||||
|
BuildRequires: apache-maven2-install-plugin
|
||||||
|
BuildRequires: apache-maven2-jar-plugin
|
||||||
|
BuildRequires: apache-maven2-javadoc-plugin
|
||||||
|
BuildRequires: apache-maven2-resources-plugin
|
||||||
|
#BuildRequires: felix maven-bundle-plugin
|
||||||
|
#BuildRequires: maven-surefire-plugin
|
||||||
|
%endif
|
||||||
|
BuildRequires: docbook-utils
|
||||||
|
BuildRequires: java-junit3
|
||||||
|
BuildRequires: jpackage-utils
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: java-openjdk
|
||||||
|
BuildRequires: java-openjdk-javadoc
|
||||||
|
BuildRequires: xmlto
|
||||||
|
Requires: jpackage-utils
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The scope of this package is to define an API in line with the current
|
||||||
|
Java(tm) Platform APIs to support an alternative invocation mechanism
|
||||||
|
which could be used instead of the above mentioned public static void
|
||||||
|
main(String[]) method. This specification cover the behavior and life
|
||||||
|
cycle of what we define as Java(tm) daemons, or, in other words, non
|
||||||
|
interactive Java(tm) applications.
|
||||||
|
|
||||||
|
Daemon is made of 2 parts. One written in C that makes the interface to the
|
||||||
|
operating system and the other in Java that provides the Daemon API
|
||||||
|
|
||||||
|
%package jsvc
|
||||||
|
Group: System/Tools
|
||||||
|
Summary: Java daemon launcher
|
||||||
|
|
||||||
|
%description jsvc
|
||||||
|
Jakarta Commons Daemon Package
|
||||||
|
|
||||||
|
This package contains %{name} Java daemon launcher
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Group: Documentation
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
Jakarta Commons Daemon Package
|
||||||
|
|
||||||
|
This package contains javadoc for %{name}
|
||||||
|
|
||||||
|
%package source
|
||||||
|
Group: Development/Languages
|
||||||
|
Summary: %{name} source
|
||||||
|
|
||||||
|
%description source
|
||||||
|
Jakarta Commons Daemon Package
|
||||||
|
|
||||||
|
This package contains %{name} source.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q -n commons-daemon-%{version}-src
|
||||||
|
%patch0 -p0
|
||||||
|
|
||||||
|
for j in $(find . -name "*.jar"); do
|
||||||
|
rm -rf $j
|
||||||
|
done
|
||||||
|
|
||||||
|
for c in $(find . -name "*.class"); do
|
||||||
|
rm -rf $c
|
||||||
|
done
|
||||||
|
|
||||||
|
%if %maven
|
||||||
|
|
||||||
|
cp %{SOURCE1} settings.xml
|
||||||
|
mkdir -p .m2/repository/JPP/maven2
|
||||||
|
sed -i -e "s|<localRepository>__INTERNAL_REPO_PLACEHOLDER__</localRepository>|<localRepository>file://`pwd`/external_repo</localRepository>|g" settings.xml
|
||||||
|
sed -i -e "s|<url>__EXTERNAL_REPOPLACEHOLDER__</url>|<url>file://`pwd`/.m2/repository</url>|g" settings.xml
|
||||||
|
|
||||||
|
%else
|
||||||
|
tar -xf %{SOURCE2}
|
||||||
|
|
||||||
|
%patch1 -p0
|
||||||
|
|
||||||
|
%endif
|
||||||
|
|
||||||
|
rm -rf src/samples/build/
|
||||||
|
chmod 644 src/samples/*
|
||||||
|
|
||||||
|
pushd src/native/unix/man
|
||||||
|
xmlto man jsvc.1.xml
|
||||||
|
popd
|
||||||
|
|
||||||
|
%build
|
||||||
|
|
||||||
|
export JAVA_HOME=/usr/lib/jvm/java
|
||||||
|
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
|
||||||
|
|
||||||
|
%if %maven
|
||||||
|
mkdir external_repo
|
||||||
|
ln -s %{_javadir} external_repo/JPP
|
||||||
|
|
||||||
|
mvn-jpp \
|
||||||
|
-e \
|
||||||
|
-s $(pwd)/settings.xml \
|
||||||
|
-Dmaven.test.failure.ignore=true \
|
||||||
|
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||||
|
ant:ant org.apache.felix:maven-bundle-plugin:ant install javadoc:javadoc
|
||||||
|
%else
|
||||||
|
|
||||||
|
export CLASSPATH=$(build-classpath junit-3.8.2)
|
||||||
|
ant \
|
||||||
|
-Dant.lib=%{_datadir}/ant/lib \
|
||||||
|
-Dant.home=%{_datadir}/ant \
|
||||||
|
-Dj2se.javadoc=%{_javadocdir}/java \
|
||||||
|
-Djunit.home=%{_javadir} \
|
||||||
|
-Djunit.jar=$(build-classpath junit-3.8.2) \
|
||||||
|
dist test
|
||||||
|
|
||||||
|
%endif
|
||||||
|
|
||||||
|
cd src/native/unix
|
||||||
|
|
||||||
|
%configure \
|
||||||
|
--with-java=$JAVA_HOME
|
||||||
|
make clean
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_javadir}
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/maven2/poms
|
||||||
|
|
||||||
|
install -m 644 %target_dir/commons-daemon-%{version}.jar \
|
||||||
|
%{buildroot}%{_javadir}/apache-commons-daemon-%{version}.jar
|
||||||
|
|
||||||
|
install -pm 644 pom.xml %{buildroot}%{_datadir}/maven2/poms/JPP-apache-commons-daemon.pom
|
||||||
|
%add_to_maven_depmap org.apache.commons commons-daemon %{version} JPP apache-commons-daemon
|
||||||
|
%add_to_maven_depmap commons-daemon commons-daemon %{version} JPP apache-commons-daemon
|
||||||
|
|
||||||
|
#(
|
||||||
|
# cd %{buildroot}%{_javadir}
|
||||||
|
# for jar in *-%{version}.jar; do
|
||||||
|
# ln -sf ${jar} `echo $jar| sed "s|apache-||g"`
|
||||||
|
# done
|
||||||
|
#)
|
||||||
|
|
||||||
|
(
|
||||||
|
cd %{buildroot}%{_javadir}
|
||||||
|
for jar in *-%{version}.jar; do
|
||||||
|
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||||
|
done
|
||||||
|
)
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_bindir}
|
||||||
|
mkdir -p %{buildroot}%{_mandir}/man1
|
||||||
|
|
||||||
|
install -pm 755 src/native/unix/jsvc %{buildroot}%{_bindir}/jsvc
|
||||||
|
install -pm 644 src/native/unix/man/jsvc.1 %{buildroot}%{_mandir}/man1/
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_javadocdir}/apache-commons-daemon-%{version}
|
||||||
|
cp -pr %api_dir/* %{buildroot}%{_javadocdir}/apache-commons-daemon-%{version}
|
||||||
|
ln -s apache-commons-daemon-%{version} %{buildroot}%{_javadocdir}/apache-commons-daemon
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_sourcedir}/apache-commons-daemon-%{version}
|
||||||
|
cp -pr %target_dir/bin/commons-daemon-%{version}-native-src.* %{buildroot}%{_sourcedir}/apache-commons-daemon-%{version}/
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
%update_maven_depmap
|
||||||
|
|
||||||
|
%postun
|
||||||
|
%update_maven_depmap
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/apache-commons-daemon-%{version}.jar
|
||||||
|
%{_javadir}/apache-commons-daemon.jar
|
||||||
|
#%{_javadir}/commons-daemon-%{version}.jar
|
||||||
|
#%{_javadir}/commons-daemon.jar
|
||||||
|
%{_datadir}/maven2/poms
|
||||||
|
%{_mavendepmapfragdir}
|
||||||
|
%doc README *.html *.txt
|
||||||
|
%doc src/docs/* src/samples
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadocdir}/apache-commons-daemon-%{version}
|
||||||
|
%{_javadocdir}/apache-commons-daemon
|
||||||
|
|
||||||
|
%files jsvc
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/jsvc
|
||||||
|
%{_mandir}/man1/jsvc.1.gz
|
||||||
|
%doc LICENSE.txt
|
||||||
|
|
||||||
|
%files source
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sourcedir}/apache-commons-daemon-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Mar 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.15-1mamba
|
||||||
|
- update to 1.0.15
|
||||||
|
|
||||||
|
* Sun Feb 27 2011 gil <puntogil@libero.it> 1.0.5-1mamba
|
||||||
|
- update to 1.0.5
|
||||||
|
|
||||||
|
* Sun Dec 12 2010 gil <puntogil@libero.it> 1.0.4-1mamba
|
||||||
|
- update to 1.0.4
|
||||||
|
|
||||||
|
* Thu Oct 01 2009 gil <puntogil@libero.it> 1.0.1-3mamba
|
||||||
|
- added jsvc manual
|
||||||
|
|
||||||
|
* Thu Jun 11 2009 gil <puntogil@libero.it> 1.0.1-2mamba
|
||||||
|
- added sources package
|
||||||
|
|
||||||
|
* Thu Feb 26 2009 gil <puntogil@libero.it> 1.0.1-1mamba
|
||||||
|
- package created by autospec
|
245
maven2-2.2.0-settings.xml
Normal file
245
maven2-2.2.0-settings.xml
Normal file
@ -0,0 +1,245 @@
|
|||||||
|
<!--
|
||||||
|
Licensed to the Apache Software Foundation (ASF) under one
|
||||||
|
or more contributor license agreements. See the NOTICE file
|
||||||
|
distributed with this work for additional information
|
||||||
|
regarding copyright ownership. The ASF licenses this file
|
||||||
|
to you under the Apache License, Version 2.0 (the
|
||||||
|
"License"); you may not use this file except in compliance
|
||||||
|
with the License. You may obtain a copy of the License at
|
||||||
|
|
||||||
|
http://www.apache.org/licenses/LICENSE-2.0
|
||||||
|
|
||||||
|
Unless required by applicable law or agreed to in writing,
|
||||||
|
software distributed under the License is distributed on an
|
||||||
|
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
|
||||||
|
KIND, either express or implied. See the License for the
|
||||||
|
specific language governing permissions and limitations
|
||||||
|
under the License.
|
||||||
|
-->
|
||||||
|
|
||||||
|
<!--
|
||||||
|
| This is the configuration file for Maven. It can be specified at two levels:
|
||||||
|
|
|
||||||
|
| 1. User Level. This settings.xml file provides configuration for a single user,
|
||||||
|
| and is normally provided in $HOME/.m2/settings.xml.
|
||||||
|
|
|
||||||
|
| NOTE: This location can be overridden with the system property:
|
||||||
|
|
|
||||||
|
| -Dorg.apache.maven.user-settings=/path/to/user/settings.xml
|
||||||
|
|
|
||||||
|
| 2. Global Level. This settings.xml file provides configuration for all maven
|
||||||
|
| users on a machine (assuming they're all using the same maven
|
||||||
|
| installation). It's normally provided in
|
||||||
|
| ${maven.home}/conf/settings.xml.
|
||||||
|
|
|
||||||
|
| NOTE: This location can be overridden with the system property:
|
||||||
|
|
|
||||||
|
| -Dorg.apache.maven.global-settings=/path/to/global/settings.xml
|
||||||
|
|
|
||||||
|
| The sections in this sample file are intended to give you a running start at
|
||||||
|
| getting the most out of your Maven installation. Where appropriate, the default
|
||||||
|
| values (values used when the setting is not specified) are provided.
|
||||||
|
|
|
||||||
|
|-->
|
||||||
|
<settings xmlns="http://maven.apache.org/settings/1.0.0"
|
||||||
|
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
||||||
|
xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
|
||||||
|
<!-- localRepository
|
||||||
|
| The path to the local repository maven will use to store artifacts.
|
||||||
|
|
|
||||||
|
| Default: ~/.m2/repository-->
|
||||||
|
<localRepository>__INTERNAL_REPO_PLACEHOLDER__</localRepository>
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
<!-- interactiveMode
|
||||||
|
| This will determine whether maven prompts you when it needs input. If set to false,
|
||||||
|
| maven will use a sensible default value, perhaps based on some other setting, for
|
||||||
|
| the parameter in question.
|
||||||
|
|
|
||||||
|
| Default: true
|
||||||
|
<interactiveMode>true</interactiveMode>
|
||||||
|
-->
|
||||||
|
|
||||||
|
<!-- offline
|
||||||
|
| Determines whether maven should attempt to connect to the network when executing a build.
|
||||||
|
| This will have an effect on artifact downloads, artifact deployment, and others.
|
||||||
|
|
|
||||||
|
| Default: false
|
||||||
|
<offline>false</offline>
|
||||||
|
-->
|
||||||
|
|
||||||
|
<!-- proxies
|
||||||
|
| This is a list of proxies which can be used on this machine to connect to the network.
|
||||||
|
| Unless otherwise specified (by system property or command-line switch), the first proxy
|
||||||
|
| specification in this list marked as active will be used.
|
||||||
|
|-->
|
||||||
|
<proxies>
|
||||||
|
<!-- proxy
|
||||||
|
| Specification for one proxy, to be used in connecting to the network.
|
||||||
|
|
|
||||||
|
<proxy>
|
||||||
|
<id>optional</id>
|
||||||
|
<active>true</active>
|
||||||
|
<protocol>http</protocol>
|
||||||
|
<username>proxyuser</username>
|
||||||
|
<password>proxypass</password>
|
||||||
|
<host>proxy.host.net</host>
|
||||||
|
<port>80</port>
|
||||||
|
<nonProxyHosts>local.net|some.host.com</nonProxyHosts>
|
||||||
|
</proxy>
|
||||||
|
-->
|
||||||
|
</proxies>
|
||||||
|
|
||||||
|
<!-- servers
|
||||||
|
| This is a list of authentication profiles, keyed by the server-id used within the system.
|
||||||
|
| Authentication profiles can be used whenever maven must make a connection to a remote server.
|
||||||
|
|-->
|
||||||
|
<servers>
|
||||||
|
<!-- server
|
||||||
|
| Specifies the authentication information to use when connecting to a particular server, identified by
|
||||||
|
| a unique name within the system (referred to by the 'id' attribute below).
|
||||||
|
|
|
||||||
|
| NOTE: You should either specify username/password OR privateKey/passphrase, since these pairings are
|
||||||
|
| used together.
|
||||||
|
|
|
||||||
|
<server>
|
||||||
|
<id>deploymentRepo</id>
|
||||||
|
<username>repouser</username>
|
||||||
|
<password>repopwd</password>
|
||||||
|
</server>
|
||||||
|
-->
|
||||||
|
|
||||||
|
<!-- Another sample, using keys to authenticate.
|
||||||
|
<server>
|
||||||
|
<id>siteServer</id>
|
||||||
|
<privateKey>/path/to/private/key</privateKey>
|
||||||
|
<passphrase>optional; leave empty if not used.</passphrase>
|
||||||
|
</server>
|
||||||
|
-->
|
||||||
|
</servers>
|
||||||
|
|
||||||
|
<!-- mirrors
|
||||||
|
| This is a list of mirrors to be used in downloading artifacts from remote repositories.
|
||||||
|
|
|
||||||
|
| It works like this: a POM may declare a repository to use in resolving certain artifacts.
|
||||||
|
| However, this repository may have problems with heavy traffic at times, so people have mirrored
|
||||||
|
| it to several places.
|
||||||
|
|
|
||||||
|
| That repository definition will have a unique id, so we can create a mirror reference for that
|
||||||
|
| repository, to be used as an alternate download site. The mirror site will be the preferred
|
||||||
|
| server for that repository.
|
||||||
|
|-->
|
||||||
|
<mirrors>
|
||||||
|
<!-- mirror
|
||||||
|
| Specifies a repository mirror site to use instead of a given repository. The repository that
|
||||||
|
| this mirror serves has an ID that matches the mirrorOf element of this mirror. IDs are used
|
||||||
|
| for inheritance and direct lookup purposes, and must be unique across the set of mirrors.
|
||||||
|
|
|
||||||
|
-->
|
||||||
|
<mirror>
|
||||||
|
<id>mirrorId</id>
|
||||||
|
<mirrorOf>repositoryId</mirrorOf>
|
||||||
|
<name>Human Readable Name for this Mirror.</name>
|
||||||
|
<url>__EXTERNAL_REPO_PLACEHOLDER__</url>
|
||||||
|
</mirror>
|
||||||
|
|
||||||
|
</mirrors>
|
||||||
|
|
||||||
|
<!-- profiles
|
||||||
|
| This is a list of profiles which can be activated in a variety of ways, and which can modify
|
||||||
|
| the build process. Profiles provided in the settings.xml are intended to provide local machine-
|
||||||
|
| specific paths and repository locations which allow the build to work in the local environment.
|
||||||
|
|
|
||||||
|
| For example, if you have an integration testing plugin - like cactus - that needs to know where
|
||||||
|
| your Tomcat instance is installed, you can provide a variable here such that the variable is
|
||||||
|
| dereferenced during the build process to configure the cactus plugin.
|
||||||
|
|
|
||||||
|
| As noted above, profiles can be activated in a variety of ways. One way - the activeProfiles
|
||||||
|
| section of this document (settings.xml) - will be discussed later. Another way essentially
|
||||||
|
| relies on the detection of a system property, either matching a particular value for the property,
|
||||||
|
| or merely testing its existence. Profiles can also be activated by JDK version prefix, where a
|
||||||
|
| value of '1.4' might activate a profile when the build is executed on a JDK version of '1.4.2_07'.
|
||||||
|
| Finally, the list of active profiles can be specified directly from the command line.
|
||||||
|
|
|
||||||
|
| NOTE: For profiles defined in the settings.xml, you are restricted to specifying only artifact
|
||||||
|
| repositories, plugin repositories, and free-form properties to be used as configuration
|
||||||
|
| variables for plugins in the POM.
|
||||||
|
|
|
||||||
|
|-->
|
||||||
|
<profiles>
|
||||||
|
<!-- profile
|
||||||
|
| Specifies a set of introductions to the build process, to be activated using one or more of the
|
||||||
|
| mechanisms described above. For inheritance purposes, and to activate profiles via <activatedProfiles/>
|
||||||
|
| or the command line, profiles have to have an ID that is unique.
|
||||||
|
|
|
||||||
|
| An encouraged best practice for profile identification is to use a consistent naming convention
|
||||||
|
| for profiles, such as 'env-dev', 'env-test', 'env-production', 'user-jdcasey', 'user-brett', etc.
|
||||||
|
| This will make it more intuitive to understand what the set of introduced profiles is attempting
|
||||||
|
| to accomplish, particularly when you only have a list of profile id's for debug.
|
||||||
|
|
|
||||||
|
| This profile example uses the JDK version to trigger activation, and provides a JDK-specific repo.
|
||||||
|
<profile>
|
||||||
|
<id>jdk-1.4</id>
|
||||||
|
|
||||||
|
<activation>
|
||||||
|
<jdk>1.4</jdk>
|
||||||
|
</activation>
|
||||||
|
|
||||||
|
<repositories>
|
||||||
|
<repository>
|
||||||
|
<id>jdk14</id>
|
||||||
|
<name>Repository for JDK 1.4 builds</name>
|
||||||
|
<url>http://www.myhost.com/maven/jdk14</url>
|
||||||
|
<layout>default</layout>
|
||||||
|
<snapshotPolicy>always</snapshotPolicy>
|
||||||
|
</repository>
|
||||||
|
</repositories>
|
||||||
|
</profile>
|
||||||
|
-->
|
||||||
|
|
||||||
|
<!--
|
||||||
|
| Here is another profile, activated by the system property 'target-env' with a value of 'dev',
|
||||||
|
| which provides a specific path to the Tomcat instance. To use this, your plugin configuration
|
||||||
|
| might hypothetically look like:
|
||||||
|
|
|
||||||
|
| ...
|
||||||
|
| <plugin>
|
||||||
|
| <groupId>org.myco.myplugins</groupId>
|
||||||
|
| <artifactId>myplugin</artifactId>
|
||||||
|
|
|
||||||
|
| <configuration>
|
||||||
|
| <tomcatLocation>${tomcatPath}</tomcatLocation>
|
||||||
|
| </configuration>
|
||||||
|
| </plugin>
|
||||||
|
| ...
|
||||||
|
|
|
||||||
|
| NOTE: If you just wanted to inject this configuration whenever someone set 'target-env' to
|
||||||
|
| anything, you could just leave off the <value/> inside the activation-property.
|
||||||
|
|
|
||||||
|
<profile>
|
||||||
|
<id>env-dev</id>
|
||||||
|
|
||||||
|
<activation>
|
||||||
|
<property>
|
||||||
|
<name>target-env</name>
|
||||||
|
<value>dev</value>
|
||||||
|
</property>
|
||||||
|
</activation>
|
||||||
|
|
||||||
|
<properties>
|
||||||
|
<tomcatPath>/path/to/tomcat/instance</tomcatPath>
|
||||||
|
</properties>
|
||||||
|
</profile>
|
||||||
|
-->
|
||||||
|
</profiles>
|
||||||
|
|
||||||
|
<!-- activeProfiles
|
||||||
|
| List of profiles that are active for all builds.
|
||||||
|
|
|
||||||
|
<activeProfiles>
|
||||||
|
<activeProfile>alwaysActiveProfile</activeProfile>
|
||||||
|
<activeProfile>anotherAlwaysActiveProfile</activeProfile>
|
||||||
|
</activeProfiles>
|
||||||
|
-->
|
||||||
|
</settings>
|
Loading…
Reference in New Issue
Block a user