diff --git a/README.md b/README.md
index c525967..6169014 100644
--- a/README.md
+++ b/README.md
@@ -1,14 +1,4 @@
 # antlrworks
 
-ANTLRWorks is a novel grammar development environment for ANTLR v3 grammars
-written by Jean Bovet (with suggested use cases from Terence Parr). It combines
-an excellent grammar-aware editor with an interpreter for rapid prototyping and
-a language-agnostic debugger for isolating grammar errors. ANTLRWorks helps
-eliminate grammar nondeterminisms, one of the most difficult problems for
-beginners and experts alike, by highlighting nondeterministic paths in the
-syntax diagram associated with a grammar. ANTLRWorks' goal is to make grammars
-more accessible to the average programmer, improve maintainability and
-readability of grammars by providing excellent grammar navigation and
-refactoring tools, and address the most common questions and problems
-encountered by grammar developers.
+ANTLRWorks is a novel grammar development environment for ANTLR v3 grammars written by Jean Bovet (with suggested use cases from Terence Parr). It combines an excellent grammar-aware editor with an interpreter for rapid prototyping and a language-agnostic debugger for isolating grammar errors. ANTLRWorks helps eliminate grammar nondeterminisms, one of the most difficult problems for beginners and experts alike, by highlighting nondeterministic paths in the syntax diagram associated with a grammar. ANTLRWorks' goal is to make grammars more accessible to the average programmer, improve maintainability and readability of grammars by providing excellent grammar navigation and refactoring tools, and address the most common questions and problems encountered by grammar developers.
 
diff --git a/antlrworks.desktop b/antlrworks.desktop
index 4c5c5e4..ac36279 100644
--- a/antlrworks.desktop
+++ b/antlrworks.desktop
@@ -1,6 +1,6 @@
 [Desktop Entry]
 Name=ANTLRWorks
-Comment=Grammar development environment for ANTLR v3 grammars
+Comment=A netbeans based grammar IDE
 Exec=antlrworks
 Icon=antlrworks
 Terminal=false
diff --git a/antlrworks.spec b/antlrworks.spec
index b82440b..96c773b 100644
--- a/antlrworks.spec
+++ b/antlrworks.spec
@@ -1,88 +1,49 @@
 Name:          antlrworks
-Version:       1.4
+Version:       2.1
 Release:       1mamba
 Summary:       The ANTLR GUI Development Environment
 Group:         Graphical Desktop/Applications/Development
 Vendor:        openmamba
 Distribution:  openmamba
-Packager:      gil <puntogil@libero.it>
-URL:           http://www.antlr.org/works/index.html
-Source0:       http://www.antlr.org/download/antlrworks-%{version}-src.zip
+Packager:      Silvan Calarco <silvan.calarco@mambasoft.it>
+URL:           http://tunnelvisionlabs.com/products/demo/antlrworks
+Source0:       http://tunnelvisionlabs.com/downloads/antlr/2013-07-21-antlrworks-%{version}.zip
 Source1:       antlrworks-script
 Source2:       antlrworks.desktop
+Source3:       https://github.com/antlr/antlrworks/raw/master/resources/icons/app.png
 Patch0:        antlrworks-1.4-build_xml.patch
 Patch1:        antlrworks-1.4-BrowserLauncher.patch
 License:       BSD
-BuildRequires: apache-ant
-BuildRequires: antlr3
-BuildRequires: desktop-file-utils
-BuildRequires: jgoodies-forms
-Requires:      antlr
-Requires:      antlr3
+## AUTOBUILDREQ-BEGIN
+## AUTOBUILDREQ-END
+BuildRequires: javapackages
+Requires:      java-environment
+#Requires:      antlr
 Requires:      graphviz
-Requires:      hicolor-icon-theme
-Requires:      java-stringtemplate32
-Requires:      jgoodies-forms
-Requires:      jpackage-utils
-BuildRoot:     %{_tmppath}/%{name}-%{version}-root
 
 %description
-ANTLRWorks is a novel grammar development environment for ANTLR v3 grammars
-written by Jean Bovet (with suggested use cases from Terence Parr). It combines
-an excellent grammar-aware editor with an interpreter for rapid prototyping and
-a language-agnostic debugger for isolating grammar errors. ANTLRWorks helps
-eliminate grammar nondeterminisms, one of the most difficult problems for
-beginners and experts alike, by highlighting nondeterministic paths in the
-syntax diagram associated with a grammar. ANTLRWorks' goal is to make grammars
-more accessible to the average programmer, improve maintainability and
-readability of grammars by providing excellent grammar navigation and
-refactoring tools, and address the most common questions and problems
-encountered by grammar developers.
+ANTLRWorks is a novel grammar development environment for ANTLR v3 grammars written by Jean Bovet (with suggested use cases from Terence Parr). It combines an excellent grammar-aware editor with an interpreter for rapid prototyping and a language-agnostic debugger for isolating grammar errors. ANTLRWorks helps eliminate grammar nondeterminisms, one of the most difficult problems for beginners and experts alike, by highlighting nondeterministic paths in the syntax diagram associated with a grammar. ANTLRWorks' goal is to make grammars more accessible to the average programmer, improve maintainability and readability of grammars by providing excellent grammar navigation and refactoring tools, and address the most common questions and problems encountered by grammar developers.
 
 %prep
 %setup -q -c %{name}-%{version}
-%patch0 -p0
-%patch1 -p0
-
-for j in $(find . -name '*.class' -o -name '*.jar'); do
-	rm -rf $j
-done
 
 %build
 
-export CLASSPATH=$(build-classpath antlr antlr3 antlr3-runtime jgoodies-forms stringtemplate32)
-ant build
-
 %install
 [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
 
-mkdir -p %{buildroot}%{_javadir}
+cd antlrworks2
 
-install -pm 0644 dist/antlrworks-%{version}.jar %{buildroot}%{_javadir}/antlrworks-%{version}.jar
+mkdir -p %{buildroot}/{etc,usr/{share/antlrworks,bin}}
+chmod +x bin/antlrworks2
+cp -r * %{buildroot}%{_datadir}/antlrworks
 
-(
-	cd %{buildroot}%{_javadir}/
-	for jar in *-%{version}.jar; do
-		ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
-	done
-)
+ln -s ../share/antlrworks/bin/antlrworks2 %{buildroot}%{_bindir}/antlrworks
 
-mkdir -p %{buildroot}%{_bindir}
-install -pm 755 %{SOURCE1} %{buildroot}%{_bindir}/antlrworks
+rm -f %{buildroot}%{_bindir}/antlrworks*.exe
 
-desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
-
-mkdir -p %{buildroot}%{_datadir}/icons/hicolor/128x128/apps
-install -pm 644 resources/icons/app.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/antlrworks.png
-mkdir -p %{buildroot}%{_datadir}/pixmaps
-install -pm 644 resources/icons/app.png %{buildroot}%{_datadir}/pixmaps/antlrworks.png
-
-for i in 16 32 64; do
-  mkdir -p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
-  install -pm 644 resources/icons/app_${i}x${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/antlrworks.png
-done
-
-desktop-file-validate %{buildroot}%{_datadir}/applications/antlrworks.desktop
+install -D -pm 644 %{SOURCE2} %{buildroot}%{_datadir}/applications/antlrworks.desktop
+install -D -pm 644 %{SOURCE3} %{buildroot}%{_datadir}/pixmaps/antlrworks.png
 
 %clean
 [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@@ -101,13 +62,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 
 %files
 %defattr(-,root,root)
-%{_javadir}/antlrworks-%{version}.jar
-%{_javadir}/antlrworks.jar
 %{_bindir}/antlrworks
+%dir %{_datadir}/antlrworks
+%{_datadir}/antlrworks/*
 %{_datadir}/applications/antlrworks.desktop
-%{_datadir}/icons/hicolor/*x*/apps/antlrworks.png
 %{_datadir}/pixmaps/antlrworks.png
 
 %changelog
+* Sat Apr 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1-1mamba
+- update to 2.1
+
 * Thu Nov 25 2010 gil <puntogil@libero.it> 1.4-1mamba
 - package created by autospec
diff --git a/app.png b/app.png
new file mode 100644
index 0000000..9ac0ee7
Binary files /dev/null and b/app.png differ