diff --git a/README.md b/README.md
index 75f307f..fa16327 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,4 @@
# antlr
+ANother Tool for Language Recognition, (formerly PCCTS) is a language tool that provides a framework for constructing recognizers, compilers, and translators from grammatical descriptions containing Java, C#, C++, or Python actions. ANTLR provides excellent support for tree construction, tree walking, and translation.
+
diff --git a/antlr-2.7.5-gcc4.patch b/antlr-2.7.5-gcc4.patch
new file mode 100644
index 0000000..cdc98af
--- /dev/null
+++ b/antlr-2.7.5-gcc4.patch
@@ -0,0 +1,18 @@
+diff -Nru antlr-2.7.5.orig/antlr/Makefile.in antlr-2.7.5/antlr/Makefile.in
+--- antlr-2.7.5.orig/antlr/Makefile.in 2005-08-17 15:29:32.000000000 +0200
++++ antlr-2.7.5/antlr/Makefile.in 2005-08-17 15:30:18.000000000 +0200
+@@ -269,13 +269,7 @@
+ @abs_top_srcdir@/antlr/debug/misc/JTreeASTPanel.java \
+ $(eol)
+
+-
+-## damned ugly hack ..
+-ifeq (gcj,@javac@)
+- antlr_java_FILES = $(antlr_java1_FILES)
+-else
+- antlr_java_FILES = $(antlr_java1_FILES) $(antlr_swing_FILES)
+-endif
++antlr_java_FILES = $(antlr_java1_FILES) $(antlr_swing_FILES)
+
+ ## rule how to compile java files
+ @ANTLR_JAR@ :: $(antlr_java_FILES)
diff --git a/antlr-2.7.7-build.xml b/antlr-2.7.7-build.xml
new file mode 100644
index 0000000..eadf11b
--- /dev/null
+++ b/antlr-2.7.7-build.xml
@@ -0,0 +1,71 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/antlr-2.7.7-includestrings.patch b/antlr-2.7.7-includestrings.patch
new file mode 100644
index 0000000..2640c07
--- /dev/null
+++ b/antlr-2.7.7-includestrings.patch
@@ -0,0 +1,10 @@
+--- antlr-2.7.7/lib/cpp/antlr/CharScanner.hpp 2006-11-01 22:37:17.000000000 +0100
++++ antlr-2.7.7/lib/cpp/antlr/CharScanner.hpp-gil 2009-02-21 00:03:22.000000000 +0100
+@@ -9,6 +9,7 @@
+ */
+
+ #include
++#include
+
+ #include