rebuilt with libgda 6.0.0 (upstream patch added) [release 3.34.0-6mamba;Tue Apr 26 2022]

This commit is contained in:
Silvan Calarco 2024-01-05 20:25:33 +01:00
parent 9a21fa2826
commit 4ab71f595f
3 changed files with 112 additions and 36 deletions

View File

@ -1,6 +1,5 @@
# anjuta # anjuta
Anjuta is a versatile Integrated Development Environment (IDE) for C and C++ on GNU/Linux. It has been written for GTK/GNOME and features a number of advanced programming facilities. These include project management, application wizards, an on-board interactive debugger, and a powerful source editor with source browsing and syntax highlighting. Anjuta is a versatile Integrated Development Environment (IDE) for C and C++ on GNU/Linux. It has been written for GTK/GNOME and features a number of advanced programming facilities. These include project management, application wizards, an on-board interactive debugger, and a powerful source editor with source browsing and syntax highlighting.
Anjuta is an effort to marry the flexibility and power of text-based command-line tools with the ease-of-use of the GNOME graphical user interface. That is why it has been made as user-friendly as possible. Anjuta is an effort to marry the flexibility and power of text-based command-line tools with the ease-of-use of the GNOME graphical user interface. That is why it has been made as user-friendly as possible.

View File

@ -0,0 +1,84 @@
From b99761d50f9f0c2bac63e5a9844deda4761b50d7 Mon Sep 17 00:00:00 2001
From: Ting-Wei Lan <lantw@src.gnome.org>
Date: Sat, 22 Sep 2018 14:51:42 +0800
Subject: [PATCH] symbol-db: Fix build with the current libgda master branch
GdaTimestamp has been removed and replaced by GDateTime. The version
number went back to 5.90 and bumped to 5.91 on the libgda master branch.
---
configure.ac | 2 +-
plugins/symbol-db/symbol-db-engine-core.c | 21 +++++++++++++++++++++
2 files changed, 22 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index cc81229e6..f1345dda4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,7 @@ GTHREAD_REQUIRED=2.22.0
GDK_PIXBUF_REQUIRED=2.0.0
GDA4_REQUIRED=4.2.0
GDA5_REQUIRED=5.0.0
-GDA6_REQUIRED=5.99.0
+GDA6_REQUIRED=5.90.0
LIBXML_REQUIRED=2.4.23
GDL_REQUIRED=3.5.5
LIBWNCK_REQUIRED=2.12
diff --git a/plugins/symbol-db/symbol-db-engine-core.c b/plugins/symbol-db/symbol-db-engine-core.c
index 37d6e048a..c3f0d4f55 100644
--- a/plugins/symbol-db/symbol-db-engine-core.c
+++ b/plugins/symbol-db/symbol-db-engine-core.c
@@ -5443,7 +5443,11 @@ symbol_db_engine_update_project_symbols (SymbolDBEngine *dbe,
G_TYPE_STRING,
G_TYPE_INT,
G_TYPE_INT,
+#ifdef HAVE_GDA6
+ G_TYPE_DATE_TIME,
+#else
GDA_TYPE_TIMESTAMP,
+#endif
G_TYPE_NONE
};
data_model = gda_connection_statement_execute_select_full (priv->db_connection,
@@ -5473,7 +5477,11 @@ symbol_db_engine_update_project_symbols (SymbolDBEngine *dbe,
for (i = 0; i < num_rows; i++)
{
const GValue *value, *value1;
+#ifdef HAVE_GDA6
+ GDateTime *timestamp;
+#else
const GdaTimestamp *timestamp;
+#endif
const gchar *file_name;
gchar *file_abs_path = NULL;
struct tm filetm;
@@ -5530,17 +5538,30 @@ symbol_db_engine_update_project_symbols (SymbolDBEngine *dbe,
}
+#ifdef HAVE_GDA6
+ timestamp = g_value_get_boxed (value1);
+#else
timestamp = gda_value_get_timestamp (value1);
+#endif
/* fill a struct tm with the date retrieved by the string. */
/* string is something like '2007-04-18 23:51:39' */
memset (&filetm, 0, sizeof (struct tm));
+#ifdef HAVE_GDA6
+ filetm.tm_year = g_date_time_get_year (timestamp) - 1900;
+ filetm.tm_mon = g_date_time_get_month (timestamp) - 1;
+ filetm.tm_mday = g_date_time_get_day_of_month (timestamp);
+ filetm.tm_hour = g_date_time_get_hour (timestamp);
+ filetm.tm_min = g_date_time_get_minute (timestamp);
+ filetm.tm_sec = g_date_time_get_second (timestamp);
+#else
filetm.tm_year = timestamp->year - 1900;
filetm.tm_mon = timestamp->month - 1;
filetm.tm_mday = timestamp->day;
filetm.tm_hour = timestamp->hour;
filetm.tm_min = timestamp->minute;
filetm.tm_sec = timestamp->second;
+#endif
/* remove one hour to the db_file_time. */
db_time = mktime (&filetm) - 3600;

View File

@ -1,47 +1,45 @@
%define majver %(echo %version|cut -d. -f1-2) %define majver %(echo %version|cut -d. -f1-2)
Name: anjuta Name: anjuta
Version: 3.34.0 Version: 3.34.0
Release: 4mamba Release: 6mamba
Summary: Integrated development environment for C and C++ Summary: Integrated development environment for C and C++
Group: Graphical Desktop/Applications/Development Group: Graphical Desktop/Applications/Development
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://anjuta.sourceforge.net/ URL: http://anjuta.org/
Source: ftp://ftp.gnome.org/pub/GNOME/sources/anjuta/%{majver}/anjuta-%{version}.tar.xz Source: https://download.gnome.org/sources/anjuta/%{majver}/anjuta-%{version}.tar.xz
Patch0: anjuta-3.8.3-gcc-4.8.patch Patch0: anjuta-3.8.3-gcc-4.8.patch
Patch1: anjuta-3.20.0-gcc-6.1.0.patch Patch1: anjuta-3.20.0-gcc-6.1.0.patch
Patch2: anjuta-3.34.0-libgda-6.0.0.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glade-devel BuildRequires: glade-devel
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: ldconfig
BuildRequires: libapr-devel BuildRequires: libapr-devel
BuildRequires: libaprutil-devel BuildRequires: libaprutil-devel
BuildRequires: libatk-devel BuildRequires: libatk-devel
BuildRequires: libblkid-devel BuildRequires: libblkid-devel
BuildRequires: libbrotli-devel
BuildRequires: libbzip2-devel BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel BuildRequires: libcairo-devel
BuildRequires: libdb47-devel BuildRequires: libdb53-devel
BuildRequires: libdbus-devel
BuildRequires: libdevhelp-devel BuildRequires: libdevhelp-devel
BuildRequires: libe2fs-devel BuildRequires: libe2fs-devel
BuildRequires: libexpat-devel BuildRequires: libexpat-devel
BuildRequires: libffi-devel BuildRequires: libffi-devel
BuildRequires: libfreetype-devel BuildRequires: libfreetype-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libgcrypt-devel BuildRequires: libgda-devel
BuildRequires: libgda4-devel
BuildRequires: libgdk-pixbuf-devel BuildRequires: libgdk-pixbuf-devel
BuildRequires: libgdl-devel BuildRequires: libgdl-devel
BuildRequires: libglib-devel BuildRequires: libglib-devel
BuildRequires: libgnome-keyring-devel
BuildRequires: libgpg-error-devel
BuildRequires: libgraphite2-devel BuildRequires: libgraphite2-devel
BuildRequires: libgtk-devel BuildRequires: libgtk3-devel
BuildRequires: libgtksourceview3-devel BuildRequires: libgtksourceview3-devel
BuildRequires: libharfbuzz-devel BuildRequires: libharfbuzz-devel
BuildRequires: libkrb5-devel BuildRequires: libkrb5-devel
BuildRequires: liblz4-devel
BuildRequires: liblzma-devel BuildRequires: liblzma-devel
BuildRequires: libmagic-devel BuildRequires: libmagic-devel
BuildRequires: libmount-devel BuildRequires: libmount-devel
@ -57,9 +55,10 @@ BuildRequires: libsasl2-devel
BuildRequires: libselinux-devel BuildRequires: libselinux-devel
BuildRequires: libsepol-devel BuildRequires: libsepol-devel
BuildRequires: libserf-devel BuildRequires: libserf-devel
BuildRequires: libsoup-devel BuildRequires: libsoup2-devel
BuildRequires: libsqlite-devel BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libutf8proc-devel
BuildRequires: libuuid-devel BuildRequires: libuuid-devel
BuildRequires: libvte-devel BuildRequires: libvte-devel
BuildRequires: libwebkit2gtk-devel BuildRequires: libwebkit2gtk-devel
@ -84,14 +83,13 @@ BuildRequires: gdb
BuildRequires: patch BuildRequires: patch
BuildRequires: libdevhelp-devel >= 3.34.0 BuildRequires: libdevhelp-devel >= 3.34.0
BuildRequires: libgtksourceview-devel >= %{majver} BuildRequires: libgtksourceview-devel >= %{majver}
BuildRequires: glade-devel >= 3.16 BuildRequires: glade-devel >= 3.38.2
Provides: perl(GBF::Make) = %{version}-%{release} Provides: perl(GBF::Make) = %{version}-%{release}
Provides: gnome-build Provides: gnome-build
Obsoletes: gnome-build Obsoletes: gnome-build < 3.34.0-5mamba
Provides: libanjuta Provides: libanjuta
Obsoletes: libanjuta Obsoletes: libanjuta < 3.34.0-5mamba
Requires: autoconf Requires: autoconf
#Requires: autoconf2.13
Requires: autogen Requires: autogen
Requires: libopts Requires: libopts
Requires: automake Requires: automake
@ -99,25 +97,13 @@ Requires: cvs
Requires: devhelp Requires: devhelp
Requires: devhelp-plugins Requires: devhelp-plugins
Requires: gdb Requires: gdb
Requires: glade3
Requires: indent Requires: indent
#Requires: libglade
#Requires: libglademm
#Requires: libgnomemm-devel
Requires: make Requires: make
Requires: patch Requires: patch
Requires: libgda4-sqlite Requires: libgda-sqlite
BuildRoot: %{_tmppath}/%{name}-%{version}-root
#------------------------------------------------------------------
#Conditionally built plugins:
#-------------------------------------------------------------------
#Building devhelp plugin: ...............................NO
#Building new (unstable) Symbol-db plugin: .......,,.....NO
#-------------------------------------------------------------------
%description %description
Anjuta is a versatile Integrated Development Environment (IDE) for C and C++ on GNU/Linux. It has been written for GTK/GNOME and features a number of advanced programming facilities. These include project management, application wizards, an on-board interactive debugger, and a powerful source editor with source browsing and syntax highlighting. Anjuta is a versatile Integrated Development Environment (IDE) for C and C++ on GNU/Linux. It has been written for GTK/GNOME and features a number of advanced programming facilities. These include project management, application wizards, an on-board interactive debugger, and a powerful source editor with source browsing and syntax highlighting.
Anjuta is an effort to marry the flexibility and power of text-based command-line tools with the ease-of-use of the GNOME graphical user interface. That is why it has been made as user-friendly as possible. Anjuta is an effort to marry the flexibility and power of text-based command-line tools with the ease-of-use of the GNOME graphical user interface. That is why it has been made as user-friendly as possible.
%package devel %package devel
@ -127,10 +113,8 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel %description devel
Anjuta is a versatile Integrated Development Environment (IDE) for C and C++ on GNU/Linux. It has been written for GTK/GNOME and features a number of advanced programming facilities. These include project management, application wizards, an on-board interactive debugger, and a powerful source editor with source browsing and syntax highlighting. Anjuta is a versatile Integrated Development Environment (IDE) for C and C++ on GNU/Linux. It has been written for GTK/GNOME and features a number of advanced programming facilities. These include project management, application wizards, an on-board interactive debugger, and a powerful source editor with source browsing and syntax highlighting.
Anjuta is an effort to marry the flexibility and power of text-based command-line tools with the ease-of-use of the GNOME graphical user interface. That is why it has been made as user-friendly as possible. Anjuta is an effort to marry the flexibility and power of text-based command-line tools with the ease-of-use of the GNOME graphical user interface. That is why it has been made as user-friendly as possible.
This package contains libraries and header files needed for development.
This package contains libraries and header files need for development.
%package static %package static
Group: Development/Libraries Group: Development/Libraries
@ -139,8 +123,7 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description static %description static
%{name} is part of the autogen build system %{name} is part of the autogen build system
This package contains static libraries needed for development.
This package contains static libraries need for development.
%package doc %package doc
Summary: Documentation for Anjuta DevStudio Summary: Documentation for Anjuta DevStudio
@ -158,6 +141,9 @@ Documentation for Anjuta DevStudio provided in DocBook format.
#:<< ___EOF #:<< ___EOF
#%patch0 -p1 #%patch0 -p1
%patch1 -p1 %patch1 -p1
%patch2 -p1 -b .libgda-6.0.0
./autogen.sh
%build %build
#:<< ____EOF #:<< ____EOF
@ -170,7 +156,8 @@ Documentation for Anjuta DevStudio provided in DocBook format.
# --host= : workaround since 3.6.0 # --host= : workaround since 3.6.0
%make -j1 GDA_LIBS="`pkg-config --libs libgda-4.0` -lrt" %make
%install %install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -267,6 +254,12 @@ fi
%doc %{_docdir}/anjuta/* %doc %{_docdir}/anjuta/*
%changelog %changelog
* Tue Apr 26 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.34.0-6mamba
- rebuilt with libgda 6.0.0 (upstream patch added)
* Mon Apr 25 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.34.0-5mamba
- rebuilt with glade 3.38.2
* Sun Apr 05 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.34.0-4mamba * Sun Apr 05 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.34.0-4mamba
- rebuilt with debug package - rebuilt with debug package