added upstream patch to fix build on aarch64 [release 0.11.1-2mamba;Mon Jan 06 2025]
This commit is contained in:
parent
a6b621afef
commit
83eab75053
44
anari-sdk-0.11.1-upstreram-aarch64_fix_helide_support.patch
Normal file
44
anari-sdk-0.11.1-upstreram-aarch64_fix_helide_support.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 8fc6f8ce445a56aaae73dababf7985b8f7a70ff0 Mon Sep 17 00:00:00 2001
|
||||
From: Jefferson Amstutz <jamstutz@nvidia.com>
|
||||
Date: Fri, 1 Nov 2024 01:36:24 +0000
|
||||
Subject: [PATCH] add helide support for aarch64 systems
|
||||
|
||||
---
|
||||
src/helide/external/embree/CMakeLists.txt | 12 +++++++++++-
|
||||
1 file changed, 11 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/helide/external/embree/CMakeLists.txt b/src/helide/external/embree/CMakeLists.txt
|
||||
index 694020cf..20249dc6 100644
|
||||
--- a/src/helide/external/embree/CMakeLists.txt
|
||||
+++ b/src/helide/external/embree/CMakeLists.txt
|
||||
@@ -3,6 +3,14 @@
|
||||
|
||||
project(local_embree LANGUAGES CXX)
|
||||
|
||||
+if (APPLE AND ${CMAKE_SYSTEM_PROCESSOR} STREQUAL "arm64")
|
||||
+ set(COMPILE_FOR_ARM ON)
|
||||
+elseif (UNIX AND ${CMAKE_SYSTEM_PROCESSOR} STREQUAL "aarch64")
|
||||
+ set(COMPILE_FOR_ARM ON)
|
||||
+else()
|
||||
+ set(COMPILE_FOR_ARM OFF)
|
||||
+endif()
|
||||
+
|
||||
option(EMBREE_GEOMETRY_CURVE "" ON)
|
||||
option(EMBREE_GEOMETRY_GRID "" OFF)
|
||||
option(EMBREE_GEOMETRY_INSTANCE "" ON)
|
||||
@@ -12,7 +20,7 @@ option(EMBREE_GEOMETRY_QUAD "" ON)
|
||||
option(EMBREE_GEOMETRY_SUBDIVISION "" OFF)
|
||||
option(EMBREE_GEOMETRY_TRIANGLE "" ON)
|
||||
option(EMBREE_GEOMETRY_USER "" OFF)
|
||||
-if ((APPLE OR UNIX) AND ${CMAKE_SYSTEM_PROCESSOR} STREQUAL "arm64")
|
||||
+if (COMPILE_FOR_ARM)
|
||||
option(EMBREE_ISA_NEON "" OFF)
|
||||
option(EMBREE_ISA_NEON2X "" ON)
|
||||
else()
|
||||
@@ -47,4 +55,6 @@ if (WIN32)
|
||||
INTERFACE
|
||||
/D__SSE__ /D__SSE2__ /D__SSE3__ /D__SSSE3__ /D__SSE4_1__ /D__SSE4_2__
|
||||
)
|
||||
+elseif(COMPILE_FOR_ARM)
|
||||
+ project_compile_options(INTERFACE -flax-vector-conversions -fsigned-char)
|
||||
endif()
|
@ -1,6 +1,6 @@
|
||||
Name: anari-sdk
|
||||
Version: 0.11.1
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: ANARI Software Development Kit (SDK)
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
@ -8,6 +8,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/KhronosGroup/ANARI-SDK
|
||||
Source: https://github.com/KhronosGroup/ANARI-SDK.git/v%{version}/ANARI-SDK-%{version}.tar.bz2
|
||||
Patch0: anari-sdk-0.11.1-upstreram-aarch64_fix_helide_support.patch
|
||||
License: Apache License 2.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -38,6 +39,7 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q -n ANARI-SDK-%{version}
|
||||
%patch 0 -p1 -b .upstreram-aarch64_fix_helide_support
|
||||
|
||||
%build
|
||||
%cmake
|
||||
@ -85,5 +87,8 @@ This package contains libraries and header files for developing applications tha
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Mon Jan 06 2025 Automatic Build System <autodist@openmamba.org> 0.11.1-2mamba
|
||||
- added upstream patch to fix build on aarch64
|
||||
|
||||
* Wed Jan 01 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 0.11.1-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user