automatic rebuild by autodist [release 0.2-3mamba;Tue Jul 16 2013]
This commit is contained in:
parent
d0f95e7f16
commit
962fc49212
@ -1,2 +1,4 @@
|
||||
# anagramarama
|
||||
|
||||
The aim is to find as many words as possible in the time available. Get the longest word and you'll advance to the next level.
|
||||
|
||||
|
89
anagramarama.install.patch
Normal file
89
anagramarama.install.patch
Normal file
@ -0,0 +1,89 @@
|
||||
diff -Nru anagramarama.orig/src/ag.c anagramarama/src/ag.c
|
||||
--- anagramarama.orig/src/ag.c 2005-07-20 12:47:54.000000000 +0200
|
||||
+++ anagramarama/src/ag.c 2005-07-20 14:27:32.000000000 +0200
|
||||
@@ -184,15 +184,15 @@
|
||||
***********************************************************/
|
||||
void bufferSounds(struct sound** soundCache){
|
||||
|
||||
- pushSound(&(*soundCache),"click-answer", "audio/click-answer.wav");
|
||||
- pushSound(&(*soundCache),"click-shuffle", "audio/click-shuffle.wav");
|
||||
- pushSound(&(*soundCache),"foundbig", "audio/foundbig.wav");
|
||||
- pushSound(&(*soundCache),"found", "audio/found.wav");
|
||||
- pushSound(&(*soundCache),"clear", "audio/clearword.wav");
|
||||
- pushSound(&(*soundCache),"duplicate", "audio/duplicate.wav");
|
||||
- pushSound(&(*soundCache),"badword", "audio/badword.wav");
|
||||
- pushSound(&(*soundCache),"shuffle", "audio/shuffle.wav");
|
||||
- pushSound(&(*soundCache),"clock-tick", "audio/clock-tick.wav");
|
||||
+ pushSound(&(*soundCache),"click-answer", "/usr/share/anagramarama-0.2/audio/click-answer.wav");
|
||||
+ pushSound(&(*soundCache),"click-shuffle", "/usr/share/anagramarama-0.2/audio/click-shuffle.wav");
|
||||
+ pushSound(&(*soundCache),"foundbig", "/usr/share/anagramarama-0.2/audio/foundbig.wav");
|
||||
+ pushSound(&(*soundCache),"found", "/usr/share/anagramarama-0.2/audio/found.wav");
|
||||
+ pushSound(&(*soundCache),"clear", "/usr/share/anagramarama-0.2/audio/clearword.wav");
|
||||
+ pushSound(&(*soundCache),"duplicate", "/usr/share/anagramarama-0.2/audio/duplicate.wav");
|
||||
+ pushSound(&(*soundCache),"badword", "/usr/share/anagramarama-0.2/audio/badword.wav");
|
||||
+ pushSound(&(*soundCache),"shuffle", "/usr/share/anagramarama-0.2/audio/shuffle.wav");
|
||||
+ pushSound(&(*soundCache),"clock-tick", "/usr/share/anagramarama-0.2/audio/clock-tick.wav");
|
||||
|
||||
}
|
||||
|
||||
@@ -982,7 +982,7 @@
|
||||
int done = 0;
|
||||
|
||||
filelocation = rand()%10000;
|
||||
- wordlist=fopen("wordlist.txt","r");
|
||||
+ wordlist=fopen("/usr/share/anagramarama-0.2/wordlist.txt","r");
|
||||
|
||||
for (i=0;i<=filelocation;i++){
|
||||
|
||||
@@ -992,7 +992,7 @@
|
||||
else{
|
||||
// go back to the start of the file
|
||||
fclose(wordlist);
|
||||
- fopen("wordlist.txt", "r");
|
||||
+ fopen("/usr/share/anagramarama-0.2/wordlist.txt", "r");
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1011,7 +1011,7 @@
|
||||
else{
|
||||
// go back to the start of the file
|
||||
fclose(wordlist);
|
||||
- fopen("wordlist.txt", "r");
|
||||
+ fopen("/usr/share/anagramarama-0.2/wordlist.txt", "r");
|
||||
fscanf(wordlist, "%s", wordFromList);
|
||||
}
|
||||
}
|
||||
@@ -1485,7 +1485,7 @@
|
||||
int i;
|
||||
|
||||
// show background
|
||||
- ShowBMP("images/background.bmp",screen, 0,0);
|
||||
+ ShowBMP("/usr/share/anagramarama-0.2/images/background.bmp",screen, 0,0);
|
||||
|
||||
destroyLetters(&(*letters));
|
||||
|
||||
@@ -1760,9 +1760,9 @@
|
||||
createDLBTree(&dlbHead);
|
||||
|
||||
// cache in-game graphics
|
||||
- letterBank = SDL_LoadBMP("images/letterBank.bmp");
|
||||
- smallLetterBank = SDL_LoadBMP("images/smallLetterBank.bmp");
|
||||
- numberBank = SDL_LoadBMP("images/numberBank.bmp");
|
||||
+ letterBank = SDL_LoadBMP("/usr/share/anagramarama-0.2/images/letterBank.bmp");
|
||||
+ smallLetterBank = SDL_LoadBMP("/usr/share/anagramarama-0.2/images/smallLetterBank.bmp");
|
||||
+ numberBank = SDL_LoadBMP("/usr/share/anagramarama-0.2/images/numberBank.bmp");
|
||||
|
||||
rootWord = malloc(sizeof(char)*9);
|
||||
newGame(&head, dlbHead, screen, &letters);
|
||||
diff -Nru anagramarama.orig/src/dlb.c anagramarama/src/dlb.c
|
||||
--- anagramarama.orig/src/dlb.c 2005-07-20 12:47:54.000000000 +0200
|
||||
+++ anagramarama/src/dlb.c 2005-07-20 14:27:32.000000000 +0200
|
||||
@@ -100,7 +100,7 @@
|
||||
//printf("createDLBTree\n");
|
||||
|
||||
// open wordlist file
|
||||
- wordlist = fopen("wordlist.txt", "r");
|
||||
+ wordlist = fopen("/usr/share/anagramarama-0.2/wordlist.txt", "r");
|
||||
|
||||
// get each word from the list
|
||||
while (fscanf(wordlist, "%s", wordFromList) != EOF){
|
BIN
anagramarama.png
Normal file
BIN
anagramarama.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 776 B |
82
anagramarama.spec
Normal file
82
anagramarama.spec
Normal file
@ -0,0 +1,82 @@
|
||||
Name: anagramarama
|
||||
Version: 0.2
|
||||
Release: 3mamba
|
||||
Summary: Anagramarama - a FREE word game for Linux
|
||||
Group: Graphical Desktop/Applications/Educational
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.coralquest.com/anagramarama/
|
||||
Source: http://www.omega.clara.net/anagramarama/dist/%{name}-%{version}.tar.gz
|
||||
Source1: anagramarama.png
|
||||
Patch1: anagramarama.install.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSDL_mixer-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libSDL-devel >= 1.2.8, libSDL_mixer-devel >= 1.2.6
|
||||
|
||||
%description
|
||||
The aim is to find as many words as possible in the time available. Get the longest word and you'll advance to the next level.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
mkdir -p %{buildroot}/usr/share/%{name}-%{version}/audio
|
||||
mkdir -p %{buildroot}/usr/share/%{name}-%{version}/images
|
||||
mkdir -p %{buildroot}/usr/bin
|
||||
|
||||
install -D -m 644 audio/*.wav %{buildroot}/usr/share/%{name}-%{version}/audio/
|
||||
install -D -m 644 images/*bmp %{buildroot}/usr/share/%{name}-%{version}/images/
|
||||
install -m 755 wordlist.txt %{buildroot}/usr/share/%{name}-%{version}/
|
||||
install -m 755 ag %{buildroot}/usr/bin
|
||||
|
||||
#Icon
|
||||
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||
install -D -m 644 %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/%{name}.png
|
||||
|
||||
# Create the system menu entry
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||
[Desktop Entry]
|
||||
Name=%{name}
|
||||
Comment=Anagramarama - a FREE word game for Linux
|
||||
Exec=ag
|
||||
Icon=%{_datadir}/pixmaps/anagramarama.png
|
||||
Terminal=0
|
||||
Type=Application
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=Education;
|
||||
EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_datadir}/%{name}-%{version}/audio/*.wav
|
||||
%{_datadir}/%{name}-%{version}/images/*.bmp
|
||||
%{_datadir}/%{name}-%{version}/*.txt
|
||||
%{_datadir}/applications/anagramarama.desktop
|
||||
%{_datadir}/pixmaps/anagramarama.png
|
||||
|
||||
%changelog
|
||||
* Tue Jul 16 2013 Automatic Build System <autodist@mambasoft.it> 0.2-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Jun 29 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2-2mamba
|
||||
- specfile updated and rebuilt
|
||||
|
||||
* Tue Jul 19 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.2-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user