rebuilt with binutils 2.24 [release 2.3.1-4mamba;Fri Dec 13 2013]

This commit is contained in:
Silvan Calarco 2024-01-05 20:22:34 +01:00
parent d48a1a7e0f
commit 554c0535c3
5 changed files with 399 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# amule
aMule is an eMule-like client for the eD2k and Kademlia networks, supporting multiple platforms.

156
aMule-2.1.3-wx.patch Normal file
View File

@ -0,0 +1,156 @@
diff -urN aMule-2.1.3.org/src/utils/wxCas/src/wxcasprefs.cpp aMule-2.1.3/src/utils/wxCas/src/wxcasprefs.cpp
--- aMule-2.1.3.org/src/utils/wxCas/src/wxcasprefs.cpp 2005-12-16 13:09:29.000000000 +0100
+++ aMule-2.1.3/src/utils/wxCas/src/wxcasprefs.cpp 2006-12-17 20:20:47.151203000 +0100
@@ -297,7 +297,7 @@
m_validateButton =
new wxButton ( this, ID_VALIDATE_BUTTON, wxString ( _( "Validate" ) ) );
m_cancelButton =
- new wxButton ( this, ID_CANCEL_BUTTON, wxString ( _( "Cancel" ) ) );
+ new wxButton ( this, wxID_CANCEL, wxString ( _( "Cancel" ) ) );
m_buttonHBox->Add ( m_validateButton, 0, wxALIGN_CENTER | wxALL, 5 );
m_buttonHBox->Add ( m_cancelButton, 0, wxALIGN_CENTER | wxALL, 5 );
@@ -321,7 +321,6 @@
EVT_BUTTON ( ID_OSPATH_BROWSE_BUTTON, WxCasPrefs::OnOSPathBrowseButton )
EVT_BUTTON ( ID_AUTOSTATIMG_BROWSE_BUTTON, WxCasPrefs::OnAutoStatImgBrowseButton )
EVT_BUTTON ( ID_VALIDATE_BUTTON, WxCasPrefs::OnValidateButton )
-EVT_BUTTON ( ID_CANCEL_BUTTON, WxCasPrefs::OnCancel ) // Defined in wxDialog
EVT_CHECKBOX ( ID_AUTOSTATIMG_CHECK, WxCasPrefs::OnAutoStatImgCheck )
EVT_CHECKBOX ( ID_FTP_UPDATE_CHECK, WxCasPrefs::OnFtpUpdateCheck )
END_EVENT_TABLE ()
--- aMule/src/utils/wxCas/src/wxcasprefs.h.org 2006-12-17 22:17:39.017417250 +0100
+++ aMule/src/utils/wxCas/src/wxcasprefs.h 2006-12-17 22:18:17.611829250 +0100
@@ -101,8 +101,7 @@
ID_AUTOSTATIMG_COMBO,
ID_AUTOSTATIMG_BROWSE_BUTTON,
ID_FTP_UPDATE_CHECK,
- ID_VALIDATE_BUTTON,
- ID_CANCEL_BUTTON
+ ID_VALIDATE_BUTTON
};
protected:
--- aMule/src/MuleGifCtrl.cpp 2006-02-03 20:14:05.000000000 +0100
+++ aMule/src/MuleGifCtrl.cpp 2006-11-19 19:35:33.000000000 +0100
@@ -24,7 +24,6 @@
#include <wx/mstream.h>
#include <wx/gifdecod.h>
-#include <wx/window.h>
#include <wx/dcbuffer.h>
#include "MuleGifCtrl.h"
@@ -35,6 +34,50 @@
EVT_ERASE_BACKGROUND(MuleGifCtrl::OnErase)
END_EVENT_TABLE()
+#if wxCHECK_VERSION(2, 7, 1)
+// Wrapper that emulates old wxGIFDecoder API
+
+class MuleGIFDecoder : public wxGIFDecoder {
+public:
+ MuleGIFDecoder(wxInputStream* stream, bool dummy) {
+ m_stream = stream;
+ dummy = dummy; // Unused.
+ m_nframe = 0;
+ }
+
+ ~MuleGIFDecoder() { /* don't delete the stream! */ }
+
+ wxGIFErrorCode ReadGIF() {
+ return LoadGIF(*m_stream);
+ }
+
+ void GoFirstFrame() { m_nframe = 0; }
+ void GoNextFrame(bool dummy) { m_nframe < GetFrameCount() ? m_nframe++ : m_nframe = 0; }
+ void GoLastFrame() { m_nframe = GetFrameCount(); }
+
+ void ConvertToImage(wxImage* image) { wxGIFDecoder::ConvertToImage(m_nframe, image); }
+
+ size_t GetLogicalScreenWidth() { return GetAnimationSize().GetWidth(); }
+ size_t GetLogicalScreenHeight() { return GetAnimationSize().GetHeight(); }
+
+ size_t GetLeft() { return 0; }
+ size_t GetTop() { return 0; }
+
+ long GetDelay() { return wxGIFDecoder::GetDelay(m_nframe); }
+
+private:
+ uint32_t m_nframe;
+ wxInputStream* m_stream;
+};
+
+#else
+class MuleGIFDecoder : public wxGIFDecoder {
+public:
+ MuleGIFDecoder(wxInputStream* stream, bool flag) : wxGIFDecoder(stream,flag) {};
+};
+#endif
+
+
MuleGifCtrl::MuleGifCtrl( wxWindow *parent, wxWindowID id, const wxPoint& pos,
const wxSize& size, long style, const wxValidator& validator,
@@ -66,7 +109,7 @@
}
wxMemoryInputStream stream(data, size);
- m_decoder = new wxGIFDecoder(&stream, TRUE);
+ m_decoder = new MuleGIFDecoder(&stream, TRUE);
if ( m_decoder->ReadGIF() != wxGIF_OK ) {
delete m_decoder;
m_decoder = NULL;
@@ -137,3 +180,4 @@
dc.DrawBitmap( m_frame, x + m_decoder->GetLeft(), y + m_decoder->GetTop(), true);
}
+// File_checked_for_headers
--- aMule/src/MuleGifCtrl.h 2006-01-01 06:17:25.000000000 +0100
+++ aMule/src/MuleGifCtrl.h 2006-11-18 05:01:22.000000000 +0100
@@ -27,11 +27,10 @@
#include <wx/control.h>
#include <wx/timer.h>
-#include <wx/bitmap.h>
const int GIFTIMERID = 271283;
-class wxGIFDecoder;
+class MuleGIFDecoder;
class wxBitmap;
/**
@@ -121,7 +120,7 @@
void OnErase( wxEraseEvent& WXUNUSED(event) ) {}
//! A pointer to the current gif-animation.
- wxGIFDecoder* m_decoder;
+ MuleGIFDecoder* m_decoder;
//! Timer used for the delay between each frame.
wxTimer m_timer;
//! Current frame.
@@ -133,3 +132,4 @@
#endif
+// File_checked_for_headers
--- aMule-2.1.3/src/MuleTextCtrl.cpp~ 2006-12-17 20:55:37.157820250 +0100
+++ aMule-2.1.3/src/MuleTextCtrl.cpp 2006-12-17 20:56:21.328580750 +0100
@@ -26,6 +26,7 @@
#include <wx/menu.h>
#include <wx/intl.h>
#include <wx/clipbrd.h>
+#include <wx/dataobj.h>
/**
* These are the IDs used to identify the different menu-items.
--- amule/src/amule.cpp~ 2006-12-17 21:53:26.474639000 +0100
+++ amule/src/amule.cpp 2006-12-17 21:55:40.307003000 +0100
@@ -96,6 +96,7 @@
#include <CoreFoundation/CFBundle.h>
#include <wx/mac/corefoundation/cfstring.h>
#endif
+ #include <wx/msgdlg.h>
#endif

8
aMule-wrapper.sh Normal file
View File

@ -0,0 +1,8 @@
#!/bin/bash
while [ 1 ]; do
/usr/bin/amule-bin
if [ $? -eq 0 ]; then
exit 0
fi
sleep 2
done

21
amule-2.3.1-gcc-4.7.patch Normal file
View File

@ -0,0 +1,21 @@
Index: b/src/ObservableQueue.h
===================================================================
--- a/src/ObservableQueue.h
+++ b/src/ObservableQueue.h
@@ -331,14 +331,14 @@
template <typename ValueType>
void CObservableQueue<ValueType>::ObserverAdded( ObserverType* o )
{
- NotifyObservers( EventType( EventType::STARTING ), o );
+ this->NotifyObservers( EventType( EventType::STARTING ), o );
}
template <typename ValueType>
void CObservableQueue<ValueType>::ObserverRemoved( ObserverType* o )
{
- NotifyObservers( EventType( EventType::STOPPING ), o );
+ this->NotifyObservers( EventType( EventType::STOPPING ), o );
}

212
amule.spec Normal file
View File

@ -0,0 +1,212 @@
Name: amule
Version: 2.3.1
Release: 4mamba
Summary: An eMule-like client for the eD2k and Kademlia file sharing networks
Group: Graphical Desktop/Applications/Internet
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.amule.org/
Source: http://downloads.sourceforge.net/project/amule/aMule/%{version}/aMule-%{version}.tar.xz
Source1: aMule-wrapper.sh
Patch1: aMule-2.1.3-wx.patch
Patch2: amule-2.3.1-gcc-4.7.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgd-devel
BuildRequires: libGeoIP-devel
BuildRequires: libjpeg-devel
BuildRequires: libpng-devel
BuildRequires: libreadline-devel
BuildRequires: libstdc++6-devel
BuildRequires: libupnp-devel
BuildRequires: libwxBase-unicode-devel
BuildRequires: libwxGTK-unicode-devel
BuildRequires: libX11-devel
BuildRequires: libXpm-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: gettext-devel
BuildRequires: libcurl-devel >= 7.12.0
BuildRequires: libopenssl-devel
BuildRequires: libcryptopp-devel >= 5.6.1
Provides: aMule
Obsoletes: aMule
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
#**** aMule Core ****
# Should aMule be compiled in debug mode? no
# Should aMule be compiled with profiling? no
# Crypto++ library/headers style? installed
# **** General Libraries and Tools ****
# Should ccache support be enabled? no
# Libraries aMule will use to build:
# wxWidgets 2.8.7 (gtk2,shared)
# crypto++ 5.5.2 (installed, in /usr)
# libupnp 1.6.6
# regex system
# libintl system
# libpng 1.2.29beta03
# libgd 2.0.35
# zlib 1.2.3
%description
aMule is an eMule-like client for the eD2k and Kademlia networks, supporting multiple platforms.
%prep
%setup -q -n aMule-%{version}
#%patch1 -p1
%patch2 -p1
%build
%configure \
--disable-debug \
--enable-optimize \
--enable-amule-gui \
--enable-webserver \
--enable-cas \
--enable-wxcas \
--enable-alc \
--enable-alcc \
--enable-amule-daemon \
--enable-amulecmd \
--enable-geoip
# --enable-webservergui \
# --enable-amulecmdgui \
%make
%install
test x%{buildroot} != x/ && rm -rf %{buildroot}
%makeinstall
mv %{buildroot}%{_bindir}/amule %{buildroot}%{_bindir}/amule-bin
install -m0755 %{SOURCE1} %{buildroot}%{_bindir}/amule
%find_lang amule
%clean
test x%{buildroot} != x/ && rm -rf %{buildroot}
%files -f amule.lang
%defattr(-,root,root,-)
%{_bindir}/alc
%{_bindir}/alcc
%{_bindir}/amule
%{_bindir}/amule-bin
%{_bindir}/amulecmd
%{_bindir}/amuled
%{_bindir}/amulegui
%{_bindir}/amuleweb
%{_bindir}/cas
%{_bindir}/ed2k
%{_bindir}/wxcas
%{_datadir}/cas/*
%{_datadir}/applications/alc.desktop
%{_datadir}/applications/amule.desktop
%{_datadir}/applications/amulegui.desktop
%{_datadir}/applications/wxcas.desktop
%{_datadir}/pixmaps/*
%dir %{_datadir}/amule
%dir %{_datadir}/amule/webserver
%{_datadir}/amule/webserver/*
%dir %{_datadir}/amule/skins
%{_datadir}/amule/skins/Mac_Gray.zip
%{_datadir}/amule/skins/gnome.zip
%{_datadir}/amule/skins/kde4.zip
%{_datadir}/amule/skins/priscilla.zip
%{_datadir}/amule/skins/tango.zip
%{_datadir}/amule/skins/xfce.zip
%{_mandir}/man1/*
%{_mandir}/*/man1/*
%dir %{_docdir}/amule
%{_docdir}/amule/*
%doc ABOUT-NLS
%changelog
* Fri Dec 13 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-4mamba
- rebuilt with binutils 2.24
* Wed Mar 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-3mamba
- binutils 2.32.2 rebuild
* Mon Nov 19 2012 Automatic Build System <autodist@mambasoft.it> 2.3.1-2mamba
- binutils 2.23.1 mass rebuild
* Wed Oct 24 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-1mamba
- update to 2.3.1
* Wed Nov 30 2011 Automatic Build System <autodist@mambasoft.it> 2.2.6-11mamba
- automatic update by autodist
* Mon Nov 28 2011 Automatic Build System <autodist@mambasoft.it> 2.2.6-10mamba
- automatic update by autodist
* Tue Jul 19 2011 Automatic Build System <autodist@mambasoft.it> 2.2.6-9mamba
- automatic update by autodist
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 2.2.6-8mamba
- automatic update by autodist
* Sun Dec 26 2010 Automatic Build System <autodist@mambasoft.it> 2.2.6-7mamba
- automatic update by autodist
* Fri Nov 12 2010 Automatic Build System <autodist@mambasoft.it> 2.2.6-6mamba
- automatic rebuild by autodist
* Fri Oct 29 2010 Automatic Build System <autodist@mambasoft.it> 2.2.6-5mamba
- automatic rebuild by autodist
* Sat Mar 06 2010 Automatic Build System <autodist@mambasoft.it> 2.2.6-4mamba
- automatic rebuild by autodist
* Tue Feb 16 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.6-3mamba
- added wrapper script to restart amule when it crashes
* Tue Oct 20 2009 Automatic Build System <autodist@mambasoft.it> 2.2.6-2mamba
- automatic rebuild by autodist
* Sat Oct 10 2009 Automatic Build System <autodist@mambasoft.it> 2.2.6-1mamba
- automatic update by autodist
* Thu Jun 04 2009 Automatic Build System <autodist@mambasoft.it> 2.2.5-1mamba
- automatic update to 2.2.5 by autodist
* Mon Apr 13 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.4-1mamba
- automatic update by autodist
* Wed Feb 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.3-1mamba
- automatic update by autodist
* Fri Oct 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-2mamba
- automatic rebuild by autodist
* Thu Aug 21 2008 gil <puntogil@libero.it> 2.2.2-1mamba
- update to 2.2.2
- new version is made with: libGeoIP, libupnp, libcryptopp
- removed patch
* Wed Nov 28 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.3-4mamba
- rebuilt against libbinutils 2.18
* Thu Sep 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.3-3mamba
- added patch and rebuilt with wxGTK 2.8
* Wed Feb 21 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.3-2qilnx
- rebuilt
* Wed Jun 21 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.3-1qilnx
- update to version 2.1.3 by autospec
* Fri Feb 24 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-1qilnx
- new version build
* Thu May 12 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-2qilnx
- rebuilt with stable 2.0.0 release and wxWidgets 2.6.0
* Thu Oct 07 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1qilnx
- package created by autospec