rebuilt with binutils 2.24 [release 2010.1.2.2.6-11mamba;Fri Dec 13 2013]

This commit is contained in:
Silvan Calarco 2024-01-05 20:22:49 +01:00
parent 0b5eba85bc
commit 5c3e00a2cb
8 changed files with 9639 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# amule-adunanza
aMule is an eMule-like client for the eD2k and Kademlia networks, supporting multiple platforms.
Adunanza is a special patched release specially made for use inside italian Fastweb networks.

14
aMule-2.1.3-servers.patch Normal file
View File

@ -0,0 +1,14 @@
diff -Nru aMule-2.1.3.orig/src/AdunanzA.h aMule-2.1.3/src/AdunanzA.h
--- aMule-2.1.3.orig/src/AdunanzA.h 2007-11-28 19:33:23.000000000 +0100
+++ aMule-2.1.3/src/AdunanzA.h 2007-11-28 19:49:40.000000000 +0100
@@ -66,8 +66,8 @@
// ADU URLS
#define ADURM_URL "http://update.adunanza.net/3-10/adu_remote.conf"
//#define ADU_SRV_URL "http://ocbmaurice.dyns.net/pl/slist.pl?download/server-best.met"
-#define ADU_SRV_URL "http://corpo.free.fr/server.met"
-#define ADU_NODES_DAT "http://update.adunanza.net/adu_nodes.dat"
+#define ADU_SRV_URL "http://elboiler.p2pforum.it/server.met"
+#define ADU_NODES_DAT "http://www.adunanza.net/files/downloads/nodes.dat"
/*
MAN Milano........................ 1.0.0.0/8

156
aMule-2.1.3-wx.patch Normal file
View File

@ -0,0 +1,156 @@
diff -urN aMule-2.1.3.org/src/utils/wxCas/src/wxcasprefs.cpp aMule-2.1.3/src/utils/wxCas/src/wxcasprefs.cpp
--- aMule-2.1.3.org/src/utils/wxCas/src/wxcasprefs.cpp 2005-12-16 13:09:29.000000000 +0100
+++ aMule-2.1.3/src/utils/wxCas/src/wxcasprefs.cpp 2006-12-17 20:20:47.151203000 +0100
@@ -297,7 +297,7 @@
m_validateButton =
new wxButton ( this, ID_VALIDATE_BUTTON, wxString ( _( "Validate" ) ) );
m_cancelButton =
- new wxButton ( this, ID_CANCEL_BUTTON, wxString ( _( "Cancel" ) ) );
+ new wxButton ( this, wxID_CANCEL, wxString ( _( "Cancel" ) ) );
m_buttonHBox->Add ( m_validateButton, 0, wxALIGN_CENTER | wxALL, 5 );
m_buttonHBox->Add ( m_cancelButton, 0, wxALIGN_CENTER | wxALL, 5 );
@@ -321,7 +321,6 @@
EVT_BUTTON ( ID_OSPATH_BROWSE_BUTTON, WxCasPrefs::OnOSPathBrowseButton )
EVT_BUTTON ( ID_AUTOSTATIMG_BROWSE_BUTTON, WxCasPrefs::OnAutoStatImgBrowseButton )
EVT_BUTTON ( ID_VALIDATE_BUTTON, WxCasPrefs::OnValidateButton )
-EVT_BUTTON ( ID_CANCEL_BUTTON, WxCasPrefs::OnCancel ) // Defined in wxDialog
EVT_CHECKBOX ( ID_AUTOSTATIMG_CHECK, WxCasPrefs::OnAutoStatImgCheck )
EVT_CHECKBOX ( ID_FTP_UPDATE_CHECK, WxCasPrefs::OnFtpUpdateCheck )
END_EVENT_TABLE ()
--- aMule/src/utils/wxCas/src/wxcasprefs.h.org 2006-12-17 22:17:39.017417250 +0100
+++ aMule/src/utils/wxCas/src/wxcasprefs.h 2006-12-17 22:18:17.611829250 +0100
@@ -101,8 +101,7 @@
ID_AUTOSTATIMG_COMBO,
ID_AUTOSTATIMG_BROWSE_BUTTON,
ID_FTP_UPDATE_CHECK,
- ID_VALIDATE_BUTTON,
- ID_CANCEL_BUTTON
+ ID_VALIDATE_BUTTON
};
protected:
--- aMule/src/MuleGifCtrl.cpp 2006-02-03 20:14:05.000000000 +0100
+++ aMule/src/MuleGifCtrl.cpp 2006-11-19 19:35:33.000000000 +0100
@@ -24,7 +24,6 @@
#include <wx/mstream.h>
#include <wx/gifdecod.h>
-#include <wx/window.h>
#include <wx/dcbuffer.h>
#include "MuleGifCtrl.h"
@@ -35,6 +34,50 @@
EVT_ERASE_BACKGROUND(MuleGifCtrl::OnErase)
END_EVENT_TABLE()
+#if wxCHECK_VERSION(2, 7, 1)
+// Wrapper that emulates old wxGIFDecoder API
+
+class MuleGIFDecoder : public wxGIFDecoder {
+public:
+ MuleGIFDecoder(wxInputStream* stream, bool dummy) {
+ m_stream = stream;
+ dummy = dummy; // Unused.
+ m_nframe = 0;
+ }
+
+ ~MuleGIFDecoder() { /* don't delete the stream! */ }
+
+ wxGIFErrorCode ReadGIF() {
+ return LoadGIF(*m_stream);
+ }
+
+ void GoFirstFrame() { m_nframe = 0; }
+ void GoNextFrame(bool dummy) { m_nframe < GetFrameCount() ? m_nframe++ : m_nframe = 0; }
+ void GoLastFrame() { m_nframe = GetFrameCount(); }
+
+ void ConvertToImage(wxImage* image) { wxGIFDecoder::ConvertToImage(m_nframe, image); }
+
+ size_t GetLogicalScreenWidth() { return GetAnimationSize().GetWidth(); }
+ size_t GetLogicalScreenHeight() { return GetAnimationSize().GetHeight(); }
+
+ size_t GetLeft() { return 0; }
+ size_t GetTop() { return 0; }
+
+ long GetDelay() { return wxGIFDecoder::GetDelay(m_nframe); }
+
+private:
+ uint32_t m_nframe;
+ wxInputStream* m_stream;
+};
+
+#else
+class MuleGIFDecoder : public wxGIFDecoder {
+public:
+ MuleGIFDecoder(wxInputStream* stream, bool flag) : wxGIFDecoder(stream,flag) {};
+};
+#endif
+
+
MuleGifCtrl::MuleGifCtrl( wxWindow *parent, wxWindowID id, const wxPoint& pos,
const wxSize& size, long style, const wxValidator& validator,
@@ -66,7 +109,7 @@
}
wxMemoryInputStream stream(data, size);
- m_decoder = new wxGIFDecoder(&stream, TRUE);
+ m_decoder = new MuleGIFDecoder(&stream, TRUE);
if ( m_decoder->ReadGIF() != wxGIF_OK ) {
delete m_decoder;
m_decoder = NULL;
@@ -137,3 +180,4 @@
dc.DrawBitmap( m_frame, x + m_decoder->GetLeft(), y + m_decoder->GetTop(), true);
}
+// File_checked_for_headers
--- aMule/src/MuleGifCtrl.h 2006-01-01 06:17:25.000000000 +0100
+++ aMule/src/MuleGifCtrl.h 2006-11-18 05:01:22.000000000 +0100
@@ -27,11 +27,10 @@
#include <wx/control.h>
#include <wx/timer.h>
-#include <wx/bitmap.h>
const int GIFTIMERID = 271283;
-class wxGIFDecoder;
+class MuleGIFDecoder;
class wxBitmap;
/**
@@ -121,7 +120,7 @@
void OnErase( wxEraseEvent& WXUNUSED(event) ) {}
//! A pointer to the current gif-animation.
- wxGIFDecoder* m_decoder;
+ MuleGIFDecoder* m_decoder;
//! Timer used for the delay between each frame.
wxTimer m_timer;
//! Current frame.
@@ -133,3 +132,4 @@
#endif
+// File_checked_for_headers
--- aMule-2.1.3/src/MuleTextCtrl.cpp~ 2006-12-17 20:55:37.157820250 +0100
+++ aMule-2.1.3/src/MuleTextCtrl.cpp 2006-12-17 20:56:21.328580750 +0100
@@ -26,6 +26,7 @@
#include <wx/menu.h>
#include <wx/intl.h>
#include <wx/clipbrd.h>
+#include <wx/dataobj.h>
/**
* These are the IDs used to identify the different menu-items.
--- amule/src/amule.cpp~ 2006-12-17 21:53:26.474639000 +0100
+++ amule/src/amule.cpp 2006-12-17 21:55:40.307003000 +0100
@@ -96,6 +96,7 @@
#include <CoreFoundation/CFBundle.h>
#include <wx/mac/corefoundation/cfstring.h>
#endif
+ #include <wx/msgdlg.h>
#endif

View File

@ -0,0 +1,14 @@
diff -Nru aMule-AdunanzA-3.14b3.orig/src/ThreadTasks.cpp aMule-AdunanzA-3.14b3/src/ThreadTasks.cpp
--- aMule-AdunanzA-3.14b3.orig/src/ThreadTasks.cpp 2008-08-26 08:47:01.000000000 +0200
+++ aMule-AdunanzA-3.14b3/src/ThreadTasks.cpp 2009-10-22 03:14:18.000000000 +0200
@@ -483,6 +483,10 @@
////////////////////////////////////////////////////////////
// CAllocateFileTask
+#if defined(HAVE_FALLOCATE)
+# undef HAVE_FALLOCATE
+#endif
+
#ifdef HAVE_FALLOCATE
# include <linux/falloc.h>
#elif defined HAVE_SYS_FALLOCATE

View File

@ -0,0 +1,21 @@
Index: b/src/ObservableQueue.h
===================================================================
--- a/src/ObservableQueue.h
+++ b/src/ObservableQueue.h
@@ -331,14 +331,14 @@
template <typename ValueType>
void CObservableQueue<ValueType>::ObserverAdded( ObserverType* o )
{
- NotifyObservers( EventType( EventType::STARTING ), o );
+ this->NotifyObservers( EventType( EventType::STARTING ), o );
}
template <typename ValueType>
void CObservableQueue<ValueType>::ObserverRemoved( ObserverType* o )
{
- NotifyObservers( EventType( EventType::STOPPING ), o );
+ this->NotifyObservers( EventType( EventType::STOPPING ), o );
}

View File

@ -0,0 +1,16 @@
--- a/src/utils/wxCas/src/wxcasframe.cpp.orig 2010-09-10 01:52:00.650000228 +0200
+++ b/src/utils/wxCas/src/wxcasframe.cpp 2010-09-10 01:52:16.669000228 +0200
@@ -285,11 +285,11 @@
#ifdef __WXMSW__
memdc.
- SetFont ( wxFont::wxFont ( 6, wxSWISS, wxNORMAL, wxBOLD ) );
+ SetFont ( wxFont ( 6, wxSWISS, wxNORMAL, wxBOLD ) );
#else
memdc.
- SetFont ( wxFont::wxFont ( 8, wxSWISS, wxNORMAL, wxBOLD ) );
+ SetFont ( wxFont ( 8, wxSWISS, wxNORMAL, wxBOLD ) );
#endif
memdc.

233
amule-adunanza.spec Normal file
View File

@ -0,0 +1,233 @@
%define amule_ver %(echo %version | cut -d. -f3-5)
%define adunanza_ver %(echo %version | cut -d. -f1-2)
Name: amule-adunanza
Epoch: 1
Version: 2010.1.2.2.6
Release: 11mamba
Summary: An eMule-like client for the eD2k and Kademlia file sharing networks
Group: Graphical Desktop/Applications/Internet
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.adunanza.net
Source: http://downloads.sourceforge.net/project/amule-adunanza/aMule-AdunanzA/Stable/aMule-AdunanzA-%{adunanza_ver}-%{amule_ver}.tar.bz2
Patch0: amuleadunanza3.11b1.patch.gz
Patch1: aMule-2.1.3-wx.patch
Patch2: aMule-2.1.3-servers.patch
Patch3: aMule-AdunanzA-3.14b3-glib-2.8.10.patch
Patch4: %{name}-2010.1.2.2.6-gcc45.patch
Patch5: amule-adunanza-2010.1.2.2.6-gcc-4.7.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libbinutils-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgd-devel
BuildRequires: libGeoIP-devel
BuildRequires: libjpeg-devel
BuildRequires: libpng-devel
BuildRequires: libreadline-devel
BuildRequires: libstdc++6-devel
BuildRequires: libtermcap-devel
BuildRequires: libupnp-devel
BuildRequires: libwxBase-unicode-devel
BuildRequires: libwxGTK-unicode-devel
BuildRequires: libX11-devel
BuildRequires: libXpm-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: gettext-devel
BuildRequires: libcurl-devel >= 7.12.0
BuildRequires: libcryptopp-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
Requires: xchat >= 2.6.6
Provides: aMule-adunanza
Obsoletes: aMule-adunanza
Provides: aMule-AdunanzA
Obsoletes: aMule-AdunanzA
%description
aMule is an eMule-like client for the eD2k and Kademlia networks, supporting multiple platforms.
Adunanza is a special patched release specially made for use inside italian Fastweb networks.
%package webserver
Summary: Webserver files for %{name}
Group: Applications/Web
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: aMule-AdunanzA-webserver
Obsoletes: aMule-AdunanzA-webserver
%description webserver
aMule is an eMule-like client for the eD2k and Kademlia networks, supporting multiple platforms.
Adunanza is a special patched release specially made for use inside italian Fastweb networks.
This package contains the webserver files.
%package doc
Summary: Webserver files for %{name}
Group: Documentation
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: aMule-AdunanzA-doc
Obsoletes: aMule-AdunanzA-doc
%description doc
aMule is an eMule-like client for the eD2k and Kademlia networks, supporting multiple platforms.
Adunanza is a special patched release specially made for use inside italian Fastweb networks.
This package contains the documentation files.
%prep
%setup -q -n aMule-AdunanzA-%{adunanza_ver}-%{amule_ver}
#-n aMule-%{amule_ver}
#%patch1 -p1
#%patch0 -p1
#%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%build
%configure \
--disable-debug \
--enable-optimize \
--enable-amule-gui \
--enable-webserver \
--enable-webservergui \
--enable-cas \
--enable-wxcas \
--enable-alc \
--enable-alcc \
--enable-amule-daemon \
--enable-amulecmd \
--enable-amulecmdgui \
--enable-geoip \
--program-suffix=-adunanza \
PACKAGE_NAME=aMule-AdunanzA
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
#mv %{buildroot}%{_datadir}/applications/amule.desktop %{buildroot}%{_datadir}/applications/amule-adunanza.desktop
#mv %{buildroot}%{_datadir}/applications/amulegui.desktop %{buildroot}%{_datadir}/applications/amulegui-adunanza.desktop
sed -i "s|Exec=amule|Exec=amule-adunanza|" %{buildroot}%{_datadir}/applications/amuleadunanza.desktop
sed -i "s|Exec=amulegui|Exec=amulegui-adunanza|" %{buildroot}%{_datadir}/applications/amuleguiadunanza.desktop
#rm -fr %{buildroot}%{_datadir}/doc/aMule-%{amule_ver}
%find_lang amuleadunanza
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f amuleadunanza.lang
%defattr(-,root,root,-)
%{_bindir}/*
%{_libdir}/xchat/plugins/xasAdunanzA.pl
%{_datadir}/applications/*.desktop
# avoid conlict with aMule package
%{_datadir}/pixmaps/*
%dir %{_datadir}/amuleadunanza
%dir %{_datadir}/amuleadunanza/skins
%{_datadir}/amuleadunanza/skins/AdunanzA_A.zip
%{_datadir}/amuleadunanza/skins/AdunanzA_B.zip
%{_datadir}/amuleadunanza/skins/AdunanzA_C.zip
%{_datadir}/amuleadunanza/skins/gnome.zip
%{_datadir}/amuleadunanza/skins/kde4.zip
%{_datadir}/amuleadunanza/skins/tango.zip
%{_datadir}/amuleadunanza/skins/xfce.zip
%{_mandir}/man1/*
%{_mandir}/*/man1/*
%files webserver
%defattr(-,root,root,-)
%dir %{_datadir}/amuleadunanza/webserver
%{_datadir}/amuleadunanza/webserver/*
%dir %{_datadir}/casAdunanzA/
%{_datadir}/casAdunanzA/*
%files doc
%defattr(-,root,root,-)
%{_datadir}/doc/amuleadunanza/*
%doc docs/Changelog docs/EC_Protocol.txt docs/ED2K-Links.HOWTO
%doc docs/README docs/amulesig.txt docs/license.txt
%doc docs/socks4.protocol
%changelog
* Fri Dec 13 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2010.1.2.2.6-11mamba
- rebuilt with binutils 2.24
* Wed Mar 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2010.1.2.2.6-10mamba
- binutils 2.32.2 rebuild
* Mon Nov 19 2012 Automatic Build System <autodist@mambasoft.it> 2010.1.2.2.6-9mamba
- binutils 2.23.1 mass rebuild
* Mon Oct 29 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2010.1.2.2.6-8mamba
- rebuild with binutils 2.23
* Wed Nov 30 2011 Automatic Build System <autodist@mambasoft.it> 2010.1.2.2.6-7mamba
- automatic update by autodist
* Mon Nov 28 2011 Automatic Build System <autodist@mambasoft.it> 2010.1.2.2.6-6mamba
- automatic update by autodist
* Wed Jul 20 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2010.1.2.2.6-5mamba
- rebuilt with binutils 2.21.1
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 2010.1.2.2.6-4mamba
- automatic update by autodist
* Sun Dec 26 2010 Automatic Build System <autodist@mambasoft.it> 2010.1.2.2.6-3mamba
- automatic update by autodist
* Fri Nov 12 2010 Automatic Build System <autodist@mambasoft.it> 2010.1.2.2.6-2mamba
- automatic rebuild by autodist
* Sat Oct 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2010.1.2.2.6-1mamba
- update to 2010.1.2.2.6
* Sat Mar 06 2010 Automatic Build System <autodist@mambasoft.it> 3.14b3.2.2.2-5mamba
- automatic rebuild by autodist
* Thu Oct 22 2009 Automatic Build System <autodist@mambasoft.it> 3.14b3.2.2.2-4mamba
- automatic rebuild by autodist
* Fri Feb 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14b3.2.2.2-3mamba
- automatic rebuild by autodist
* Thu Dec 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14b3.2.2.2-2mamba
- fixed desktop entry: launch amule-adunanza
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14b3.2.2.2-1mamba
- update to 2.2.2
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080430-3mamba
- removed conflicts with amule to allow cohexistence
- added webserver and doc subpackages
* Fri Oct 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080430-2mamba
- automatic rebuild by autodist
* Sat Sep 06 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20080430-1mamba
- update to 20080430
- renamed to amule-adunanza
* Wed Nov 28 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11b1-5mamba
- rebuilt against libbinutils 2.18
* Thu Sep 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11b1-4mamba
- added patch for glib 2.14
- added patch for wxGTK 2.8
* Mon Oct 30 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11b1-3qilnx
- rebuilt
* Wed Sep 06 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11b1-2qilnx
- rebuilt
* Sun Jul 30 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11b1-1qilnx
- first adunanza build based on aMule 2.1.3

9182
amuleadunanza3.11b1.patch Normal file

File diff suppressed because it is too large Load Diff