update to 3.1.0 [release 3.1.0-1mamba;Wed Aug 14 2024]
This commit is contained in:
parent
3c7adb1bb3
commit
a2d0b5d597
@ -1,10 +0,0 @@
|
||||
--- amarok-2.8.0/src/scanner/GenericScanManager.h.orig 2013-10-25 12:05:21.446179242 +0000
|
||||
+++ amarok-2.8.0/src/scanner/GenericScanManager.h 2013-10-25 12:04:04.379911780 +0000
|
||||
@@ -31,6 +31,7 @@
|
||||
#include <QObject>
|
||||
#include <QString>
|
||||
#include <QMutex>
|
||||
+#include <QSharedPointer>
|
||||
|
||||
class GenericScannerJob;
|
||||
template<class T >
|
41
amarok.spec
41
amarok.spec
@ -1,5 +1,5 @@
|
||||
Name: amarok
|
||||
Version: 3.0.1
|
||||
Version: 3.1.0
|
||||
Release: 1mamba
|
||||
Epoch: 1
|
||||
Summary: A powerful music player for KDE
|
||||
@ -9,15 +9,13 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://amarok.kde.org
|
||||
Source: https://download.kde.org/stable/amarok/%{version}/amarok-%{version}.tar.xz
|
||||
Patch0: amarok-2.8.0-x86_64-include-QSharedPointer.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5Svg-devel
|
||||
BuildRequires: libattica5-devel
|
||||
BuildRequires: libavcodec-ffmpeg-devel
|
||||
BuildRequires: libavformat-ffmpeg-devel
|
||||
BuildRequires: libavutil-ffmpeg-devel
|
||||
BuildRequires: libavcodec-devel
|
||||
BuildRequires: libavformat-devel
|
||||
BuildRequires: libavutil-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
@ -31,7 +29,6 @@ BuildRequires: libkconfigwidgets-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libkcrash-devel
|
||||
BuildRequires: libkdbusaddons-devel
|
||||
BuildRequires: libkdeclarative-devel
|
||||
BuildRequires: libkdnssd-devel
|
||||
BuildRequires: libkglobalaccel-devel
|
||||
BuildRequires: libkguiaddons-devel
|
||||
@ -39,10 +36,8 @@ BuildRequires: libki18n-devel
|
||||
BuildRequires: libkiconthemes-devel
|
||||
BuildRequires: libkio-devel
|
||||
BuildRequires: libkitemviews-devel
|
||||
BuildRequires: libknewstuff-devel
|
||||
BuildRequires: libknotifications-devel
|
||||
BuildRequires: libkpackage-devel
|
||||
BuildRequires: libkservice-devel
|
||||
BuildRequires: libktexteditor-devel
|
||||
BuildRequires: libktextwidgets-devel
|
||||
BuildRequires: libkwallet-devel
|
||||
@ -60,25 +55,19 @@ BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtag-devel
|
||||
BuildRequires: libtag-extras-devel
|
||||
BuildRequires: libthreadweaver-devel
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: qt5-qtdeclarative-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libxml2-utils
|
||||
BuildRequires: gmock-devel
|
||||
BuildRequires: liblastfm5-devel >= 1.1.0
|
||||
BuildRequires: clamz
|
||||
BuildRequires: qtscriptgenerator
|
||||
Requires: libvisual-plugins
|
||||
Requires: moodbar
|
||||
Requires: ruby
|
||||
Requires: qtscriptgenerator
|
||||
Requires: clamz
|
||||
BuildRequires: libxml2-utils
|
||||
#BuildRequires: qtscriptgenerator
|
||||
#Requires: libvisual-plugins
|
||||
#Requires: moodbar
|
||||
#Requires: ruby
|
||||
#Requires: qtscriptgenerator
|
||||
Provides: amarok4
|
||||
Obsoletes: amarok4 < 1:2.9.75
|
||||
Obsoletes: amarok-engine-xine < 1:2.9.75
|
||||
@ -111,9 +100,6 @@ Amarok is a powerful music player for Linux and Unix, MacOS X and Windows with a
|
||||
%setup -q -n amarok-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch 0 -p1
|
||||
|
||||
sed -i "s|mygpo-qt5/|mygpo-qt/|" src/services/gpodder/*.h src/services/gpodder/*.cpp
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -177,7 +163,6 @@ exit 0
|
||||
%{_datadir}/dbus-1/services/org.kde.amarok.service
|
||||
%{_kde5_sharedir}/metainfo/org.kde.amarok.*.xml
|
||||
%{_datadir}/applications/org.kde.amarok*.desktop
|
||||
%{_datadir}/metainfo/org.kde.amarok.context.appdata.xml
|
||||
%{_datadir}/knotifications5/amarok.notifyrc
|
||||
%dir %{_datadir}/kpackage/amarok
|
||||
%{_datadir}/kpackage/amarok/*
|
||||
@ -185,11 +170,8 @@ exit 0
|
||||
%{_datadir}/kpackage/genericqml/org.kde.amarok.context/*
|
||||
%{_kde5_datadir}/amarok
|
||||
%{_kde5_datadir}/solid/actions/amarok-play-audiocd.desktop
|
||||
%{_kde5_datadir}/kconf_update/*
|
||||
%{_kde5_kcfgdir}/amarokconfig.kcfg
|
||||
%{_kde5_configdir}/amarok_homerc
|
||||
%{_datadir}/knsrcfiles/amarok.knsrc
|
||||
%{_kde5_dbusinterfacesdir}/org.kde.amarok.Collection.xml
|
||||
%{_kde5_icondir}/hicolor/*/apps/amarok.png
|
||||
%{_kde5_servicesdir}/ServiceMenus/*.desktop
|
||||
%{_kde5_servicesdir}/*.desktop
|
||||
@ -198,6 +180,9 @@ exit 0
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%changelog
|
||||
* Wed Aug 14 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.0-1mamba
|
||||
- update to 3.1.0
|
||||
|
||||
* Mon Jun 03 2024 Automatic Build System <autodist@openmamba.org> 3.0.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user