rebuilt with libtag 1.10 [release 2.8.0-5mamba;Fri Mar 25 2016]
This commit is contained in:
parent
56e39ae4e4
commit
8c6233c41c
85
amarok-2.8.0-ffmpeg-3.0.patch
Normal file
85
amarok-2.8.0-ffmpeg-3.0.patch
Normal file
@ -0,0 +1,85 @@
|
|||||||
|
diff --git a/src/musicbrainz/MusicDNSAudioDecoder.cpp b/src/musicbrainz/MusicDNSAudioDecoder.cpp
|
||||||
|
index 6216e5ce26cc3461b89aea560943ad7a79101af9..65a92fb43811d0cbdde5e2442880496b3417da68 100644
|
||||||
|
--- a/src/musicbrainz/MusicDNSAudioDecoder.cpp
|
||||||
|
+++ b/src/musicbrainz/MusicDNSAudioDecoder.cpp
|
||||||
|
@@ -243,7 +243,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
{
|
||||||
|
if( !decodedFrame )
|
||||||
|
{
|
||||||
|
- decodedFrame = avcodec_alloc_frame();
|
||||||
|
+ decodedFrame = av_frame_alloc();
|
||||||
|
if( !decodedFrame )
|
||||||
|
{
|
||||||
|
warning() << "Unable to allocate enough memory to decode file.";
|
||||||
|
@@ -251,7 +251,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
else
|
||||||
|
- avcodec_get_frame_defaults( decodedFrame );
|
||||||
|
+ av_frame_unref( decodedFrame );
|
||||||
|
}
|
||||||
|
|
||||||
|
decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
|
||||||
|
@@ -287,7 +287,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
|
||||||
|
avcodec_close( pCodecCtx );
|
||||||
|
avformat_close_input( &pFormatCtx );
|
||||||
|
- av_free( decodedFrame );
|
||||||
|
+ av_frame_free( &decodedFrame );
|
||||||
|
|
||||||
|
return data->duration();
|
||||||
|
}
|
||||||
|
@@ -361,7 +361,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
{
|
||||||
|
if( !decodedFrame )
|
||||||
|
{
|
||||||
|
- decodedFrame = avcodec_alloc_frame();
|
||||||
|
+ decodedFrame = av_frame_alloc();
|
||||||
|
if( !decodedFrame )
|
||||||
|
{
|
||||||
|
warning() << "Unable to allocate enough memory to decode file.";
|
||||||
|
@@ -369,7 +369,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
else
|
||||||
|
- avcodec_get_frame_defaults( decodedFrame );
|
||||||
|
+ av_frame_unref( decodedFrame );
|
||||||
|
}
|
||||||
|
|
||||||
|
decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
|
||||||
|
@@ -405,7 +405,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
|
||||||
|
avcodec_close( pCodecCtx );
|
||||||
|
avformat_close_input( &pFormatCtx );
|
||||||
|
- av_free( decodedFrame );
|
||||||
|
+ av_frame_free( &decodedFrame );
|
||||||
|
|
||||||
|
return data->duration();
|
||||||
|
}
|
||||||
|
@@ -479,7 +479,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
{
|
||||||
|
if( !decodedFrame )
|
||||||
|
{
|
||||||
|
- decodedFrame = avcodec_alloc_frame();
|
||||||
|
+ decodedFrame = av_frame_alloc();
|
||||||
|
if( !decodedFrame )
|
||||||
|
{
|
||||||
|
warning() << "Unable to allocate enough memory to decode file.";
|
||||||
|
@@ -487,7 +487,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
else
|
||||||
|
- avcodec_get_frame_defaults( decodedFrame );
|
||||||
|
+ av_frame_unref( decodedFrame );
|
||||||
|
}
|
||||||
|
|
||||||
|
decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
|
||||||
|
@@ -523,7 +523,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c
|
||||||
|
|
||||||
|
avcodec_close( pCodecCtx );
|
||||||
|
av_close_input_file( pFormatCtx );
|
||||||
|
- av_free( decodedFrame );
|
||||||
|
+ av_frame_free( &decodedFrame );
|
||||||
|
|
||||||
|
return data->duration();
|
||||||
|
}
|
25
amarok-2.8.0-libtag-1.10.patch
Normal file
25
amarok-2.8.0-libtag-1.10.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
--- a/cmake/modules/FindTaglib.cmake
|
||||||
|
+++ b/cmake/modules/FindTaglib.cmake
|
||||||
|
@@ -29,10 +29,10 @@
|
||||||
|
|
||||||
|
exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --version RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_VERSION)
|
||||||
|
|
||||||
|
- if(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
|
||||||
|
+ if("${TAGLIB_MIN_VERSION}" VERSION_GREATER TAGLIB_VERSION)
|
||||||
|
message(STATUS "TagLib version too old: version searched :${TAGLIB_MIN_VERSION}, found ${TAGLIB_VERSION}")
|
||||||
|
set(TAGLIB_FOUND FALSE)
|
||||||
|
- else(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
|
||||||
|
+ else("${TAGLIB_MIN_VERSION}" VERSION_GREATER TAGLIB_VERSION)
|
||||||
|
|
||||||
|
exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_LIBRARIES)
|
||||||
|
|
||||||
|
@@ -42,7 +42,7 @@
|
||||||
|
set(TAGLIB_FOUND TRUE)
|
||||||
|
endif(TAGLIB_LIBRARIES AND TAGLIB_CFLAGS)
|
||||||
|
string(REGEX REPLACE " *-I" ";" TAGLIB_INCLUDES "${TAGLIB_CFLAGS}")
|
||||||
|
- endif(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
|
||||||
|
+ endif("${TAGLIB_MIN_VERSION}" VERSION_GREATER TAGLIB_VERSION)
|
||||||
|
mark_as_advanced(TAGLIB_CFLAGS TAGLIB_LIBRARIES TAGLIB_INCLUDES)
|
||||||
|
|
||||||
|
else(TAGLIBCONFIG_EXECUTABLE)
|
||||||
|
|
14
amarok.spec
14
amarok.spec
@ -1,6 +1,6 @@
|
|||||||
Name: amarok
|
Name: amarok
|
||||||
Version: 2.8.0
|
Version: 2.8.0
|
||||||
Release: 4mamba
|
Release: 5mamba
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: A powerful music player for KDE
|
Summary: A powerful music player for KDE
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
@ -10,6 +10,8 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: http://amarok.kde.org
|
URL: http://amarok.kde.org
|
||||||
Source: ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/amarok-%{version}.tar.bz2
|
Source: ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/amarok-%{version}.tar.bz2
|
||||||
Patch0: amarok-2.8.0-x86_64-include-QSharedPointer.patch
|
Patch0: amarok-2.8.0-x86_64-include-QSharedPointer.patch
|
||||||
|
Patch1: amarok-2.8.0-libtag-1.10.patch
|
||||||
|
Patch2: amarok-2.8.0-ffmpeg-3.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -49,7 +51,7 @@ BuildRequires: doxygen
|
|||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: libxml2-utils
|
BuildRequires: libxml2-utils
|
||||||
BuildRequires: libtag-devel >= 1.9
|
BuildRequires: libtag-devel >= 1.10
|
||||||
BuildRequires: gmock-devel
|
BuildRequires: gmock-devel
|
||||||
BuildRequires: liblastfm-devel >= 1.0.3
|
BuildRequires: liblastfm-devel >= 1.0.3
|
||||||
BuildRequires: clamz
|
BuildRequires: clamz
|
||||||
@ -94,11 +96,14 @@ Amarok is a powerful music player for Linux and Unix, MacOS X and Windows with a
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n amarok-%{version}
|
%setup -q -n amarok-%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Tests disabled since kde 4.10, see https://bugs.archlinux.org/task/33457
|
# Tests disabled since kde 4.10, see https://bugs.archlinux.org/task/33457
|
||||||
%cmake_kde4 -d build \
|
%cmake_kde4 -d build \
|
||||||
-DKDE4_BUILD_TESTS=OFF
|
-DKDE4_BUILD_TESTS=OFF \
|
||||||
|
-Wno-dev
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -197,6 +202,9 @@ exit 0
|
|||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 25 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.0-5mamba
|
||||||
|
- rebuilt with libtag 1.10
|
||||||
|
|
||||||
* Tue Nov 10 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.0-4mamba
|
* Tue Nov 10 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.0-4mamba
|
||||||
- rebuilt with libtag 1.9
|
- rebuilt with libtag 1.9
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user