package created by autospec [release 0.3.10-1mamba;Tue Dec 07 2010]
This commit is contained in:
parent
62ee0bd279
commit
7c5d697c8a
@ -1,2 +1,4 @@
|
|||||||
# altermime
|
# altermime
|
||||||
|
|
||||||
|
A program which is used to alter mime-encoded mailpacks as typically received by Inflex, Xamime and AMaViS.
|
||||||
|
|
||||||
|
132
altermime-0.3.10-gcc-4.9.patch
Normal file
132
altermime-0.3.10-gcc-4.9.patch
Normal file
@ -0,0 +1,132 @@
|
|||||||
|
diff -Nru altermime-0.3.10.orig/MIME_headers.c altermime-0.3.10/MIME_headers.c
|
||||||
|
--- altermime-0.3.10.orig/MIME_headers.c 2008-11-16 09:45:45.000000000 +0100
|
||||||
|
+++ altermime-0.3.10/MIME_headers.c 2014-07-22 21:23:41.214442354 +0200
|
||||||
|
@@ -1081,12 +1081,10 @@
|
||||||
|
int linesize=0;
|
||||||
|
int totalsize_original=0;
|
||||||
|
int result = 0;
|
||||||
|
- int firstline = 1;
|
||||||
|
int search_count=0;
|
||||||
|
char *tmp;
|
||||||
|
char *tmp_original;
|
||||||
|
char *fget_result = NULL;
|
||||||
|
- char *headerline_end;
|
||||||
|
char *p;
|
||||||
|
char *linestart;
|
||||||
|
char *lineend;
|
||||||
|
@@ -1184,7 +1182,6 @@
|
||||||
|
glb.headerline = tmp;
|
||||||
|
totalsize = linesize;
|
||||||
|
PLD_strncpy(glb.headerline, linestart, (linesize +1));
|
||||||
|
- headerline_end = glb.headerline +totalsize;
|
||||||
|
} // If the global headerline is currently NULL
|
||||||
|
else
|
||||||
|
{
|
||||||
|
@@ -1271,7 +1268,6 @@
|
||||||
|
FFGET_SDL_MODE = 0;
|
||||||
|
} // FFGET_doubleCR test
|
||||||
|
|
||||||
|
- firstline = 0;
|
||||||
|
} // While reading more headers from the source file.
|
||||||
|
|
||||||
|
|
||||||
|
@@ -2724,14 +2720,13 @@
|
||||||
|
{
|
||||||
|
/** scan through our headers string looking for information that is
|
||||||
|
** valid **/
|
||||||
|
- char *safeh, *h, *safehl;
|
||||||
|
+ char *h, *safehl;
|
||||||
|
char *current_header_position;
|
||||||
|
int headerlength;
|
||||||
|
|
||||||
|
if (MIMEH_DNORMAL) LOGGER_log("%s:%d:MIMEH_parse_headers:DEBUG: Start [hinfo=%p]\n",FL, hinfo);
|
||||||
|
|
||||||
|
- safeh = h = headers;
|
||||||
|
-
|
||||||
|
+ h = headers;
|
||||||
|
/** Duplicate the headers for processing - this way we don't 'taint' the
|
||||||
|
** original headers during our searching / altering. **/
|
||||||
|
|
||||||
|
diff -Nru altermime-0.3.10.orig/mime_alter.c altermime-0.3.10/mime_alter.c
|
||||||
|
--- altermime-0.3.10.orig/mime_alter.c 2008-11-16 09:45:45.000000000 +0100
|
||||||
|
+++ altermime-0.3.10/mime_alter.c 2014-07-22 21:20:18.301397948 +0200
|
||||||
|
@@ -2432,7 +2432,6 @@
|
||||||
|
char mpackold[AM_1K_BUFFER_SIZE+1]="";
|
||||||
|
struct AM_disclaimer_details dd;
|
||||||
|
int result = 0;
|
||||||
|
- int segment_read = 0;
|
||||||
|
|
||||||
|
/* create our temp filename */
|
||||||
|
snprintf(mpacktmp,AM_1K_BUFFER_SIZE, "%s.tmp",mpackname);
|
||||||
|
@@ -2622,8 +2621,6 @@
|
||||||
|
having to resort to ugly GOTO hacks or similar
|
||||||
|
*/
|
||||||
|
|
||||||
|
-
|
||||||
|
- segment_read = 0;
|
||||||
|
if (FFGET_feof(&f)) break;
|
||||||
|
|
||||||
|
// If we've found a boundary and a text content section...
|
||||||
|
@@ -3698,7 +3695,6 @@
|
||||||
|
int AM_attachment_replace_recurse( struct MIMEH_header_info *hinfo, FFGET_FILE *f, FILE *outputfile, regex_t *preg, char *new_attachment_name, int iteration )
|
||||||
|
{
|
||||||
|
int result = 0;
|
||||||
|
- int boundary_exists=0;
|
||||||
|
size_t bc;
|
||||||
|
|
||||||
|
if (AM_DNORMAL) LOGGER_log("%s:%d:AM_attachment_replace_recurse:DEBUG: Starting: iteration=%d",FL, iteration );
|
||||||
|
@@ -3776,7 +3772,6 @@
|
||||||
|
{
|
||||||
|
if (AM_DNORMAL)LOGGER_log("%s:%d:AM_attachment_replace_recurse:DEBUG: pushing BS='%s'",FL, hinfo->boundary );
|
||||||
|
BS_push( hinfo->boundary );
|
||||||
|
- boundary_exists = 1;
|
||||||
|
}
|
||||||
|
|
||||||
|
// Now, determine if this block/segment is the one which contains our file which we must 'nullify'
|
||||||
|
Binary files altermime-0.3.10.orig/mime_alter.o and altermime-0.3.10/mime_alter.o differ
|
||||||
|
diff -Nru altermime-0.3.10.orig/qpe.c altermime-0.3.10/qpe.c
|
||||||
|
--- altermime-0.3.10.orig/qpe.c 2008-11-16 09:45:45.000000000 +0100
|
||||||
|
+++ altermime-0.3.10/qpe.c 2014-07-22 21:25:23.927464832 +0200
|
||||||
|
@@ -97,7 +97,7 @@
|
||||||
|
op+= strlen(paragraph);// +3; /** jump the output + =\r\n **/
|
||||||
|
out_remaining-= (strlen(paragraph)); // Was +3, updated to fix Outlook problems
|
||||||
|
|
||||||
|
- QPD fprintf(stdout, "Soft break (%d + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
|
||||||
|
+ QPD fprintf(stdout, "Soft break (%ld + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
|
||||||
|
|
||||||
|
/** reinitialize the paragraph **/
|
||||||
|
paragraph[0] = '\0';
|
||||||
|
@@ -108,7 +108,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
snprintf(pp, pp_remaining, "%s", charout);
|
||||||
|
- QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%d result='%s'\n", charout, charout_size, pp_remaining, paragraph);
|
||||||
|
+ QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%ld result='%s'\n", charout, charout_size, pp_remaining, paragraph);
|
||||||
|
pp += charout_size;
|
||||||
|
pp_remaining -= charout_size;
|
||||||
|
p++;
|
||||||
|
@@ -149,13 +149,13 @@
|
||||||
|
out_size = in_size *3;
|
||||||
|
in_buffer = malloc( sizeof(char) *in_size +1);
|
||||||
|
if (in_buffer == NULL) {
|
||||||
|
- QPD fprintf(stdout,"Error allocating %d bytes for input buffer\n", in_size);
|
||||||
|
+ QPD fprintf(stdout,"Error allocating %ld bytes for input buffer\n", in_size);
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
out_buffer = malloc( sizeof(char) *out_size *3 +1);
|
||||||
|
if (in_buffer == NULL) {
|
||||||
|
- QPD fprintf(stdout,"Error allocating %d bytes for output buffer\n", out_size);
|
||||||
|
+ QPD fprintf(stdout,"Error allocating %ld bytes for output buffer\n", out_size);
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -169,7 +169,7 @@
|
||||||
|
** we segfault ;) **/
|
||||||
|
*(in_buffer +in_size) = '\0';
|
||||||
|
|
||||||
|
- QPD fprintf(stdout,"file %s is loaded, size = %d\n", fname, in_size);
|
||||||
|
+ QPD fprintf(stdout,"file %s is loaded, size = %ld\n", fname, in_size);
|
||||||
|
|
||||||
|
qp_encode( out_buffer, out_size, in_buffer, in_size );
|
||||||
|
|
42
altermime.spec
Normal file
42
altermime.spec
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
Name: altermime
|
||||||
|
Version: 0.3.10
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A program which is used to alter mime-encoded mailpacks as typically received by Inflex, Xamime and AMaViS
|
||||||
|
Group: System/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.pldaniels.com/altermime/
|
||||||
|
Source: http://www.pldaniels.com/altermime/altermime-%{version}.tar.gz
|
||||||
|
Patch0: altermime-0.3.10-gcc-4.9.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
A program which is used to alter mime-encoded mailpacks as typically received by Inflex, Xamime and AMaViS.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make CC=%{_host}-gcc
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
install -D -m0755 altermime %{buildroot}%{_bindir}/altermime
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/altermime
|
||||||
|
%doc LICENCE README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Dec 07 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.10-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user