update to 1.4.20210408 [release 1.4.20210408-1mamba;Thu Dec 23 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 20:19:42 +01:00
parent c8186e1997
commit 77493374d6
4 changed files with 190 additions and 0 deletions

78
AlephOne-fix-build.patch Normal file
View File

@ -0,0 +1,78 @@
--- AlephOne-20051119/Source_Files/Misc/sdl_widgets.h~ 2005-08-20 16:16:02.000000000 +0200
+++ AlephOne-20051119/Source_Files/Misc/sdl_widgets.h 2006-10-19 16:07:14.000000000 +0200
@@ -944,7 +944,7 @@
virtual ~SelectorWidget () {}
protected:
- SelectorWidget::SelectorWidget (widget* in_widget)
+ SelectorWidget (widget* in_widget)
: SDLWidgetWidget (in_widget)
, m_callback (NULL)
{}
@@ -955,7 +955,7 @@
class PopupSelectorWidget : public SelectorWidget
{
public:
- PopupSelectorWidget::PopupSelectorWidget (w_select_popup* select_popup_w)
+ PopupSelectorWidget (w_select_popup* select_popup_w)
: SelectorWidget (select_popup_w)
, m_select_popup (select_popup_w)
{ select_popup_w->set_popup_callback (boost::bind(&PopupSelectorWidget::massage_callback, this, _1), NULL); }
@@ -974,7 +974,7 @@
class SelectSelectorWidget : public SelectorWidget
{
public:
- SelectSelectorWidget::SelectSelectorWidget (w_select* select_w)
+ SelectSelectorWidget (w_select* select_w)
: SelectorWidget (select_w)
, m_select (select_w)
{ m_select->set_selection_changed_callback (boost::bind(&SelectSelectorWidget::massage_callback, this, _1)); }
@@ -996,7 +996,7 @@
class ColourSelectorWidget : public SelectSelectorWidget
{
public:
- ColourSelectorWidget::ColourSelectorWidget (w_player_color* player_color_w)
+ ColourSelectorWidget (w_player_color* player_color_w)
: SelectSelectorWidget (player_color_w) {}
// We ignore the labels and use swatches of colour instead
@@ -1028,7 +1028,7 @@
class StaticTextWidget : public SDLWidgetWidget
{
public:
- StaticTextWidget::StaticTextWidget (w_static_text* static_text_w)
+ StaticTextWidget (w_static_text* static_text_w)
: SDLWidgetWidget (static_text_w)
, m_static_text (static_text_w)
{}
--- AlephOne-20051119/Source_Files/TCPMess/CommunicationsChannel.h~ 2005-10-01 23:54:32.000000000 +0200
+++ AlephOne-20051119/Source_Files/TCPMess/CommunicationsChannel.h 2006-10-19 16:20:08.000000000 +0200
@@ -95,7 +95,7 @@
// Calls back message handlers (if appropriate)
void dispatchIncomingMessages();
- bool CommunicationsChannel::isMessageAvailable();
+ bool isMessageAvailable();
// Call does not return unless (1) times out (NULL); (2) disconnected (NULL); or
// (3) some message received (pointer to inflated message object).
--- AlephOne-20051119/Source_Files/Network/network_dialogs_sdl.cpp~ 2005-10-02 14:45:34.000000000 +0200
+++ AlephOne-20051119/Source_Files/Network/network_dialogs_sdl.cpp 2006-10-19 16:25:41.000000000 +0200
@@ -838,7 +838,7 @@
class SdlGatherDialog : public GatherDialog
{
public:
- SdlGatherDialog::SdlGatherDialog()
+ SdlGatherDialog()
{
m_dialog.add(new w_static_text("GATHER NETWORK GAME", TITLE_FONT, TITLE_COLOR));
@@ -921,7 +921,7 @@
class SdlJoinDialog : public JoinDialog
{
public:
- SdlJoinDialog::SdlJoinDialog()
+ SdlJoinDialog()
{
m_dialog.add(new w_static_text("JOIN NETWORK GAME", TITLE_FONT, TITLE_COLOR));
m_dialog.add(new w_spacer());

View File

@ -1,2 +1,4 @@
# alephone
Aleph One is an Open Source 3D first-person shooter game, based on the game Marathon 2 by Bungie Software. It is set in a Sci-Fi universe dominated by deviant computer AIs and features a well thought-out plot.

BIN
alephone.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 3.1 KiB

110
alephone.spec Normal file
View File

@ -0,0 +1,110 @@
%define pkgver %(echo %version | cut -d. -f3)
Name: alephone
Epoch: 1
Version: 1.4.20210408
Release: 1mamba
Summary: 3D first-person shooter game
Group: Applications/Games
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://alephone.lhowon.org/
Source0: https://github.com/Aleph-One-Marathon/alephone/releases/download/release-%{pkgver}/AlephOne-%{pkgver}.tar.bz2
Source1: alephone.png
Patch: AlephOne-fix-build.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libGLU-devel
BuildRequires: libSDL2-devel
BuildRequires: libSDL2_ttf-devel
BuildRequires: libalsa-devel
BuildRequires: libavcodec-ffmpeg-devel
BuildRequires: libavformat-ffmpeg-devel
BuildRequires: libavutil-ffmpeg-devel
BuildRequires: libboost-devel
BuildRequires: libcurl-devel
BuildRequires: libexpat-devel
BuildRequires: libgcc
BuildRequires: libglvnd-devel
BuildRequires: libmad-devel
BuildRequires: libpng-devel
BuildRequires: libsdl2_image-devel
BuildRequires: libsdl2_net-devel
BuildRequires: libsndfile-devel
BuildRequires: libspeex-devel
BuildRequires: libspeexdsp-devel
BuildRequires: libstdc++6-devel
BuildRequires: libswscale-ffmpeg-devel
BuildRequires: libvorbis-devel
BuildRequires: libz-devel
BuildRequires: libzzip-devel
## AUTOBUILDREQ-END
Requires: alephone-data
Provides: AlephOne
Obsoletes: AlephOne < 1:1.4
%description
Aleph One is an Open Source 3D first-person shooter game, based on the game Marathon 2 by Bungie Software. It is set in a Sci-Fi universe dominated by deviant computer AIs and features a well thought-out plot.
%debug_package
%prep
%setup -q -n AlephOne-%{pkgver}
#%patch0 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
install -m 644 %{S:1} %{buildroot}%{_datadir}/pixmaps/alephone.png
%{__mkdir_p} %{buildroot}%{_datadir}/applications
cat > %{buildroot}%{_datadir}/applications/alephone.desktop << EOF
[Desktop Entry]
Encoding=UTF-8
Name=AlephOne
Comment=An open source version of Marathon Infinity
Exec=/usr/bin/alephone -g -m
Terminal=false
Icon=/usr/share/pixmaps/alephone.png
Type=Application
Categories=Application;Game;
EOF
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/alephone
%{_datadir}/pixmaps/alephone.png
%{_datadir}/applications/alephone.desktop
%{_datadir}/mime/packages/alephone.xml
%dir %{_datadir}/AlephOne
%{_datadir}/AlephOne/*
%{_datadir}/icons/hicolor/*/mimetypes/application-x-alephone-*.png
%{_datadir}/icons/hicolor/*/mimetypes/text-x-alephone-mml.png
%{_mandir}/man6/alephone.6*
%doc AUTHORS COPYING
%changelog
* Thu Dec 23 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.20210408-1mamba
- update to 1.4.20210408
* Sat Apr 07 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 20120128-1mamba
- update to version 20120128
* Tue Nov 23 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 20110731-1mamba
- update to version of 31-07-2011
* Fri Aug 08 2008 gil <puntogil@libero.it> 20070401-1mamba
- added file desktop
- fixed buildrequires AlephOne-data