automatic version update by autodist [release 2.10.1-1mamba;Fri May 31 2024]

This commit is contained in:
Automatic Build System 2024-06-01 11:12:06 +02:00
parent 30b2d42bbf
commit aa0667e299
2 changed files with 11 additions and 61 deletions

View File

@ -1,57 +0,0 @@
From f1322a322cb1e5739742c405fe329b4a07820ade Mon Sep 17 00:00:00 2001
From: Vicente Adolfo Bolea Sanchez <vicente.bolea@kitware.com>
Date: Wed, 17 Apr 2024 14:22:40 -0400
Subject: [PATCH] pugixml,cmake: fix linkage when pugixml is external
---
source/adios2/toolkit/remote/CMakeLists.txt | 12 ++++--------
source/utils/CMakeLists.txt | 8 +-------
2 files changed, 5 insertions(+), 15 deletions(-)
diff --git a/source/adios2/toolkit/remote/CMakeLists.txt b/source/adios2/toolkit/remote/CMakeLists.txt
index a739e1ad63..fdea6ec841 100644
--- a/source/adios2/toolkit/remote/CMakeLists.txt
+++ b/source/adios2/toolkit/remote/CMakeLists.txt
@@ -6,15 +6,11 @@
if (NOT ADIOS2_USE_PIP)
add_executable(adios2_remote_server ./remote_server.cpp remote_common.cpp)
- target_link_libraries(adios2_remote_server PUBLIC EVPath::EVPath adios2_core adios2sys
- PRIVATE $<$<PLATFORM_ID:Windows>:shlwapi>)
+ target_link_libraries(adios2_remote_server
+ PUBLIC EVPath::EVPath adios2_core adios2sys
+ PRIVATE adios2::thirdparty::pugixml $<$<PLATFORM_ID:Windows>:shlwapi>)
- get_property(pugixml_headers_path
- TARGET pugixml
- PROPERTY INTERFACE_INCLUDE_DIRECTORIES
- )
-
- target_include_directories(adios2_remote_server PRIVATE ${PROJECT_BINARY_DIR} ${pugixml_headers_path})
+ target_include_directories(adios2_remote_server PRIVATE ${PROJECT_BINARY_DIR})
set_property(TARGET adios2_remote_server PROPERTY OUTPUT_NAME adios2_remote_server${ADIOS2_EXECUTABLE_SUFFIX})
install(TARGETS adios2_remote_server EXPORT adios2
diff --git a/source/utils/CMakeLists.txt b/source/utils/CMakeLists.txt
index 30dd48411f..01f5f93c34 100644
--- a/source/utils/CMakeLists.txt
+++ b/source/utils/CMakeLists.txt
@@ -13,17 +13,11 @@ configure_file(
add_executable(bpls ./bpls/bpls.cpp)
target_link_libraries(bpls
PUBLIC adios2_core adios2sys
- PRIVATE $<$<PLATFORM_ID:Windows>:shlwapi>)
-
-get_property(pugixml_headers_path
- TARGET pugixml
- PROPERTY INTERFACE_INCLUDE_DIRECTORIES
-)
+ PRIVATE adios2::thirdparty::pugixml $<$<PLATFORM_ID:Windows>:shlwapi>)
target_include_directories(bpls PRIVATE
${PROJECT_BINARY_DIR}
${PROJECT_SOURCE_DIR}/bindings/C
- ${pugixml_headers_path}
)
set_property(TARGET bpls PROPERTY OUTPUT_NAME bpls${ADIOS2_EXECUTABLE_SUFFIX})

View File

@ -1,5 +1,5 @@
Name: adios2
Version: 2.10.0
Version: 2.10.1
Release: 1mamba
Summary: A framework for scientific data I/O to publish and subscribe to data when and where required
Group: Development/Tools
@ -8,7 +8,6 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/ornladios/ADIOS2
Source: https://github.com/ornladios/ADIOS2.git/v%{version}/ADIOS2-%{version}.tar.bz2
Patch0: adios2-2.10.0-pugixml-1.14.patch
License: Apache License 2.0
## AUTOBUILDREQ-BEGIN
BuildRequires: gcc-fortran
@ -29,6 +28,7 @@ BuildRequires: libzeromq-devel
BuildRequires: pugixml-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
BuildRequires: python-pybind11-devel
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description
@ -53,13 +53,15 @@ This package contains libraries and header files for developing applications tha
%prep
%setup -q -n ADIOS2-%{version}
%patch 0 -p1 -b .pugixml-1.14
%build
%cmake \
-DADIOS2_USE_EXTERNAL_DEPENDENCIES=ON \
-DADIOS2_HAVE_HDF5_VOL=OFF \
-DADIOS2_BUILD_EXAMPLES=OFF
-DADIOS2_BUILD_EXAMPLES=OFF \
%ifarch %{ix86}
-DCMAKE_CXX_FLAGS="%{optflags} -Wno-narrowing"
%endif
%cmake_build
@ -77,8 +79,10 @@ export CMAKE_PREFIX_PATH=%{buildroot}%{_libdir}/cmake
%files
%defattr(-,root,root)
%{_bindir}/adios2_*
%ifnarch %{ix86}
%{_bindir}/bp2h5
%{_bindir}/bp2h5_mpi
%endif
%{_bindir}/bp4dbg
%{_bindir}/bp5dbg
%{_bindir}/bpls
@ -107,5 +111,8 @@ export CMAKE_PREFIX_PATH=%{buildroot}%{_libdir}/cmake
%{_libdir}/cmake/adios2/*
%changelog
* Fri May 31 2024 Automatic Build System <autodist@openmamba.org> 2.10.1-1mamba
- automatic version update by autodist
* Mon May 06 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.0-1mamba
- package created using the webbuild interface