automatic version update by autodist [release 20240321-1mamba;Thu Apr 04 2024]
This commit is contained in:
parent
0eefacbe12
commit
9a896a50f8
@ -1,26 +0,0 @@
|
|||||||
--- acpica-unix-20061109/compiler/Makefile.deps 2006-11-09 15:56:22.000000000 -0500
|
|
||||||
+++ acpica-unix-20061109/compiler/Makefile 2007-01-26 06:00:48.000000000 -0500
|
|
||||||
@@ -87,6 +87,7 @@ SRCS= aslcompilerparse.c aslcompilerlex.
|
|
||||||
../tables/tbutils.c \
|
|
||||||
../tables/tbxface.c \
|
|
||||||
../osunixxf.c
|
|
||||||
+OBJS = $(SRCS:%.c=%.o)
|
|
||||||
|
|
||||||
NOMAN= YES
|
|
||||||
CFLAGS+= -Wall -O2 -Wstrict-prototypes -D_LINUX -DACPI_ASL_COMPILER -I../include
|
|
||||||
@@ -103,9 +104,12 @@ YFLAGS+= -y -pAslCompiler
|
|
||||||
#CFLAGS+= -D_USE_BERKELEY_YACC
|
|
||||||
#.endif
|
|
||||||
|
|
||||||
-aslmain : $(patsubst %.c,%.o, $(SRCS))
|
|
||||||
- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) \
|
|
||||||
- $(LOADLIBES) $(LDLIBS) -o iasl
|
|
||||||
+aslmain: aslcompilerparse.c
|
|
||||||
+ $(MAKE) $(PROG)
|
|
||||||
+
|
|
||||||
+$(PROG): $(OBJS)
|
|
||||||
+ $(CC) $(LDFLAGS) $(OBJS) \
|
|
||||||
+ $(LOADLIBES) $(LDLIBS) -o $@
|
|
||||||
|
|
||||||
CLEANFILES= y.output y.tab.c y.tab.h aslcompiler.y.h \
|
|
||||||
aslcompilerparse.c aslcompilerlex.c iasl
|
|
11
acpica.spec
11
acpica.spec
@ -1,5 +1,5 @@
|
|||||||
Name: acpica
|
Name: acpica
|
||||||
Version: 20230628
|
Version: 20240321
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Advanced Configuration & Power Interface Component Architecture
|
Summary: Advanced Configuration & Power Interface Component Architecture
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
@ -7,12 +7,11 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html
|
URL: https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html
|
||||||
# NOTE: manually downloaded from website
|
# NOTE: needs manual url update
|
||||||
Source: https://acpica.org/sites/acpica/files/acpica-unix-%{version}.tar.gz
|
Source: https://downloadmirror.intel.com/819451/acpica-unix-%{version}.tar.gz
|
||||||
Source1: %{name}-license
|
Source1: %{name}-license
|
||||||
Source2: http://www.intel.com/technology/iapc/acpi/downloads/AslCompiler.pdf
|
Source2: http://www.intel.com/technology/iapc/acpi/downloads/AslCompiler.pdf
|
||||||
Source3: http://www.intel.com/technology/iapc/acpi/downloads/ACPICA-ProgRef.pdf
|
Source3: http://www.intel.com/technology/iapc/acpi/downloads/ACPICA-ProgRef.pdf
|
||||||
Patch0: %{name}-20061109-makefile.patch
|
|
||||||
Patch1: %{name}-20061109-iasl_manpage.patch
|
Patch1: %{name}-20061109-iasl_manpage.patch
|
||||||
License: Intel Software License Agreement
|
License: Intel Software License Agreement
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -31,7 +30,6 @@ This includes: AML interpreter and debugger, Namespace Management, ACPI hardware
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-unix-%{version}
|
%setup -q -n %{name}-unix-%{version}
|
||||||
cd source
|
cd source
|
||||||
#%patch0 -p1
|
|
||||||
%patch 1 -p1
|
%patch 1 -p1
|
||||||
|
|
||||||
cp %{S:1} LICENSE
|
cp %{S:1} LICENSE
|
||||||
@ -56,6 +54,9 @@ export CFLAGS="%{optflags} -Wno-dangling-pointer -Wno-format-overflow"
|
|||||||
%doc source/LICENSE
|
%doc source/LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 04 2024 Automatic Build System <autodist@openmamba.org> 20240321-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Wed Aug 16 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 20230628-1mamba
|
* Wed Aug 16 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 20230628-1mamba
|
||||||
- update to 20230628
|
- update to 20230628
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user