path: scoped-mock-log: fix protobuf build (ref. https://github.com/abseil/abseil-cpp/issues/1407) [release 20230802.1-2mamba;Thu Sep 21 2023]
This commit is contained in:
parent
523389a3f7
commit
380b8709a3
12
abseil-cpp-20230802.1-scoped-mock-log.patch
Normal file
12
abseil-cpp-20230802.1-scoped-mock-log.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/absl/log/CMakeLists.txt b/absl/log/CMakeLists.txt
|
||||
index 78adbf1d..b64822dd 100644
|
||||
--- a/absl/log/CMakeLists.txt
|
||||
+++ b/absl/log/CMakeLists.txt
|
||||
@@ -637,7 +637,6 @@ absl_cc_library(
|
||||
GTest::gmock
|
||||
GTest::gtest
|
||||
PUBLIC
|
||||
- TESTONLY
|
||||
)
|
||||
|
||||
absl_cc_library(
|
@ -1,6 +1,6 @@
|
||||
Name: abseil-cpp
|
||||
Version: 20230802.1
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: An open-source collection of C++ code (compliant to C++11) designed to augment the C++ standard library
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -8,10 +8,12 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://abseil.io/
|
||||
Source: https://github.com/abseil/abseil-cpp.git/%{version}/abseil-cpp-%{version}.tar.bz2
|
||||
Patch0: abseil-cpp-20230802.1-scoped-mock-log.patch
|
||||
License: Apache License 2.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgmock-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
@ -40,11 +42,23 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%debug_package
|
||||
|
||||
# Don't clean build at the end
|
||||
%global __spec_rmbuild_cmd /bin/true
|
||||
|
||||
%global __requires_exclude ^pkgconfig\\(absl_random_internal_mock_overload_set\\)
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .scoped-mock-log
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
%cmake -d build \
|
||||
-DCMAKE_CXX_STANDARD=17 \
|
||||
-DBUILD_SHARED_LIBS=ON \
|
||||
-DABSL_BUILD_TEST_HELPERS=ON \
|
||||
-DABSL_USE_EXTERNAL_GOOGLETEST=ON \
|
||||
-DABSL_FIND_GOOGLETEST=ON
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -73,6 +87,9 @@ This package contains libraries and header files for developing applications tha
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Thu Sep 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 20230802.1-2mamba
|
||||
- path: scoped-mock-log: fix protobuf build (ref. https://github.com/abseil/abseil-cpp/issues/1407)
|
||||
|
||||
* Tue Sep 19 2023 Automatic Build System <autodist@mambasoft.it> 20230802.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user