automatic version update by autodist [release 4.15.6-1mamba;Fri Mar 15 2024]
This commit is contained in:
parent
4ff4edc5b3
commit
eba69bada7
@ -1,27 +0,0 @@
|
|||||||
--- a2ps-4.13/lib/path-concat.c.includes 1999-10-10 14:34:46.000000000 -0400
|
|
||||||
+++ a2ps-4.13/lib/path-concat.c 2004-10-01 08:25:27.048395690 -0400
|
|
||||||
@@ -26,13 +26,12 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include <stdio.h>
|
|
||||||
+#include <stdlib.h>
|
|
||||||
#if HAVE_STRING_H
|
|
||||||
# include <string.h>
|
|
||||||
#endif
|
|
||||||
#include <sys/types.h>
|
|
||||||
|
|
||||||
-char *malloc ();
|
|
||||||
-
|
|
||||||
#ifndef DIRECTORY_SEPARATOR
|
|
||||||
# define DIRECTORY_SEPARATOR '/'
|
|
||||||
#endif
|
|
||||||
--- a2ps-4.13/lib/quotearg.c.includes 2000-01-19 03:19:48.000000000 -0500
|
|
||||||
+++ a2ps-4.13/lib/quotearg.c 2004-10-01 08:30:52.892125379 -0400
|
|
||||||
@@ -26,6 +26,7 @@
|
|
||||||
#include <xalloc.h>
|
|
||||||
|
|
||||||
#include <ctype.h>
|
|
||||||
+#include <wctype.h>
|
|
||||||
#if defined (STDC_HEADERS) || (!defined (isascii) && !defined (HAVE_ISASCII))
|
|
||||||
# define ISASCII(c) 1
|
|
||||||
#else
|
|
28
a2ps.spec
28
a2ps.spec
@ -1,5 +1,5 @@
|
|||||||
Name: a2ps
|
Name: a2ps
|
||||||
Version: 4.15.5
|
Version: 4.15.6
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: GNU a2ps is an Any to PostScript filter
|
Summary: GNU a2ps is an Any to PostScript filter
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
@ -7,9 +7,8 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.gnu.org/software/a2ps/
|
URL: http://www.gnu.org/software/a2ps/
|
||||||
Source: ftp://ftp.gnu.org/gnu/a2ps/a2ps-%{version}.tar.gz
|
Source: https://ftp.gnu.org/gnu/a2ps/a2ps-%{version}.tar.gz
|
||||||
Patch0: %{name}-4.13-includes.patch
|
Patch1: a2ps-4.14-ghostscript_fonts_path.patch
|
||||||
Patch1: %{name}-4.14-ghostscript_fonts_path.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -26,8 +25,6 @@ BuildRequires: groff
|
|||||||
BuildRequires: gv
|
BuildRequires: gv
|
||||||
BuildRequires: perl-devel
|
BuildRequires: perl-devel
|
||||||
BuildRequires: psutils
|
BuildRequires: psutils
|
||||||
#BuildRequires: tetex-dvips
|
|
||||||
#BuildRequires: tetex-latex
|
|
||||||
BuildRequires: texinfo
|
BuildRequires: texinfo
|
||||||
BuildRequires: emacs-nox
|
BuildRequires: emacs-nox
|
||||||
Requires: file
|
Requires: file
|
||||||
@ -37,11 +34,6 @@ Requires: emacs >= 21.3-3
|
|||||||
Requires(post):%{__install_info}
|
Requires(post):%{__install_info}
|
||||||
Obsoletes: a2ps-devel < 4.15
|
Obsoletes: a2ps-devel < 4.15
|
||||||
|
|
||||||
# FIXME:
|
|
||||||
# checking for html2ps... no
|
|
||||||
# An HTML to PostScript converter written in Perl
|
|
||||||
# http://user.it.uu.se/~jan/html2ps.html
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GNU a2ps is an Any to PostScript filter.
|
GNU a2ps is an Any to PostScript filter.
|
||||||
Of course it processes plain text files, but also pretty prints quite a few popular languages.
|
Of course it processes plain text files, but also pretty prints quite a few popular languages.
|
||||||
@ -60,13 +52,11 @@ This package contains static libraries and header files needed for development.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1 -b .includes
|
|
||||||
%patch 1 -p1 -b .ghostscript_fonts_path
|
%patch 1 -p1 -b .ghostscript_fonts_path
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--with-medium=A4
|
--with-medium=A4
|
||||||
# --with-included-gettext
|
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -79,6 +69,7 @@ This package contains static libraries and header files needed for development.
|
|||||||
%define info_files %{name}.info ogonkify.info regex.info
|
%define info_files %{name}.info ogonkify.info regex.info
|
||||||
|
|
||||||
rm -f %{buildroot}%{_libdir}/*.a
|
rm -f %{buildroot}%{_libdir}/*.a
|
||||||
|
rm -f %{buildroot}%{_infodir}/dir
|
||||||
|
|
||||||
%post
|
%post
|
||||||
for info_file in %info_files
|
for info_file in %info_files
|
||||||
@ -113,15 +104,12 @@ exit 0
|
|||||||
%{_infodir}/ogonkify.*
|
%{_infodir}/ogonkify.*
|
||||||
%{_infodir}/regex.info*
|
%{_infodir}/regex.info*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%doc AUTHORS
|
%doc AUTHORS COPYING
|
||||||
#COPYING
|
|
||||||
|
|
||||||
#%files devel
|
|
||||||
#%defattr(-,root,root)
|
|
||||||
#%{_includedir}/*.h
|
|
||||||
#%doc NEWS README THANKS TODO ChangeLog
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 15 2024 Automatic Build System <autodist@openmamba.org> 4.15.6-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Jun 23 2023 Automatic Build System <autodist@mambasoft.it> 4.15.5-1mamba
|
* Fri Jun 23 2023 Automatic Build System <autodist@mambasoft.it> 4.15.5-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user