rebuilt to remove executable requirements [release 4.14-3mamba;Thu Feb 04 2010]

This commit is contained in:
Silvan Calarco 2024-01-05 20:07:46 +01:00
parent a891e48a73
commit d45e8fc412
4 changed files with 228 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# a2ps
GNU a2ps is an Any to PostScript filter.
Of course it processes plain text files, but also pretty prints quite a few popular languages.

27
a2ps-4.13-includes.patch Normal file
View File

@ -0,0 +1,27 @@
--- a2ps-4.13/lib/path-concat.c.includes 1999-10-10 14:34:46.000000000 -0400
+++ a2ps-4.13/lib/path-concat.c 2004-10-01 08:25:27.048395690 -0400
@@ -26,13 +26,12 @@
#endif
#include <stdio.h>
+#include <stdlib.h>
#if HAVE_STRING_H
# include <string.h>
#endif
#include <sys/types.h>
-char *malloc ();
-
#ifndef DIRECTORY_SEPARATOR
# define DIRECTORY_SEPARATOR '/'
#endif
--- a2ps-4.13/lib/quotearg.c.includes 2000-01-19 03:19:48.000000000 -0500
+++ a2ps-4.13/lib/quotearg.c 2004-10-01 08:30:52.892125379 -0400
@@ -26,6 +26,7 @@
#include <xalloc.h>
#include <ctype.h>
+#include <wctype.h>
#if defined (STDC_HEADERS) || (!defined (isascii) && !defined (HAVE_ISASCII))
# define ISASCII(c) 1
#else

View File

@ -0,0 +1,32 @@
--- a2ps-4.14/configure 2007-12-29 04:28:03.000000000 +0100
+++ a2ps-4.14/configure.font 2008-01-07 21:29:31.000000000 +0100
@@ -30760,12 +30760,28 @@
# Find out if ghostscript is installed
ac_psfont_path=
for ac_dir in /usr/local/ghostscript/fonts \
- /usr/local/share/ghostscript/fonts;
+ /usr/local/share/ghostscript/fonts \
+ /usr/ghostscript/fonts \
+ /usr/share/ghostscript/fonts/;
do
if test "cd $ac_dir 2>/dev/null && echo *.afm"; then
ac_psfont_path="$ac_psfont_path:$ac_dir";
fi
done
+# Try to find where are the TeX fonts.
+for ac_dir in /usr/share/texmf;
+do
+ if test -d "$ac_dir/fonts"; then
+ # There are fonts here. Let's fetch all the directories.
+ for ac_dir2 in `find $ac_dir/fonts/* -type d`;
+ do
+ if test -n "`echo $ac_dir2/*.afm $ac_dir2/*.gsf $ac_dir2/*.pf?`"; then
+ ac_psfont_path="$ac_psfont_path:$ac_dir2";
+ fi
+ done
+ fi
+done
+# Remove the leading `:'
if test -n "$ac_psfont_path"; then
PSFONT_PATH=`echo "$ac_psfont_path" | sed -e 's/^://'`
fi

166
a2ps.spec Normal file
View File

@ -0,0 +1,166 @@
Name: a2ps
Version: 4.14
Release: 3mamba
Summary: GNU a2ps is an Any to PostScript filter
Group: Applications/Publishing
Vendor: openmamba
Distribution: openmamba
Packager: Aleph0 <aleph0@openmamba.org>
URL: http://www.gnu.org/software/a2ps/
Source: ftp://ftp.gnu.org/gnu/a2ps/a2ps-%{version}.tar.gz
Patch0: %{name}-4.13-includes.patch
Patch1: %{name}-4.14-ghostscript_fonts_path.patch
License: GPL
BuildRequires: bash
BuildRequires: bison
BuildRequires: flex
BuildRequires: gettext-devel
BuildRequires: ghostscript
BuildRequires: gperf
BuildRequires: groff
BuildRequires: gv
BuildRequires: perl-devel
BuildRequires: psutils
#BuildRequires: tetex-dvips
#BuildRequires: tetex-latex
BuildRequires: texinfo
BuildRequires: emacs-nox
## AUTOBUILDREQ-BEGIN
BuildRequires: binutils
BuildRequires: debianutils
BuildRequires: emacs
BuildRequires: file
BuildRequires: glibc-devel
BuildRequires: libpaper-devel
## AUTOBUILDREQ-END
Requires: file
Requires: binutils
Requires: debianutils
Requires: emacs >= 21.3-3
Requires(post):%{__install_info}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# FIXME:
# checking for html2ps... no
# An HTML to PostScript converter written in Perl
# http://user.it.uu.se/~jan/html2ps.html
%description
GNU a2ps is an Any to PostScript filter.
Of course it processes plain text files, but also pretty prints quite a few popular languages.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
GNU a2ps is an Any to PostScript filter.
Of course it processes plain text files, but also pretty prints quite a few popular languages.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1 -b .includes
%patch1 -p1 -b .ghostscript_fonts_path
%build
%configure \
--with-medium=A4
# --with-included-gettext
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%{find_lang} %{name}
%define info_files %{name}.info ogonkify.info regex.info
rm -f %{buildroot}%{_libdir}/*.a
%post
for info_file in %info_files
do %install_info $info_file
done
# adapt /usr/share/a2ps/afm/fonts.map to the current system environment
( cd %{_datadir}/%{name}/afm/
./make_fonts_map.sh >/dev/null 2>&1
mv -f fonts.map.new fonts.map)
exit 0
%preun
for info_file in %info_files
do %uninstall_info $info_file
done
exit 0
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/a2ps
%{_bindir}/card
%{_bindir}/composeglyphs
%{_bindir}/fixnt
%{_bindir}/fixps
%{_bindir}/ogonkify
%{_bindir}/pdiff
%{_bindir}/psmandup
%{_bindir}/psset
%{_bindir}/texi2dvi4a2ps
%config(noreplace) %{_sysconfdir}/a2ps.cfg
%config(noreplace) %{_sysconfdir}/a2ps-site.cfg
%dir %{_datadir}/a2ps
%{_datadir}/a2ps/*
%{_datadir}/emacs/site-lisp/*
%dir %{_datadir}/ogonkify
%{_datadir}/ogonkify/*
%{_infodir}/a2ps.info*
%{_infodir}/ogonkify.*
%{_infodir}/regex.info*
%{_mandir}/man1/*
%doc AUTHORS COPYING NEWS README THANKS TODO
%files devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_libdir}/*.la
%doc ChangeLog
%changelog
* Thu Feb 04 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14-3mamba
- rebuilt to remove executable requirements
* Tue Jul 15 2008 gil <puntogil@libero.it> 4.14-2mamba
- rebuild with new libpaper-1.1.21-1mamba
* Mon Jan 07 2008 Aleph0 <aleph0@openmamba.org> 4.14-1mamba
- update to 4.14 (also fixes CAN-2004-1170, CVE-2004-1377)
- removed obsolete patches
* Mon Dec 03 2007 Aleph0 <aleph0@openmamba.org> 4.13b-7mamba
- use A4 format by default
- use system gettext library
- new package mantainer
* Wed Oct 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 4.13b-6mamba
- specfile update and rebuild
* Fri Jan 13 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 4.13b-5qilnx
- added missing build requirement
* Wed Nov 16 2005 Davide Madrisan <davide.madrisan@qilinux.it> 4.13b-4qilnx
- rebuilt
* Fri Apr 15 2005 Davide Madrisan <davide.madrisan@qilinux.it> 4.13b-3qilnx
- %%post, %%preun: install/uninstall info pages
* Fri Dec 10 2004 Davide Madrisan <davide.madrisan@qilinux.it> 4.13b-2qilnx
- fixed `a2ps-4.13-badscripts.patch'
* Mon Nov 29 2004 Davide Madrisan <davide.madrisan@qilinux.it> 4.13b-1qilnx
- package created by autospec