automatic version update by autodist [release 7.0.14-1mamba;Tue Feb 06 2024]
This commit is contained in:
parent
7d5ff79fd0
commit
d13e5aa3e7
@ -1,30 +0,0 @@
|
||||
--- VirtualBox-4.0.8_OSE.orig/Config.kmk 2011-05-16 18:32:40.000000000 +0200
|
||||
+++ VirtualBox-4.0.8_OSE/Config.kmk 2011-05-28 17:34:35.884436301 +0200
|
||||
@@ -486,7 +486,7 @@
|
||||
# Enables the ffmpeg module for recording test runs.
|
||||
# TODO: Enable this for normal build server builds?
|
||||
#if1of ($(KBUILD_TARGET), linux)
|
||||
-# VBOX_WITH_FFMPEG = 1
|
||||
+VBOX_WITH_FFMPEG = 1
|
||||
#endif
|
||||
# Enable shared folders
|
||||
VBOX_WITH_SHARED_FOLDERS = 1
|
||||
@@ -892,7 +892,6 @@
|
||||
endif
|
||||
VBOX_WITH_TESTSUITE=
|
||||
VBOX_WITH_INTEL_PXE=
|
||||
- VBOX_WITH_FFMPEG=
|
||||
ifn1of ($(KBUILD_TARGET), darwin linux solaris win)
|
||||
VBOX_WITH_INSTALLER=
|
||||
endif
|
||||
--- VirtualBox-4.0.8_OSE.orig/src/libs/Makefile.kmk 2011-05-16 18:34:01.000000000 +0200
|
||||
+++ VirtualBox-4.0.8_OSE/src/libs/Makefile.kmk 2011-05-28 17:47:24.224649687 +0200
|
||||
@@ -72,7 +72,7 @@
|
||||
endif
|
||||
|
||||
# FFmpeg for test videos.
|
||||
- if defined(VBOX_WITH_FFMPEG) && !defined(VBOX_OSE) && !defined(VBOX_ONLY_DOCS) && !defined(VBOX_WITH_SDK)
|
||||
+ if defined(VBOX_WITH_FFMPEG) && !defined(VBOX_ONLY_DOCS) && !defined(VBOX_WITH_SDK)
|
||||
if1of ($(KBUILD_TARGET), darwin linux solaris)
|
||||
include $(PATH_SUB_CURRENT)/ffmpeg-20060710/Makefile.kmk
|
||||
endif
|
@ -1,11 +0,0 @@
|
||||
diff -Nru VirtualBox-4.1.8_OSE.orig/configure VirtualBox-4.1.8_OSE/configure
|
||||
--- VirtualBox-4.1.8_OSE.orig/configure 2012-05-24 10:45:09.102915885 +0000
|
||||
+++ VirtualBox-4.1.8_OSE/configure 2012-05-24 10:44:58.926034932 +0000
|
||||
@@ -2600,7 +2600,6 @@
|
||||
fi
|
||||
check_libcap
|
||||
check_compiler_h
|
||||
- [ "$BUILD_MACHINE" = "amd64" -a $WITH_VMMRAW -eq 1 ] && check_32bit
|
||||
# tools/common/makeself*
|
||||
[ $OSE -ge 1 ] && check_makeself
|
||||
fi
|
@ -1,17 +0,0 @@
|
||||
--- VirtualBox-4.2.16/src/VBox/Installer/linux/VBoxCreateUSBNode.sh.orig 2013-08-11 16:18:03.024582594 +0200
|
||||
+++ VirtualBox-4.2.16/src/VBox/Installer/linux/VBoxCreateUSBNode.sh 2013-08-11 16:18:26.475361230 +0200
|
||||
@@ -37,11 +37,11 @@
|
||||
exit 0
|
||||
fi
|
||||
case "$group" in "") group="vboxusers";; esac
|
||||
- mkdir /dev/vboxusb -m 0750 2>/dev/null
|
||||
+ mkdir /dev/vboxusb -m 0755 2>/dev/null
|
||||
chown root:$group /dev/vboxusb 2>/dev/null
|
||||
- mkdir "$devdir" -m 0750 2>/dev/null
|
||||
+ mkdir "$devdir" -m 0755 2>/dev/null
|
||||
chown root:$group "$devdir" 2>/dev/null
|
||||
- mknod "$devpath" c $1 $2 -m 0660 2>/dev/null
|
||||
+ mknod "$devpath" c $1 $2 -m 0666 2>/dev/null
|
||||
chown root:$group "$devpath" 2>/dev/null
|
||||
;;
|
||||
1)
|
@ -1,14 +0,0 @@
|
||||
--- VirtualBox-4.3.12/configure.orig 2014-05-16 14:18:25.000000000 +0200
|
||||
+++ VirtualBox-4.3.12/configure 2014-05-18 16:29:23.400318654 +0200
|
||||
@@ -420,9 +420,9 @@
|
||||
elif [ $cc_maj -lt 3 \
|
||||
-o \( $cc_maj -eq 3 -a $cc_min -lt 2 \) \
|
||||
-o \( $cc_maj -eq 4 -a $cc_min -lt 1 -a "$OS" != "darwin" \) \
|
||||
- -o \( $cc_maj -eq 4 -a $cc_min -gt 8 \) \
|
||||
+ -o \( $cc_maj -eq 4 -a $cc_min -gt 9 \) \
|
||||
-o $cc_maj -gt 4 ]; then
|
||||
- log_failure "gcc version $cc_ver found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<8"
|
||||
+ log_failure "gcc version $cc_ver found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<9"
|
||||
fail really
|
||||
else
|
||||
log_success "found version $cc_ver"
|
@ -1,15 +0,0 @@
|
||||
diff -Nru VirtualBox-4.3.12.orig/configure VirtualBox-4.3.12/configure
|
||||
--- VirtualBox-4.3.12.orig/configure 2014-05-16 14:18:25.000000000 +0200
|
||||
+++ VirtualBox-4.3.12/configure 2014-06-15 16:23:03.372080228 +0200
|
||||
@@ -420,9 +420,9 @@
|
||||
elif [ $cc_maj -lt 3 \
|
||||
-o \( $cc_maj -eq 3 -a $cc_min -lt 2 \) \
|
||||
-o \( $cc_maj -eq 4 -a $cc_min -lt 1 -a "$OS" != "darwin" \) \
|
||||
- -o \( $cc_maj -eq 4 -a $cc_min -gt 8 \) \
|
||||
+ -o \( $cc_maj -eq 4 -a $cc_min -gt 9 \) \
|
||||
-o $cc_maj -gt 4 ]; then
|
||||
- log_failure "gcc version $cc_ver found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<8"
|
||||
+ log_failure "gcc version $cc_ver found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<10"
|
||||
fail really
|
||||
else
|
||||
log_success "found version $cc_ver"
|
@ -1,43 +0,0 @@
|
||||
Index: virtualbox/src/VBox/Additions/common/crOpenGL/Makefile.kmk
|
||||
===================================================================
|
||||
--- virtualbox.orig/src/VBox/Additions/common/crOpenGL/Makefile.kmk 2015-04-02 15:44:24.955670965 +0200
|
||||
+++ virtualbox/src/VBox/Additions/common/crOpenGL/Makefile.kmk 2015-04-02 15:44:24.955670965 +0200
|
||||
@@ -67,18 +67,12 @@
|
||||
VBoxOGL_INCS = .
|
||||
if1of ($(KBUILD_TARGET), linux solaris freebsd)
|
||||
VBoxOGL_INCS += \
|
||||
- $(VBOX_PATH_X11_ROOT)/libXdamage-1.1 \
|
||||
- $(VBOX_PATH_X11_ROOT)/libXcomposite-0.4.0 \
|
||||
- $(VBOX_PATH_X11_ROOT)/libXext-1.3.1 \
|
||||
- $(VBOX_PATH_X11_ROOT)/libXfixes-4.0.3 \
|
||||
- $(VBOX_PATH_X11_ROOT)/damageproto-1.1.0 \
|
||||
- $(VBOX_PATH_X11_ROOT)/compositeproto-0.4 \
|
||||
- $(VBOX_PATH_X11_ROOT)/fixesproto-4.0 \
|
||||
- $(VBOX_PATH_X11_ROOT)/libx11-1.1.5-other \
|
||||
- $(VBOX_PATH_X11_ROOT)/xextproto-7.1.1 \
|
||||
- $(VBOX_PATH_X11_ROOT)/xproto-7.0.18 \
|
||||
+ /usr/include/x11 \
|
||||
+ /usr/include/xorg \
|
||||
+ /usr/include/pixman-1 \
|
||||
$(VBOX_MESA_INCS) \
|
||||
- $(PATH_ROOT)/src/VBox/Additions/x11/x11include/libdrm-2.4.13
|
||||
+ /usr/include/drm \
|
||||
+ /usr/include/libdrm
|
||||
VBoxOGL_DEFS += VBOX_NO_NATIVEGL
|
||||
endif
|
||||
|
||||
@@ -213,10 +207,10 @@
|
||||
|
||||
if1of ($(KBUILD_TARGET), linux solaris freebsd)
|
||||
VBoxOGL_LIBS += \
|
||||
- $(PATH_STAGE_LIB)/libXcomposite.so \
|
||||
- $(PATH_STAGE_LIB)/libXdamage.so \
|
||||
- $(PATH_STAGE_LIB)/libXfixes.so \
|
||||
- $(PATH_STAGE_LIB)/libXext.so
|
||||
+ Xcomposite \
|
||||
+ Xdamage \
|
||||
+ Xfixes \
|
||||
+ Xext
|
||||
ifdef VBoxOGL_FAKEDRI
|
||||
ifeq ($(KBUILD_TARGET), freebsd)
|
||||
VBoxOGL_LIBS += \
|
@ -1,24 +0,0 @@
|
||||
Index: trunk/src/VBox/ExtPacks/VNC/VBoxVNC.cpp
|
||||
===================================================================
|
||||
--- a/trunk/src/VBox/ExtPacks/VNC/VBoxVNC.cpp
|
||||
+++ b/trunk/src/VBox/ExtPacks/VNC/VBoxVNC.cpp
|
||||
@@ -104,6 +104,6 @@
|
||||
unsigned char *mFrameBuffer;
|
||||
uint32_t uClients;
|
||||
- static DECLCALLBACK(enum rfbNewClientAction) rfbNewClientEvent(rfbClientPtr cl);
|
||||
- static DECLCALLBACK(void) vncMouseEvent(int buttonMask, int x, int y, rfbClientPtr cl);
|
||||
+ static enum rfbNewClientAction rfbNewClientEvent(rfbClientPtr cl);
|
||||
+ static void vncMouseEvent(int buttonMask, int x, int y, rfbClientPtr cl);
|
||||
static void vncKeyboardEvent(rfbBool down, rfbKeySym keySym, rfbClientPtr cl);
|
||||
static void clientGoneHook(rfbClientPtr cl);
|
||||
Index: trunk/src/VBox/Additions/linux/lightdm-greeter/vbox-greeter.cpp
|
||||
===================================================================
|
||||
--- a/trunk/src/VBox/Additions/linux/lightdm-greeter/vbox-greeter.cpp
|
||||
+++ b/trunk/src/VBox/Additions/linux/lightdm-greeter/vbox-greeter.cpp
|
||||
@@ -843,5 +843,5 @@
|
||||
* @param pfnLog
|
||||
*/
|
||||
-static void vboxGreeterLogHeaderFooter(PRTLOGGER pLoggerRelease, RTLOGPHASE enmPhase, PFNRTLOGPHASEMSG pfnLog)
|
||||
+static DECLCALLBACK(void) vboxGreeterLogHeaderFooter(PRTLOGGER pLoggerRelease, RTLOGPHASE enmPhase, PFNRTLOGPHASEMSG pfnLog)
|
||||
{
|
||||
/* Some introductory information. */
|
@ -1,11 +0,0 @@
|
||||
--- VirtualBox-5.1.22/src/VBox/Main/webservice/Makefile.kmk.orig 2017-06-19 10:29:53.521378379 +0200
|
||||
+++ VirtualBox-5.1.22/src/VBox/Main/webservice/Makefile.kmk 2017-06-19 10:30:17.469556522 +0200
|
||||
@@ -733,7 +733,7 @@
|
||||
$(RECOMPILE_ON_MAKEFILE_CURRENT) | $$(dir $$@)
|
||||
$(call MSG_GENERATE,,lots of files,$(GSOAPH_RELEVANT))
|
||||
$(RM) -f $@
|
||||
- $(REDIRECT) -C $(VBOXWEB_OUT_DIR) -- $(VBOX_SOAPCPP2) $(VBOXWEB_SOAPCPP2_SKIP_FILES) -L -2 -w -I$(VBOX_PATH_GSOAP_IMPORT) $(GSOAPH_RELEVANT)
|
||||
+ $(REDIRECT) -C $(VBOXWEB_OUT_DIR) -- $(VBOX_SOAPCPP2) $(VBOXWEB_SOAPCPP2_SKIP_FILES) -z1 -L -2 -w -I$(VBOX_PATH_GSOAP_IMPORT) $(GSOAPH_RELEVANT)
|
||||
ifeq ($(KBUILD_TARGET),win) # MSC -Wall workaround.
|
||||
$(CP) -f "$(VBOXWEB_SOAP_CLIENT_H)" "$(VBOXWEB_SOAP_CLIENT_H).tmp"
|
||||
$(SED) -f $(VBOX_PATH_WEBSERVICE)/stdsoap2.sed --output "$(VBOXWEB_SOAP_CLIENT_H)" "$(VBOXWEB_SOAP_CLIENT_H).tmp"
|
@ -1,73 +0,0 @@
|
||||
--- "VirtualBox-6 1.0.10-orig/src/VBox/Devices/PC/vbox-cpuhotplug.dsl" 2019-08-28 14:37:51.872756997 +0200
|
||||
+++ "VirtualBox-6 1.0.10/src/VBox/Devices/PC/vbox-cpuhotplug.dsl" 2019-08-28 14:38:58.122755384 +0200
|
||||
@@ -95,38 +95,38 @@ DefinitionBlock ("SSDT-cpuhotplug.aml",
|
||||
} \
|
||||
} \
|
||||
|
||||
- GENERATE_CPU_OBJECT(0x00, SCK0, "SCKCPU0", CPU0, "SCK0-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x01, SCK1, "SCKCPU1", CPU1, "SCK1-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x02, SCK2, "SCKCPU2", CPU2, "SCK2-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x03, SCK3, "SCKCPU3", CPU3, "SCK3-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x04, SCK4, "SCKCPU4", CPU4, "SCK4-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x05, SCK5, "SCKCPU5", CPU5, "SCK5-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x06, SCK6, "SCKCPU6", CPU6, "SCK6-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x07, SCK7, "SCKCPU7", CPU7, "SCK7-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x08, SCK8, "SCKCPU8", CPU8, "SCK8-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x09, SCK9, "SCKCPU9", CPU9, "SCK9-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x0a, SCKA, "SCKCPUA", CPUA, "SCKA-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x0b, SCKB, "SCKCPUB", CPUB, "SCKB-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x0c, SCKC, "SCKCPUC", CPUC, "SCKC-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x0d, SCKD, "SCKCPUD", CPUD, "SCKD-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x0e, SCKE, "SCKCPUE", CPUE, "SCKE-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x0f, SCKF, "SCKCPUF", CPUF, "SCKF-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x10, SCKG, "SCKCPUG", CPUG, "SCKG-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x11, SCKH, "SCKCPUH", CPUH, "SCKH-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x12, SCKI, "SCKCPUI", CPUI, "SCKI-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x13, SCKJ, "SCKCPUJ", CPUJ, "SCKJ-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x14, SCKK, "SCKCPUK", CPUK, "SCKK-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x15, SCKL, "SCKCPUL", CPUL, "SCKL-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x16, SCKM, "SCKCPUM", CPUM, "SCKM-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x17, SCKN, "SCKCPUN", CPUN, "SCKN-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x18, SCKO, "SCKCPUO", CPUO, "SCKO-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x19, SCKP, "SCKCPUP", CPUP, "SCKP-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x1a, SCKQ, "SCKCPUQ", CPUQ, "SCKQ-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x1b, SCKR, "SCKCPUR", CPUR, "SCKR-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x1c, SCKS, "SCKCPUS", CPUS, "SCKS-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x1d, SCKT, "SCKCPUT", CPUT, "SCKT-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x1e, SCKU, "SCKCPUU", CPUU, "SCKU-CPU0")
|
||||
- GENERATE_CPU_OBJECT(0x1f, SCKV, "SCKCPUV", CPUV, "SCKV-CPU0")
|
||||
+ GENERATE_CPU_OBJECT(0x00, SCK0, "SCKCPU0", CPU0, 0)
|
||||
+ GENERATE_CPU_OBJECT(0x01, SCK1, "SCKCPU1", CPU1, 1)
|
||||
+ GENERATE_CPU_OBJECT(0x02, SCK2, "SCKCPU2", CPU2, 2)
|
||||
+ GENERATE_CPU_OBJECT(0x03, SCK3, "SCKCPU3", CPU3, 3)
|
||||
+ GENERATE_CPU_OBJECT(0x04, SCK4, "SCKCPU4", CPU4, 4)
|
||||
+ GENERATE_CPU_OBJECT(0x05, SCK5, "SCKCPU5", CPU5, 5)
|
||||
+ GENERATE_CPU_OBJECT(0x06, SCK6, "SCKCPU6", CPU6, 6)
|
||||
+ GENERATE_CPU_OBJECT(0x07, SCK7, "SCKCPU7", CPU7, 7)
|
||||
+ GENERATE_CPU_OBJECT(0x08, SCK8, "SCKCPU8", CPU8, 8)
|
||||
+ GENERATE_CPU_OBJECT(0x09, SCK9, "SCKCPU9", CPU9, 9)
|
||||
+ GENERATE_CPU_OBJECT(0x0a, SCKA, "SCKCPUA", CPUA, 10)
|
||||
+ GENERATE_CPU_OBJECT(0x0b, SCKB, "SCKCPUB", CPUB, 11)
|
||||
+ GENERATE_CPU_OBJECT(0x0c, SCKC, "SCKCPUC", CPUC, 12)
|
||||
+ GENERATE_CPU_OBJECT(0x0d, SCKD, "SCKCPUD", CPUD, 13)
|
||||
+ GENERATE_CPU_OBJECT(0x0e, SCKE, "SCKCPUE", CPUE, 14)
|
||||
+ GENERATE_CPU_OBJECT(0x0f, SCKF, "SCKCPUF", CPUF, 15)
|
||||
+ GENERATE_CPU_OBJECT(0x10, SCKG, "SCKCPUG", CPUG, 16)
|
||||
+ GENERATE_CPU_OBJECT(0x11, SCKH, "SCKCPUH", CPUH, 17)
|
||||
+ GENERATE_CPU_OBJECT(0x12, SCKI, "SCKCPUI", CPUI, 18)
|
||||
+ GENERATE_CPU_OBJECT(0x13, SCKJ, "SCKCPUJ", CPUJ, 19)
|
||||
+ GENERATE_CPU_OBJECT(0x14, SCKK, "SCKCPUK", CPUK, 20)
|
||||
+ GENERATE_CPU_OBJECT(0x15, SCKL, "SCKCPUL", CPUL, 21)
|
||||
+ GENERATE_CPU_OBJECT(0x16, SCKM, "SCKCPUM", CPUM, 22)
|
||||
+ GENERATE_CPU_OBJECT(0x17, SCKN, "SCKCPUN", CPUN, 23)
|
||||
+ GENERATE_CPU_OBJECT(0x18, SCKO, "SCKCPUO", CPUO, 24)
|
||||
+ GENERATE_CPU_OBJECT(0x19, SCKP, "SCKCPUP", CPUP, 25)
|
||||
+ GENERATE_CPU_OBJECT(0x1a, SCKQ, "SCKCPUQ", CPUQ, 26)
|
||||
+ GENERATE_CPU_OBJECT(0x1b, SCKR, "SCKCPUR", CPUR, 27)
|
||||
+ GENERATE_CPU_OBJECT(0x1c, SCKS, "SCKCPUS", CPUS, 28)
|
||||
+ GENERATE_CPU_OBJECT(0x1d, SCKT, "SCKCPUT", CPUT, 29)
|
||||
+ GENERATE_CPU_OBJECT(0x1e, SCKU, "SCKCPUU", CPUU, 30)
|
||||
+ GENERATE_CPU_OBJECT(0x1f, SCKV, "SCKCPUV", CPUV, 31)
|
||||
|
||||
#undef GENERATE_CPU_OBJECT
|
||||
}
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/VBox/Main/webservice/vboxweb.cpp b/src/VBox/Main/webservice/vboxweb.cpp
|
||||
index 8dd3ca1b..9d5c9138 100644
|
||||
--- a/src/VBox/Main/webservice/vboxweb.cpp
|
||||
+++ b/src/VBox/Main/webservice/vboxweb.cpp
|
||||
@@ -944,7 +944,7 @@ static void doQueuesLoop()
|
||||
if (rv == 0)
|
||||
continue; // timeout, not necessary to bother gsoap
|
||||
// r < 0, errno
|
||||
- if (soap_socket_errno(soap.master) == SOAP_EINTR)
|
||||
+ if (soap_socket_errno == SOAP_EINTR)
|
||||
rv = 0; // re-check if we should terminate
|
||||
break;
|
||||
}
|
@ -1,13 +0,0 @@
|
||||
--- VirtualBox-6.1.18/src/VBox/HostDrivers/Support/SUPDrvTracer.cpp.orig 2021-04-15 15:20:45.932726596 +0200
|
||||
+++ VirtualBox-6.1.18/src/VBox/HostDrivers/Support/SUPDrvTracer.cpp 2021-04-15 15:22:18.820418821 +0200
|
||||
@@ -1479,6 +1479,10 @@
|
||||
# if defined(RT_ARCH_AMD64)
|
||||
__asm__(" \
|
||||
movq g_pfnSupdrvProbeFireKernel(%rip), %rax \n\
|
||||
+999:\n\
|
||||
+ .pushsection .discard.retpoline_safe\n\
|
||||
+ .quad 999b\n\
|
||||
+ .popsection\n\
|
||||
jmp *%rax \n\
|
||||
");
|
||||
# elif defined(RT_ARCH_X86)
|
@ -1,18 +0,0 @@
|
||||
--- a/Config.kmk
|
||||
+++ b/Config.kmk
|
||||
@@ -4502,11 +4502,14 @@ ifeq ($(VBOX_LDR_FMT),elf)
|
||||
TEMPLATE_VBoxR0_TOOL = $(VBOX_GCC_TOOL)
|
||||
TEMPLATE_VBoxR0_CFLAGS = -fno-pie -nostdinc -g $(VBOX_GCC_pipe) $(VBOX_GCC_WERR) $(VBOX_GCC_PEDANTIC_C) \
|
||||
$(VBOX_GCC_Wno-variadic-macros) $(VBOX_GCC_R0_OPT) $(VBOX_GCC_R0_FP) -fno-strict-aliasing -fno-exceptions \
|
||||
- $(VBOX_GCC_fno-stack-protector) -fno-common $(VBOX_GCC_fvisibility-hidden) -std=gnu99 $(VBOX_GCC_IPRT_FMT_CHECK)
|
||||
+ $(VBOX_GCC_fno-stack-protector) -fno-common -ffreestanding $(VBOX_GCC_fvisibility-hidden) -std=gnu99 $(VBOX_GCC_IPRT_FMT_CHECK)
|
||||
TEMPLATE_VBoxR0_CXXFLAGS = -fno-pie -nostdinc -g $(VBOX_GCC_pipe) $(VBOX_GCC_WERR) $(VBOX_GCC_PEDANTIC_CXX) \
|
||||
$(VBOX_GCC_Wno-variadic-macros) $(VBOX_GCC_R0_OPT) $(VBOX_GCC_R0_FP) -fno-strict-aliasing -fno-exceptions \
|
||||
$(VBOX_GCC_fno-stack-protector) -fno-common $(VBOX_GCC_fvisibility-inlines-hidden) $(VBOX_GCC_fvisibility-hidden) \
|
||||
-fno-rtti $(VBOX_GCC_IPRT_FMT_CHECK)
|
||||
+ if $(VBOX_GCC_VERSION_CC) >= 40500 # 4.1.2 complains, 4.5.2 is okay, didn't check which version inbetween made it okay with g++.
|
||||
+TEMPLATE_VBoxR0_CXXFLAGS += -ffreestanding
|
||||
+ endif
|
||||
TEMPLATE_VBoxR0_CFLAGS.amd64 = -m64 -mno-red-zone -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -fasynchronous-unwind-tables -ffreestanding
|
||||
TEMPLATE_VBoxR0_CXXFLAGS.amd64 = -m64 -mno-red-zone -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -fasynchronous-unwind-tables
|
||||
TEMPLATE_VBoxR0_CXXFLAGS.freebsd = -ffreestanding
|
47
VirtualBox-7.0.14-libxml2-2.12.5.patch
Normal file
47
VirtualBox-7.0.14-libxml2-2.12.5.patch
Normal file
@ -0,0 +1,47 @@
|
||||
diff --git a/include/iprt/cpp/xml.h b/include/iprt/cpp/xml.h
|
||||
index 40975e86..7639c281 100644
|
||||
--- a/include/iprt/cpp/xml.h
|
||||
+++ b/include/iprt/cpp/xml.h
|
||||
@@ -113,9 +113,9 @@ public:
|
||||
class RT_DECL_CLASS XmlError : public RuntimeError
|
||||
{
|
||||
public:
|
||||
- XmlError(xmlErrorPtr aErr);
|
||||
+ XmlError(const xmlError *aErr);
|
||||
|
||||
- static char* Format(xmlErrorPtr aErr);
|
||||
+ static char* Format(const xmlError *aErr);
|
||||
};
|
||||
|
||||
// Logical errors
|
||||
diff --git a/src/VBox/Runtime/r3/xml.cpp b/src/VBox/Runtime/r3/xml.cpp
|
||||
index a6661760..b301a6c6 100644
|
||||
--- a/src/VBox/Runtime/r3/xml.cpp
|
||||
+++ b/src/VBox/Runtime/r3/xml.cpp
|
||||
@@ -131,7 +131,7 @@ LogicError::LogicError(RT_SRC_POS_DECL)
|
||||
RTStrFree(msg);
|
||||
}
|
||||
|
||||
-XmlError::XmlError(xmlErrorPtr aErr)
|
||||
+XmlError::XmlError(const xmlError *aErr)
|
||||
{
|
||||
if (!aErr)
|
||||
throw EInvalidArg(RT_SRC_POS);
|
||||
@@ -145,7 +145,7 @@ XmlError::XmlError(xmlErrorPtr aErr)
|
||||
* Composes a single message for the given error. The caller must free the
|
||||
* returned string using RTStrFree() when no more necessary.
|
||||
*/
|
||||
-/* static */ char *XmlError::Format(xmlErrorPtr aErr)
|
||||
+/* static */ char *XmlError::Format(const xmlError *aErr)
|
||||
{
|
||||
const char *msg = aErr->message ? aErr->message : "<none>";
|
||||
size_t msgLen = strlen(msg);
|
||||
@@ -1856,7 +1856,7 @@ static void xmlParserBaseGenericError(void *pCtx, const char *pszMsg, ...) RT_NO
|
||||
va_end(args);
|
||||
}
|
||||
|
||||
-static void xmlParserBaseStructuredError(void *pCtx, xmlErrorPtr error) RT_NOTHROW_DEF
|
||||
+static void xmlParserBaseStructuredError(void *pCtx, const xmlError *error) RT_NOTHROW_DEF
|
||||
{
|
||||
NOREF(pCtx);
|
||||
/* we expect that there is always a trailing NL */
|
@ -17,7 +17,7 @@
|
||||
%endif
|
||||
|
||||
Name: VirtualBox
|
||||
Version: 7.0.12
|
||||
Version: 7.0.14
|
||||
Release: 1mamba
|
||||
Summary: A general-purpose full virtualizer for x86 hardware
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
@ -39,23 +39,12 @@ Source12: vboxdrmclient.service
|
||||
Source13: vboxdrmclient.path
|
||||
Source14: vboxguest.rules
|
||||
Source15: virtualbox-guest.sysusers
|
||||
Patch0: %{name}-4.0.8-enable_ffmpeg_capture.patch
|
||||
Patch1: %{name}-4.1.8-x86_64-disable_check_32bit.patch
|
||||
Patch2: VirtualBox-4.3.12-gcc-4.9.patch
|
||||
Patch3: VirtualBox-4.2.16-vboxusb-permissions.patch
|
||||
Patch4: VirtualBox-4.3.12-gcc-4.9.0.patch
|
||||
Patch5: VirtualBox-4.3.26-vdfuse.patch
|
||||
Patch6: VirtualBox-5.0.4-x86-upstream-buildfixes.patch
|
||||
Patch7: VirtualBox-5.1.22-build-gsoap.patch
|
||||
Patch8: VirtualBox-5.0.24-ogl-include-path.patch
|
||||
Patch9: VirtualBox-7.0.10-no-vboxvideo.patch
|
||||
Patch10: VirtualBox-5.2.30-x86-conflicting_type_ptrdiff_t.patch
|
||||
Patch11: VirtualBox-6.0.14-vbox-cpuhotplug-build.patch
|
||||
Patch12: VirtualBox-6.1.10-vboxweb-gsoap.patch
|
||||
Patch13: VirtualBox-6.1.18-kernel-5.10.patch
|
||||
Patch14: VirtualBox-6.1.34-ffreestanding.patch
|
||||
Patch15: VirtualBox-7.0.10-dxvk-native-gcc-13.2.patch
|
||||
Patch16: VirtualBox-7.0.10-VBoxClient-all-disable-notification.patch
|
||||
Patch17: VirtualBox-7.0.14-libxml2-2.12.5.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -183,16 +172,13 @@ X.org mouse driver for VirtualBox guest machine.
|
||||
#% setup -q -D -T
|
||||
#:<< _EOF
|
||||
%patch 5 -p1
|
||||
#%patch 7 -p1
|
||||
%patch 9 -p1
|
||||
%ifarch %{ix86}
|
||||
%patch 10 -p1
|
||||
%endif
|
||||
#%patch12 -p1
|
||||
#%patch13 -p1
|
||||
#%patch14 -p1 -b .ffreestanding
|
||||
%patch 15 -p1
|
||||
%patch 16 -p1
|
||||
%patch 17 -p1 -b .libxml2-2.12.5
|
||||
|
||||
%ifarch %{ix86}
|
||||
sed -i "s|VBOX_SUPPORTED_HOST_ARCHS := amd64|VBOX_SUPPORTED_HOST_ARCHS := x86|" Config.kmk
|
||||
@ -671,6 +657,9 @@ KERNEL=/boot/vmlinuz-$KVER
|
||||
%{_libdir}/%{name}/additions/VBoxGuestAdditions.iso
|
||||
|
||||
%changelog
|
||||
* Tue Feb 06 2024 Automatic Build System <autodist@openmamba.org> 7.0.14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 18 2023 Automatic Build System <autodist@mambasoft.it> 7.0.12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user