60 lines
1.7 KiB
RPMSpec
60 lines
1.7 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
||
Name: PyQtChart
|
||
Version: 5.14.0
|
||
Release: 1mamba
|
||
Summary: A set of Python bindings for The Qt Company’s Qt Charts library
|
||
Group: System/Libraries
|
||
Vendor: openmamba
|
||
Distribution: openmamba
|
||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||
URL: https://pypi.org/project/PyQtChart/
|
||
Source: https://pypi.debian.net/PyQtChart/PyQtChart-%{version}.tar.gz
|
||
License: GPL
|
||
## AUTOBUILDREQ-BEGIN
|
||
## note: run 'autospec -u -a6 python-PyQtChart' to get the list of build requirements.
|
||
## AUTOBUILDREQ-END
|
||
BuildRequires: libpython3-devel
|
||
BuildRequires: libpython36-devel
|
||
BuildRequires: PyQt5-py3 >= %{majver}
|
||
BuildRequires: PyQt5-py36 >= %{majver}
|
||
BuildRequires: python-sip-py3
|
||
BuildRequires: python-sip-py36
|
||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||
|
||
%description
|
||
%{summary}.
|
||
|
||
%if 0%{?with_pyver}
|
||
%pyver_package
|
||
%endif
|
||
|
||
%prep
|
||
%setup -q -n PyQtChart-%{version}
|
||
|
||
%build
|
||
%{__python} configure.py \
|
||
CXXFLAGS="%{optflags}" CFLAGS="%{optflags}" \
|
||
--qmake=%{_qt5_qmake} \
|
||
-d %{python_sitearch}
|
||
|
||
%make
|
||
|
||
%install
|
||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||
%makeinstall INSTALL_ROOT=%{buildroot}
|
||
|
||
%files %{?pyappend}
|
||
%defattr(-,root,root)
|
||
%{python_sitearch}/PyQt5/QtChart.pyi
|
||
%{python_sitearch}/QtChart.so
|
||
%dir %{python_sitearch}/PyQtChart-%{version}.dist-info
|
||
%{python_sitearch}/PyQtChart-%{version}.dist-info/*
|
||
%{_datadir}/qt5/qsci/api/python/PyQtChart.api
|
||
%dir %{_datadir}/sip/PyQt5/QtChart
|
||
%{_datadir}/sip/PyQt5/QtChart/*.sip
|
||
%doc LICENSE
|
||
|
||
%changelog
|
||
* Tue Apr 14 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 5.14.0-1mamba
|
||
- package created using the webbuild interface
|