automatic version update by autodist [release 6.7.1-1mamba;Wed Aug 14 2024]
This commit is contained in:
parent
e066beb624
commit
d01ad1d372
@ -1,12 +0,0 @@
|
||||
diff -ru PyQt6-6.5.2.orig/sip/QtSql/qsqlresult.sip PyQt6-6.5.2/sip/QtSql/qsqlresult.sip
|
||||
--- PyQt6-6.5.2.orig/sip/QtSql/qsqlresult.sip 2023-10-11 16:46:02.317332289 +0200
|
||||
+++ PyQt6-6.5.2/sip/QtSql/qsqlresult.sip 2023-10-11 17:26:17.722706788 +0200
|
||||
@@ -63,7 +63,7 @@
|
||||
QSql::ParamType bindValueType(const QString &placeholder) const;
|
||||
QSql::ParamType bindValueType(int pos) const;
|
||||
int boundValueCount() const;
|
||||
- QList<QVariant> &boundValues() const;
|
||||
+ QVariantList boundValues() const;
|
||||
QString executedQuery() const;
|
||||
QString boundValueName(int pos) const;
|
||||
void clear();
|
14
PyQt6.spec
14
PyQt6.spec
@ -2,7 +2,7 @@
|
||||
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: PyQt6
|
||||
Version: 6.7.0
|
||||
Version: 6.7.1
|
||||
Release: 1mamba
|
||||
Summary: Python bindings for the Qt6 cross platform GUI toolkit
|
||||
Group: System/Libraries
|
||||
@ -11,7 +11,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.riverbankcomputing.com/software/pyqt
|
||||
Source: https://pypi.debian.net/PyQt6/PyQt6-%{version}.tar.gz
|
||||
Patch0: PyQt6-6.5.3-qt6-6.6.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -19,9 +18,8 @@ BuildRequires: libQt6SerialPort-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libpython310-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: python3.10dist(pyqt6-sip)
|
||||
BuildRequires: qt6-qtbase-devel
|
||||
BuildRequires: qt6-qtconnectivity-devel
|
||||
BuildRequires: qt6-qtdeclarative-devel
|
||||
@ -44,8 +42,6 @@ BuildRequires: libdbus-devel
|
||||
## WARNING: do not parametrize python-sip-devel version or it will be useless for ports
|
||||
BuildRequires: python-dbus-py3
|
||||
BuildRequires: PyQt-builder-py3
|
||||
BuildRequires: python-dbus-py310
|
||||
BuildRequires: PyQt-builder-py310
|
||||
BuildRequires: qt6-qtbase-devel >= %{majver}
|
||||
BuildRequires: python-dbus-devel
|
||||
|
||||
@ -80,13 +76,12 @@ Obsoletes: PyQt6-QtDesigner-py310 <= 6.6.0-1mamba
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#%patch 0 -p1 -b .qt6-6.6.0
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
export CXXFLAGS+=" -DQT_NO_INT128" # Fix build with Qt 6.6
|
||||
|
||||
sip-build-py%{with_pyver} \
|
||||
sip-build \
|
||||
--confirm-license \
|
||||
--no-make \
|
||||
--api-dir %{_datadir}/qt6/qsci/api/python \
|
||||
@ -140,6 +135,9 @@ done
|
||||
%{_qt6_plugindir}/designer/*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 14 2024 Automatic Build System <autodist@openmamba.org> 6.7.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Apr 27 2024 Automatic Build System <autodist@openmamba.org> 6.7.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user