obsolete PyQt6-py310 [release 6.6.0-2mamba;Mon Nov 06 2023]
This commit is contained in:
parent
3d534f2f1f
commit
be5df744bf
@ -1,11 +0,0 @@
|
||||
--- PyQt-gpl-5.3.2/configure.py.orig 2014-09-21 01:58:28.591540643 +0200
|
||||
+++ PyQt-gpl-5.3.2/configure.py 2014-09-21 01:59:14.195602717 +0200
|
||||
@@ -2386,6 +2386,8 @@
|
||||
# This is needed for Windows.
|
||||
pro_lines.append('INCLUDEPATH += .')
|
||||
|
||||
+ pro_lines.append('INCLUDEPATH += /usr/include/qt5/QtPrintSupport')
|
||||
+
|
||||
# Make sure the SIP include directory is searched before the Python include
|
||||
# directory if they are different.
|
||||
pro_lines.append('INCLUDEPATH += %s' % target_config.sip_inc_dir)
|
12
PyQt6-6.5.3-qt6-6.6.0.patch
Normal file
12
PyQt6-6.5.3-qt6-6.6.0.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ru PyQt6-6.5.2.orig/sip/QtSql/qsqlresult.sip PyQt6-6.5.2/sip/QtSql/qsqlresult.sip
|
||||
--- PyQt6-6.5.2.orig/sip/QtSql/qsqlresult.sip 2023-10-11 16:46:02.317332289 +0200
|
||||
+++ PyQt6-6.5.2/sip/QtSql/qsqlresult.sip 2023-10-11 17:26:17.722706788 +0200
|
||||
@@ -63,7 +63,7 @@
|
||||
QSql::ParamType bindValueType(const QString &placeholder) const;
|
||||
QSql::ParamType bindValueType(int pos) const;
|
||||
int boundValueCount() const;
|
||||
- QList<QVariant> &boundValues() const;
|
||||
+ QVariantList boundValues() const;
|
||||
QString executedQuery() const;
|
||||
QString boundValueName(int pos) const;
|
||||
void clear();
|
44
PyQt6.spec
44
PyQt6.spec
@ -2,8 +2,8 @@
|
||||
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: PyQt6
|
||||
Version: 6.5.2
|
||||
Release: 1mamba
|
||||
Version: 6.6.0
|
||||
Release: 2mamba
|
||||
Summary: Python bindings for the Qt6 cross platform GUI toolkit
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -11,7 +11,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.riverbankcomputing.com/software/pyqt
|
||||
Source: https://pypi.debian.net/PyQt6/PyQt6-%{version}.tar.gz
|
||||
Patch3: PyQt5-5.3.2-python-sip-4.16.1.patch
|
||||
Patch0: PyQt6-6.5.3-qt6-6.6.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -64,29 +64,31 @@ Group: System/Libraries
|
||||
%{name} is a comprehensive set of Python bindings for Qt6 cross platform GUI toolkit.
|
||||
This package contains the QtDesigner support components for %{name}.
|
||||
|
||||
%define py_requires_append \
|
||||
Requires: python-dbus-py%{?with_pyver}
|
||||
|
||||
%if 0%{?with_pyver}
|
||||
%pyver_package
|
||||
|
||||
%package QtDesigner%{?with_pyver:-py%{pyver}}
|
||||
%package QtDesigner%{?with_pyver:-py%{with_pyver}}
|
||||
Summary: QtDesigner support components for %{name}
|
||||
Group: System/Libraries
|
||||
Requires: PyQt6%{?with_pyver:-py%{pyver}} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: PyQt6%{?with_pyver:-py%{with_pyver}} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description QtDesigner%{?with_pyver:-py%{pyver}}
|
||||
%description QtDesigner%{?with_pyver:-py%{with_pyver}}
|
||||
%{name} is a comprehensive set of Python bindings for Qt6 cross platform GUI toolkit.
|
||||
This package contains the QtDesigner support components for %{name}.
|
||||
%endif
|
||||
|
||||
%define py_requires_append \
|
||||
Requires: python-dbus-py%{?with_pyver} \
|
||||
Obsoletes: PyQt6-py310 <= 6.6.0-1mamba \
|
||||
Obsoletes: PyQt6-QtDesigner-py310 <= 6.6.0-1mamba
|
||||
|
||||
%pyver_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#%patch3 -p1
|
||||
#%patch 0 -p1 -b .qt6-6.6.0
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
export CXXFLAGS+=" -DQT_NO_INT128" # Fix build with Qt 6.6
|
||||
|
||||
sip-build-py%{with_pyver} \
|
||||
--confirm-license \
|
||||
--no-make \
|
||||
@ -103,8 +105,8 @@ make
|
||||
# Fix documentation permissions
|
||||
find examples/ -type f -exec chmod 0644 {} ';'
|
||||
|
||||
%if "0%{pyver}" != "0310"
|
||||
rm -f %{buildroot}%{_qt6_plugindir}/PyQt5/libpyqt6qmlplugin.so
|
||||
%if "%{pyver}" != "3"
|
||||
rm -f %{buildroot}%{_qt6_plugindir}/PyQt6/libpyqt6qmlplugin.so
|
||||
%endif
|
||||
|
||||
for f in pylupdate6 pyuic6; do
|
||||
@ -130,17 +132,23 @@ done
|
||||
%exclude %{python_sitearch}/PyQt6/QtDesigner.abi3.so
|
||||
%dir %{_qt6_plugindir}/PyQt6
|
||||
%{_datadir}/qt6/qsci/api/python/PyQt6.api
|
||||
%if "%{pyver}" == "310"
|
||||
%if "%{pyver}" == "3"
|
||||
%{_qt6_plugindir}/PyQt6/libpyqt6qmlplugin.so
|
||||
%endif
|
||||
%doc LICENSE*
|
||||
|
||||
%files QtDesigner%{?with_pyver:-py%{pyver}}
|
||||
%files QtDesigner%{?with_pyver:-py%{with_pyver}}
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/PyQt6/QtDesigner.abi3.so
|
||||
%{_qt6_plugindir}/designer/*
|
||||
|
||||
%changelog
|
||||
* Mon Nov 06 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 6.6.0-2mamba
|
||||
- obsolete PyQt6-py310
|
||||
|
||||
* Sat Nov 04 2023 Automatic Build System <autodist@mambasoft.it> 6.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jul 25 2023 Automatic Build System <autodist@mambasoft.it> 6.5.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user