PyQt4/PyQt4.spec
Silvan Calarco fc4d087b56 x86_64, aarch64: install dbus/mainloop/qt.so under %python_sitearch
build only py3 version with obsoletes [release 4.12.3-5mamba;Sat Mar 27 2021]
2024-01-05 17:52:19 +01:00

285 lines
9.2 KiB
RPMSpec

%define pythonsip_ver %(sip -V)
Name: PyQt4
Version: 4.12.3
Release: 5mamba
Summary: Python bindings for the Qt cross platform GUI toolkit
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.riverbankcomputing.com/software/pyqt
Source: https://sourceforge.net/projects/pyqt/files/PyQt4/PyQt-%{version}/PyQt4_gpl_x11-%{version}.tar.gz
Patch0: %{name}-egl.patch
Patch1: %{name}-4.7.3-qreal_float_support.patch
Patch2: PyQt4-4.9.4-x86_64.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libGL-devel
BuildRequires: libQtAssistantClient-devel
BuildRequires: libQtDeclarative
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libdbus-devel
BuildRequires: libgcc
BuildRequires: libphonon4-devel
BuildRequires: libpython3-devel
BuildRequires: libqt4-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: libpython3-devel >= 3.7.4
BuildRequires: sip4
BuildRequires: chrpath
BuildRequires: libXcursor-devel
BuildRequires: python-dbus-py3
BuildRequires: python-dbus-devel
BuildRequires: python-sip4-py3 >= 4.19.22
%description
PyQt4 is a comprehensive set of Python bindings for Qt4 cross platform GUI toolkit.
%package devel
Summary: Development files for PyQt4
Group: Development/Libraries
Requires: %{name}-py3 = %{?epoch:%epoch:}%{version}-%{release}
%description devel
PyQt4 is a comprehensive set of Python bindings for Nokia's Qt4 cross platform GUI toolkit.
This package contains files needed for development.
%if 0%{?with_pyver}
%define py_requires_append \
Requires: python-dbus%{?with_pyver:-py%{pyver}} \
Provides: PyQt4 \
Obsoletes: PyQt4 <= 4.12.3-4mamba
Obsoletes: PyQt4-py36 <= 4.12.3-4mamba
%pyver_package
%endif
%package %{?with_pyver:py%{pyver}-}QtDesigner
Summary: QtDesigner support components for PyQt4
Group: System/Libraries
Requires: %{name}%{?with_pyver:-py%{pyver}} = %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: PyQt4-QtDesigner <= 4.12.3-4mamba
Obsoletes: PyQt4-py36-QtDesigner <= 4.12.3-4mamba
%description %{?with_pyver:py%{pyver}-}QtDesigner
PyQt4 is a comprehensive set of Python bindings for Nokia's Qt4 cross platform GUI toolkit.
This package contains the QtDesigner support components for PyQt4.
%prep
%setup -q -n PyQt4_gpl_x11-%{version}
%build
sed -i "/generate_code(\"phonon\")/s:phonon\":&, extra_include_dirs=[\"%{_includedir}/phonon\"]:" configure.py
%{__python} configure.py CXXFLAGS="%{optflags}" CFLAGS="%{optflags}" \
--qmake=%{_qt4_qmake} \
-d %{python_sitearch} \
--confirm-license \
--assume-shared \
--verbose
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall INSTALL_ROOT=%{buildroot}
# Remove rpaths
chrpath --list %{buildroot}%{python_sitearch}/PyQt4/QtCore.so
chrpath --delete %{buildroot}%{python_sitearch}/PyQt4/QtCore.so
chrpath --list %{buildroot}%{python_sitearch}/PyQt4/QtGui.so
chrpath --delete %{buildroot}%{python_sitearch}/PyQt4/QtGui.so
chrpath --list %{buildroot}%{python_sitearch}/PyQt4/QtDesigner.so
chrpath --delete %{buildroot}%{python_sitearch}/PyQt4/QtDesigner.so
# Fix documentation permissions
find examples/ -type f -exec chmod 0644 {} ';'
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files %{?with_pyver:py%{pyver}}
%defattr(-,root,root)
%{python_sitearch}/dbus/mainloop/qt.so
%dir %{python_sitearch}/PyQt4
%{python_sitearch}/PyQt4/Qt.so
%{python_sitearch}/PyQt4/QtAssistant.so
%{python_sitearch}/PyQt4/QtCore.so
%{python_sitearch}/PyQt4/QtDBus.so
%{python_sitearch}/PyQt4/QtDeclarative.so
%{python_sitearch}/PyQt4/QtGui.so
%{python_sitearch}/PyQt4/QtHelp.so
%{python_sitearch}/PyQt4/QtMultimedia.so
%{python_sitearch}/PyQt4/QtNetwork.so
%{python_sitearch}/PyQt4/QtOpenGL.so
%{python_sitearch}/PyQt4/QtScript.so
%{python_sitearch}/PyQt4/QtScriptTools.so
%{python_sitearch}/PyQt4/QtSql.so
%{python_sitearch}/PyQt4/QtSvg.so
%{python_sitearch}/PyQt4/QtTest.so
%{python_sitearch}/PyQt4/QtXml.so
%{python_sitearch}/PyQt4/QtXmlPatterns.so
%{python_sitearch}/PyQt4/__init__.py
%{python_sitearch}/PyQt4/phonon.so
%ifnarch aarch64
%{python_sitearch}/PyQt4/QtWebKit.so
%endif
%{python_sitearch}/PyQt4/pyqtconfig.py
%dir %{python_sitearch}/PyQt4/uic
%{python_sitearch}/PyQt4/uic/*
#%{python_sitelib}/dbus/mainloop/qt.so
%doc LICENSE*
%files devel
%defattr(-,root,root)
%{_bindir}/*
%dir %{_datadir}/sip/PyQt4
%{_datadir}/sip/PyQt4/*
%ifnarch aarch64
%{_qt4_datadir}/qsci/api/python/PyQt4.api
%endif
#%doc doc/* examples
#%doc NEWS README THANKS
%files %{?with_pyver:py%{pyver}-}QtDesigner
%defattr(-,root,root)
%{python_sitearch}/PyQt4/QtDesigner.so
%{_qt4_plugindir}/designer/*
%changelog
* Sat Mar 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.3-5mamba
- x86_64, aarch64: install dbus/mainloop/qt.so under %python_sitearch
- build only py3 version with obsoletes
* Fri Apr 10 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.3-4mamba
- rebuilt with python-sip4
* Wed Oct 30 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.3-3mamba
- rebuilt with python-sip 4.19.19
* Thu Aug 08 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.3-2mamba
- rebuilt with python3 3.7.4
* Fri Dec 28 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.3-1mamba
- update to 4.12.3
* Fri Nov 14 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.3-1mamba
- update to 4.11.3
- added -py3 subpackage support
- require python-sip 4.16.4
* Thu Sep 25 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.2-1mamba
- update to 4.11.2
* Wed Dec 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.10.3-2mamba
- rebuilt with python-sip 4.15.3
* Mon Sep 30 2013 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.10.3-1mamba
- update to 4.10.3
* Thu Jul 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.10.2-1mamba
- update to 4.10.2
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.10.1-2mamba
- rebuilt with python 2.7
* Sat May 11 2013 Automatic Build System <autodist@mambasoft.it> 4.10.1-1mamba
- update to 4.10.1
* Thu Feb 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.9.6-1mamba
- update to 4.9.6
* Sat Aug 11 2012 Automatic Build System <autodist@mambasoft.it> 4.9.4-1mamba
- automatic version update by autodist
* Thu Feb 09 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.6-1mamba
- update to 4.8.6
- move uic module to main package as requires by system-config-printer-kde
- added patch to fix build with Qt EGL enabled
* Sun Sep 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.5-2mamba
- added PyQt4-QtDesigner subpackage
* Sun Aug 21 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.8.5-1mamba
- update to 4.8.5
* Thu Jul 07 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.4-2mamba
- rebuilt with python-sip 4.12.3
* Wed May 18 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.8.4-1mamba
- update to 4.8.4
* Tue Mar 08 2011 Automatic Build System <autodist@mambasoft.it> 4.8.3-1mamba
- automatic update by autodist
* Sat Jan 08 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.1-2mamba
- rebuilt with python-sip 4.12
* Sat Nov 13 2010 Automatic Build System <autodist@mambasoft.it> 4.8.1-1mamba
- automatic update by autodist
* Sat Oct 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8-2mamba
- rebuilt with libqt 4.7.0
* Thu Oct 28 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8-1mamba
- update to 4.8
- added string version requirement for python-sip
* Wed Jul 14 2010 Automatic Build System <autodist@mambasoft.it> 4.7.4-1mamba
- automatic update by autodist
* Wed May 05 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.7.3-1mamba
- update to 4.7.3
* Sun Apr 11 2010 Davide Madrisan <davide.madrisan@gmail.com> 4.7.2-1mamba
- update to 4.7.2
- add missing %%defattr directive
- dropped patch for phonon: it was merged upstream
* Tue Mar 09 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.7-2mamba
- added devel package
* Thu Jan 28 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7-1mamba
- update to 4.7
* Tue Nov 10 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.6.1-1mamba
- update to 4.6.1
* Wed Aug 12 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.4-1mamba
- update to 4.5.4
* Fri Dec 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.4-3mamba
- added requirement for python-cups
* Fri Dec 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.4-2mamba
- rebuilt
* Mon Nov 10 2008 gil <puntogil@libero.it> 4.4.4-1mamba
- update to 4.4.4 with python 2.6
* Sun Oct 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.3-2mamba
- don't pass 'echo yes' but just 'yes' to accept license question
* Sat Oct 11 2008 gil <puntogil@libero.it> 4.4.3-1mamba
- update to 4.4.3
* Tue May 13 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.3-2mamba
- repackaged with dbus support
* Fri May 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.3-1mamba
- update to 4.3.3
* Fri Oct 05 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.17.3-1mamba
- update to 3.17.3
* Mon Jul 10 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 3.16-1qilnx
- update to version 3.16 by autospec
* Wed Mar 16 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14.1-1qilnx
- package created by autospec