smart backend: added a patch to fix remove-packages function [release 0.8.11-2mamba;Mon Sep 23 2013]

This commit is contained in:
Silvan Calarco 2024-01-05 17:51:42 +01:00
parent 7bfd5854ec
commit 3e3237f11b
15 changed files with 775 additions and 0 deletions

View File

@ -0,0 +1,28 @@
From 11872c12358cb3ec1491c5309280f548d04aa00e Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Tue, 15 Mar 2011 11:08:58 +0000
Subject: [PATCH] Fix a crash where the error code was pointing to freed memory. Fixes rh#684464
---
src/pk-transaction.c | 5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/src/pk-transaction.c b/src/pk-transaction.c
index 5dd4577..34ded99 100644
--- a/src/pk-transaction.c
+++ b/src/pk-transaction.c
@@ -1874,8 +1874,9 @@ pk_transaction_set_running (PkTransaction *transaction)
/* set proxy */
ret = pk_transaction_set_session_state (transaction, &error);
if (!ret) {
- g_debug ("failed to set the session state (non-fatal): %s", error->message);
- g_error_free (error);
+ g_debug ("failed to set the session state (non-fatal): %s",
+ error->message);
+ g_clear_error (&error);
}
/* we are no longer waiting, we are setting up */
--
1.6.1

View File

@ -0,0 +1,26 @@
From a32482c30d3760ed5a158d4cad7c1f2a569b49ae Mon Sep 17 00:00:00 2001
From: Dimitar Popov <dimitar.georgiev.popov@googlemail.com>
Date: Mon, 14 Mar 2011 15:12:06 +0000
Subject: [PATCH] qt: Fix typo in SearchGroups
Signed-off-by: Richard Hughes <richard@hughsie.com>
---
lib/packagekit-qt/src/transaction.cpp | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/lib/packagekit-qt/src/transaction.cpp b/lib/packagekit-qt/src/transaction.cpp
index fad5255..c08d638 100644
--- a/lib/packagekit-qt/src/transaction.cpp
+++ b/lib/packagekit-qt/src/transaction.cpp
@@ -528,7 +528,7 @@ void Transaction::searchGroups(Enum::Groups groups, Enum::Filters filters)
groupsSL << Util::enumToString<Enum>(group, "Group", "Group");
}
- searchGroups(groups, filters);
+ searchGroups(groupsSL, filters);
}
void Transaction::searchGroups(Enum::Group group, Enum::Filters filters)
--
1.6.1

View File

@ -0,0 +1,13 @@
diff -Nru PackageKit-0.6.13.orig//backends/smart/smartBackend.py PackageKit-0.6.13/backends/smart/smartBackend.py
--- PackageKit-0.6.13.orig//backends/smart/smartBackend.py 2011-04-24 17:46:40.515400442 +0200
+++ PackageKit-0.6.13/backends/smart/smartBackend.py 2011-04-24 17:47:09.923720527 +0200
@@ -403,8 +403,7 @@
continue
info = loader.getInfo(package)
if hasattr(info, 'getChangeLog'):
- changelog = info.getChangeLog()
- changelog = ';'.join(changelog)
+ changelog = info.getChangeLog()[0] + ';' + info.getChangeLog()[1]
if hasattr(loader, 'getErrata'):
errata = loader.getErrata(package)

View File

@ -0,0 +1,14 @@
diff -Nru PackageKit-0.6.13.orig//backends/smart/smartBackend.py PackageKit-0.6.13/backends/smart/smartBackend.py
--- PackageKit-0.6.13.orig//backends/smart/smartBackend.py 2011-04-24 15:46:32.744153747 +0200
+++ PackageKit-0.6.13/backends/smart/smartBackend.py 2011-04-24 15:47:05.073518384 +0200
@@ -912,9 +912,9 @@
def _best_package_from_list(self, package_list):
for installed in (True, False):
best = None
for package in package_list:
- if not best or package > best:
+ if not best or (package.installed and not best.installed):
best = package
if best:
return best

View File

@ -0,0 +1,14 @@
diff -Nru PackageKit-0.6.21.orig/lib/python/packagekit/backend.py PackageKit-0.6.21/lib/python/packagekit/backend.py
--- PackageKit-0.6.21.orig/lib/python/packagekit/backend.py 2011-12-05 11:02:02.000000000 +0100
+++ PackageKit-0.6.21/lib/python/packagekit/backend.py 2011-12-12 20:05:54.663934072 +0100
@@ -91,8 +91,8 @@
def __init__(self, cmds):
# Make sys.stdout/stderr cope with UTF-8
- sys.stdout = _UTF8Writer(sys.stdout)
- sys.stderr = _UTF8Writer(sys.stderr)
+ #sys.stdout = _UTF8Writer(sys.stdout)
+ #sys.stderr = _UTF8Writer(sys.stderr)
# Setup a custom exception handler
installExceptionHandler(self)

View File

@ -0,0 +1,20 @@
--- PackageKit-0.6.21.orig/contrib/browser-plugin/pk-main.c 2011-12-05 11:23:45.000000000 +0100
+++ PackageKit-0.6.21/contrib/browser-plugin/pk-main.c 2011-12-12 04:01:55.094124426 +0100
@@ -541,17 +541,6 @@
}
/**
- * NP_GetMIMEDescription:
- **/
-const char *
-NP_GetMIMEDescription (void)
-{
- pk_debug ("NP_GetMIMEDescription");
-
- return (gchar*) "application/x-packagekit-plugin:bsc:PackageKit Plugin";
-}
-
-/**
* NP_GetValue:
**/
NPError

View File

@ -0,0 +1,18 @@
diff -Nru PackageKit-0.6.22.orig/lib/python/packagekit/backend.py PackageKit-0.6.22/lib/python/packagekit/backend.py
--- PackageKit-0.6.22.orig/lib/python/packagekit/backend.py 2012-08-21 17:30:49.780155890 +0200
+++ PackageKit-0.6.22/lib/python/packagekit/backend.py 2012-08-21 17:32:29.138192772 +0200
@@ -845,12 +845,13 @@
# Call backend custom Traceback handler
if not base.customTracebackHandler(typ):
etb = traceback.extract_tb(tb)
- errmsg = 'Error Type: %s;' % str(typ)
+ errmsg = '<html>Error Type: %s;' % str(typ)
errmsg += 'Error Value: %s;' % str(value)
for tub in etb:
f, l, m, c = tub # file, lineno, function, codeline
errmsg += ' File : %s, line %s, in %s;' % (f, str(l), m)
errmsg += ' %s;' % c
+ errmsg += '</html>'
# send the traceback to PackageKit
base.error(ERROR_INTERNAL_ERROR, errmsg, exit=True)

View File

@ -0,0 +1,82 @@
diff -ru PackageKit-0.6.6.orig//backends/smart/smartBackend.py PackageKit-0.6.6/backends/smart/smartBackend.py
--- PackageKit-0.6.6.orig//backends/smart/smartBackend.py 2010-05-07 22:08:17.000000000 +0200
+++ PackageKit-0.6.6/backends/smart/smartBackend.py 2010-07-24 15:54:02.830191319 +0200
@@ -674,6 +674,78 @@
'Text tools' : GROUP_ACCESSORIES,
'Toys' : GROUP_GAMES,
'Video' : GROUP_MULTIMEDIA,
+ # RPM (openmamba)
+ 'Applications/Accessibility' : GROUP_ACCESSIBILITY,
+ 'Applications/Development' : GROUP_PROGRAMMING,
+ 'Applications/Educational' : GROUP_EDUCATION,
+ 'Applications/Fonts' : GROUP_FONTS,
+ 'Applications/Games' : GROUP_GAMES,
+ 'Applications/Graphics' : GROUP_GRAPHICS,
+ 'Applications/Mathematics' : GROUP_SCIENCE,
+ 'Applications/Networking' : GROUP_NETWORK,
+ 'Applications/Scientific' : GROUP_SCIENCE,
+ 'Applications/Security' : GROUP_SECURITY,
+ 'Applications/Shells' : GROUP_SYSTEM,
+ 'Applications/Spelling Checker' : GROUP_ACCESSORIES,
+ 'Applications/Web' : GROUP_OTHER,
+ 'Development/Bindings' : GROUP_PROGRAMMING,
+ 'Development/Applications' : GROUP_PROGRAMMING,
+ 'Development/Kernel' : GROUP_PROGRAMMING,
+ 'Development/Libraries/Java' : GROUP_PROGRAMMING,
+ 'Development/Libraries/Perl' : GROUP_PROGRAMMING,
+ 'Development/Libraries/Python' : GROUP_PROGRAMMING,
+ 'Graphical Desktop/Applications/Accessibility' : GROUP_ACCESSIBILITY,
+ 'Graphical Desktop/Applications/Administration' : GROUP_ADMIN_TOOLS,
+ 'Graphical Desktop/Applications/Archiving': GROUP_ACCESSORIES,
+ 'Graphical Desktop/Applications/Configuration' : GROUP_ADMIN_TOOLS,
+ 'Graphical Desktop/Applications/Databases': GROUP_ADMIN_TOOLS,
+ 'Graphical Desktop/Applications/Development' : GROUP_PROGRAMMING,
+ 'Graphical Desktop/Applications/Educational' : GROUP_EDUCATION,
+ 'Graphical Desktop/Applications/Environment' : GROUP_SYSTEM,
+ 'Graphical Desktop/Applications/Games' : GROUP_GAMES,
+ 'Graphical Desktop/Applications/Graphics' : GROUP_GRAPHICS,
+ 'Graphical Desktop/Applications/Internet' : GROUP_INTERNET,
+ 'Graphical Desktop/Applications/Multimedia' : GROUP_MULTIMEDIA,
+ 'Graphical Desktop/Applications/Networking' : GROUP_NETWORK,
+ 'Graphical Desktop/Applications/Office' : GROUP_OFFICE,
+ 'Graphical Desktop/Applications/Other' : GROUP_DESKTOP_OTHER,
+ 'Graphical Desktop/Applications/Publishing' : GROUP_PUBLISHING,
+ 'Graphical Desktop/Applications/Scientific' : GROUP_SCIENCE,
+ 'Graphical Desktop/Applications/Security' : GROUP_SECURITY,
+ 'Graphical Desktop/Applications/Utilities': GROUP_ACCESSORIES,
+ 'Graphical Desktop/Fonts' : GROUP_FONTS,
+ 'Graphical Desktop/Libraries/GNOME' : GROUP_DESKTOP_GNOME,
+ 'Graphical Desktop/Libraries/QT' : GROUP_DESKTOP_KDE,
+ 'Graphical Desktop/Libraries/KDE' : GROUP_DESKTOP_KDE,
+ 'Graphical Desktop/Look \'n\' feel' : GROUP_DESKTOP_KDE,
+ 'Graphical Desktop/Look \'n\' feel/Themes' : GROUP_DESKTOP_KDE,
+ 'Graphical Desktop/Look \'n\' feel/Screensavers' : GROUP_DESKTOP_KDE,
+ 'Network/File Transfer' : GROUP_NETWORK,
+ 'Network/File System' : GROUP_NETWORK,
+ 'Network/High Availability' : GROUP_NETWORK,
+ 'Network/Libraries' : GROUP_SYSTEM,
+ 'Network/Monitoring' : GROUP_NETWORK,
+ 'Network/Routing' : GROUP_NETWORK,
+ 'Network/Security' : GROUP_SECURITY,
+ 'System/Benchmarks' : GROUP_SYSTEM,
+ 'System/Clustering' : GROUP_SYSTEM,
+ 'System/Configuration' : GROUP_SYSTEM,
+ 'System/Database' : GROUP_SYSTEM,
+ 'System/Kernel and Hardware' : GROUP_SYSTEM,
+ 'System/Kernel and Hardware/Drivers' : GROUP_SYSTEM,
+ 'System/Fonts' : GROUP_FONTS,
+ 'System/Hardware' : GROUP_SYSTEM,
+ 'System/Internationalization' : GROUP_LOCALIZATION,
+ 'System/Libraries/Java' : GROUP_SYSTEM,
+ 'System/Libraries/Perl' : GROUP_SYSTEM,
+ 'System/Libraries/PHP' : GROUP_SYSTEM,
+ 'System/Libraries/Python' : GROUP_SYSTEM,
+ 'System/Management' : GROUP_SYSTEM,
+ 'System/Multimedia' : GROUP_SYSTEM,
+ 'System/Servers' : GROUP_SYSTEM,
+ 'System/Spooling' : GROUP_SYSTEM,
+ 'System/Telephony' : GROUP_SYSTEM,
+ 'System/Tools' : GROUP_SYSTEM,
# DEB
"admin" : GROUP_ADMIN_TOOLS,
"base" : GROUP_SYSTEM,

View File

@ -0,0 +1,10 @@
diff -Nru PackageKit-0.6.9.orig//contrib/command-not-found/CommandNotFound.conf PackageKit-0.6.9/contrib/command-not-found/CommandNotFound.conf
--- PackageKit-0.6.9.orig//contrib/command-not-found/CommandNotFound.conf 2010-09-13 16:33:08.000000000 +0200
+++ PackageKit-0.6.9/contrib/command-not-found/CommandNotFound.conf 2010-10-07 10:27:32.751429419 +0200
@@ -69,5 +69,5 @@
# Value is the number of milliseconds to allow.
#
# default=2000
-MaxSearchTime=2000
+MaxSearchTime=5000

View File

@ -0,0 +1,14 @@
--- PackageKit-0.7.3/etc/Vendor.conf.orig 2012-02-18 12:01:34.000000000 +0100
+++ PackageKit-0.7.3/etc/Vendor.conf 2012-04-09 15:45:43.425905950 +0200
@@ -54,9 +54,9 @@
# The vendor name shown for the 'vendor' group
#
# default=My Vendor
-VendorName=My Vendor
+VendorName=openmamba
# The vendor icon name shown for the 'vendor' group
#
# default=emblem-favorite
-VendorIcon=emblem-favorite
+VendorIcon=openmamba

View File

@ -0,0 +1,62 @@
--- PackageKit-0.7.3/backends/smart/pk-backend-smart.c.orig 2012-04-09 15:51:47.815045302 +0200
+++ PackageKit-0.7.3/backends/smart/pk-backend-smart.c 2012-04-09 15:52:44.828441254 +0200
@@ -20,6 +20,7 @@
* Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
*/
+#include <stdio.h>
#include <pk-backend.h>
#include <pk-backend-spawn.h>
@@ -492,6 +493,25 @@
}
/**
+ * pk_backend_what_provides:
+ */
+static void
+backend_what_provides (PkBackend *backend, PkBitfield filters, PkProvidesEnum provides, gchar **values)
+{
+ gchar *search_tmp;
+ gchar *filters_text;
+ const gchar *provides_text;
+
+ provides_text = pk_provides_enum_to_text (provides);
+ filters_text = pk_filter_bitfield_to_string (filters);
+ search_tmp = g_strjoinv ("&", values);
+ fprintf(stderr,"prova: %s\n", provides_text);
+ pk_backend_spawn_helper (spawn, BACKEND_FILE, "what-provides", filters_text, provides_text, search_tmp, NULL);
+ g_free (filters_text);
+ g_free (search_tmp);
+}
+
+/**
* pk_backend_get_description:
*/
gchar *
--- PackageKit-0.6.13.orig//backends/smart/smartBackend.py 2011-04-24 13:53:16.796854052 +0200
+++ PackageKit-0.6.13/backends/smart/smartBackend.py 2011-04-24 15:03:58.644185808 +0200
@@ -551,6 +551,23 @@
self._post_process_package_list(filters)
self._show_package_list()
+ @needs_cache
+ def what_provides(self, filters, provides_type, values):
+ self.status(STATUS_QUERY)
+ self.allow_cancel(True)
+ if provides_type != PROVIDES_ANY:
+ self.error(ERROR_NOT_SUPPORTED,
+ "provide %s not supported" % provides_type)
+ return
+ for value in values:
+ providers = self.ctrl.getCache().getProvides(value)
+ for provider in providers:
+ for package in provider.packages:
+ if self._package_passes_filters(package, filters):
+ self._add_package(package)
+ self._post_process_package_list(filters)
+ self._show_package_list()
+
def refresh_cache(self, force):
# TODO: use force ?
self.status(STATUS_REFRESH_CACHE)

View File

@ -0,0 +1,11 @@
--- PackageKit-0.8.11/backends/smart/pk-backend-smart.c.orig 2013-09-23 17:36:30.145979165 +0200
+++ PackageKit-0.8.11/backends/smart/pk-backend-smart.c 2013-09-23 17:36:57.691715613 +0200
@@ -324,7 +324,7 @@
/* send the complete list as stdin */
package_ids_temp = pk_package_ids_to_string (package_ids);
transaction_flags_temp = pk_transaction_flag_bitfield_to_string (transaction_flags);
- pk_backend_spawn_helper (spawn, job, BACKEND_FILE, "remove-packages", transaction_flags_temp, package_ids_temp, pk_backend_bool_to_string (autoremove), NULL);
+ pk_backend_spawn_helper (spawn, job, BACKEND_FILE, "remove-packages", transaction_flags_temp, package_ids_temp, pk_backend_bool_to_string(allow_deps), pk_backend_bool_to_string (autoremove), NULL);
g_free (package_ids_temp);
g_free (transaction_flags_temp);
}

View File

@ -0,0 +1,59 @@
diff -Nru PackageKit-0.8.7.orig/backends/smart/smartBackend.py PackageKit-0.8.7/backends/smart/smartBackend.py
--- PackageKit-0.8.7.orig/backends/smart/smartBackend.py 2013-03-06 15:22:47.965497048 +0100
+++ PackageKit-0.8.7/backends/smart/smartBackend.py 2013-03-06 19:34:16.385058826 +0100
@@ -172,9 +172,6 @@
@needs_cache
def install_packages(self, transaction_flags, packageids):
- if TRANSACTION_FLAG_ONLY_TRUSTED in transaction_flags:
- self.error(ERROR_MISSING_GPG_SIGNATURE, "Trusted packages not available.")
- return
packages = []
for packageid in packageids:
ratio, results, suggestions = self._search_packageid(packageid)
@@ -211,9 +208,6 @@
@needs_cache
def install_files(self, transaction_flags, paths):
- if TRANSACTION_FLAG_ONLY_TRUSTED in transaction_flags:
- self.error(ERROR_MISSING_GPG_SIGNATURE, "Trusted packages not available.")
- return
for path in paths:
self.ctrl.addFileChannel(path)
self.ctrl.reloadChannels()
@@ -280,9 +274,6 @@
@needs_cache
def update_packages(self, transaction_flags, packageids):
- if TRANSACTION_FLAG_ONLY_TRUSTED in transaction_flags:
- self.error(ERROR_MISSING_GPG_SIGNATURE, "Trusted packages not available.")
- return
packages = []
for packageid in packageids:
ratio, results, suggestions = self._search_packageid(packageid)
@@ -292,13 +283,13 @@
'Package %s was not found' % packagestring)
packages.extend(self._process_search_results(results))
- installed = [package for package in packages if package.installed]
+ installed = [package for package in packages]
if len(installed) < 1:
return
trans = smart.transaction.Transaction(self.ctrl.getCache(),
smart.transaction.PolicyUpgrade)
for package in installed:
- trans.enqueue(package, smart.transaction.UPGRADE)
+ trans.enqueue(package, smart.transaction.INSTALL)
self.allow_cancel(False)
self.status(STATUS_DEP_RESOLVE)
@@ -334,9 +325,6 @@
@needs_cache
def update_system(self, transaction_flags):
- if TRANSACTION_FLAG_ONLY_TRUSTED in transaction_flags:
- self.error(ERROR_MISSING_GPG_SIGNATURE, "Trusted packages not available.")
- return
self.status(STATUS_INFO)
cache = self.ctrl.getCache()

402
PackageKit.spec Normal file
View File

@ -0,0 +1,402 @@
Name: PackageKit
Version: 0.8.11
Release: 2mamba
Summary: A system designed to make installing and updating software on your computer easier
Group: System/Management
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.packagekit.org
Source: http://www.packagekit.org/releases/PackageKit-%{version}.tar.xz
Patch0: %{name}-0.6.6-openmamba-groups.patch
Patch1: %{name}-0.7.3-openmamba-Vendor.conf.patch
Patch2: %{name}-0.6.9-command_not_found_raise_timeout.patch
Patch3: %{name}-0.7.3-smart-what_provides.patch
Patch4: %{name}-0.6.13-smartBackend_fix_best_package.patch
Patch5: %{name}-0.6.13-smartBackend_fix_Changelog.patch
Patch6: %{name}-0.6.13-qt_fix_searchGroups.patch
Patch7: %{name}-0.6.13-pk-transaction_fix_crash.patch
Patch8: %{name}-0.8.7-smartBackend-fix_trust_and_upgrade.patch
Patch9: %{name}-0.6.21-xulrunner-7.patch
Patch10: %{name}-0.6.21-revert_utf8_for_smart.patch
Patch11: PackageKit-0.6.22-display_smart_errors_as_html.patch
Patch12: PackageKit-0.8.11-smartBackend-fix-remove-packages.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libacl-devel
BuildRequires: libarchive-devel
BuildRequires: libatk-devel
BuildRequires: libattr-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgraphite2-devel
BuildRequires: libgstreamer010-devel
BuildRequires: libgtk2-devel
BuildRequires: libgtk-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libicu-devel
BuildRequires: liblzma-devel
BuildRequires: liblzo-devel
BuildRequires: libnettle-devel
BuildRequires: libnspr-devel
BuildRequires: libpango-devel
BuildRequires: libpng-devel
BuildRequires: libpython-devel
BuildRequires: libselinux-devel
BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
BuildRequires: polkit-devel
BuildRequires: systemd-devel
BuildRequires: udev-devel
## AUTOBUILDREQ-END
BuildRequires: gobject-introspection-devel
BuildRequires: pm-utils-devel
BuildRequires: libcppunit-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains static libraries and header files need for development.
%package glib
Summary: glib interface library for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description glib
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the glib interface library for %{name}.
%package glib-devel
Summary: Devel package for %{name}-glib
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-glib = %{?epoch:%epoch:}%{version}-%{release}
%description glib-devel
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains static libraries and header files need for development.
%package gtk
Summary: Gtk interface library for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-glib = %{?epoch:%epoch:}%{version}-%{release}
%description gtk
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the Gtk interface library for %{name}.
%package gtk2
Summary: Gtk 2 interface library for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-glib = %{?epoch:%epoch:}%{version}-%{release}
%description gtk2
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the Gtk 2 interface library for %{name}.
%package mozilla
Summary: Mozilla plugin for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description mozilla
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the Mozilla plugin for %{name}.
%package qt2
Summary: New QT interface library for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: %{name}-qt
%description qt2
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the new QT interface library for %{name}.
%package qt2-devel
Summary: Devel package for %{name}-qt2
Group: Development/Libraries
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-qt2 = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-gtk = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-gtk2 = %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: %{name}-qt-devel
%description qt2-devel
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains static libraries and header files need for development.
%debug_package
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
#%patch6 -p1
#%patch7 -p1
%patch8 -p1
#%patch9 -p1
#%patch10 -p1
%patch11 -p1
%patch12 -p1
#sed -i "s|/usr/bin/python$|/usr/bin/python%{python27_version}|" backends/smart/smartBackend.py
%build
%configure \
--enable-smart \
--enable-pm-utils \
--with-default-backend=smart \
--enable-introspection \
--enable-networkmanager \
PYTHON=%{__python}
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
rm -f %{buildroot}/var/lib/PackageKit/transactions.db
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_sysconfdir}/PackageKit/*.conf
%{_sysconfdir}/cron.daily/packagekit-background.cron
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PackageKit.conf
%{_sysconfdir}/profile.d/PackageKit.sh
%{_sysconfdir}/PackageKit/events/post-transaction.d/README
%{_sysconfdir}/PackageKit/events/pre-transaction.d/README
%config(noreplace) %{_sysconfdir}/sysconfig/packagekit-background
%{_bindir}/packagekit-bugreport.sh
%{_bindir}/pk-debuginfo-install
%{_bindir}/pkcon
%{_bindir}/pkgenpack
%{_bindir}/pkmon
%{_sbindir}/pk-device-rebind
%dir %{_libdir}/packagekit-backend
%{_libdir}/packagekit-backend/libpk_backend_*
%dir %{_libdir}/packagekit-plugins
%{_libdir}/packagekit-plugins/libpk_plugin*
%{_libdir}/pm-utils/sleep.d/95packagekit
%{_libdir}/girepository-1.0/PackageKitPlugin-1.0.typelib
/lib/systemd/system/packagekit-offline-update.service
%{_libexecdir}/pk-clear-offline-update
%{_libexecdir}/pk-offline-update
%{_libexecdir}/pk-trigger-offline-update
%{_libexecdir}/packagekitd
%{_libexecdir}/pk-command-not-found
%{_libexecdir}/pk-gstreamer-install
%{_datadir}/bash-completion/completions/pkcon
%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
%{_datadir}/mime/packages/packagekit-*.xml
%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
%{_datadir}/PackageKit/helpers
%{_datadir}/PackageKit/pk-upgrade-distro.sh
%dir %{python_sitearch}/packagekit
%{python_sitearch}/packagekit/*
%dir /var/lib/PackageKit
%{_mandir}/man1/pkcon.1.gz
%{_mandir}/man1/pk-debuginfo-install.1.gz
%{_mandir}/man1/pk-device-rebind.1.gz
%{_mandir}/man1/pkgenpack.1.gz
%{_mandir}/man1/pkmon.1.gz
%doc AUTHORS COPYING
%files gtk
%defattr(-,root,root)
%{_libdir}/gtk-3.0/modules/libpk-gtk-module.*
%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
%files gtk2
%defattr(-,root,root)
%{_libdir}/gtk-2.0/modules/libpk-gtk-module.*
%if "%{stage1}" != "1"
%files mozilla
%defattr(-,root,root)
%{_libdir}/mozilla/plugins/packagekit-plugin.*
%endif
#%files qt2
#%defattr(-,root,root)
#%{_libdir}/libpackagekit-qt2.so.*
#%files qt2-devel
#%defattr(-,root,root)
#%{_includedir}/PackageKit/packagekit-qt2/*
#%{_libdir}/libpackagekit-qt2.a
#%{_libdir}/libpackagekit-qt2.la
#%{_libdir}/libpackagekit-qt2.so
#%{_libdir}/pkgconfig/packagekit-qt2.pc
#%{_libdir}/cmake/packagekit-qt2/packagekit-qt2-config-version.cmake
#%{_libdir}/cmake/packagekit-qt2/packagekit-qt2-config.cmake
%files glib
%defattr(-,root,root)
%{_libdir}/libpackagekit-glib2.so.*
%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
#%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.gtk-modules-packagekit.gschema.xml
%files glib-devel
%defattr(-,root,root)
%{_includedir}/PackageKit/packagekit-glib2/*.h
%{_libdir}/libpackagekit-glib2.a
%{_libdir}/libpackagekit-glib2.la
%{_libdir}/libpackagekit-glib2.so
%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
%{_libdir}/pkgconfig/packagekit-glib2.pc
%files devel
%defattr(-,root,root)
#%dir %{_includedir}/PackageKit/backend
#%{_includedir}/PackageKit/backend/*.h
%dir %{_includedir}/PackageKit/plugin
%{_includedir}/PackageKit/plugin/*.h
%{_datadir}/gtk-doc/html/PackageKit
%{_datadir}/gir-1.0/PackageKitPlugin-1.0.gir
%{_libdir}/pkgconfig/packagekit-plugin.pc
%doc ChangeLog NEWS README TODO
%changelog
* Mon Sep 23 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.11-2mamba
- smart backend: added a patch to fix remove-packages function
* Sun Sep 08 2013 Automatic Build System <autodist@mambasoft.it> 0.8.11-1mamba
- automatic update by autodist
* Tue Aug 06 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.9-2mamba
- git typelib files moved from -devel to main packages
* Sun Jun 30 2013 Automatic Build System <autodist@mambasoft.it> 0.8.9-1mamba
- automatic version update by autodist
* Wed Mar 06 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.7-3mamba
- reapply smartbackend patch to disable packages trust and fix upgrade
- also port patch to display errors as html in apper
* Wed Mar 06 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.7-2mamba
- rebuilt using python 2.7
* Sat Mar 02 2013 Automatic Build System <autodist@mambasoft.it> 0.8.7-1mamba
- automatic version update by autodist
* Fri Dec 07 2012 Automatic Build System <autodist@mambasoft.it> 0.7.6-1mamba
- automatic version update by autodist
* Tue Aug 21 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.4-1mamba
- update to 0.7.4
* Tue Aug 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.22-1mamba
- update to 0.6.22
* Mon Apr 09 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.21-3mamba
- rebuilt after moving libattr
* Mon Dec 12 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.21-2mamba
- cleaned some debugging code in the smart backend patches
- revert utf-8 changes in backend.py to workaround smart backend not working anymore
* Mon Dec 12 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.21-1mamba
- update to 0.6.21
* Mon Dec 12 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.19-1mamba
- update to 0.6.19
* Mon Dec 12 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.20-1mamba
- update to 0.6.20
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 0.6.16-1mamba
- update to 0.6.16
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 0.6.15-1mamba
- automatic update by autodist
* Wed May 04 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.14-1mamba
- update to 0.6.14
- added PackageKit-qt2 from upstream
- split devel packages
- rebuild with NetworkManager and instrospection support
* Mon Apr 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.13-3mamba
- SmartBackend: added patch to fix upgrade and disable trust check because it is not supported
* Sun Apr 24 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.13-2mamba
- smart backend: revert a patch that disables What-Provides function (http://cgit.freedesktop.org/packagekit/patch/?id=1184745dd4e4597839b5e595d23b0816ff54c3d0)
- smartBackend.py: added patch to fix best install choice by preferring already installed packages for virtual provides
- smartBackend.py: added patch to fix error on ChangeLog parsing
- packagekit-qt: added upstream patch to fix searchGroups function
* Sun Apr 24 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.13-1mamba
- update to 0.6.13
* Sat Mar 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.12-1mamba
- update to 0.6.12
* Wed Jan 12 2011 Automatic Build System <autodist@mambasoft.it> 0.6.9-2mamba
- automatic update by autodist
* Thu Oct 07 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.9-1mamba
- update to 0.6.9
* Wed Oct 06 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.8-2mamba
- rebuilt with --disable-networkmanager
* Wed Oct 06 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.8-1mamba
- update to 0.6.8
* Tue Aug 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.7-1mamba
- update to 0.6.7
* Sat Jul 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.6-1mamba
- update to 0.6.6
- added a patch that adds matches between openmamba groups and PackageKit ones
- added patch to configure Vendor.conf for openmamba
* Wed Jun 02 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.5-1mamba
- update to 0.6.5
* Sat Apr 03 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.3-1mamba
- update to 0.6.3
* Mon Mar 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.2-1mamba
- package created by autospec

View File

@ -1,2 +1,4 @@
# PackageKit
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.