update to 3.4.0 [release 3.4.0-1mamba;Fri Feb 12 2016]
This commit is contained in:
parent
4c77b4dbfa
commit
fb75f1e2ef
11
OpenSceneGraph-2.9.7-ffmpeg-0.6.1.patch
Normal file
11
OpenSceneGraph-2.9.7-ffmpeg-0.6.1.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -Nru OpenSceneGraph-2.9.7.orig//src/osgPlugins/ffmpeg/CMakeLists.txt OpenSceneGraph-2.9.7/src/osgPlugins/ffmpeg/CMakeLists.txt
|
||||||
|
--- OpenSceneGraph-2.9.7.orig//src/osgPlugins/ffmpeg/CMakeLists.txt 2009-07-03 21:16:53.000000000 +0200
|
||||||
|
+++ OpenSceneGraph-2.9.7/src/osgPlugins/ffmpeg/CMakeLists.txt 2011-03-05 19:43:42.645431330 +0100
|
||||||
|
@@ -2,6 +2,7 @@
|
||||||
|
LINK_DIRECTORIES(${FFMPEG_LIBRARY_DIRS})
|
||||||
|
SET(TARGET_EXTERNAL_LIBRARIES ${FFMPEG_LIBRARIES} )
|
||||||
|
|
||||||
|
+ADD_DEFINITIONS(-D__STDC_CONSTANT_MACROS)
|
||||||
|
|
||||||
|
IF(FFMPEG_LIBSWSCALE_FOUND)
|
||||||
|
|
153
OpenSceneGraph.spec
Normal file
153
OpenSceneGraph.spec
Normal file
@ -0,0 +1,153 @@
|
|||||||
|
Name: OpenSceneGraph
|
||||||
|
Version: 3.4.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: An open source high performance 3D graphics toolkit
|
||||||
|
Group: Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.openscenegraph.org/projects/osg
|
||||||
|
Source: http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-%{version}/source/OpenSceneGraph-%{version}.zip
|
||||||
|
Patch0: %{name}-2.9.7-ffmpeg-0.6.1.patch
|
||||||
|
License: OSGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libSDL-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXrandr-devel
|
||||||
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
|
BuildRequires: libavdevice-ffmpeg-devel
|
||||||
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
BuildRequires: libdcmtk-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgdal-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libgif-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libilmbase-devel
|
||||||
|
BuildRequires: libjasper-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libopenexr-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libpoppler-glib-devel
|
||||||
|
BuildRequires: libqt5-devel
|
||||||
|
BuildRequires: librsvg-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
|
BuildRequires: libtiff-devel
|
||||||
|
BuildRequires: libvncserver-devel
|
||||||
|
BuildRequires: libxine-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
An open source high performance 3D graphics toolkit, used by application developers in fields such as visual simulation, games, virtual reality, scientific visualization and modelling. Written entirely in Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now well established as the world leading scene graph technology, used widely in the vis-sim, space, scientific, oil-gas, games and virtual reality industries.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%define minver %(echo %version | cut -d. -f2)
|
||||||
|
|
||||||
|
if [ "`expr %minver % 2`" == "1" ]; then
|
||||||
|
echo "WARNING: unstable version detected; don't want to build it to support FlightGear."
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
:
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake -d build
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/osgarchive
|
||||||
|
%{_bindir}/osgconv
|
||||||
|
%{_bindir}/osgfilecache
|
||||||
|
%{_bindir}/osgversion
|
||||||
|
%{_bindir}/osgviewer
|
||||||
|
%{_bindir}/present3D
|
||||||
|
%{_includedir}/osg*/*
|
||||||
|
%{_includedir}/OpenThreads/*
|
||||||
|
%{_libdir}/libOpenThreads.so*
|
||||||
|
%{_libdir}/libosg*.so*
|
||||||
|
%{_libdir}/osgPlugins-%{version}/*.so
|
||||||
|
%{_libdir}/pkgconfig/openscenegraph*.pc
|
||||||
|
%{_libdir}/pkgconfig/openthreads.pc
|
||||||
|
%doc ChangeLog README.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Feb 12 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.0-1mamba
|
||||||
|
- update to 3.4.0
|
||||||
|
|
||||||
|
* Sat Mar 21 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.1-1mamba
|
||||||
|
- update to 3.2.1
|
||||||
|
- revert to stable for FlighGear 3.4 build
|
||||||
|
|
||||||
|
* Thu Jan 29 2015 Automatic Build System <autodist@mambasoft.it> 3.3.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 25 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.0-2mamba
|
||||||
|
- rebuilt with ffmpeg 2.2
|
||||||
|
|
||||||
|
* Sun Oct 06 2013 Automatic Build System <autodist@mambasoft.it> 3.3.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 27 2013 Automatic Build System <autodist@mambasoft.it> 3.2.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jul 18 2013 Automatic Build System <autodist@mambasoft.it> 3.1.9-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Jun 21 2013 Automatic Build System <autodist@mambasoft.it> 3.1.8-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 19 2013 Automatic Build System <autodist@mambasoft.it> 3.1.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Feb 20 2013 Automatic Build System <autodist@mambasoft.it> 3.1.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Oct 08 2012 Automatic Build System <autodist@mambasoft.it> 3.1.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Apr 11 2012 Automatic Build System <autodist@mambasoft.it> 3.1.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Mar 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.7-3mamba
|
||||||
|
- rebuilt with libpoppler-glib 0.16
|
||||||
|
|
||||||
|
* Wed Jun 09 2010 Automatic Build System <autodist@mambasoft.it> 2.9.7-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sun May 16 2010 Automatic Build System <autodist@mambasoft.it> 2.9.7-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Nov 25 2009 Automatic Build System <autodist@mambasoft.it> 2.9.4-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue Apr 28 2009 Automatic Build System <autodist@mambasoft.it> 2.9.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Apr 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Mar 23 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.1-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Jan 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1-1mamba
|
||||||
|
- package created by autospec
|
@ -1,2 +1,4 @@
|
|||||||
# OpenSceneGraph
|
# OpenSceneGraph
|
||||||
|
|
||||||
|
An open source high performance 3D graphics toolkit, used by application developers in fields such as visual simulation, games, virtual reality, scientific visualization and modelling. Written entirely in Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now well established as the world leading scene graph technology, used widely in the vis-sim, space, scientific, oil-gas, games and virtual reality industries.
|
||||||
|
|
||||||
|
Reference in New Issue
Block a user