rebuilt with libgdal 3.8.3 [release 3.6.5-5mamba;Sun Feb 04 2024]

This commit is contained in:
Silvan Calarco 2024-02-06 12:50:54 +01:00
parent 71876e6d30
commit 8b764fa96b
5 changed files with 201 additions and 21 deletions

View File

@ -1,11 +0,0 @@
diff -Nru OpenSceneGraph-2.9.7.orig//src/osgPlugins/ffmpeg/CMakeLists.txt OpenSceneGraph-2.9.7/src/osgPlugins/ffmpeg/CMakeLists.txt
--- OpenSceneGraph-2.9.7.orig//src/osgPlugins/ffmpeg/CMakeLists.txt 2009-07-03 21:16:53.000000000 +0200
+++ OpenSceneGraph-2.9.7/src/osgPlugins/ffmpeg/CMakeLists.txt 2011-03-05 19:43:42.645431330 +0100
@@ -2,6 +2,7 @@
LINK_DIRECTORIES(${FFMPEG_LIBRARY_DIRS})
SET(TARGET_EXTERNAL_LIBRARIES ${FFMPEG_LIBRARIES} )
+ADD_DEFINITIONS(-D__STDC_CONSTANT_MACROS)
IF(FFMPEG_LIBSWSCALE_FOUND)

View File

@ -1,4 +1,4 @@
# OpenSceneGraph
# openscenegraph
OpenSceneGraph is an open source high performance 3D graphics toolkit, used by application developers in fields such as visual simulation, games, virtual reality, scientific visualization and modelling. Written entirely in Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now well established as the world leading scene graph technology, used widely in the vis-sim, space, scientific, oil-gas, games and virtual reality industries.

View File

@ -0,0 +1,96 @@
diff -rupN --no-dereference OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/connection.cpp OpenSceneGraph-OpenSceneGraph-3.6.5-new/src/osgPlugins/RestHttpDevice/connection.cpp
--- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/connection.cpp 2020-01-31 12:03:07.000000000 +0100
+++ OpenSceneGraph-OpenSceneGraph-3.6.5-new/src/osgPlugins/RestHttpDevice/connection.cpp 2022-11-13 19:16:22.452241561 +0100
@@ -10,7 +10,6 @@
#include "connection.hpp"
#include <vector>
-#include <boost/bind.hpp>
#include "request_handler.hpp"
#include <osg/Notify>
@@ -39,9 +38,9 @@ void connection::start()
OSG_DEBUG << "RestHttpDevice :: connection::start" << std::endl;
socket_.async_read_some(asio::buffer(buffer_),
- boost::bind(&connection::handle_read, shared_from_this(),
- asio::placeholders::error,
- asio::placeholders::bytes_transferred));
+ std::bind(&connection::handle_read, shared_from_this(),
+ std::placeholders::_1,
+ std::placeholders::_2));
}
void connection::handle_read(const asio::error_code& e,
@@ -57,22 +56,22 @@ void connection::handle_read(const asio:
{
request_handler_.handle_request(request_, reply_);
asio::async_write(socket_, reply_.to_buffers(),
- boost::bind(&connection::handle_write, shared_from_this(),
- asio::placeholders::error));
+ std::bind(&connection::handle_write, shared_from_this(),
+ std::placeholders::_1));
}
else if (!result)
{
reply_ = reply::stock_reply(reply::bad_request);
asio::async_write(socket_, reply_.to_buffers(),
- boost::bind(&connection::handle_write, shared_from_this(),
- asio::placeholders::error));
+ std::bind(&connection::handle_write, shared_from_this(),
+ std::placeholders::_1));
}
else
{
socket_.async_read_some(asio::buffer(buffer_),
- boost::bind(&connection::handle_read, shared_from_this(),
- asio::placeholders::error,
- asio::placeholders::bytes_transferred));
+ std::bind(&connection::handle_read, shared_from_this(),
+ std::placeholders::_1,
+ std::placeholders::_2));
}
}
diff -rupN --no-dereference OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/server.cpp OpenSceneGraph-OpenSceneGraph-3.6.5-new/src/osgPlugins/RestHttpDevice/server.cpp
--- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/server.cpp 2020-01-31 12:03:07.000000000 +0100
+++ OpenSceneGraph-OpenSceneGraph-3.6.5-new/src/osgPlugins/RestHttpDevice/server.cpp 2022-11-13 19:16:22.452241561 +0100
@@ -9,7 +9,6 @@
//
#include "server.hpp"
-#include <boost/bind.hpp>
namespace http {
namespace server {
@@ -23,7 +22,7 @@ server::server(const std::string& addres
request_handler_(doc_root)
{
// Open the acceptor with the option to reuse the address (i.e. SO_REUSEADDR).
- asio::ip::tcp::resolver resolver(acceptor_.get_io_service());
+ asio::ip::tcp::resolver resolver(acceptor_.get_executor());
asio::ip::tcp::resolver::query query(address, port);
asio::ip::tcp::endpoint endpoint = *resolver.resolve(query);
acceptor_.open(endpoint.protocol());
@@ -31,8 +30,8 @@ server::server(const std::string& addres
acceptor_.bind(endpoint);
acceptor_.listen();
acceptor_.async_accept(new_connection_->socket(),
- boost::bind(&server::handle_accept, this,
- asio::placeholders::error));
+ std::bind(&server::handle_accept, this,
+ std::placeholders::_1));
}
void server::run()
@@ -56,8 +55,8 @@ void server::handle_accept(const asio::e
new_connection_.reset(new connection(
io_service_pool_.get_io_service(), request_handler_));
acceptor_.async_accept(new_connection_->socket(),
- boost::bind(&server::handle_accept, this,
- asio::placeholders::error));
+ std::bind(&server::handle_accept, this,
+ std::placeholders::_1));
}
else
{

View File

@ -0,0 +1,82 @@
diff --git a/CMakeModules/FindOpenEXR.cmake b/CMakeModules/FindOpenEXR.cmake
index 233be972b..d1b022881 100644
--- a/CMakeModules/FindOpenEXR.cmake
+++ b/CMakeModules/FindOpenEXR.cmake
@@ -51,11 +51,11 @@ MACRO(OPENEXR_FIND libname)
OPENEXR_FIND_VAR(OPENEXR_${libname}_LIBRARY_DEBUG ${libname}d)
ENDMACRO(OPENEXR_FIND)
-OPENEXR_FIND(IlmImf)
+OPENEXR_FIND(OpenEXR)
SET(OPENEXR_FOUND "NO")
-IF(OPENEXR_INCLUDE_DIR AND OPENEXR_IlmImf_LIBRARY)
- SET(OPENEXR_LIBRARIES ${OPENEXR_IlmImf_LIBRARY} )
- SET(OPENEXR_LIBRARIES_VARS OPENEXR_IlmImf_LIBRARY )
+IF(OPENEXR_INCLUDE_DIR AND OPENEXR_OpenEXR_LIBRARY)
+ SET(OPENEXR_LIBRARIES ${OPENEXR_OpenEXR_LIBRARY} )
+ SET(OPENEXR_LIBRARIES_VARS OPENEXR_OpenEXR_LIBRARY )
SET(OPENEXR_FOUND "YES")
-ENDIF(OPENEXR_INCLUDE_DIR AND OPENEXR_IlmImf_LIBRARY)
+ENDIF(OPENEXR_INCLUDE_DIR AND OPENEXR_OpenEXR_LIBRARY)
diff --git a/CMakeModules/Findilmbase.cmake b/CMakeModules/Findilmbase.cmake
index 4b076c7c9..4610497fa 100644
--- a/CMakeModules/Findilmbase.cmake
+++ b/CMakeModules/Findilmbase.cmake
@@ -10,7 +10,7 @@
# Created by Robert Osfield.
-FIND_PATH(ILMBASE_INCLUDE_DIR OpenEXR/ImathVec.h
+FIND_PATH(ILMBASE_INCLUDE_DIR Imath/ImathVec.h
$ENV{ILMBASE_DIR}/include
$ENV{ILMBASE_DIR}
~/Library/Frameworks
@@ -28,7 +28,7 @@ FIND_PATH(ILMBASE_INCLUDE_DIR OpenEXR/ImathVec.h
# example: ILMBASE_FIND_VAR(OPENEXR_IlmThread_LIBRARY IlmThread)
MACRO(ILMBASE_FIND_VAR varname libname)
FIND_LIBRARY( ${varname}
- NAMES ${libname} ${libname}-2_1 ${libname}-2_2
+ NAMES ${libname} ${libname}-2_1 ${libname}-2_2 ${libname}-3_0
PATHS
$ENV{ILMBASE_DIR}/lib
$ENV{ILMBASE_DIR}
@@ -53,11 +53,11 @@ ENDMACRO(ILMBASE_FIND)
ILMBASE_FIND(IlmThread)
ILMBASE_FIND(Iex)
-ILMBASE_FIND(Half)
+ILMBASE_FIND(Imath)
SET(ILMBASE_FOUND "NO")
-IF(ILMBASE_INCLUDE_DIR AND ILMBASE_IlmThread_LIBRARY AND ILMBASE_Iex_LIBRARY AND ILMBASE_Half_LIBRARY)
- SET(ILMBASE_LIBRARIES ${ILMBASE_IlmThread_LIBRARY} ${ILMBASE_Half_LIBRARY} ${ILMBASE_Iex_LIBRARY} )
- SET(ILMBASE_LIBRARIES_VARS ILMBASE_IlmThread_LIBRARY ILMBASE_Half_LIBRARY ILMBASE_Iex_LIBRARY )
+IF(ILMBASE_INCLUDE_DIR AND ILMBASE_IlmThread_LIBRARY AND ILMBASE_Iex_LIBRARY AND ILMBASE_Imath_LIBRARY)
+ SET(ILMBASE_LIBRARIES ${ILMBASE_IlmThread_LIBRARY} ${ILMBASE_Imath_LIBRARY} ${ILMBASE_Iex_LIBRARY} )
+ SET(ILMBASE_LIBRARIES_VARS ILMBASE_IlmThread_LIBRARY ILMBASE_Imath_LIBRARY ILMBASE_Iex_LIBRARY )
SET(ILMBASE_FOUND "YES")
-ENDIF(ILMBASE_INCLUDE_DIR AND ILMBASE_IlmThread_LIBRARY AND ILMBASE_Iex_LIBRARY AND ILMBASE_Half_LIBRARY)
+ENDIF(ILMBASE_INCLUDE_DIR AND ILMBASE_IlmThread_LIBRARY AND ILMBASE_Iex_LIBRARY AND ILMBASE_Imath_LIBRARY)
diff --git a/src/osgPlugins/exr/CMakeLists.txt b/src/osgPlugins/exr/CMakeLists.txt
index 6191ed18f..9a368b2c2 100644
--- a/src/osgPlugins/exr/CMakeLists.txt
+++ b/src/osgPlugins/exr/CMakeLists.txt
@@ -1,4 +1,4 @@
-INCLUDE_DIRECTORIES( ${ILMBASE_INCLUDE_DIR}/OpenEXR )
+INCLUDE_DIRECTORIES( ${ILMBASE_INCLUDE_DIR}/Imath )
INCLUDE_DIRECTORIES( ${OPENEXR_INCLUDE_DIR}/OpenEXR )
SET(TARGET_SRC ReaderWriterEXR.cpp )
diff --git a/src/osgPlugins/exr/ReaderWriterEXR.cpp b/src/osgPlugins/exr/ReaderWriterEXR.cpp
index 7132e97f8..96c5507ef 100644
--- a/src/osgPlugins/exr/ReaderWriterEXR.cpp
+++ b/src/osgPlugins/exr/ReaderWriterEXR.cpp
@@ -13,6 +13,7 @@
#include <osgDB/FileNameUtils>
#include <osgDB/FileUtils>
+#include <ImfInt64.h>
#include <ImfRgbaFile.h>
#include <ImfIO.h>
#include <ImfArray.h>

View File

@ -1,6 +1,6 @@
Name: OpenSceneGraph
Name: openscenegraph
Version: 3.6.5
Release: 3mamba
Release: 5mamba
Summary: An open source high performance 3D graphics toolkit
Group: Applications/Graphics
Vendor: openmamba
@ -8,9 +8,10 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.openscenegraph.com/
Source: https://github.com/openscenegraph/OpenSceneGraph/archive/refs/tags/OpenSceneGraph-%{version}.tar.gz
Patch0: %{name}-2.9.7-ffmpeg-0.6.1.patch
Patch1: OpenSceneGraph-3.6.5-libocct-7.6.0.patch
Patch2: OpenSceneGraph-3.6.5-ffmpeg-4.4.patch
Patch3: openscenegraph-3.6.5-openexr-3.2.1.patch
Patch4: openscenegraph-3.6.5-boost-1.84.0.patch
License: OSGPL
## AUTOBUILDREQ-BEGIN
#libavresample.so.4()(64bit): .so link not found
@ -38,10 +39,12 @@ BuildRequires: libglib-devel
BuildRequires: libglvnd-devel
BuildRequires: libgst-plugins-base-devel
BuildRequires: libgstreamer-devel
BuildRequires: libimath-devel
BuildRequires: libjasper-devel
BuildRequires: libjpeg-devel
BuildRequires: libnsl-devel
BuildRequires: libocct-devel
BuildRequires: libopenexr-devel
BuildRequires: libpng-devel
BuildRequires: libpoppler-glib-devel
BuildRequires: librsvg-devel
@ -52,11 +55,13 @@ BuildRequires: libtiff-devel
BuildRequires: libvncserver-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libgdal-devel >= 0:3.6.2-1mamba
BuildRequires: libdcmtk-devel >= 3.6.7
BuildRequires: dcmtk >= 3.6.7
BuildRequires: libgdal-devel >= 3.8.3
BuildRequires: libdcmtk-devel >= 3.6.8
BuildRequires: dcmtk >= 3.6.8
BuildRequires: cmake
Requires: libosg = %{?epoch:%epoch:}%{version}-%{release}
Provides: OpenSceneGraph
Obsoletes: OpenSceneGraph < 3.6.5-4mamba
%description
OpenSceneGraph is an open source high performance 3D graphics toolkit, used by application developers in fields such as visual simulation, games, virtual reality, scientific visualization and modelling. Written entirely in Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now well established as the world leading scene graph technology, used widely in the vis-sim, space, scientific, oil-gas, games and virtual reality industries.
@ -83,9 +88,10 @@ This package contains libraries and header files for developing applications tha
%setup -q -n OpenSceneGraph-OpenSceneGraph-%{version}
#-D -T
#:<< _EOF
#%patch0 -p1
%patch1 -p1
%patch2 -p1 -b .ffmpeg-4.4
%patch 1 -p1
%patch 2 -p1 -b .ffmpeg-4.4
%patch 3 -p1 -b .openexr-3.2.1
%patch 4 -p1 -b .boost-1.84.0
%define minver %(echo %version | cut -d. -f2)
@ -145,6 +151,13 @@ export PKG_CONFIG_PATH="%{_libdir}/ffmpeg4/pkgconfig"
%{_libdir}/libosg*.so
%changelog
* Sun Feb 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.5-5mamba
- rebuilt with libgdal 3.8.3
* Sun Feb 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.5-4mamba
- rebuilt with dcmtk 3.6.8 and gdal 3.7.3
- source renamed from OpenSceneGraph to openscenegraph
* Sat Feb 11 2023 Sdk Build System <sdk@mambasoft.it> 3.6.5-3mamba
- rebuilt by autoport with build requirements: libgdal-devel>=0:3.6.2-1mamba