rebuilt without .la files
source renamed from OpenSP to opensp [release 1.5.2-7mamba;Sun Sep 29 2024]
This commit is contained in:
parent
410e4fcc62
commit
d84d0603db
@ -1,20 +0,0 @@
|
||||
Submitted By: Jim Gifford (jim at linuxfromscratch dot org)
|
||||
Date: 2004-04-24
|
||||
Initial Package Version: 1.5.1
|
||||
Origin: OpenJade SourceForge Patch Page
|
||||
Upstream Status: Fixed
|
||||
Description: Fixes Compile Issues with GCC 3.4
|
||||
|
||||
$LastChangedBy: bdubbs $
|
||||
$Date: 2004-08-07 18:56:30 -0600 (Sat, 07 Aug 2004) $
|
||||
|
||||
--- OpenSP-1.5.1/include/RangeMap.cxx.orig 2004-04-24 17:39:50.000691400 +0000
|
||||
+++ OpenSP-1.5.1/include/RangeMap.cxx 2004-04-24 17:39:59.682536194 +0000
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "RangeMap.h"
|
||||
#include "ISet.h"
|
||||
#include "types.h"
|
||||
+#include "constant.h"
|
||||
|
||||
#ifdef SP_NAMESPACE
|
||||
namespace SP_NAMESPACE {
|
@ -1,12 +0,0 @@
|
||||
diff -dpruN --exclude='config*' OpenSP-1.5.1.orig/include/InternalInputSource.h OpenSP-1.5.1/include/InternalInputSource.h
|
||||
--- OpenSP-1.5.1.orig/include/InternalInputSource.h 2003-07-17 20:14:00.000000000 +0200
|
||||
+++ OpenSP-1.5.1/include/InternalInputSource.h 2005-11-16 07:22:04.700397800 +0100
|
||||
@@ -34,7 +34,7 @@ public:
|
||||
void pushCharRef(Char ch, const NamedCharRef &);
|
||||
Boolean rewind(Messenger &);
|
||||
const StringC *contents();
|
||||
- InternalInputSource *InternalInputSource::asInternalInputSource();
|
||||
+ InternalInputSource *asInternalInputSource();
|
||||
~InternalInputSource();
|
||||
private:
|
||||
InternalInputSource(const InternalInputSource &); // undefined
|
198
opensp-1.5.2-configure-c99.patch
Normal file
198
opensp-1.5.2-configure-c99.patch
Normal file
@ -0,0 +1,198 @@
|
||||
Avoid implicit function declarations because they have been removed
|
||||
from C in 1999. Future compilers are likely to reject them by
|
||||
default.
|
||||
|
||||
No need to upstream this because the aclocal.m4 file is not checked
|
||||
into the repository since:
|
||||
|
||||
------------------------------------------------------------------------
|
||||
r412 | clasen | 1999-11-06 14:10:34 +0100 (Sat, 06 Nov 1999) | 3 lines
|
||||
Changed paths:
|
||||
M /trunk/sp/Makefile.in
|
||||
D /trunk/sp/config/aclocal.m4
|
||||
D /trunk/sp/config/configure.in
|
||||
M /trunk/sp/configure
|
||||
A /trunk/sp/configure.in
|
||||
|
||||
Install headers in $(includedir)/OpenSP, move configure.in to toplevel,
|
||||
remove generated file aclocal.m4.
|
||||
|
||||
diff --git a/aclocal.m4 b/aclocal.m4
|
||||
index d7cc45cf7b80ca54..2fde71fb866f12bc 100644
|
||||
--- a/aclocal.m4
|
||||
+++ b/aclocal.m4
|
||||
@@ -833,10 +833,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -850,7 +846,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}]
|
||||
EOF
|
||||
if AC_TRY_EVAL(ac_link) && test -s conftest${ac_exeext} 2>/dev/null; then
|
||||
diff --git a/configure b/configure
|
||||
index caa2d31585b112bd..90dce8e854b35393 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2917,7 +2917,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
for ac_declaration in \
|
||||
- '' \
|
||||
+ '#include <stdlib.h>' \
|
||||
'extern "C" void std::exit (int) throw (); using std::exit;' \
|
||||
'extern "C" void std::exit (int); using std::exit;' \
|
||||
'extern "C" void exit (int) throw ();' \
|
||||
@@ -5186,8 +5186,8 @@ main ()
|
||||
for (i = 0; i < 256; i++)
|
||||
if (XOR (islower (i), ISLOWER (i))
|
||||
|| toupper (i) != TOUPPER (i))
|
||||
- exit(2);
|
||||
- exit (0);
|
||||
+ return 2;
|
||||
+ return 0;
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest$ac_exeext
|
||||
@@ -9508,10 +9508,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -9525,7 +9521,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -9606,10 +9602,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -9623,7 +9615,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -13321,10 +13313,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -13338,7 +13326,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -13419,10 +13407,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -13436,7 +13420,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -19110,10 +19094,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -19127,7 +19107,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -19208,10 +19188,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -19225,7 +19201,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -27450,8 +27426,8 @@ main ()
|
||||
for (i = 0; i < 256; i++)
|
||||
if (XOR (islower (i), ISLOWER (i))
|
||||
|| toupper (i) != TOUPPER (i))
|
||||
- exit(2);
|
||||
- exit (0);
|
||||
+ return 2;
|
||||
+ return 0;
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest$ac_exeext
|
@ -1,33 +1,31 @@
|
||||
Name: OpenSP
|
||||
Name: opensp
|
||||
Version: 1.5.2
|
||||
Release: 6mamba
|
||||
Release: 7mamba
|
||||
Summary: A suite of SGML processing tools
|
||||
Group: Applications/Publishing
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://openjade.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/openjade/%{name}-%{version}.tar.gz
|
||||
URL: https://openjade.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/openjade/OpenSP-%{version}.tar.gz
|
||||
Patch0: OpenSP-1.5.1-LITLEN-1.patch
|
||||
Patch1: OpenSP-1.5.1-gcc34-1.patch
|
||||
Patch2: OpenSP-1.5.1-gcc41.patch
|
||||
Patch3: OpenSP-1.5.2-sigsegv.patch
|
||||
Patch4: OpenSP-1.5.2-manpage.patch
|
||||
Patch5: OpenSP-1.5.2-multilib.patch
|
||||
Patch6: OpenSP-1.5.2-nodeids.patch
|
||||
Patch1: OpenSP-1.5.2-sigsegv.patch
|
||||
Patch2: OpenSP-1.5.2-manpage.patch
|
||||
Patch3: OpenSP-1.5.2-multilib.patch
|
||||
Patch4: OpenSP-1.5.2-nodeids.patch
|
||||
Patch5: opensp-1.5.2-configure-c99.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libnsl-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtirpc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: sgml-common
|
||||
BuildRequires: xmlto
|
||||
Requires: libosp = %{version}-%{release}
|
||||
Provides: OpenSP
|
||||
Obsoletes: OpenSP < 1.5.2-7mamba
|
||||
|
||||
%description
|
||||
A suite of SGML processing tools.
|
||||
@ -57,14 +55,13 @@ This is the devel package.
|
||||
|
||||
%prep
|
||||
%setup -q -n OpenSP-%{version}
|
||||
%patch0 -p1
|
||||
%patch 0 -p1
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
%patch3 -p1 -b .sigsegv
|
||||
%patch4 -p1 -b .manpage
|
||||
%patch5 -p1 -b .multilib
|
||||
%patch6 -p1 -b .nodeids
|
||||
%patch 1 -p1 -b .sigsegv
|
||||
%patch 2 -p1 -b .manpage
|
||||
%patch 3 -p1 -b .multilib
|
||||
%patch 4 -p1 -b .nodeids
|
||||
%patch 5 -p1 -b .configure-c99
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -74,19 +71,16 @@ sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
--enable-default-search-path=%{_datadir}/sgml:%{_datadir}/xml
|
||||
|
||||
%make
|
||||
#pkgdatadir=%{_datadir}/sgml/OpenSP-%{version}
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
#pkgdatadir=%{_datadir}/sgml/OpenSP-%{version}
|
||||
|
||||
ln -s onsgmls %{buildroot}%{_bindir}/nsgmls
|
||||
ln -s osgmlnorm %{buildroot}%{_bindir}/sgmlnorm
|
||||
ln -s ospam %{buildroot}%{_bindir}/spam
|
||||
ln -s ospcat %{buildroot}%{_bindir}/spcat
|
||||
ln -s ospent %{buildroot}%{_bindir}/spent
|
||||
#ln -s osx %{buildroot}%{_bindir}/sx
|
||||
ln -s osx %{buildroot}%{_bindir}/sgml2xml
|
||||
ln -s libosp.so %{buildroot}%{_libdir}/libsp.so
|
||||
|
||||
@ -109,7 +103,6 @@ ln -s libosp.so %{buildroot}%{_libdir}/libsp.so
|
||||
%{_bindir}/spam
|
||||
%{_bindir}/spcat
|
||||
%{_bindir}/spent
|
||||
#%{_bindir}/sx
|
||||
%dir %{_datadir}/doc/OpenSP
|
||||
%{_datadir}/doc/OpenSP/*
|
||||
%dir %{_datadir}/OpenSP
|
||||
@ -126,11 +119,14 @@ ln -s libosp.so %{buildroot}%{_libdir}/libsp.so
|
||||
%{_includedir}/OpenSP/*.h
|
||||
%{_includedir}/OpenSP/*.cxx
|
||||
%{_libdir}/libosp.a
|
||||
%{_libdir}/libosp.la
|
||||
%{_libdir}/libosp.so
|
||||
%{_libdir}/libsp.so
|
||||
|
||||
%changelog
|
||||
* Sun Sep 29 2024 Automatic Build System <autodist@openmamba.org> 1.5.2-7mamba
|
||||
- rebuilt without .la files
|
||||
- source renamed from OpenSP to opensp
|
||||
|
||||
* Sun Oct 24 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-6mamba
|
||||
- added sigsegv and the other patches from Fedora
|
||||
|
Reference in New Issue
Block a user