added sigsegv and the other patches from Fedora [release 1.5.2-6mamba;Sun Oct 24 2021]
This commit is contained in:
parent
d17e538026
commit
410e4fcc62
39
OpenSP-1.5.2-manpage.patch
Normal file
39
OpenSP-1.5.2-manpage.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
diff -urNp OpenSP-1.5.2-orig/docsrc/osgmlnorm.xml OpenSP-1.5.2/docsrc/osgmlnorm.xml
|
||||||
|
--- OpenSP-1.5.2-orig/docsrc/osgmlnorm.xml 2005-12-08 20:34:01.000000000 +0100
|
||||||
|
+++ OpenSP-1.5.2/docsrc/osgmlnorm.xml 2013-08-15 14:58:01.284430911 +0200
|
||||||
|
@@ -173,6 +173,15 @@
|
||||||
|
<para>Show error numbers in error messages.</para>
|
||||||
|
</listitem>
|
||||||
|
</varlistentry>
|
||||||
|
+
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>-g</option></term>
|
||||||
|
+ <term><option>--open-elements</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>Show the generic identifiers of open elements in error
|
||||||
|
+ messages.</para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
|
||||||
|
<varlistentry>
|
||||||
|
<term><option>-h</option></term>
|
||||||
|
diff -urNp OpenSP-1.5.2-orig/docsrc/ospam.xml OpenSP-1.5.2/docsrc/ospam.xml
|
||||||
|
--- OpenSP-1.5.2-orig/docsrc/ospam.xml 2005-12-08 20:34:01.000000000 +0100
|
||||||
|
+++ OpenSP-1.5.2/docsrc/ospam.xml 2013-08-15 14:53:58.414782217 +0200
|
||||||
|
@@ -151,6 +151,16 @@
|
||||||
|
of stderr.</para>
|
||||||
|
</listitem>
|
||||||
|
</varlistentry>
|
||||||
|
+
|
||||||
|
+ <varlistentry>
|
||||||
|
+ <term><option>-g</option></term>
|
||||||
|
+ <term><option>--open-elements</option></term>
|
||||||
|
+ <listitem>
|
||||||
|
+ <para>Show the generic identifiers of open elements in error
|
||||||
|
+ messages.</para>
|
||||||
|
+ </listitem>
|
||||||
|
+ </varlistentry>
|
||||||
|
+
|
||||||
|
<varlistentry>
|
||||||
|
<term><option>-h</option></term>
|
||||||
|
<term><option>--hoist-omitted-tags</option></term>
|
91
OpenSP-1.5.2-multilib.patch
Normal file
91
OpenSP-1.5.2-multilib.patch
Normal file
@ -0,0 +1,91 @@
|
|||||||
|
--- OpenSP-1.5.2/configure.in.multilib 2005-12-23 14:15:21.000000000 +0000
|
||||||
|
+++ OpenSP-1.5.2/configure.in 2006-06-13 13:36:49.000000000 +0100
|
||||||
|
@@ -90,7 +90,7 @@
|
||||||
|
#define SP_SIZEOF_BOOL_1
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if (SIZEOF_WCHAR_T == SIZEOF_UNSIGNED_SHORT)
|
||||||
|
+#if (WCHAR_MAX == SHRT_MAX)
|
||||||
|
#define SP_WCHAR_T_USHORT
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--- OpenSP-1.5.2/lib/parser_inst.cxx.multilib 2005-07-21 16:33:41.000000000 +0100
|
||||||
|
+++ OpenSP-1.5.2/lib/parser_inst.cxx 2006-06-13 13:36:49.000000000 +0100
|
||||||
|
@@ -9,6 +9,7 @@
|
||||||
|
// Copyright (c) 1994 James Clark
|
||||||
|
// See the file COPYING for copying permission.
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
#include "splib.h"
|
||||||
|
|
||||||
|
#ifdef SP_MANUAL_INST
|
||||||
|
@@ -1338,7 +1339,7 @@
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
// we really just want to test if size_t == unsigned int
|
||||||
|
-#if !defined(SIZEOF_SIZE_T) || !defined(SIZEOF_UNSIGNED_INT) || (SIZEOF_SIZE_T != SIZEOF_UNSIGNED_INT)
|
||||||
|
+#if INT_MAX != SSIZE_MAX
|
||||||
|
#ifdef __DECCXX
|
||||||
|
#pragma define_template Vector<unsigned int>
|
||||||
|
#else
|
||||||
|
--- OpenSP-1.5.2/lib/parser_inst.m4.multilib 2005-05-14 10:17:35.000000000 +0100
|
||||||
|
+++ OpenSP-1.5.2/lib/parser_inst.m4 2006-06-13 13:36:49.000000000 +0100
|
||||||
|
@@ -1,6 +1,7 @@
|
||||||
|
// Copyright (c) 1994 James Clark
|
||||||
|
// See the file COPYING for copying permission.
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
#include "splib.h"
|
||||||
|
|
||||||
|
#ifdef SP_MANUAL_INST
|
||||||
|
@@ -166,7 +167,7 @@
|
||||||
|
__instantiate(Vector<LeafContentToken*>)
|
||||||
|
__instantiate(Vector<size_t>)
|
||||||
|
// we really just want to test if size_t == unsigned int
|
||||||
|
-#if !defined(SIZEOF_SIZE_T) || !defined(SIZEOF_UNSIGNED_INT) || (SIZEOF_SIZE_T != SIZEOF_UNSIGNED_INT)
|
||||||
|
+#if INT_MAX != SSIZE_MAX
|
||||||
|
__instantiate(Vector<unsigned int>)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--- OpenSP-1.5.2/config.h.in.multilib 2005-11-05 09:43:42.000000000 +0000
|
||||||
|
+++ OpenSP-1.5.2/config.h.in 2006-06-13 13:41:45.000000000 +0100
|
||||||
|
@@ -1,5 +1,7 @@
|
||||||
|
/* config.h.in. Generated from configure.in by autoheader. */
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
/* Define to one of `_getb67', `GETB67', `getb67' for Cray-2 and Cray-YMP
|
||||||
|
systems. This function is required for `alloca.c' support on those systems.
|
||||||
|
*/
|
||||||
|
@@ -333,22 +335,6 @@
|
||||||
|
/* The size of a `bool', as computed by sizeof. */
|
||||||
|
#undef SIZEOF_BOOL
|
||||||
|
|
||||||
|
-/* The size of a `size_t', as computed by sizeof. */
|
||||||
|
-#undef SIZEOF_SIZE_T
|
||||||
|
-
|
||||||
|
-/* The size of a `unsigned int', as computed by sizeof. */
|
||||||
|
-#undef SIZEOF_UNSIGNED_INT
|
||||||
|
-
|
||||||
|
-/* The size of a `unsigned short', as computed by sizeof. */
|
||||||
|
-#undef SIZEOF_UNSIGNED_SHORT
|
||||||
|
-
|
||||||
|
-/* The size of a `wchar_t', as computed by sizeof. */
|
||||||
|
-#undef SIZEOF_WCHAR_T
|
||||||
|
-
|
||||||
|
-/* Define as the maximum value of type 'size_t', if the system doesn't define
|
||||||
|
- it. */
|
||||||
|
-#undef SIZE_MAX
|
||||||
|
-
|
||||||
|
/* define this if h_errno should be declared extern int */
|
||||||
|
#undef SP_DECLARE_H_ERRNO
|
||||||
|
|
||||||
|
@@ -503,7 +489,7 @@
|
||||||
|
#define SP_SIZEOF_BOOL_1
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if (SIZEOF_WCHAR_T == SIZEOF_UNSIGNED_SHORT)
|
||||||
|
+#if (WCHAR_MAX == SHRT_MAX)
|
||||||
|
#define SP_WCHAR_T_USHORT
|
||||||
|
#endif
|
||||||
|
|
128
OpenSP-1.5.2-nodeids.patch
Normal file
128
OpenSP-1.5.2-nodeids.patch
Normal file
@ -0,0 +1,128 @@
|
|||||||
|
--- OpenSP-1.5.2/docsrc/releasenotes.xml.nodeids 2006-10-13 13:54:59.000000000 +0100
|
||||||
|
+++ OpenSP-1.5.2/docsrc/releasenotes.xml 2006-10-13 13:58:25.000000000 +0100
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
<?xml version='1.0'?>
|
||||||
|
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
|
||||||
|
"http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
|
||||||
|
-<book>
|
||||||
|
+<book id="relnotesb">
|
||||||
|
<bookinfo>
|
||||||
|
<title>OpenSP 1.5.2</title>
|
||||||
|
<subtitle>Release Notes</subtitle>
|
||||||
|
@@ -16,7 +16,7 @@
|
||||||
|
</copyright>
|
||||||
|
</bookinfo>
|
||||||
|
|
||||||
|
- <chapter><title>OpenSP 1.5.2 Release Notes</title>
|
||||||
|
+ <chapter id="relnotesc"><title>OpenSP 1.5.2 Release Notes</title>
|
||||||
|
|
||||||
|
<para>The OpenJade project provides a suite of tools and libraries for
|
||||||
|
validating, processing and applying DSSSL (Document Style Semantics and
|
||||||
|
@@ -29,7 +29,7 @@
|
||||||
|
can be used as a basis for either open source or commerical projects. The
|
||||||
|
library can be built as either a dynamic or static library.
|
||||||
|
</para>
|
||||||
|
- <sect1><title>Applications of OpenSP</title>
|
||||||
|
+ <sect1 id="apps"><title>Applications of OpenSP</title>
|
||||||
|
<para>The OpenSP library has been used in a number of projects. The
|
||||||
|
World Wide Web consortium on-line HTML and XHTML validator is based on the
|
||||||
|
OpenSP library. In addition to the OpenSP library a set of command line tools
|
||||||
|
@@ -41,7 +41,7 @@
|
||||||
|
tools.</para>
|
||||||
|
</sect1>
|
||||||
|
|
||||||
|
- <sect1><title>Obtaining OpenSP</title>
|
||||||
|
+ <sect1 id="obtaining"><title>Obtaining OpenSP</title>
|
||||||
|
<para>OpenSP is a project hosted at sourceforge.net and is available
|
||||||
|
from the OpenJade web site at http://openjade.sourceforge.net or directly from
|
||||||
|
the OpenJade project page at http://sourceforge.net/projects/openjade</para>
|
||||||
|
@@ -49,7 +49,7 @@
|
||||||
|
linkend="bindist"/> for information on how to obtain pre-compiled
|
||||||
|
binary packages.</para>
|
||||||
|
</sect1>
|
||||||
|
- <sect1><title>Supported Platforms</title>
|
||||||
|
+ <sect1 id="supported"><title>Supported Platforms</title>
|
||||||
|
<para>OpenSP is intended to be as portable as possible. It should be
|
||||||
|
possible to compile and build on most contemporary UNIX type platforms. In
|
||||||
|
addition OpenSP should also build on Microsoft's Win32 based operating
|
||||||
|
@@ -166,7 +166,7 @@
|
||||||
|
<email>openjade-devel@lists.sourceforge.net</email>, including any
|
||||||
|
diffs/patches you have used.</para>
|
||||||
|
</sect1>
|
||||||
|
- <sect1><title>Building OpenSP from Source</title>
|
||||||
|
+ <sect1 id="building"><title>Building OpenSP from Source</title>
|
||||||
|
<para>OpenSP requires 20Mb to 50Mb of disk space to build. An
|
||||||
|
installation will require around 10Mb to 20Mb depending on
|
||||||
|
architecture.</para>
|
||||||
|
@@ -249,7 +249,7 @@
|
||||||
|
the latest version of OpenSP to be available from your distributor in due
|
||||||
|
course.</para>
|
||||||
|
</sect1>
|
||||||
|
- <sect1><title>Installation</title>
|
||||||
|
+ <sect1 id="installation"><title>Installation</title>
|
||||||
|
<para>In addition to the OpenSP executables and libraries you will also
|
||||||
|
need various DTDs and declaration files. Some DTDs and associated files
|
||||||
|
(entity definitions) are available in the <filename>pubtext</filename>
|
||||||
|
@@ -263,7 +263,7 @@
|
||||||
|
recommended that you set up and use such a catalog system.
|
||||||
|
</para>
|
||||||
|
</sect1>
|
||||||
|
- <sect1><title>Support</title>
|
||||||
|
+ <sect1 id="support"><title>Support</title>
|
||||||
|
<para>If, after reading the documentation, you still have a problem,
|
||||||
|
then you may require some additional help. The OpenJade project is a volunteer
|
||||||
|
effort and as such does not provide any formal support. Instead, you should
|
||||||
|
@@ -299,7 +299,7 @@
|
||||||
|
often the case that someone has had the same problem before.</para>
|
||||||
|
|
||||||
|
</sect1>
|
||||||
|
- <sect1><title>Version 1.5.2</title>
|
||||||
|
+ <sect1 id="v152"><title>Version 1.5.2</title>
|
||||||
|
<formalpara><title>Released December 2005.</title>
|
||||||
|
<para>The release contains a number of enhancements together with
|
||||||
|
support for version 4.0 of the GNU C++ compiler.</para>
|
||||||
|
@@ -418,7 +418,7 @@
|
||||||
|
</table>
|
||||||
|
</sect1>
|
||||||
|
|
||||||
|
- <sect1><title>Version 1.5.1</title>
|
||||||
|
+ <sect1 id="v151"><title>Version 1.5.1</title>
|
||||||
|
<formalpara><title>Released October 2003.</title>
|
||||||
|
<para>The release contains a number of new features together with
|
||||||
|
support for version 3.3 for the GNU C++ compiler.</para>
|
||||||
|
@@ -613,7 +613,7 @@
|
||||||
|
</table>
|
||||||
|
</sect1>
|
||||||
|
|
||||||
|
- <sect1><title>Version 1.5</title>
|
||||||
|
+ <sect1 id="v15"><title>Version 1.5</title>
|
||||||
|
<formalpara><title>Released November 2002.</title>
|
||||||
|
<para>In addition to many new features this version also supports the
|
||||||
|
latest GNU C++ compiler: gcc 3.2 at the time of writing.</para>
|
||||||
|
@@ -976,7 +976,7 @@
|
||||||
|
</tgroup>
|
||||||
|
</table>
|
||||||
|
</sect1>
|
||||||
|
- <sect1>
|
||||||
|
+ <sect1 id="v14">
|
||||||
|
<title>Version 1.4</title>
|
||||||
|
<formalpara><title>Released February 2000</title>
|
||||||
|
<para>Version 1.4 added many improvements. Changes
|
||||||
|
@@ -1023,7 +1023,7 @@
|
||||||
|
</listitem>
|
||||||
|
</itemizedlist>
|
||||||
|
</sect1>
|
||||||
|
- <sect1><title>Version 1.3.4</title>
|
||||||
|
+ <sect1 id="v134"><title>Version 1.3.4</title>
|
||||||
|
<formalpara><title>Released October 1999</title>
|
||||||
|
<para>The second release from the OpenJade project. This version was
|
||||||
|
distributed as part of OpenJade 1.3</para>
|
||||||
|
@@ -1040,7 +1040,7 @@
|
||||||
|
|
||||||
|
</itemizedlist>
|
||||||
|
</sect1>
|
||||||
|
- <sect1><title>Version 1.3.3</title>
|
||||||
|
+ <sect1 id="v133"><title>Version 1.3.3</title>
|
||||||
|
<para>The first release from the OpenJade project</para>
|
||||||
|
</sect1>
|
||||||
|
</chapter>
|
20
OpenSP-1.5.2-sigsegv.patch
Normal file
20
OpenSP-1.5.2-sigsegv.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- OpenSP-1.5.2/lib/ExtendEntityManager.cxx 2005-11-05 10:05:20.000000000 +0100
|
||||||
|
+++ OpenSP-1.5.2.new/lib/ExtendEntityManager.cxx 2007-06-21 12:56:26.000000000 +0200
|
||||||
|
@@ -1238,7 +1238,8 @@ StorageObjectSpec::StorageObjectSpec()
|
||||||
|
}
|
||||||
|
|
||||||
|
StorageObjectSpec::StorageObjectSpec(const StorageObjectSpec& x)
|
||||||
|
-: codingSystemName(x.codingSystemName),
|
||||||
|
+: storageManager(x.storageManager),
|
||||||
|
+ codingSystemName(x.codingSystemName),
|
||||||
|
codingSystem(x.codingSystem),
|
||||||
|
specId(x.specId),
|
||||||
|
baseId(x.baseId),
|
||||||
|
@@ -1253,6 +1254,7 @@ StorageObjectSpec::StorageObjectSpec(con
|
||||||
|
StorageObjectSpec& StorageObjectSpec::operator=(const StorageObjectSpec& x)
|
||||||
|
{
|
||||||
|
if (this != &x) {
|
||||||
|
+ storageManager = x.storageManager;
|
||||||
|
codingSystemName = x.codingSystemName;
|
||||||
|
codingSystem = x.codingSystem;
|
||||||
|
specId = x.specId;
|
16
OpenSP.spec
16
OpenSP.spec
@ -1,6 +1,6 @@
|
|||||||
Name: OpenSP
|
Name: OpenSP
|
||||||
Version: 1.5.2
|
Version: 1.5.2
|
||||||
Release: 5mamba
|
Release: 6mamba
|
||||||
Summary: A suite of SGML processing tools
|
Summary: A suite of SGML processing tools
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -11,6 +11,10 @@ Source: http://downloads.sourceforge.net/sourceforge/openjade/%{name}-%{v
|
|||||||
Patch0: OpenSP-1.5.1-LITLEN-1.patch
|
Patch0: OpenSP-1.5.1-LITLEN-1.patch
|
||||||
Patch1: OpenSP-1.5.1-gcc34-1.patch
|
Patch1: OpenSP-1.5.1-gcc34-1.patch
|
||||||
Patch2: OpenSP-1.5.1-gcc41.patch
|
Patch2: OpenSP-1.5.1-gcc41.patch
|
||||||
|
Patch3: OpenSP-1.5.2-sigsegv.patch
|
||||||
|
Patch4: OpenSP-1.5.2-manpage.patch
|
||||||
|
Patch5: OpenSP-1.5.2-multilib.patch
|
||||||
|
Patch6: OpenSP-1.5.2-nodeids.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -57,14 +61,17 @@ This is the devel package.
|
|||||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
#%patch2 -p1
|
#%patch2 -p1
|
||||||
|
%patch3 -p1 -b .sigsegv
|
||||||
|
%patch4 -p1 -b .manpage
|
||||||
|
%patch5 -p1 -b .multilib
|
||||||
|
%patch6 -p1 -b .nodeids
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--enable-http \
|
--enable-http \
|
||||||
--enable-xml-messages \
|
--enable-xml-messages \
|
||||||
--enable-default-catalog=/etc/sgml/catalog \
|
--enable-default-catalog=/etc/sgml/catalog \
|
||||||
--enable-default-search-path=%{_datadir}/sgml:%{_datadir}/xml \
|
--enable-default-search-path=%{_datadir}/sgml:%{_datadir}/xml
|
||||||
--enable-xml-messages
|
|
||||||
|
|
||||||
%make
|
%make
|
||||||
#pkgdatadir=%{_datadir}/sgml/OpenSP-%{version}
|
#pkgdatadir=%{_datadir}/sgml/OpenSP-%{version}
|
||||||
@ -124,6 +131,9 @@ ln -s libosp.so %{buildroot}%{_libdir}/libsp.so
|
|||||||
%{_libdir}/libsp.so
|
%{_libdir}/libsp.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 24 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-6mamba
|
||||||
|
- added sigsegv and the other patches from Fedora
|
||||||
|
|
||||||
* Tue Jun 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-5mamba
|
* Tue Jun 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-5mamba
|
||||||
- rebuilt with %{_datadir}/xml added to --enable-default-search-path and --enable-xml-messages; remove pkgdatadir in make
|
- rebuilt with %{_datadir}/xml added to --enable-default-search-path and --enable-xml-messages; remove pkgdatadir in make
|
||||||
|
|
||||||
|
Reference in New Issue
Block a user