fix sgmlnorm symlink to osgmlnorm [release 1.5.2-3mamba;Wed Dec 01 2010]
This commit is contained in:
parent
0305fce807
commit
39ded574f4
54
OpenSP-1.5.1-LITLEN-1.patch
Normal file
54
OpenSP-1.5.1-LITLEN-1.patch
Normal file
@ -0,0 +1,54 @@
|
|||||||
|
Submitted By: BLFS Book <blfs-book@linuxfromscratch.org>
|
||||||
|
Date: 2003-10-05
|
||||||
|
Initial Package Version: 1.5
|
||||||
|
Origin: BLFS Book
|
||||||
|
Description: Remove some annonying messages when running openjade.
|
||||||
|
|
||||||
|
$LastChangedBy: bdubbs $
|
||||||
|
$Date: 2004-08-07 18:56:30 -0600 (Sat, 07 Aug 2004) $
|
||||||
|
|
||||||
|
diff -Naur OpenSP-1.5/lib/Syntax.cxx OpenSP-1.5-patched/lib/Syntax.cxx
|
||||||
|
--- OpenSP-1.5/lib/Syntax.cxx 2000-03-14 23:17:25.000000000 +0000
|
||||||
|
+++ OpenSP-1.5-patched/lib/Syntax.cxx 2003-05-24 18:36:39.000000000
|
||||||
|
+0000
|
||||||
|
@@ -24,7 +24,7 @@
|
||||||
|
16,
|
||||||
|
16,
|
||||||
|
16,
|
||||||
|
- 32,
|
||||||
|
+ 253,
|
||||||
|
96,
|
||||||
|
16,
|
||||||
|
240,
|
||||||
|
diff -Naur OpenSP-1.5/unicode/gensyntax.pl
|
||||||
|
OpenSP-1.5-patched/unicode/gensyntax.pl
|
||||||
|
--- OpenSP-1.5/unicode/gensyntax.pl 1999-11-04 08:36:18.000000000
|
||||||
|
+0000
|
||||||
|
+++ OpenSP-1.5-patched/unicode/gensyntax.pl 2003-05-24
|
||||||
|
18:39:53.000000000 +0000
|
||||||
|
@@ -185,7 +185,7 @@
|
||||||
|
|
||||||
|
QUANTITY SGMLREF -- To be determined --
|
||||||
|
ATTSPLEN 1920 -- ?? --
|
||||||
|
- LITLEN 240 -- ?? --
|
||||||
|
+ LITLEN 8092 -- ?? --
|
||||||
|
NAMELEN 240 -- ?? --
|
||||||
|
PILEN 1920 -- ?? --
|
||||||
|
TAGLEN 1920 -- ?? --
|
||||||
|
diff -Naur OpenSP-1.5/unicode/unicode.syn
|
||||||
|
OpenSP-1.5-patched/unicode/unicode.syn
|
||||||
|
--- OpenSP-1.5/unicode/unicode.syn 1999-11-04 08:36:18.000000000
|
||||||
|
+0000
|
||||||
|
+++ OpenSP-1.5-patched/unicode/unicode.syn 2003-05-24
|
||||||
|
18:40:12.000000000 +0000
|
||||||
|
@@ -1266,7 +1266,7 @@
|
||||||
|
|
||||||
|
QUANTITY SGMLREF -- To be determined --
|
||||||
|
ATTSPLEN 1920 -- ?? --
|
||||||
|
- LITLEN 240 -- ?? --
|
||||||
|
+ LITLEN 8092 -- ?? --
|
||||||
|
NAMELEN 240 -- ?? --
|
||||||
|
PILEN 1920 -- ?? --
|
||||||
|
TAGLEN 1920 -- ?? --
|
||||||
|
|
||||||
|
|
20
OpenSP-1.5.1-gcc34-1.patch
Normal file
20
OpenSP-1.5.1-gcc34-1.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
Submitted By: Jim Gifford (jim at linuxfromscratch dot org)
|
||||||
|
Date: 2004-04-24
|
||||||
|
Initial Package Version: 1.5.1
|
||||||
|
Origin: OpenJade SourceForge Patch Page
|
||||||
|
Upstream Status: Fixed
|
||||||
|
Description: Fixes Compile Issues with GCC 3.4
|
||||||
|
|
||||||
|
$LastChangedBy: bdubbs $
|
||||||
|
$Date: 2004-08-07 18:56:30 -0600 (Sat, 07 Aug 2004) $
|
||||||
|
|
||||||
|
--- OpenSP-1.5.1/include/RangeMap.cxx.orig 2004-04-24 17:39:50.000691400 +0000
|
||||||
|
+++ OpenSP-1.5.1/include/RangeMap.cxx 2004-04-24 17:39:59.682536194 +0000
|
||||||
|
@@ -7,6 +7,7 @@
|
||||||
|
#include "RangeMap.h"
|
||||||
|
#include "ISet.h"
|
||||||
|
#include "types.h"
|
||||||
|
+#include "constant.h"
|
||||||
|
|
||||||
|
#ifdef SP_NAMESPACE
|
||||||
|
namespace SP_NAMESPACE {
|
12
OpenSP-1.5.1-gcc41.patch
Normal file
12
OpenSP-1.5.1-gcc41.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -dpruN --exclude='config*' OpenSP-1.5.1.orig/include/InternalInputSource.h OpenSP-1.5.1/include/InternalInputSource.h
|
||||||
|
--- OpenSP-1.5.1.orig/include/InternalInputSource.h 2003-07-17 20:14:00.000000000 +0200
|
||||||
|
+++ OpenSP-1.5.1/include/InternalInputSource.h 2005-11-16 07:22:04.700397800 +0100
|
||||||
|
@@ -34,7 +34,7 @@ public:
|
||||||
|
void pushCharRef(Char ch, const NamedCharRef &);
|
||||||
|
Boolean rewind(Messenger &);
|
||||||
|
const StringC *contents();
|
||||||
|
- InternalInputSource *InternalInputSource::asInternalInputSource();
|
||||||
|
+ InternalInputSource *asInternalInputSource();
|
||||||
|
~InternalInputSource();
|
||||||
|
private:
|
||||||
|
InternalInputSource(const InternalInputSource &); // undefined
|
147
OpenSP.spec
Normal file
147
OpenSP.spec
Normal file
@ -0,0 +1,147 @@
|
|||||||
|
Name: OpenSP
|
||||||
|
Version: 1.5.2
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: A suite of SGML processing tools
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://openjade.sourceforge.net/
|
||||||
|
Source: http://switch.dl.sourceforge.net/sourceforge/openjade/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: OpenSP-1.5.1-LITLEN-1.patch
|
||||||
|
Patch1: OpenSP-1.5.1-gcc34-1.patch
|
||||||
|
Patch2: OpenSP-1.5.1-gcc41.patch
|
||||||
|
License: GPL
|
||||||
|
Requires: libosp = %{version}-%{release}
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: xmlto
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
||||||
|
|
||||||
|
%description
|
||||||
|
A suite of SGML processing tools.
|
||||||
|
|
||||||
|
%package -n libosp
|
||||||
|
Summary: Libraries for OpenSP
|
||||||
|
Group: System/Libraries
|
||||||
|
Provides: libOpenSP
|
||||||
|
Obsoletes: libOpenSP
|
||||||
|
|
||||||
|
%description -n libosp
|
||||||
|
OpenSP is a suite of SGML processing tools.
|
||||||
|
This package contains the system libraries.
|
||||||
|
|
||||||
|
%package -n libosp-devel
|
||||||
|
Summary: Devel package for OpenSP
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: libosp = %{version}-%{release}
|
||||||
|
Provides: libOpenSP-devel
|
||||||
|
Obsoletes: libOpenSP-devel
|
||||||
|
|
||||||
|
%description -n libosp-devel
|
||||||
|
OpenSP is a suite of SGML processing tools.
|
||||||
|
This is the devel package.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n OpenSP-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
#%patch2 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
--enable-http \
|
||||||
|
--enable-xml-messages \
|
||||||
|
--enable-default-catalog=/etc/sgml/catalog \
|
||||||
|
--enable-default-search-path=%{_datadir}/sgml
|
||||||
|
|
||||||
|
%make pkgdatadir=%{_datadir}/sgml/OpenSP-%{version}
|
||||||
|
|
||||||
|
%install
|
||||||
|
test x%{buildroot} != x/ && rm -rf %{buildroot}
|
||||||
|
%makeinstall pkgdatadir=%{_datadir}/sgml/OpenSP-%{version}
|
||||||
|
ln -s onsgmls %{buildroot}%{_bindir}/nsgmls
|
||||||
|
ln -s osgmlnorm %{buildroot}%{_bindir}/sgmlnorm
|
||||||
|
ln -s ospam %{buildroot}%{_bindir}/spam
|
||||||
|
ln -s ospcat %{buildroot}%{_bindir}/spcat
|
||||||
|
ln -s ospent %{buildroot}%{_bindir}/spent
|
||||||
|
#ln -s osx %{buildroot}%{_bindir}/sx
|
||||||
|
ln -s osx %{buildroot}%{_bindir}/sgml2xml
|
||||||
|
ln -s libosp.so %{buildroot}%{_libdir}/libsp.so
|
||||||
|
|
||||||
|
%find_lang sp5
|
||||||
|
|
||||||
|
%clean
|
||||||
|
test x%{buildroot} != x/ && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/onsgmls
|
||||||
|
%{_bindir}/osgmlnorm
|
||||||
|
%{_bindir}/ospam
|
||||||
|
%{_bindir}/ospcat
|
||||||
|
%{_bindir}/ospent
|
||||||
|
%{_bindir}/osx
|
||||||
|
%{_bindir}/nsgmls
|
||||||
|
%{_bindir}/sgml2xml
|
||||||
|
%{_bindir}/sgmlnorm
|
||||||
|
%{_bindir}/spam
|
||||||
|
%{_bindir}/spcat
|
||||||
|
%{_bindir}/spent
|
||||||
|
#%{_bindir}/sx
|
||||||
|
%dir %{_datadir}/doc/OpenSP
|
||||||
|
%{_datadir}/doc/OpenSP/*
|
||||||
|
%dir %{_datadir}/sgml/OpenSP-%{version}
|
||||||
|
%{_datadir}/sgml/OpenSP-%{version}/*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
|
%files -n libosp -f sp5.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libosp.so.*
|
||||||
|
|
||||||
|
%files -n libosp-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/OpenSP
|
||||||
|
%{_includedir}/OpenSP/*.h
|
||||||
|
%{_includedir}/OpenSP/*.cxx
|
||||||
|
%{_libdir}/libosp.a
|
||||||
|
%{_libdir}/libosp.la
|
||||||
|
%{_libdir}/libosp.so
|
||||||
|
%{_libdir}/libsp.so
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Dec 01 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-3mamba
|
||||||
|
- fix sgmlnorm symlink to osgmlnorm
|
||||||
|
|
||||||
|
* Sun Apr 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-2mamba
|
||||||
|
- rebuilt with libxml2 2.7.7
|
||||||
|
|
||||||
|
* Fri Feb 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Sep 24 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-5mamba
|
||||||
|
- move pkgdatadir into /usr/share/sgml
|
||||||
|
|
||||||
|
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-4mamba
|
||||||
|
- specfile updated
|
||||||
|
- added nsgmls symlink to onsgmls
|
||||||
|
- rename libOpenSP[-devel] to libosp[-devel]
|
||||||
|
|
||||||
|
* Fri May 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-3qilnx
|
||||||
|
- rebuilt with default SGML search path
|
||||||
|
|
||||||
|
* Fri May 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-2qilnx
|
||||||
|
- rebuilt with system default SGML catalog set (/etc/sgml/catalog)
|
||||||
|
|
||||||
|
* Fri Feb 25 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-1qilnx
|
||||||
|
- update to version 1.5.1 by autospec
|
||||||
|
- specfile Group entry fix
|
||||||
|
|
||||||
|
* Thu Dec 11 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.5-2qilnx
|
||||||
|
- added missing RPM requirement
|
||||||
|
|
||||||
|
* Wed Nov 19 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5-1qilnx
|
||||||
|
- first build
|
Reference in New Issue
Block a user