update hotspot connectivity check from https to a http url [release 1.46.0-4mamba;Wed May 15 2024]
This commit is contained in:
parent
db4cceadaa
commit
36823c152b
@ -1,10 +0,0 @@
|
||||
--- NetworkManager-0.9.10.0/data/NetworkManager.service.in.orig 2014-11-22 15:00:54.227221107 +0100
|
||||
+++ NetworkManager-0.9.10.0/data/NetworkManager.service.in 2014-11-22 15:01:03.284221718 +0100
|
||||
@@ -2,6 +2,7 @@
|
||||
Description=Network Manager
|
||||
Wants=network.target
|
||||
Before=network.target @DISTRO_NETWORK_SERVICE@
|
||||
+After=dbus.service
|
||||
|
||||
[Service]
|
||||
Type=dbus
|
@ -1,14 +0,0 @@
|
||||
diff -Nru NetworkManager-0.9.4.0.orig/src/nm-device-wifi.c NetworkManager-0.9.4.0/src/nm-device-wifi.c
|
||||
--- NetworkManager-0.9.4.0.orig/src/nm-device-wifi.c 2012-03-22 17:49:43.000000000 +0100
|
||||
+++ NetworkManager-0.9.4.0/src/nm-device-wifi.c 2012-05-03 12:26:47.861700288 +0200
|
||||
@@ -2426,8 +2426,8 @@
|
||||
|
||||
priv = NM_DEVICE_WIFI_GET_PRIVATE (self);
|
||||
|
||||
- /* Set up a timeout on the connection attempt to fail it after 25 seconds */
|
||||
- id = g_timeout_add_seconds (25, supplicant_connection_timeout_cb, self);
|
||||
+ /* Set up a timeout on the connection attempt to fail it after 90 seconds */
|
||||
+ id = g_timeout_add_seconds (90, supplicant_connection_timeout_cb, self);
|
||||
if (id == 0) {
|
||||
nm_log_err (LOGD_DEVICE | LOGD_WIFI,
|
||||
"Activation (%s/wireless): couldn't start supplicant "
|
@ -1,15 +0,0 @@
|
||||
--- NetworkManager-1.0.8/src/platform/nm-platform.c.orig 2015-11-25 22:06:03.836872636 +0100
|
||||
+++ NetworkManager-1.0.8/src/platform/nm-platform.c 2015-11-25 22:07:36.586087286 +0100
|
||||
@@ -39,6 +39,12 @@
|
||||
#include "nm-enum-types.h"
|
||||
#include "nm-core-internal.h"
|
||||
|
||||
+#if HAVE_LIBNL_INET6_ADDR_GEN_MODE && HAVE_KERNEL_INET6_ADDR_GEN_MODE
|
||||
+#include <linux/if_link.h>
|
||||
+#else
|
||||
+#define IN6_ADDR_GEN_MODE_NONE 1
|
||||
+#endif
|
||||
+
|
||||
#define ADDRESS_LIFETIME_PADDING 5
|
||||
|
||||
G_STATIC_ASSERT (sizeof ( ((NMPlatformLink *) NULL)->addr.data ) == NM_UTILS_HWADDR_LEN_MAX);
|
@ -1,11 +0,0 @@
|
||||
--- NetworkManager-1.20.2/meson.build.orig 2019-09-07 14:46:31.521000000 +0200
|
||||
+++ NetworkManager-1.20.2/meson.build 2019-09-07 14:46:43.328000000 +0200
|
||||
@@ -646,7 +646,7 @@
|
||||
if enable_nmcli
|
||||
# FIXME: check for readline
|
||||
# AX_LIB_READLINE
|
||||
- readline_dep = declare_dependency(link_args: '-lreadline')
|
||||
+ readline_dep = declare_dependency(link_args: ['-lreadline','-ltermcap'])
|
||||
'''
|
||||
foreach readline_lib: ['-lreadline', '-ledit', '-leditline']
|
||||
if not is_variable('readline_dep')
|
@ -1,57 +0,0 @@
|
||||
From a369e61d2a20493e6fcde9b6ac7e800174487a41 Mon Sep 17 00:00:00 2001
|
||||
From: Beniamino Galvani <bgalvani@redhat.com>
|
||||
Date: Fri, 6 Sep 2019 11:00:52 +0200
|
||||
Subject: [PATCH] build: use regexp in gtkdoc --ignore-decorators option
|
||||
|
||||
gtkdoc-scan supports regular expressions in the --ignore-decorators
|
||||
command-line option. Since it is easier to use a regexp than grepping
|
||||
macros from a source file, revert the ugly solution from commit
|
||||
2d941dc95a1d ('build: fix errors when building with gtk-doc 1.32').
|
||||
|
||||
(cherry picked from commit 11cf082a6233a5c2f17da1b49457a66266062678)
|
||||
---
|
||||
docs/libnm/Makefile.am | 4 +---
|
||||
docs/libnm/meson.build | 5 +----
|
||||
tools/decorators.sh | 7 -------
|
||||
3 files changed, 2 insertions(+), 14 deletions(-)
|
||||
delete mode 100755 tools/decorators.sh
|
||||
|
||||
diff --git a/docs/libnm/Makefile.am b/docs/libnm/Makefile.am
|
||||
index ded32f821..20dc8de57 100644
|
||||
--- a/docs/libnm/Makefile.am
|
||||
+++ b/docs/libnm/Makefile.am
|
||||
@@ -18,10 +18,8 @@ DOC_SOURCE_DIR= \
|
||||
$(top_srcdir)/libnm \
|
||||
$(top_builddir)/libnm
|
||||
|
||||
-decorators := $(shell $(top_srcdir)/tools/decorators.sh $(top_srcdir)/libnm-core/nm-version.h)
|
||||
-
|
||||
# Extra options to supply to gtkdoc-scan.
|
||||
-SCAN_OPTIONS=--rebuild-types --rebuild-sections --ignore-decorators "$(decorators)"
|
||||
+SCAN_OPTIONS=--rebuild-types --rebuild-sections --ignore-decorators="NM_AVAILABLE_IN_\d_\d\d?|NM_DEPRECATED_IN_\d_\d\d?"
|
||||
|
||||
# Extra options to supply to gtkdoc-mkdb.
|
||||
MKDB_OPTIONS=--sgml-mode --output-format=xml
|
||||
diff --git a/docs/libnm/meson.build b/docs/libnm/meson.build
|
||||
index 3403b339d..b4a23729b 100644
|
||||
--- a/docs/libnm/meson.build
|
||||
+++ b/docs/libnm/meson.build
|
||||
@@ -32,9 +32,6 @@ configure_file(
|
||||
configuration: version_conf,
|
||||
)
|
||||
|
||||
-result = run_command(join_paths(meson.source_root(), 'tools', 'decorators.sh'),
|
||||
- join_paths(meson.source_root(), 'libnm-core', 'nm-version.h'))
|
||||
-
|
||||
gnome.gtkdoc(
|
||||
doc_module,
|
||||
main_xml: doc_module + '-docs.xml',
|
||||
@@ -46,7 +43,7 @@ gnome.gtkdoc(
|
||||
scan_args: [
|
||||
'--rebuild-types',
|
||||
'--rebuild-sections',
|
||||
- '--ignore-decorators=' + result.stdout().strip(),
|
||||
+ '--ignore-decorators=NM_AVAILABLE_IN_\d_\d\d?|NM_DEPRECATED_IN_\d_\d\d?',
|
||||
'--ignore-headers=' + ' '.join(private_headers),
|
||||
],
|
||||
scanobjs_args: '--type-init-func="g_type_init();"',
|
8
NetworkManager-connectivity-openmamba.conf
Normal file
8
NetworkManager-connectivity-openmamba.conf
Normal file
@ -0,0 +1,8 @@
|
||||
# Enable connectivity checking for NetworkManager.
|
||||
# See `man NetworkManager.conf`.
|
||||
#
|
||||
# Note that connectivity checking works badly with rp_filter set to
|
||||
# strict. Check "/proc/sys/net/ipv4/conf/*/rp_filter".
|
||||
[connectivity]
|
||||
enabled=true
|
||||
uri=http://openmamba.org/static/hotspot.txt
|
@ -2,7 +2,7 @@
|
||||
%define pppdver %(rpm -q --queryformat '%%{version}\\n' ppp | head -n1)
|
||||
Name: NetworkManager
|
||||
Version: 1.46.0
|
||||
Release: 2mamba
|
||||
Release: 4mamba
|
||||
Summary: A hardware level network management tool integrated with D-Bus
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
@ -11,11 +11,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://networkmanager.dev/
|
||||
Source: https://download.gnome.org/sources/NetworkManager/%{majver}/%{name}-%{version}.tar.xz
|
||||
Source1: NetworkManager-0.8.2-polkit-localauthority.patch
|
||||
Patch0: NetworkManager-0.9.10.0-stop-before-dbus.patch
|
||||
Patch7: %{name}-0.9.4.0-wpa_supplicant_longer_timeout.patch
|
||||
Patch8: NetworkManager-1.0.8-kernel-headers-3.17.patch
|
||||
Patch9: NetworkManager-1.20.2-upstream-gtkdoc-fix.patch
|
||||
Patch10: NetworkManager-1.20.2-readline-termcap.patch
|
||||
Source2: NetworkManager-connectivity-openmamba.conf
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -92,7 +88,6 @@ This package includes the %{name} API documentation.
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#%patch10 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -121,14 +116,6 @@ This package includes the %{name} API documentation.
|
||||
-D qt=false \
|
||||
-D pppd=%{_sbindir}/pppd \
|
||||
-D pppd_plugin_dir=%{_libdir}/pppd/%{pppdver}
|
||||
|
||||
# -D ebpf=true \
|
||||
# -D dbus_conf_dir=/usr/share/dbus-1/system.d
|
||||
# -D dist_version="$pkgver-$pkgrel"
|
||||
# -D selinux=false
|
||||
|
||||
# --enable-wimax \
|
||||
# --with-distro=redhat \
|
||||
|
||||
%meson_build
|
||||
|
||||
@ -141,10 +128,9 @@ install -D -m0644 %{SOURCE1} \
|
||||
%{buildroot}%{_sysconfdir}/polkit-1/localauthority/50-local.d/10-org-freedesktop-network-manager-settings.pkla
|
||||
rm -f %{buildroot}%{_libdir}/libnm-*.a
|
||||
|
||||
#install -d -m0755 %{buildroot}%{_sysconfdir}/NetworkManager/conf.d
|
||||
#install -d -m0755 %{buildroot}%{_sysconfdir}/NetworkManager/system-connections
|
||||
#install -d -m0755 %{buildroot}%{_sysconfdir}/NetworkManager/VPN
|
||||
#install -d -m0755 %{buildroot}%{_sysconfdir}/sysconfig/network-scripts
|
||||
# Install hotspot connectivity check
|
||||
install -D -m0644 %{SOURCE2} \
|
||||
%{buildroot}%{_sysconfdir}/NetworkManager/conf.d/20-connectivity-openmamba.conf
|
||||
|
||||
%{find_lang} %{name}
|
||||
|
||||
@ -153,11 +139,6 @@ cat > %{buildroot}%{_sysconfdir}/NetworkManager/NetworkManager.conf << _EOF
|
||||
plugins=keyfile,ifcfg-rh
|
||||
_EOF
|
||||
|
||||
## 1.12.2: built but not installed by make install
|
||||
#cp ./src/settings/plugins/ibft/.libs/libnm-settings-plugin-ibft.{so,la} \
|
||||
# ./src/devices/team/.libs/libnm-device-plugin-team.{so,la} \
|
||||
# %{buildroot}%{_libdir}/NetworkManager/%{version}/
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
@ -198,6 +179,7 @@ fi
|
||||
%dir %{_sysconfdir}/NetworkManager
|
||||
%config(noreplace) %{_sysconfdir}/NetworkManager/NetworkManager.conf
|
||||
%dir %{_sysconfdir}/NetworkManager/conf.d
|
||||
%config(noreplace) %{_sysconfdir}/NetworkManager/conf.d/20-connectivity-openmamba.conf
|
||||
%dir %{_sysconfdir}/NetworkManager/dispatcher.d
|
||||
%dir %{_sysconfdir}/NetworkManager/dispatcher.d/*.d
|
||||
%dir %{_sysconfdir}/NetworkManager/dnsmasq-shared.d
|
||||
@ -246,9 +228,6 @@ fi
|
||||
%files -n libnm
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libnm.so.*
|
||||
#%{_libdir}/libnm-util.so.*
|
||||
#%{_libdir}/libnm-glib-vpn.so.*
|
||||
#%{_libdir}/libnm-glib.so.*
|
||||
%dir %{_libdir}/NetworkManager
|
||||
%{_libdir}/NetworkManager/%{version}/libnm-device-plugin-*.so
|
||||
%{_libdir}/NetworkManager/%{version}/libnm-settings-plugin-*.so
|
||||
@ -256,8 +235,6 @@ fi
|
||||
%{_libdir}/NetworkManager/%{version}/libnm-wwan.so
|
||||
%{_libdir}/pppd/*/nm-pppd-plugin.so
|
||||
%{_libdir}/girepository-1.0/NM-1.0.typelib
|
||||
#%{_libdir}/girepository-1.0/NMClient-1.0.typelib
|
||||
#%{_libdir}/girepository-1.0/NetworkManager-1.0.typelib
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libnm-devel
|
||||
@ -282,6 +259,12 @@ fi
|
||||
%{_datadir}/doc/NetworkManager/examples/server.conf
|
||||
|
||||
%changelog
|
||||
* Wed May 15 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.46.0-4mamba
|
||||
- update hotspot connectivity check from https to a http url
|
||||
|
||||
* Tue May 14 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.46.0-3mamba
|
||||
- install hotspot connectivity check conf.d file for openmamba
|
||||
|
||||
* Thu Mar 07 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.46.0-2mamba
|
||||
- fix ipv4 dhcp disabling ebpf (see https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/1485#note_2297552 )
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user