NetworkManager-vpnc/NetworkManager-vpnc-1.2.6-libnm-1.22.2.patch

65 lines
2.6 KiB
Diff

From ce9e64259a252fd30cda35c58664161b0b7c4414 Mon Sep 17 00:00:00 2001
From: Lubomir Rintel <lkundrak@v3.sk>
Date: Wed, 17 Oct 2018 15:21:30 +0200
Subject: [PATCH] build: disable libnm-glib support by default
By now nobody should be using this. Keep the code around for a little
longer just in case anybody still uses this.
The libnm-glib support also serves as an example how do we build two
different versions of the properties plugin. We'll soon be in a similar
situation with Gtk 4.0. (sigh.) Just don't drop it yet.
---
NEWS | 10 ++++++++++
configure.ac | 8 ++++----
2 files changed, 14 insertions(+), 4 deletions(-)
diff --git a/NEWS b/NEWS
index b5afcc4..2c29da4 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,13 @@
+=======================================================
+NetworkManager-vpnc-1.2.8 (not released yet)
+Overview of changes since NetworkManager-vpnc-1.2.6
+=======================================================
+
+* libnm-glib compatibility (NetworkManager < 1.0) is disabled by default.
+ It can be enabled by passing --with-libnm-glib to configure script.
+ Nobody should need it by now. Users that still use this are encourage
+ to let us know before the libnm-glib support is removed for good.
+
=======================================================
NetworkManager-vpnc-1.2.6
Overview of changes since NetworkManager-vpnc-1.2.4
diff --git a/configure.ac b/configure.ac
index 272c4c2..dc6279c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,7 +66,7 @@ dnl
dnl GNOME support
dnl
AC_ARG_WITH(gnome, AS_HELP_STRING([--without-gnome], [Build NetworkManager-vpnc without GNOME support, e.g. vpn service only]), [], [with_gnome_specified=no])
-AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--without-libnm-glib], [Build NetworkManager-vpnc without libnm-glib comatibility]), [], [with_libnm_glib_specified=no])
+AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--with-libnm-glib], [Build NetworkManager-vpnc with libnm-glib comatibility (depreacted)]), [], [with_libnm_glib_specified=no])
if test "$with_libnm_glib_specified" != no -a "$with_libnm_glib" != no; then
if test "$with_gnome_specified" != no -a "$with_gnome" == no; then
AC_MSG_ERROR(Building --with-libnm-glib conflicts with --without-gnome)
@@ -76,10 +76,10 @@ if test "$with_gnome" != no; then
with_gnome=yes
fi
if test "$with_libnm_glib_specified" == no; then
- with_libnm_glib="$with_gnome"
+ with_libnm_glib=no
fi
-if test "$with_libnm_glib" != no; then
- with_libnm_glib=yes
+if test "$with_libnm_glib" != yes; then
+ with_libnm_glib=no
fi
AM_CONDITIONAL(WITH_GNOME, test "$with_gnome" != no)
AM_CONDITIONAL(WITH_LIBNM_GLIB, test "$with_libnm_glib" != no)
--
2.24.1