rebuilt with libnm 1.22.2 [release 1.2.6-2mamba;Fri Jan 10 2020]
This commit is contained in:
parent
5a04c89f13
commit
e5689997e2
@ -1,8 +1,7 @@
|
|||||||
diff -Nru NetworkManager-vpnc-0.8.2.orig//nm-vpnc-service.conf NetworkManager-vpnc-0.8.2/nm-vpnc-service.conf
|
--- NetworkManager-vpnc-1.2.6/nm-vpnc-service.conf.orig 2018-06-05 12:32:40.000000000 +0200
|
||||||
--- NetworkManager-vpnc-0.8.2.orig//nm-vpnc-service.conf 2010-04-06 08:34:46.000000000 +0200
|
+++ NetworkManager-vpnc-1.2.6/nm-vpnc-service.conf 2020-01-10 15:50:36.422000000 +0100
|
||||||
+++ NetworkManager-vpnc-0.8.2/nm-vpnc-service.conf 2011-06-17 14:34:37.018948643 +0200
|
|
||||||
@@ -6,6 +6,14 @@
|
@@ -6,6 +6,14 @@
|
||||||
<allow own="org.freedesktop.NetworkManager.vpnc"/>
|
<allow own_prefix="org.freedesktop.NetworkManager.vpnc"/>
|
||||||
<allow send_destination="org.freedesktop.NetworkManager.vpnc"/>
|
<allow send_destination="org.freedesktop.NetworkManager.vpnc"/>
|
||||||
</policy>
|
</policy>
|
||||||
+ <policy group="sysadmin">
|
+ <policy group="sysadmin">
|
||||||
@ -14,5 +13,5 @@ diff -Nru NetworkManager-vpnc-0.8.2.orig//nm-vpnc-service.conf NetworkManager-vp
|
|||||||
+ <allow send_destination="org.freedesktop.NetworkManager.vpnc"/>
|
+ <allow send_destination="org.freedesktop.NetworkManager.vpnc"/>
|
||||||
+ </policy>
|
+ </policy>
|
||||||
<policy context="default">
|
<policy context="default">
|
||||||
<deny own="org.freedesktop.NetworkManager.vpnc"/>
|
<deny own_prefix="org.freedesktop.NetworkManager.vpnc"/>
|
||||||
<deny send_destination="org.freedesktop.NetworkManager.vpnc"/>
|
<deny send_destination="org.freedesktop.NetworkManager.vpnc"/>
|
64
NetworkManager-vpnc-1.2.6-libnm-1.22.2.patch
Normal file
64
NetworkManager-vpnc-1.2.6-libnm-1.22.2.patch
Normal file
@ -0,0 +1,64 @@
|
|||||||
|
From ce9e64259a252fd30cda35c58664161b0b7c4414 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||||
|
Date: Wed, 17 Oct 2018 15:21:30 +0200
|
||||||
|
Subject: [PATCH] build: disable libnm-glib support by default
|
||||||
|
|
||||||
|
By now nobody should be using this. Keep the code around for a little
|
||||||
|
longer just in case anybody still uses this.
|
||||||
|
|
||||||
|
The libnm-glib support also serves as an example how do we build two
|
||||||
|
different versions of the properties plugin. We'll soon be in a similar
|
||||||
|
situation with Gtk 4.0. (sigh.) Just don't drop it yet.
|
||||||
|
---
|
||||||
|
NEWS | 10 ++++++++++
|
||||||
|
configure.ac | 8 ++++----
|
||||||
|
2 files changed, 14 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/NEWS b/NEWS
|
||||||
|
index b5afcc4..2c29da4 100644
|
||||||
|
--- a/NEWS
|
||||||
|
+++ b/NEWS
|
||||||
|
@@ -1,3 +1,13 @@
|
||||||
|
+=======================================================
|
||||||
|
+NetworkManager-vpnc-1.2.8 (not released yet)
|
||||||
|
+Overview of changes since NetworkManager-vpnc-1.2.6
|
||||||
|
+=======================================================
|
||||||
|
+
|
||||||
|
+* libnm-glib compatibility (NetworkManager < 1.0) is disabled by default.
|
||||||
|
+ It can be enabled by passing --with-libnm-glib to configure script.
|
||||||
|
+ Nobody should need it by now. Users that still use this are encourage
|
||||||
|
+ to let us know before the libnm-glib support is removed for good.
|
||||||
|
+
|
||||||
|
=======================================================
|
||||||
|
NetworkManager-vpnc-1.2.6
|
||||||
|
Overview of changes since NetworkManager-vpnc-1.2.4
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 272c4c2..dc6279c 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -66,7 +66,7 @@ dnl
|
||||||
|
dnl GNOME support
|
||||||
|
dnl
|
||||||
|
AC_ARG_WITH(gnome, AS_HELP_STRING([--without-gnome], [Build NetworkManager-vpnc without GNOME support, e.g. vpn service only]), [], [with_gnome_specified=no])
|
||||||
|
-AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--without-libnm-glib], [Build NetworkManager-vpnc without libnm-glib comatibility]), [], [with_libnm_glib_specified=no])
|
||||||
|
+AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--with-libnm-glib], [Build NetworkManager-vpnc with libnm-glib comatibility (depreacted)]), [], [with_libnm_glib_specified=no])
|
||||||
|
if test "$with_libnm_glib_specified" != no -a "$with_libnm_glib" != no; then
|
||||||
|
if test "$with_gnome_specified" != no -a "$with_gnome" == no; then
|
||||||
|
AC_MSG_ERROR(Building --with-libnm-glib conflicts with --without-gnome)
|
||||||
|
@@ -76,10 +76,10 @@ if test "$with_gnome" != no; then
|
||||||
|
with_gnome=yes
|
||||||
|
fi
|
||||||
|
if test "$with_libnm_glib_specified" == no; then
|
||||||
|
- with_libnm_glib="$with_gnome"
|
||||||
|
+ with_libnm_glib=no
|
||||||
|
fi
|
||||||
|
-if test "$with_libnm_glib" != no; then
|
||||||
|
- with_libnm_glib=yes
|
||||||
|
+if test "$with_libnm_glib" != yes; then
|
||||||
|
+ with_libnm_glib=no
|
||||||
|
fi
|
||||||
|
AM_CONDITIONAL(WITH_GNOME, test "$with_gnome" != no)
|
||||||
|
AM_CONDITIONAL(WITH_LIBNM_GLIB, test "$with_libnm_glib" != no)
|
||||||
|
--
|
||||||
|
2.24.1
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: NetworkManager-vpnc
|
Name: NetworkManager-vpnc
|
||||||
Version: 1.2.6
|
Version: 1.2.6
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: NetworkManager plugin for CISCO VPN clients
|
Summary: NetworkManager plugin for CISCO VPN clients
|
||||||
Group: Network/Libraries
|
Group: Network/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -9,49 +9,42 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.gnome.org
|
URL: http://www.gnome.org
|
||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/NetworkManager-vpnc/%{majver}/NetworkManager-vpnc-%{version}.tar.xz
|
Source: http://ftp.gnome.org/pub/GNOME/sources/NetworkManager-vpnc/%{majver}/NetworkManager-vpnc-%{version}.tar.xz
|
||||||
Patch0: %{name}-0.8.2-dbus_policy.patch
|
Patch0: %{name}-1.2.6-dbus_policy.patch
|
||||||
Patch1: NetworkManager-vpnc-0.9.6.0-gtk-3.6.patch
|
Patch1: NetworkManager-vpnc-0.9.6.0-gtk-3.6.patch
|
||||||
|
Patch2: NetworkManager-vpnc-1.2.6-libnm-1.22.2.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: GConf-devel
|
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: ldconfig
|
||||||
BuildRequires: libatk-devel
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libblkid-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libdbus-devel
|
BuildRequires: libffi-devel
|
||||||
BuildRequires: libdbus-glib-devel
|
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcr-devel
|
||||||
BuildRequires: libgcrypt-devel
|
BuildRequires: libgcrypt-devel
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglade-devel
|
|
||||||
BuildRequires: libGL-devel
|
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libglitz-devel
|
|
||||||
BuildRequires: libgnome-keyring-devel
|
|
||||||
BuildRequires: libgpg-error-devel
|
BuildRequires: libgpg-error-devel
|
||||||
BuildRequires: libgtk2-devel
|
BuildRequires: libgraphite2-devel
|
||||||
|
BuildRequires: libgtk-devel
|
||||||
|
BuildRequires: libgudev-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
|
BuildRequires: libmount-devel
|
||||||
BuildRequires: libnm-devel
|
BuildRequires: libnm-devel
|
||||||
BuildRequires: libnspr-devel
|
BuildRequires: libnm-gtk-devel
|
||||||
BuildRequires: libnss-devel
|
BuildRequires: libp11-kit-devel
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libpixman-devel
|
BuildRequires: libpcre-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpthread-stubs-devel
|
BuildRequires: libsecret-devel
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libsepol-devel
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libXau-devel
|
|
||||||
BuildRequires: libxcb-devel
|
|
||||||
BuildRequires: libxcb-util-devel
|
|
||||||
BuildRequires: libXdmcp-devel
|
|
||||||
BuildRequires: libxml2-devel
|
|
||||||
BuildRequires: libXrender-devel
|
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: ORBit2-devel
|
|
||||||
BuildRequires: udev-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libnm-devel >= 1.22.2
|
||||||
Requires: vpnc
|
Requires: vpnc
|
||||||
Provides: networkmanagervpnplugin
|
Provides: networkmanagervpnplugin
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -63,6 +56,9 @@ NetworkManager plugin for CISCO VPN clients.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
|
autoreconf -f -i
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -79,12 +75,12 @@ NetworkManager plugin for CISCO VPN clients.
|
|||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_sysconfdir}/NetworkManager/VPN/nm-vpnc-service.name
|
#%{_sysconfdir}/NetworkManager/VPN/nm-vpnc-service.name
|
||||||
%{_sysconfdir}/dbus-1/system.d/nm-vpnc-service.conf
|
%{_sysconfdir}/dbus-1/system.d/nm-vpnc-service.conf
|
||||||
%{_prefix}/lib/NetworkManager/VPN/nm-vpnc-service.name
|
%{_prefix}/lib/NetworkManager/VPN/nm-vpnc-service.name
|
||||||
%{_libdir}/NetworkManager/libnm-vpnc-properties.a
|
#%{_libdir}/NetworkManager/libnm-vpnc-properties.a
|
||||||
%{_libdir}/NetworkManager/libnm-vpnc-properties.la
|
#%{_libdir}/NetworkManager/libnm-vpnc-properties.la
|
||||||
%{_libdir}/NetworkManager/libnm-vpnc-properties.so
|
#%{_libdir}/NetworkManager/libnm-vpnc-properties.so
|
||||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.a
|
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.a
|
||||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.la
|
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.la
|
||||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.so
|
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.so
|
||||||
@ -100,6 +96,9 @@ NetworkManager plugin for CISCO VPN clients.
|
|||||||
#ChangeLog NEWS
|
#ChangeLog NEWS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 10 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.6-2mamba
|
||||||
|
- rebuilt with libnm 1.22.2
|
||||||
|
|
||||||
* Thu Sep 06 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.6-1mamba
|
* Thu Sep 06 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.6-1mamba
|
||||||
- update to 1.2.6
|
- update to 1.2.6
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user