automatic version update by autodist [release 1.4.0-1mamba;Mon Nov 18 2024]
This commit is contained in:
parent
58543f4cb2
commit
193399dde4
@ -1,37 +0,0 @@
|
||||
Index: network-manager-vpnc-0.9.2.0+git201201080319.236292c/auth-dialog/vpn-password-dialog.c
|
||||
===================================================================
|
||||
--- network-manager-vpnc-0.9.2.0+git201201080319.236292c.orig/auth-dialog/vpn-password-dialog.c 2012-02-10 14:41:30.000000000 -0500
|
||||
+++ network-manager-vpnc-0.9.2.0+git201201080319.236292c/auth-dialog/vpn-password-dialog.c 2012-02-10 15:10:40.120355818 -0500
|
||||
@@ -123,8 +123,8 @@
|
||||
label = gtk_label_new_with_mnemonic (label_text);
|
||||
gtk_misc_set_alignment (GTK_MISC (label), 0.0, 0.5);
|
||||
|
||||
- gtk_table_attach_defaults (GTK_TABLE (table), label, 0, 1, row, row + 1);
|
||||
- gtk_table_attach_defaults (GTK_TABLE (table), entry, 1, 2, row, row + 1);
|
||||
+ gtk_grid_attach (GTK_GRID (table), label, 0, row, 1, 1);
|
||||
+ gtk_grid_attach (GTK_GRID (table), entry, 1, row, 1, 1);
|
||||
|
||||
gtk_label_set_mnemonic_widget (GTK_LABEL (label), entry);
|
||||
}
|
||||
@@ -153,7 +153,7 @@
|
||||
if (priv->show_password_secondary)
|
||||
add_row (priv->table, row++, priv->secondary_password_label, priv->password_entry_secondary);
|
||||
|
||||
- gtk_table_attach_defaults (GTK_TABLE (priv->table), priv->show_passwords_checkbox, 1, 2, row, row + 1);
|
||||
+ gtk_grid_attach (GTK_GRID (priv->table), priv->show_passwords_checkbox, 1, row, 1, 1);
|
||||
|
||||
gtk_widget_show_all (priv->table);
|
||||
}
|
||||
@@ -227,9 +227,9 @@
|
||||
|
||||
priv->group = gtk_size_group_new (GTK_SIZE_GROUP_HORIZONTAL);
|
||||
|
||||
- priv->table = gtk_table_new (4, 2, FALSE);
|
||||
- gtk_table_set_col_spacings (GTK_TABLE (priv->table), 12);
|
||||
- gtk_table_set_row_spacings (GTK_TABLE (priv->table), 6);
|
||||
+ priv->table = gtk_grid_new ();
|
||||
+ gtk_grid_set_column_spacing (GTK_GRID (priv->table), 12);
|
||||
+ gtk_grid_set_row_spacing (GTK_GRID (priv->table), 6);
|
||||
gtk_container_add (GTK_CONTAINER (priv->table_alignment), priv->table);
|
||||
|
||||
priv->password_entry = gtk_entry_new ();
|
@ -1,64 +0,0 @@
|
||||
From ce9e64259a252fd30cda35c58664161b0b7c4414 Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Wed, 17 Oct 2018 15:21:30 +0200
|
||||
Subject: [PATCH] build: disable libnm-glib support by default
|
||||
|
||||
By now nobody should be using this. Keep the code around for a little
|
||||
longer just in case anybody still uses this.
|
||||
|
||||
The libnm-glib support also serves as an example how do we build two
|
||||
different versions of the properties plugin. We'll soon be in a similar
|
||||
situation with Gtk 4.0. (sigh.) Just don't drop it yet.
|
||||
---
|
||||
NEWS | 10 ++++++++++
|
||||
configure.ac | 8 ++++----
|
||||
2 files changed, 14 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/NEWS b/NEWS
|
||||
index b5afcc4..2c29da4 100644
|
||||
--- a/NEWS
|
||||
+++ b/NEWS
|
||||
@@ -1,3 +1,13 @@
|
||||
+=======================================================
|
||||
+NetworkManager-vpnc-1.2.8 (not released yet)
|
||||
+Overview of changes since NetworkManager-vpnc-1.2.6
|
||||
+=======================================================
|
||||
+
|
||||
+* libnm-glib compatibility (NetworkManager < 1.0) is disabled by default.
|
||||
+ It can be enabled by passing --with-libnm-glib to configure script.
|
||||
+ Nobody should need it by now. Users that still use this are encourage
|
||||
+ to let us know before the libnm-glib support is removed for good.
|
||||
+
|
||||
=======================================================
|
||||
NetworkManager-vpnc-1.2.6
|
||||
Overview of changes since NetworkManager-vpnc-1.2.4
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 272c4c2..dc6279c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -66,7 +66,7 @@ dnl
|
||||
dnl GNOME support
|
||||
dnl
|
||||
AC_ARG_WITH(gnome, AS_HELP_STRING([--without-gnome], [Build NetworkManager-vpnc without GNOME support, e.g. vpn service only]), [], [with_gnome_specified=no])
|
||||
-AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--without-libnm-glib], [Build NetworkManager-vpnc without libnm-glib comatibility]), [], [with_libnm_glib_specified=no])
|
||||
+AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--with-libnm-glib], [Build NetworkManager-vpnc with libnm-glib comatibility (depreacted)]), [], [with_libnm_glib_specified=no])
|
||||
if test "$with_libnm_glib_specified" != no -a "$with_libnm_glib" != no; then
|
||||
if test "$with_gnome_specified" != no -a "$with_gnome" == no; then
|
||||
AC_MSG_ERROR(Building --with-libnm-glib conflicts with --without-gnome)
|
||||
@@ -76,10 +76,10 @@ if test "$with_gnome" != no; then
|
||||
with_gnome=yes
|
||||
fi
|
||||
if test "$with_libnm_glib_specified" == no; then
|
||||
- with_libnm_glib="$with_gnome"
|
||||
+ with_libnm_glib=no
|
||||
fi
|
||||
-if test "$with_libnm_glib" != no; then
|
||||
- with_libnm_glib=yes
|
||||
+if test "$with_libnm_glib" != yes; then
|
||||
+ with_libnm_glib=no
|
||||
fi
|
||||
AM_CONDITIONAL(WITH_GNOME, test "$with_gnome" != no)
|
||||
AM_CONDITIONAL(WITH_LIBNM_GLIB, test "$with_libnm_glib" != no)
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: NetworkManager-vpnc
|
||||
Version: 1.2.8
|
||||
Version: 1.4.0
|
||||
Release: 1mamba
|
||||
Summary: NetworkManager plugin for CISCO VPN clients
|
||||
Group: Network/Libraries
|
||||
@ -10,29 +10,18 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.gnome.org/
|
||||
Source: https://download.gnome.org/sources/NetworkManager-vpnc/%{majver}/NetworkManager-vpnc-%{version}.tar.xz
|
||||
Patch0: %{name}-1.2.6-dbus_policy.patch
|
||||
Patch1: NetworkManager-vpnc-0.9.6.0-gtk-3.6.patch
|
||||
Patch2: NetworkManager-vpnc-1.2.6-libnm-1.22.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcr-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libnm-devel
|
||||
BuildRequires: libnma-devel
|
||||
BuildRequires: libp11-kit-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libsecret-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
@ -48,8 +37,6 @@ NetworkManager plugin for CISCO VPN clients.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
|
||||
autoreconf -f -i
|
||||
|
||||
@ -70,11 +57,7 @@ autoreconf -f -i
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/dbus-1/system.d/nm-vpnc-service.conf
|
||||
%{_prefix}/lib/NetworkManager/VPN/nm-vpnc-service.name
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.a
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.la
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc-editor.so
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc.a
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc.la
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc.so
|
||||
%{_libexecdir}/nm-vpnc-auth-dialog
|
||||
%{_libexecdir}/nm-vpnc-service
|
||||
@ -84,6 +67,9 @@ autoreconf -f -i
|
||||
#ChangeLog NEWS
|
||||
|
||||
%changelog
|
||||
* Mon Nov 18 2024 Automatic Build System <autodist@openmamba.org> 1.4.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Mar 21 2022 Automatic Build System <autodist@mambasoft.it> 1.2.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user