rebuilt with ppp 2.5.2 [release 1.2.12-4mamba;Sun Jan 05 2025]
This commit is contained in:
parent
f041b28184
commit
f52f8b2d45
@ -1,37 +0,0 @@
|
|||||||
Index: network-manager-vpnc-0.9.2.0+git201201080319.236292c/auth-dialog/vpn-password-dialog.c
|
|
||||||
===================================================================
|
|
||||||
--- network-manager-vpnc-0.9.2.0+git201201080319.236292c.orig/auth-dialog/vpn-password-dialog.c 2012-02-10 14:41:30.000000000 -0500
|
|
||||||
+++ network-manager-vpnc-0.9.2.0+git201201080319.236292c/auth-dialog/vpn-password-dialog.c 2012-02-10 15:10:40.120355818 -0500
|
|
||||||
@@ -123,8 +123,8 @@
|
|
||||||
label = gtk_label_new_with_mnemonic (label_text);
|
|
||||||
gtk_misc_set_alignment (GTK_MISC (label), 0.0, 0.5);
|
|
||||||
|
|
||||||
- gtk_table_attach_defaults (GTK_TABLE (table), label, 0, 1, row, row + 1);
|
|
||||||
- gtk_table_attach_defaults (GTK_TABLE (table), entry, 1, 2, row, row + 1);
|
|
||||||
+ gtk_grid_attach (GTK_GRID (table), label, 0, row, 1, 1);
|
|
||||||
+ gtk_grid_attach (GTK_GRID (table), entry, 1, row, 1, 1);
|
|
||||||
|
|
||||||
gtk_label_set_mnemonic_widget (GTK_LABEL (label), entry);
|
|
||||||
}
|
|
||||||
@@ -153,7 +153,7 @@
|
|
||||||
if (priv->show_password_secondary)
|
|
||||||
add_row (priv->table, row++, priv->secondary_password_label, priv->password_entry_secondary);
|
|
||||||
|
|
||||||
- gtk_table_attach_defaults (GTK_TABLE (priv->table), priv->show_passwords_checkbox, 1, 2, row, row + 1);
|
|
||||||
+ gtk_grid_attach (GTK_GRID (priv->table), priv->show_passwords_checkbox, 1, row, 1, 1);
|
|
||||||
|
|
||||||
gtk_widget_show_all (priv->table);
|
|
||||||
}
|
|
||||||
@@ -227,9 +227,9 @@
|
|
||||||
|
|
||||||
priv->group = gtk_size_group_new (GTK_SIZE_GROUP_HORIZONTAL);
|
|
||||||
|
|
||||||
- priv->table = gtk_table_new (4, 2, FALSE);
|
|
||||||
- gtk_table_set_col_spacings (GTK_TABLE (priv->table), 12);
|
|
||||||
- gtk_table_set_row_spacings (GTK_TABLE (priv->table), 6);
|
|
||||||
+ priv->table = gtk_grid_new ();
|
|
||||||
+ gtk_grid_set_column_spacing (GTK_GRID (priv->table), 12);
|
|
||||||
+ gtk_grid_set_row_spacing (GTK_GRID (priv->table), 6);
|
|
||||||
gtk_container_add (GTK_CONTAINER (priv->table_alignment), priv->table);
|
|
||||||
|
|
||||||
priv->password_entry = gtk_entry_new ();
|
|
@ -1,66 +0,0 @@
|
|||||||
From 42183b79dc53b42c370c16a6c2596c9560e92c56 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
|
||||||
Date: Wed, 17 Oct 2018 15:21:30 +0200
|
|
||||||
Subject: [PATCH] build: disable libnm-glib support by default
|
|
||||||
|
|
||||||
By now nobody should be using this. Keep the code around for a little
|
|
||||||
longer just in case anybody still uses this.
|
|
||||||
|
|
||||||
The libnm-glib support also serves as an example how do we build two
|
|
||||||
different versions of the properties plugin. We'll soon be in a similar
|
|
||||||
situation with Gtk 4.0. (sigh.) Just don't drop it yet.
|
|
||||||
|
|
||||||
https://gitlab.gnome.org/GNOME/NetworkManager-pptp/merge_requests/4
|
|
||||||
---
|
|
||||||
NEWS | 10 ++++++++++
|
|
||||||
configure.ac | 8 ++++----
|
|
||||||
2 files changed, 14 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/NEWS b/NEWS
|
|
||||||
index dc830e6..705bde6 100644
|
|
||||||
--- a/NEWS
|
|
||||||
+++ b/NEWS
|
|
||||||
@@ -1,3 +1,13 @@
|
|
||||||
+==========================================================
|
|
||||||
+NetworkManager-pptp-1.2.10 (not released yet)
|
|
||||||
+Overview of changes since NetworkManager-pptp-1.2.8
|
|
||||||
+==========================================================
|
|
||||||
+
|
|
||||||
+* libnm-glib compatibility (NetworkManager < 1.0) is disabled by default.
|
|
||||||
+ It can be enabled by passing --with-libnm-glib to configure script.
|
|
||||||
+ Nobody should need it by now. Users that still use this are encourage
|
|
||||||
+ to let us know before the libnm-glib support is removed for good.
|
|
||||||
+
|
|
||||||
=======================================================
|
|
||||||
NetworkManager-pptp-1.2.8
|
|
||||||
Overview of changes since NetworkManager-pptp-1.2.6
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 757c573..d42fba3 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -72,7 +72,7 @@ dnl
|
|
||||||
dnl GNOME support
|
|
||||||
dnl
|
|
||||||
AC_ARG_WITH(gnome, AS_HELP_STRING([--without-gnome], [Build NetworkManager-pptp without GNOME support, e.g. vpn service only]), [], [with_gnome_specified=no])
|
|
||||||
-AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--without-libnm-glib], [Build NetworkManager-pptp without libnm-glib comatibility]), [], [with_libnm_glib_specified=no])
|
|
||||||
+AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--with-libnm-glib], [Build NetworkManager-pptp with libnm-glib comatibility (depreacted)]), [], [with_libnm_glib_specified=no])
|
|
||||||
if test "$with_libnm_glib_specified" != no -a "$with_libnm_glib" != no; then
|
|
||||||
if test "$with_gnome_specified" != no -a "$with_gnome" == no; then
|
|
||||||
AC_MSG_ERROR(Building --with-libnm-glib conflicts with --without-gnome)
|
|
||||||
@@ -82,10 +82,10 @@ if test "$with_gnome" != no; then
|
|
||||||
with_gnome=yes
|
|
||||||
fi
|
|
||||||
if test "$with_libnm_glib_specified" == no; then
|
|
||||||
- with_libnm_glib="$with_gnome"
|
|
||||||
+ with_libnm_glib=no
|
|
||||||
fi
|
|
||||||
-if test "$with_libnm_glib" != no; then
|
|
||||||
- with_libnm_glib=yes
|
|
||||||
+if test "$with_libnm_glib" != yes; then
|
|
||||||
+ with_libnm_glib=no
|
|
||||||
fi
|
|
||||||
AM_CONDITIONAL(WITH_GNOME, test "$with_gnome" != no)
|
|
||||||
AM_CONDITIONAL(WITH_LIBNM_GLIB, test "$with_libnm_glib" != no)
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
@ -1,8 +1,8 @@
|
|||||||
%define ppp_version 2.5.1
|
%define ppp_version 2.5.2
|
||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: NetworkManager-pptp
|
Name: NetworkManager-pptp
|
||||||
Version: 1.2.12
|
Version: 1.2.12
|
||||||
Release: 3mamba
|
Release: 4mamba
|
||||||
Summary: NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol
|
Summary: NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol
|
||||||
Group: Network/Libraries
|
Group: Network/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -10,9 +10,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.gnome.org/
|
URL: https://www.gnome.org/
|
||||||
Source: https://download.gnome.org/sources/NetworkManager-pptp/%{majver}/NetworkManager-pptp-%{version}.tar.xz
|
Source: https://download.gnome.org/sources/NetworkManager-pptp/%{majver}/NetworkManager-pptp-%{version}.tar.xz
|
||||||
Patch0: %{name}-1.2.8-dbus_policy.patch
|
Patch0: NetworkManager-pptp-1.2.8-dbus_policy.patch
|
||||||
Patch1: NetworkManager-pptp-0.9.6.0-gtk-3.6.patch
|
|
||||||
Patch2: NetworkManager-pptp-1.2.8-libnm-1.22.2.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -36,13 +34,9 @@ Provides: networkmanagervpnplugin
|
|||||||
%description
|
%description
|
||||||
NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol.
|
NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol.
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch 0 -p1
|
%patch 0 -p1
|
||||||
#%patch1 -p1
|
|
||||||
#%patch2 -p1
|
|
||||||
|
|
||||||
autoreconf -f -i
|
autoreconf -f -i
|
||||||
|
|
||||||
@ -75,6 +69,9 @@ autoreconf -f -i
|
|||||||
#ChangeLog NEWS README TODO
|
#ChangeLog NEWS README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jan 05 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.12-4mamba
|
||||||
|
- rebuilt with ppp 2.5.2
|
||||||
|
|
||||||
* Fri Oct 11 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.12-3mamba
|
* Fri Oct 11 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.12-3mamba
|
||||||
- rebuilt with ppp 2.5.1
|
- rebuilt with ppp 2.5.1
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user