update to 1.2.8 [release 1.2.8-1mamba;Fri Jan 10 2020]
This commit is contained in:
parent
13a8e315f3
commit
abfc62b268
@ -1,9 +1,8 @@
|
||||
diff -Nru NetworkManager-pptp-0.8.2.orig//nm-pptp-service.conf NetworkManager-pptp-0.8.2/nm-pptp-service.conf
|
||||
--- NetworkManager-pptp-0.8.2.orig//nm-pptp-service.conf 2010-04-06 08:34:08.000000000 +0200
|
||||
+++ NetworkManager-pptp-0.8.2/nm-pptp-service.conf 2011-06-17 14:36:15.924733505 +0200
|
||||
@@ -9,6 +9,20 @@
|
||||
<allow own="org.freedesktop.NetworkManager.pptp-ppp"/>
|
||||
<allow send_destination="org.freedesktop.NetworkManager.pptp-ppp"/>
|
||||
--- NetworkManager-pptp-1.2.8/nm-pptp-service.conf.orig 2016-04-21 15:50:41.000000000 +0200
|
||||
+++ NetworkManager-pptp-1.2.8/nm-pptp-service.conf 2020-01-10 15:37:08.725000000 +0100
|
||||
@@ -7,6 +7,20 @@
|
||||
<allow send_destination="org.freedesktop.NetworkManager.pptp"/>
|
||||
<allow send_interface="org.freedesktop.NetworkManager.pptp.ppp"/>
|
||||
</policy>
|
||||
+ <policy group="sysadmin">
|
||||
+ <allow own="org.freedesktop.NetworkManager.pptp"/>
|
||||
@ -20,5 +19,5 @@ diff -Nru NetworkManager-pptp-0.8.2.orig//nm-pptp-service.conf NetworkManager-pp
|
||||
+ <allow send_destination="org.freedesktop.NetworkManager.pptp-ppp"/>
|
||||
+ </policy>
|
||||
<policy context="default">
|
||||
<deny own="org.freedesktop.NetworkManager.pptp"/>
|
||||
<deny own_prefix="org.freedesktop.NetworkManager.pptp"/>
|
||||
<deny send_destination="org.freedesktop.NetworkManager.pptp"/>
|
66
NetworkManager-pptp-1.2.8-libnm-1.22.2.patch
Normal file
66
NetworkManager-pptp-1.2.8-libnm-1.22.2.patch
Normal file
@ -0,0 +1,66 @@
|
||||
From 42183b79dc53b42c370c16a6c2596c9560e92c56 Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Wed, 17 Oct 2018 15:21:30 +0200
|
||||
Subject: [PATCH] build: disable libnm-glib support by default
|
||||
|
||||
By now nobody should be using this. Keep the code around for a little
|
||||
longer just in case anybody still uses this.
|
||||
|
||||
The libnm-glib support also serves as an example how do we build two
|
||||
different versions of the properties plugin. We'll soon be in a similar
|
||||
situation with Gtk 4.0. (sigh.) Just don't drop it yet.
|
||||
|
||||
https://gitlab.gnome.org/GNOME/NetworkManager-pptp/merge_requests/4
|
||||
---
|
||||
NEWS | 10 ++++++++++
|
||||
configure.ac | 8 ++++----
|
||||
2 files changed, 14 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/NEWS b/NEWS
|
||||
index dc830e6..705bde6 100644
|
||||
--- a/NEWS
|
||||
+++ b/NEWS
|
||||
@@ -1,3 +1,13 @@
|
||||
+==========================================================
|
||||
+NetworkManager-pptp-1.2.10 (not released yet)
|
||||
+Overview of changes since NetworkManager-pptp-1.2.8
|
||||
+==========================================================
|
||||
+
|
||||
+* libnm-glib compatibility (NetworkManager < 1.0) is disabled by default.
|
||||
+ It can be enabled by passing --with-libnm-glib to configure script.
|
||||
+ Nobody should need it by now. Users that still use this are encourage
|
||||
+ to let us know before the libnm-glib support is removed for good.
|
||||
+
|
||||
=======================================================
|
||||
NetworkManager-pptp-1.2.8
|
||||
Overview of changes since NetworkManager-pptp-1.2.6
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 757c573..d42fba3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -72,7 +72,7 @@ dnl
|
||||
dnl GNOME support
|
||||
dnl
|
||||
AC_ARG_WITH(gnome, AS_HELP_STRING([--without-gnome], [Build NetworkManager-pptp without GNOME support, e.g. vpn service only]), [], [with_gnome_specified=no])
|
||||
-AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--without-libnm-glib], [Build NetworkManager-pptp without libnm-glib comatibility]), [], [with_libnm_glib_specified=no])
|
||||
+AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--with-libnm-glib], [Build NetworkManager-pptp with libnm-glib comatibility (depreacted)]), [], [with_libnm_glib_specified=no])
|
||||
if test "$with_libnm_glib_specified" != no -a "$with_libnm_glib" != no; then
|
||||
if test "$with_gnome_specified" != no -a "$with_gnome" == no; then
|
||||
AC_MSG_ERROR(Building --with-libnm-glib conflicts with --without-gnome)
|
||||
@@ -82,10 +82,10 @@ if test "$with_gnome" != no; then
|
||||
with_gnome=yes
|
||||
fi
|
||||
if test "$with_libnm_glib_specified" == no; then
|
||||
- with_libnm_glib="$with_gnome"
|
||||
+ with_libnm_glib=no
|
||||
fi
|
||||
-if test "$with_libnm_glib" != no; then
|
||||
- with_libnm_glib=yes
|
||||
+if test "$with_libnm_glib" != yes; then
|
||||
+ with_libnm_glib=no
|
||||
fi
|
||||
AM_CONDITIONAL(WITH_GNOME, test "$with_gnome" != no)
|
||||
AM_CONDITIONAL(WITH_LIBNM_GLIB, test "$with_libnm_glib" != no)
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,7 +1,7 @@
|
||||
%define ppp_version 2.4.7
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: NetworkManager-pptp
|
||||
Version: 1.2.6
|
||||
Version: 1.2.8
|
||||
Release: 1mamba
|
||||
Summary: NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol
|
||||
Group: Network/Libraries
|
||||
@ -10,49 +10,43 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.gnome.org
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/NetworkManager-pptp/%{majver}/NetworkManager-pptp-%{version}.tar.xz
|
||||
Patch0: %{name}-0.8.2-dbus_policy.patch
|
||||
Patch0: %{name}-1.2.8-dbus_policy.patch
|
||||
Patch1: NetworkManager-pptp-0.9.6.0-gtk-3.6.patch
|
||||
Patch2: NetworkManager-pptp-1.2.8-libnm-1.22.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: GConf-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcr-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglade-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglitz-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libgudev-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libmount-devel
|
||||
BuildRequires: libnm-devel
|
||||
BuildRequires: libnspr-devel
|
||||
BuildRequires: libnss-devel
|
||||
BuildRequires: libnm-gtk-devel
|
||||
BuildRequires: libp11-kit-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpthread-stubs-devel
|
||||
BuildRequires: libsecret-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsepol-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcb-util-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: ORBit2-devel
|
||||
BuildRequires: udev-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libnm-devel >= 1.22.2
|
||||
BuildRequires: libnm-gtk-devel >= 1.8.24-2mamba
|
||||
BuildRequires: ppp = %{ppp_version}
|
||||
Requires: ppp >= %{ppp_version}
|
||||
Provides: networkmanagervpnplugin
|
||||
@ -65,6 +59,9 @@ NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protoco
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
autoreconf -f -i
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -83,15 +80,15 @@ NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protoco
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/NetworkManager/VPN/nm-pptp-service.name
|
||||
#%{_sysconfdir}/NetworkManager/VPN/nm-pptp-service.name
|
||||
%{_sysconfdir}/dbus-1/system.d/nm-pptp-service.conf
|
||||
%{_prefix}/lib/NetworkManager/VPN/nm-pptp-service.name
|
||||
%{_libdir}/pppd/%{ppp_version}/nm-pptp-pppd-plugin.a
|
||||
%{_libdir}/pppd/%{ppp_version}/nm-pptp-pppd-plugin.la
|
||||
%{_libdir}/pppd/%{ppp_version}/nm-pptp-pppd-plugin.so
|
||||
%{_libdir}/NetworkManager/libnm-pptp-properties.a
|
||||
%{_libdir}/NetworkManager/libnm-pptp-properties.la
|
||||
%{_libdir}/NetworkManager/libnm-pptp-properties.so
|
||||
#%{_libdir}/NetworkManager/libnm-pptp-properties.a
|
||||
#%{_libdir}/NetworkManager/libnm-pptp-properties.la
|
||||
#%{_libdir}/NetworkManager/libnm-pptp-properties.so
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-pptp-editor.a
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-pptp-editor.la
|
||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-pptp-editor.so
|
||||
@ -105,6 +102,9 @@ NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protoco
|
||||
#ChangeLog NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Fri Jan 10 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.8-1mamba
|
||||
- update to 1.2.8
|
||||
|
||||
* Thu May 10 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.6-1mamba
|
||||
- update to 1.2.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user