diff --git a/NetworkManager-pptp-0.8.2-dbus_policy.patch b/NetworkManager-pptp-0.8.2-dbus_policy.patch
new file mode 100644
index 0000000..f6abe7b
--- /dev/null
+++ b/NetworkManager-pptp-0.8.2-dbus_policy.patch
@@ -0,0 +1,24 @@
+diff -Nru NetworkManager-pptp-0.8.2.orig//nm-pptp-service.conf NetworkManager-pptp-0.8.2/nm-pptp-service.conf
+--- NetworkManager-pptp-0.8.2.orig//nm-pptp-service.conf 2010-04-06 08:34:08.000000000 +0200
++++ NetworkManager-pptp-0.8.2/nm-pptp-service.conf 2011-06-17 14:36:15.924733505 +0200
+@@ -9,6 +9,20 @@
+
+
+
++
++
++
++
++
++
++
++
++
++
++
++
++
++
+
+
+
diff --git a/NetworkManager-pptp-0.9.6.0-gtk-3.6.patch b/NetworkManager-pptp-0.9.6.0-gtk-3.6.patch
new file mode 100644
index 0000000..4a3bcc2
--- /dev/null
+++ b/NetworkManager-pptp-0.9.6.0-gtk-3.6.patch
@@ -0,0 +1,37 @@
+Index: network-manager-vpnc-0.9.2.0+git201201080319.236292c/auth-dialog/vpn-password-dialog.c
+===================================================================
+--- network-manager-vpnc-0.9.2.0+git201201080319.236292c.orig/auth-dialog/vpn-password-dialog.c 2012-02-10 14:41:30.000000000 -0500
++++ network-manager-vpnc-0.9.2.0+git201201080319.236292c/auth-dialog/vpn-password-dialog.c 2012-02-10 15:10:40.120355818 -0500
+@@ -123,8 +123,8 @@
+ label = gtk_label_new_with_mnemonic (label_text);
+ gtk_misc_set_alignment (GTK_MISC (label), 0.0, 0.5);
+
+- gtk_table_attach_defaults (GTK_TABLE (table), label, 0, 1, row, row + 1);
+- gtk_table_attach_defaults (GTK_TABLE (table), entry, 1, 2, row, row + 1);
++ gtk_grid_attach (GTK_GRID (table), label, 0, row, 1, 1);
++ gtk_grid_attach (GTK_GRID (table), entry, 1, row, 1, 1);
+
+ gtk_label_set_mnemonic_widget (GTK_LABEL (label), entry);
+ }
+@@ -153,7 +153,7 @@
+ if (priv->show_password_secondary)
+ add_row (priv->table, row++, priv->secondary_password_label, priv->password_entry_secondary);
+
+- gtk_table_attach_defaults (GTK_TABLE (priv->table), priv->show_passwords_checkbox, 1, 2, row, row + 1);
++ gtk_grid_attach (GTK_GRID (priv->table), priv->show_passwords_checkbox, 1, row, 1, 1);
+
+ gtk_widget_show_all (priv->table);
+ }
+@@ -227,9 +227,9 @@
+
+ priv->group = gtk_size_group_new (GTK_SIZE_GROUP_HORIZONTAL);
+
+- priv->table = gtk_table_new (4, 2, FALSE);
+- gtk_table_set_col_spacings (GTK_TABLE (priv->table), 12);
+- gtk_table_set_row_spacings (GTK_TABLE (priv->table), 6);
++ priv->table = gtk_grid_new ();
++ gtk_grid_set_column_spacing (GTK_GRID (priv->table), 12);
++ gtk_grid_set_row_spacing (GTK_GRID (priv->table), 6);
+ gtk_container_add (GTK_CONTAINER (priv->table_alignment), priv->table);
+
+ priv->password_entry = gtk_entry_new ();
diff --git a/NetworkManager-pptp.spec b/NetworkManager-pptp.spec
new file mode 100644
index 0000000..d66da28
--- /dev/null
+++ b/NetworkManager-pptp.spec
@@ -0,0 +1,139 @@
+%define ppp_version 2.4.6
+%define majver %(echo %version | cut -d. -f1-2)
+Name: NetworkManager-pptp
+Version: 0.9.8.4
+Release: 2mamba
+Summary: NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol
+Group: Network/Libraries
+Vendor: openmamba
+Distribution: openmamba
+Packager: Silvan Calarco
+URL: http://www.gnome.org
+Source: http://ftp.gnome.org/pub/GNOME/sources/NetworkManager-pptp/%{majver}/NetworkManager-pptp-%{version}.tar.xz
+Patch0: %{name}-0.8.2-dbus_policy.patch
+Patch1: NetworkManager-pptp-0.9.6.0-gtk-3.6.patch
+License: GPL
+## AUTOBUILDREQ-BEGIN
+BuildRequires: GConf-devel
+BuildRequires: glibc-devel
+BuildRequires: libatk-devel
+BuildRequires: libcairo-devel
+BuildRequires: libdbus-devel
+BuildRequires: libdbus-glib-devel
+BuildRequires: libexpat-devel
+BuildRequires: libfontconfig-devel
+BuildRequires: libfreetype-devel
+BuildRequires: libgcrypt-devel
+BuildRequires: libgdk-pixbuf-devel
+BuildRequires: libglade-devel
+BuildRequires: libGL-devel
+BuildRequires: libglib-devel
+BuildRequires: libglitz-devel
+BuildRequires: libgnome-keyring-devel
+BuildRequires: libgpg-error-devel
+BuildRequires: libgtk2-devel
+BuildRequires: libnm-devel
+BuildRequires: libnspr-devel
+BuildRequires: libnss-devel
+BuildRequires: libpango-devel
+BuildRequires: libpixman-devel
+BuildRequires: libpng-devel
+BuildRequires: libpthread-stubs-devel
+BuildRequires: libselinux-devel
+BuildRequires: libstdc++6-devel
+BuildRequires: libuuid-devel
+BuildRequires: libX11-devel
+BuildRequires: libXau-devel
+BuildRequires: libxcb-devel
+BuildRequires: libxcb-util-devel
+BuildRequires: libXdmcp-devel
+BuildRequires: libxml2-devel
+BuildRequires: libXrender-devel
+BuildRequires: libz-devel
+BuildRequires: ORBit2-devel
+BuildRequires: udev-devel
+## AUTOBUILDREQ-END
+BuildRequires: ppp = %{ppp_version}
+Requires: ppp >= %{ppp_version}
+Provides: networkmanagervpnplugin
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+
+%description
+NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%configure \
+ --with-pppd-plugin-dir=%{_libdir}/pppd/%{ppp_version}
+
+%make
+
+%install
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+%makeinstall
+
+%find_lang %{name}
+
+%clean
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+
+%files -f %{name}.lang
+%defattr(-,root,root)
+%{_sysconfdir}/NetworkManager/VPN/nm-pptp-service.name
+%{_sysconfdir}/dbus-1/system.d/nm-pptp-service.conf
+%{_libdir}/pppd/%{ppp_version}/nm-pptp-pppd-plugin.a
+%{_libdir}/pppd/%{ppp_version}/nm-pptp-pppd-plugin.la
+%{_libdir}/pppd/%{ppp_version}/nm-pptp-pppd-plugin.so
+%{_libdir}/NetworkManager/libnm-pptp-properties.a
+%{_libdir}/NetworkManager/libnm-pptp-properties.la
+%{_libdir}/NetworkManager/libnm-pptp-properties.so
+%{_libexecdir}/nm-pptp-auth-dialog
+%{_libexecdir}/nm-pptp-service
+%{_datadir}/gnome-vpn-properties/pptp/nm-pptp-dialog.ui
+%doc AUTHORS COPYING
+#ChangeLog NEWS README TODO
+
+%changelog
+* Sun Feb 23 2014 Silvan Calarco 0.9.8.4-2mamba
+- rebuilt with ppp 2.4.6
+
+* Sun Sep 15 2013 Automatic Build System 0.9.8.4-1mamba
+- automatic update by autodist
+
+* Sat Jun 08 2013 Automatic Build System 0.9.8.2-1mamba
+- automatic version update by autodist
+
+* Thu Feb 21 2013 Automatic Build System 0.9.8.0-1mamba
+- automatic version update by autodist
+
+* Tue Feb 05 2013 Silvan Calarco 0.9.6.0-2mamba
+- added patch to fix build against gtk >= 3.6
+
+* Sat Aug 11 2012 Automatic Build System 0.9.6.0-1mamba
+- automatic version update by autodist
+
+* Thu May 03 2012 Silvan Calarco 0.9.4.0-1mamba
+- update to 0.9.4.0
+
+* Mon Mar 12 2012 Silvan Calarco 0.9.2.0-1mamba
+- update to 0.9.2.0
+
+* Sat Sep 17 2011 Silvan Calarco 0.9.0-1mamba
+- update to 0.9.0
+
+* Tue Jul 26 2011 Automatic Build System 0.8.4-1mamba
+- update to 0.8.4
+
+* Tue Jun 28 2011 Silvan Calarco 0.8.2-3mamba
+- fix dbus policy: patch was not applied
+
+* Fri Jun 17 2011 Silvan Calarco 0.8.2-2mamba
+- added virtual provide networkmanagervpnplugin
+- configure dbus policy for at_console user and sysadmin group
+
+* Wed Jun 15 2011 Silvan Calarco 0.8.2-1mamba
+- package created by autospec
diff --git a/README.md b/README.md
index 5925672..82ce39b 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,4 @@
# NetworkManager-pptp
+NetworkManager plugin for VPN clients using the Point-to-Point Tunneling Protocol.
+