update to 1.8.10
built with libnm-devel 1.22.2 and libnm-gtk 1.8.24-2mamba [release 1.8.10-1mamba;Fri Jan 10 2020]
This commit is contained in:
parent
ea3fbac523
commit
70973bc816
@ -1,8 +1,7 @@
|
|||||||
diff -Nru NetworkManager-openvpn-0.8.2.orig//nm-openvpn-service.conf NetworkManager-openvpn-0.8.2/nm-openvpn-service.conf
|
--- NetworkManager-openvpn-1.8.10/nm-openvpn-service.conf.orig 2020-01-10 15:18:07.556000000 +0100
|
||||||
--- NetworkManager-openvpn-0.8.2.orig//nm-openvpn-service.conf 2010-04-06 08:34:56.000000000 +0200
|
+++ NetworkManager-openvpn-1.8.10/nm-openvpn-service.conf 2020-01-10 15:18:32.733000000 +0100
|
||||||
+++ NetworkManager-openvpn-0.8.2/nm-openvpn-service.conf 2011-06-17 14:40:09.768132076 +0200
|
|
||||||
@@ -6,6 +6,14 @@
|
@@ -6,6 +6,14 @@
|
||||||
<allow own="org.freedesktop.NetworkManager.openvpn"/>
|
<allow own_prefix="org.freedesktop.NetworkManager.openvpn"/>
|
||||||
<allow send_destination="org.freedesktop.NetworkManager.openvpn"/>
|
<allow send_destination="org.freedesktop.NetworkManager.openvpn"/>
|
||||||
</policy>
|
</policy>
|
||||||
+ <policy group="sysadmin">
|
+ <policy group="sysadmin">
|
||||||
@ -14,5 +13,5 @@ diff -Nru NetworkManager-openvpn-0.8.2.orig//nm-openvpn-service.conf NetworkMana
|
|||||||
+ <allow send_destination="org.freedesktop.NetworkManager.openvpn"/>
|
+ <allow send_destination="org.freedesktop.NetworkManager.openvpn"/>
|
||||||
+ </policy>
|
+ </policy>
|
||||||
<policy context="default">
|
<policy context="default">
|
||||||
<deny own="org.freedesktop.NetworkManager.openvpn"/>
|
<deny own_prefix="org.freedesktop.NetworkManager.openvpn"/>
|
||||||
<deny send_destination="org.freedesktop.NetworkManager.openvpn"/>
|
<deny send_destination="org.freedesktop.NetworkManager.openvpn"/>
|
51
NetworkManager-openvpn-1.8.10-libnm-1.22.2.patch
Normal file
51
NetworkManager-openvpn-1.8.10-libnm-1.22.2.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
From 52aad4911ffad04cf8274b5574124a4d5470c7fa Mon Sep 17 00:00:00 2001
|
||||||
|
Message-Id: <52aad4911ffad04cf8274b5574124a4d5470c7fa.1549642989.git.jan.steffens@gmail.com>
|
||||||
|
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||||
|
Date: Wed, 17 Oct 2018 15:21:30 +0200
|
||||||
|
Subject: [PATCH] build: disable libnm-glib support by default
|
||||||
|
|
||||||
|
By now nobody should be using this. Keep the code around for a little
|
||||||
|
longer just in case anybody still uses this.
|
||||||
|
|
||||||
|
The libnm-glib support also serves as an example how do we build two
|
||||||
|
different versions of the properties plugin. We'll soon be in a similar
|
||||||
|
situation with Gtk 4.0. (sigh.) Just don't drop it yet.
|
||||||
|
|
||||||
|
Conflicts:
|
||||||
|
NEWS
|
||||||
|
---
|
||||||
|
configure.ac | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 11ff5d0..eaf015b 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -75,20 +75,20 @@ dnl
|
||||||
|
dnl GNOME support
|
||||||
|
dnl
|
||||||
|
AC_ARG_WITH(gnome, AS_HELP_STRING([--without-gnome], [Build NetworkManager-openvpn without GNOME support, e.g. vpn service only]), [], [with_gnome_specified=no])
|
||||||
|
-AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--without-libnm-glib], [Build NetworkManager-openvpn without libnm-glib comatibility]), [], [with_libnm_glib_specified=no])
|
||||||
|
+AC_ARG_WITH(libnm-glib, AS_HELP_STRING([--with-libnm-glib], [Build NetworkManager-openvpn with libnm-glib comatibility (depreacted)]), [], [with_libnm_glib_specified=no])
|
||||||
|
if test "$with_libnm_glib_specified" != no -a "$with_libnm_glib" != no; then
|
||||||
|
if test "$with_gnome_specified" != no -a "$with_gnome" == no; then
|
||||||
|
AC_MSG_ERROR(Building --with-libnm-glib conflicts with --without-gnome)
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
if test "$with_gnome" != no; then
|
||||||
|
with_gnome=yes
|
||||||
|
fi
|
||||||
|
if test "$with_libnm_glib_specified" == no; then
|
||||||
|
- with_libnm_glib="$with_gnome"
|
||||||
|
+ with_libnm_glib=no
|
||||||
|
fi
|
||||||
|
-if test "$with_libnm_glib" != no; then
|
||||||
|
- with_libnm_glib=yes
|
||||||
|
+if test "$with_libnm_glib" != yes; then
|
||||||
|
+ with_libnm_glib=no
|
||||||
|
fi
|
||||||
|
AM_CONDITIONAL(WITH_GNOME, test "$with_gnome" != no)
|
||||||
|
AM_CONDITIONAL(WITH_LIBNM_GLIB, test "$with_libnm_glib" != no)
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: NetworkManager-openvpn
|
Name: NetworkManager-openvpn
|
||||||
Version: 1.8.4
|
Version: 1.8.10
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: NetworkManager plugin for openvpn VPN clients
|
Summary: NetworkManager plugin for openvpn VPN clients
|
||||||
Group: Network/Libraries
|
Group: Network/Libraries
|
||||||
@ -9,23 +9,19 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.gnome.org
|
URL: http://www.gnome.org
|
||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/NetworkManager-openvpn/%{majver}/NetworkManager-openvpn-%{version}.tar.xz
|
Source: http://ftp.gnome.org/pub/GNOME/sources/NetworkManager-openvpn/%{majver}/NetworkManager-openvpn-%{version}.tar.xz
|
||||||
Patch0: %{name}-0.8.2-dbus_policy.patch
|
Patch0: %{name}-1.8.10-dbus_policy.patch
|
||||||
Patch1: NetworkManager-openvpn-0.9.6.0-gtk-3.6.patch
|
Patch1: NetworkManager-openvpn-0.9.6.0-gtk-3.6.patch
|
||||||
|
Patch2: NetworkManager-openvpn-1.8.10-libnm-1.22.2.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
Requires: openvpn
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: ldconfig
|
||||||
BuildRequires: libatk-devel
|
BuildRequires: libatk-devel
|
||||||
BuildRequires: libblkid-devel
|
BuildRequires: libblkid-devel
|
||||||
BuildRequires: libbzip2-devel
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libdbus-devel
|
|
||||||
BuildRequires: libdbus-glib-devel
|
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
BuildRequires: libfontconfig-devel
|
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libfribidi-devel
|
|
||||||
BuildRequires: libgcr-devel
|
BuildRequires: libgcr-devel
|
||||||
BuildRequires: libgcrypt-devel
|
BuildRequires: libgcrypt-devel
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
@ -38,8 +34,6 @@ BuildRequires: libharfbuzz-devel
|
|||||||
BuildRequires: libmount-devel
|
BuildRequires: libmount-devel
|
||||||
BuildRequires: libnm-devel
|
BuildRequires: libnm-devel
|
||||||
BuildRequires: libnm-gtk-devel
|
BuildRequires: libnm-gtk-devel
|
||||||
BuildRequires: libnspr-devel
|
|
||||||
BuildRequires: libnss-devel
|
|
||||||
BuildRequires: libp11-kit-devel
|
BuildRequires: libp11-kit-devel
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libpcre-devel
|
BuildRequires: libpcre-devel
|
||||||
@ -47,13 +41,12 @@ BuildRequires: libpng-devel
|
|||||||
BuildRequires: libsecret-devel
|
BuildRequires: libsecret-devel
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
BuildRequires: libsepol-devel
|
BuildRequires: libsepol-devel
|
||||||
BuildRequires: libsystemd-devel
|
|
||||||
BuildRequires: libtermcap-devel
|
|
||||||
BuildRequires: libthai-devel
|
|
||||||
BuildRequires: libudev-devel
|
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libnm-devel >= 1.22.2
|
||||||
|
BuildRequires: libnm-gtk-devel >= 1.8.24-2mamba
|
||||||
|
Requires: openvpn
|
||||||
Provides: networkmanagervpnplugin
|
Provides: networkmanagervpnplugin
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
@ -64,6 +57,9 @@ NetworkManager plugin for openvpn VPN clients.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
|
autoreconf -f -i
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -80,12 +76,12 @@ NetworkManager plugin for openvpn VPN clients.
|
|||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_sysconfdir}/NetworkManager/VPN/nm-openvpn-service.name
|
#%{_sysconfdir}/NetworkManager/VPN/nm-openvpn-service.name
|
||||||
%{_sysconfdir}/dbus-1/system.d/nm-openvpn-service.conf
|
%{_sysconfdir}/dbus-1/system.d/nm-openvpn-service.conf
|
||||||
%{_prefix}/lib/NetworkManager/VPN/nm-openvpn-service.name
|
%{_prefix}/lib/NetworkManager/VPN/nm-openvpn-service.name
|
||||||
%{_libdir}/NetworkManager/libnm-openvpn-properties.a
|
#%{_libdir}/NetworkManager/libnm-openvpn-properties.a
|
||||||
%{_libdir}/NetworkManager/libnm-openvpn-properties.la
|
#%{_libdir}/NetworkManager/libnm-openvpn-properties.la
|
||||||
%{_libdir}/NetworkManager/libnm-openvpn-properties.so
|
#%{_libdir}/NetworkManager/libnm-openvpn-properties.so
|
||||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-openvpn-editor.a
|
%{_libdir}/NetworkManager/libnm-vpn-plugin-openvpn-editor.a
|
||||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-openvpn-editor.la
|
%{_libdir}/NetworkManager/libnm-vpn-plugin-openvpn-editor.la
|
||||||
%{_libdir}/NetworkManager/libnm-vpn-plugin-openvpn-editor.so
|
%{_libdir}/NetworkManager/libnm-vpn-plugin-openvpn-editor.so
|
||||||
@ -100,6 +96,10 @@ NetworkManager plugin for openvpn VPN clients.
|
|||||||
#ChangeLog NEWS README
|
#ChangeLog NEWS README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 10 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.10-1mamba
|
||||||
|
- update to 1.8.10
|
||||||
|
- built with libnm-devel 1.22.2 and libnm-gtk 1.8.24-2mamba
|
||||||
|
|
||||||
* Thu Sep 06 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.4-1mamba
|
* Thu Sep 06 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.4-1mamba
|
||||||
- update to 1.8.4
|
- update to 1.8.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user