rebuild with --enable-xa, --enable-omx, --enable-opencl, --enable-opencl-icd [release 10.2.7-2mamba;Thu Sep 18 2014]
This commit is contained in:
parent
b2e32aa3b1
commit
b4f6666038
26
Mesa-10.2.7-llvm-3.5.patch
Normal file
26
Mesa-10.2.7-llvm-3.5.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 564821c917f4a9d5a0de2ee77b90b0cd85e3d3a6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Aaron Watry <awatry@gmail.com>
|
||||||
|
Date: Fri, 20 Jun 2014 19:13:30 -0500
|
||||||
|
Subject: gallivm: Fix build after LLVM commit 211259
|
||||||
|
|
||||||
|
Signed-off-by: Aaron Watry <awatry@gmail.com>
|
||||||
|
Reviewed-by: Tom Stellard <thomas.stellard@amd.com>
|
||||||
|
|
||||||
|
diff --git a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
|
||||||
|
index df26883..413a0c2 100644
|
||||||
|
--- a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
|
||||||
|
+++ b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
|
||||||
|
@@ -51,7 +51,9 @@
|
||||||
|
#include <llvm/MC/MCInstPrinter.h>
|
||||||
|
#include <llvm/MC/MCRegisterInfo.h>
|
||||||
|
|
||||||
|
-#if HAVE_LLVM >= 0x0303
|
||||||
|
+#if HAVE_LLVM >= 0x0305
|
||||||
|
+#define OwningPtr std::unique_ptr
|
||||||
|
+#elif HAVE_LLVM >= 0x0303
|
||||||
|
#include <llvm/ADT/OwningPtr.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--
|
||||||
|
cgit v0.10.2
|
||||||
|
|
98
Mesa.spec
98
Mesa.spec
@ -11,7 +11,7 @@
|
|||||||
Name: Mesa
|
Name: Mesa
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 10.2.7
|
Version: 10.2.7
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A 3-D graphics library with an API which is very similar to that of OpenGL
|
Summary: A 3-D graphics library with an API which is very similar to that of OpenGL
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -24,27 +24,31 @@ Source3: Mesa-7.0.3-libGL.la
|
|||||||
Patch0: %{name}-7.10.2-driproto-2.4.patch
|
Patch0: %{name}-7.10.2-driproto-2.4.patch
|
||||||
Patch1: %{name}-7.10.2-fix_nouveau_dri_includes.patch
|
Patch1: %{name}-7.10.2-fix_nouveau_dri_includes.patch
|
||||||
Patch2: %{name}-8.0.4-llvm-3.1-fixes-1.patch
|
Patch2: %{name}-8.0.4-llvm-3.1-fixes-1.patch
|
||||||
|
Patch3: Mesa-10.2.7-llvm-3.5.patch
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libdrm
|
|
||||||
BuildRequires: libdrm-devel
|
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libstdc++6-devel
|
|
||||||
BuildRequires: libtalloc-devel
|
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libxcb-devel
|
BuildRequires: libXau-devel
|
||||||
BuildRequires: libXdamage-devel
|
BuildRequires: libXdamage-devel
|
||||||
|
BuildRequires: libXdmcp-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libXfixes-devel
|
BuildRequires: libXfixes-devel
|
||||||
BuildRequires: libXi-devel
|
BuildRequires: libXv-devel
|
||||||
BuildRequires: libXmu-devel
|
BuildRequires: libXvMC-devel
|
||||||
BuildRequires: libXt-devel
|
|
||||||
BuildRequires: libXxf86vm-devel
|
BuildRequires: libXxf86vm-devel
|
||||||
BuildRequires: udev-devel
|
BuildRequires: libdrm-devel
|
||||||
|
BuildRequires: libelf-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libllvm-devel
|
||||||
|
BuildRequires: libpciaccess-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libxcb-devel
|
||||||
|
BuildRequires: libxshmfence-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libdrm
|
BuildRequires: libdrm
|
||||||
|
BuildRequires: libllvm-devel >= 3.5.0
|
||||||
BuildRequires: xproto-devel >= 7.1
|
BuildRequires: xproto-devel >= 7.1
|
||||||
BuildRequires: dri2proto-devel
|
BuildRequires: dri2proto-devel
|
||||||
BuildRequires: glproto-devel
|
BuildRequires: glproto-devel
|
||||||
@ -56,6 +60,10 @@ BuildRequires: libvdpau-devel
|
|||||||
BuildRequires: dri3proto-devel
|
BuildRequires: dri3proto-devel
|
||||||
BuildRequires: libxshmfence-devel
|
BuildRequires: libxshmfence-devel
|
||||||
BuildRequires: presentproto-devel
|
BuildRequires: presentproto-devel
|
||||||
|
BuildRequires: libomxil-bellagio-devel
|
||||||
|
%ifnarch arm
|
||||||
|
BuildRequires: libclc-devel
|
||||||
|
%endif
|
||||||
Provides: libgl
|
Provides: libgl
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
@ -235,7 +243,22 @@ Requires: libOpenVG == %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
|
|
||||||
%description -n libOpenVG-devel
|
%description -n libOpenVG-devel
|
||||||
Mesa implementation of the OpenVG graphics library.
|
Mesa implementation of the OpenVG graphics library.
|
||||||
|
This package contains the headers and other files needed for development.
|
||||||
|
|
||||||
|
%package -n libxatracker
|
||||||
|
Summary: Mesa XA tracker library
|
||||||
|
Group: System/Libraries
|
||||||
|
|
||||||
|
%description -n libxatracker
|
||||||
|
Mesa XA tracker library.
|
||||||
|
|
||||||
|
%package -n libxatracker-devel
|
||||||
|
Summary: Development files for libxatracker
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: libxatracker == %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n libxatracker-devel
|
||||||
|
Mesa XA tracker library.
|
||||||
This package contains the headers and other files needed for development.
|
This package contains the headers and other files needed for development.
|
||||||
|
|
||||||
%package -n libgbm
|
%package -n libgbm
|
||||||
@ -271,6 +294,13 @@ Provides: xvmcplugins
|
|||||||
%description -n libXvMC-Mesa
|
%description -n libXvMC-Mesa
|
||||||
Mesa plugins for libXvMC.
|
Mesa plugins for libXvMC.
|
||||||
|
|
||||||
|
%package -n libMesaOpenCL
|
||||||
|
Summary: Mesa OpenCL library
|
||||||
|
Group: System/Libraries
|
||||||
|
|
||||||
|
%description -n libMesaOpenCL
|
||||||
|
Mesa OpenCL library.
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
@ -282,6 +312,7 @@ Mesa plugins for libXvMC.
|
|||||||
sed -i 's|default_driver="xlib"|default_driver="dri"|' configure
|
sed -i 's|default_driver="xlib"|default_driver="dri"|' configure
|
||||||
%endif
|
%endif
|
||||||
#%patch2 -p1
|
#%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< ___EOF
|
#:<< ___EOF
|
||||||
@ -289,6 +320,8 @@ sed -i 's|default_driver="xlib"|default_driver="dri"|' configure
|
|||||||
--with-dri-drivers=swrast \
|
--with-dri-drivers=swrast \
|
||||||
--with-gallium-drivers=swrast
|
--with-gallium-drivers=swrast
|
||||||
|
|
||||||
|
export CXXFLAGS="%{optflags} -std=c++11"
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
--enable-osmesa \
|
--enable-osmesa \
|
||||||
--with-osmesa-bits=8 \
|
--with-osmesa-bits=8 \
|
||||||
@ -303,7 +336,9 @@ sed -i 's|default_driver="xlib"|default_driver="dri"|' configure
|
|||||||
--enable-glx-tls \
|
--enable-glx-tls \
|
||||||
--enable-vdpau \
|
--enable-vdpau \
|
||||||
--enable-xvmc \
|
--enable-xvmc \
|
||||||
%ifnarch %{ix86} x86_64
|
--enable-omx \
|
||||||
|
--with-clang-libdir=%{_prefix}/lib \
|
||||||
|
%ifarch arm
|
||||||
--with-dri-drivers=swrast \
|
--with-dri-drivers=swrast \
|
||||||
--with-gallium-drivers=swrast \
|
--with-gallium-drivers=swrast \
|
||||||
--enable-openvg \
|
--enable-openvg \
|
||||||
@ -313,8 +348,10 @@ sed -i 's|default_driver="xlib"|default_driver="dri"|' configure
|
|||||||
--enable-openvg \
|
--enable-openvg \
|
||||||
--enable-gallium-egl \
|
--enable-gallium-egl \
|
||||||
--enable-gallium-llvm \
|
--enable-gallium-llvm \
|
||||||
--enable-gallium-g3dvl \
|
|
||||||
--with-gallium-drivers=nouveau,r300,r600,swrast \
|
--with-gallium-drivers=nouveau,r300,r600,swrast \
|
||||||
|
--enable-xa \
|
||||||
|
--enable-opencl \
|
||||||
|
--enable-opencl-icd \
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# --with-driver=dri \
|
# --with-driver=dri \
|
||||||
@ -407,6 +444,12 @@ sed -i "s|%{_prefix}/lib/libGL.la||" %{_libdir}/*.la
|
|||||||
%endif
|
%endif
|
||||||
:
|
:
|
||||||
|
|
||||||
|
%post -n libxatracker -p /sbin/ldconfig
|
||||||
|
%postun -n libxatracker -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%post -n libMesaOpenCL -p /sbin/ldconfig
|
||||||
|
%postun -n libMesaOpenCL -p /sbin/ldconfig
|
||||||
|
|
||||||
%files -n libgbm
|
%files -n libgbm
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libgbm.so.*
|
%{_libdir}/libgbm.so.*
|
||||||
@ -453,6 +496,12 @@ sed -i "s|%{_prefix}/lib/libGL.la||" %{_libdir}/*.la
|
|||||||
%{_sysconfdir}/drirc
|
%{_sysconfdir}/drirc
|
||||||
%{_libdir}/libGL.so.1.2.0
|
%{_libdir}/libGL.so.1.2.0
|
||||||
%{_libdir}/libGL_so.*
|
%{_libdir}/libGL_so.*
|
||||||
|
%ifnarch arm
|
||||||
|
%{_libdir}/bellagio/libomx_nouveau.la
|
||||||
|
%{_libdir}/bellagio/libomx_nouveau.so
|
||||||
|
%{_libdir}/bellagio/libomx_r600.la
|
||||||
|
%{_libdir}/bellagio/libomx_r600.so
|
||||||
|
%endif
|
||||||
#%{_libdir}/libdricore%{version}*.so.*
|
#%{_libdir}/libdricore%{version}*.so.*
|
||||||
%dir %{_libdir}/dri
|
%dir %{_libdir}/dri
|
||||||
%{_libdir}/dri/*.so
|
%{_libdir}/dri/*.so
|
||||||
@ -567,7 +616,28 @@ sed -i "s|%{_prefix}/lib/libGL.la||" %{_libdir}/*.la
|
|||||||
%{_libdir}/libOpenVG.so
|
%{_libdir}/libOpenVG.so
|
||||||
%{_libdir}/pkgconfig/vg.pc
|
%{_libdir}/pkgconfig/vg.pc
|
||||||
|
|
||||||
|
%ifnarch arm
|
||||||
|
%files -n libxatracker
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libxatracker.so.*
|
||||||
|
|
||||||
|
%files -n libxatracker-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_includedir}/xa_*.h
|
||||||
|
%{_libdir}/libxatracker.so
|
||||||
|
%{_libdir}/pkgconfig/xatracker.pc
|
||||||
|
|
||||||
|
%files -n libMesaOpenCL
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sysconfdir}/OpenCL/vendors/mesa.icd
|
||||||
|
%{_libdir}/libMesaOpenCL.so
|
||||||
|
%{_libdir}/libMesaOpenCL.so.*
|
||||||
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 10.2.7-2mamba
|
||||||
|
- rebuild with --enable-xa, --enable-omx, --enable-opencl, --enable-opencl-icd
|
||||||
|
|
||||||
* Sat Sep 06 2014 Automatic Build System <autodist@mambasoft.it> 10.2.7-1mamba
|
* Sat Sep 06 2014 Automatic Build System <autodist@mambasoft.it> 10.2.7-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user