automatic version update by autodist [release 21.2.5-1mamba;Sun Nov 07 2021]
This commit is contained in:
parent
ff21395dd3
commit
3112854895
66
Mesa-21.2.5-aarch64-rip-out-VC4-forced-NEON.patch
Normal file
66
Mesa-21.2.5-aarch64-rip-out-VC4-forced-NEON.patch
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
From 23cbe6d5c1076551540159ce617ad0680b02a029 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Mon, 4 Feb 2019 17:54:45 -0700
|
||||||
|
Subject: [PATCH] Rip out VC4 forced NEON
|
||||||
|
|
||||||
|
Breaks with distro-supplied CFLAGS.
|
||||||
|
---
|
||||||
|
meson.build | 1 -
|
||||||
|
src/broadcom/meson.build | 5 +----
|
||||||
|
src/gallium/drivers/vc4/meson.build | 11 -----------
|
||||||
|
3 files changed, 1 insertion(+), 16 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 155db287796..ff703e8e631 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -1282,7 +1282,6 @@ elif host_machine.cpu_family() == 'x86_64'
|
||||||
|
elif host_machine.cpu_family() == 'arm'
|
||||||
|
if system_has_kms_drm
|
||||||
|
with_asm_arch = 'arm'
|
||||||
|
- pre_args += ['-DUSE_ARM_ASM']
|
||||||
|
endif
|
||||||
|
elif host_machine.cpu_family() == 'aarch64'
|
||||||
|
if system_has_kms_drm
|
||||||
|
diff --git a/src/broadcom/meson.build b/src/broadcom/meson.build
|
||||||
|
index 2e1145dd0c0..c6266af9654 100644
|
||||||
|
--- a/src/broadcom/meson.build
|
||||||
|
+++ b/src/broadcom/meson.build
|
||||||
|
@@ -50,12 +50,9 @@ foreach ver : v3d_versions
|
||||||
|
)
|
||||||
|
endforeach
|
||||||
|
|
||||||
|
-v3d_args = ['-DV3D_BUILD_NEON']
|
||||||
|
+v3d_args = []
|
||||||
|
|
||||||
|
v3d_neon_c_args = []
|
||||||
|
-if host_machine.cpu_family() == 'arm'
|
||||||
|
- v3d_neon_c_args = '-mfpu=neon'
|
||||||
|
-endif
|
||||||
|
|
||||||
|
libv3d_neon = static_library(
|
||||||
|
'v3d_neon',
|
||||||
|
diff --git a/src/gallium/drivers/vc4/meson.build b/src/gallium/drivers/vc4/meson.build
|
||||||
|
index 90a772d5dc6..3074933584c 100644
|
||||||
|
--- a/src/gallium/drivers/vc4/meson.build
|
||||||
|
+++ b/src/gallium/drivers/vc4/meson.build
|
||||||
|
@@ -84,17 +84,6 @@ files_libvc4 = files(
|
||||||
|
vc4_c_args = []
|
||||||
|
|
||||||
|
libvc4_neon = []
|
||||||
|
-if host_machine.cpu_family() == 'arm'
|
||||||
|
- libvc4_neon = static_library(
|
||||||
|
- 'vc4_neon',
|
||||||
|
- 'vc4_tiling_lt_neon.c',
|
||||||
|
- include_directories : [
|
||||||
|
- inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_broadcom
|
||||||
|
- ],
|
||||||
|
- c_args : '-mfpu=neon',
|
||||||
|
- )
|
||||||
|
- vc4_c_args += '-DUSE_ARM_ASM'
|
||||||
|
-endif
|
||||||
|
|
||||||
|
if dep_simpenrose.found()
|
||||||
|
vc4_c_args += '-DUSE_VC4_SIMULATOR'
|
||||||
|
--
|
||||||
|
2.30.0
|
91
Mesa-21.2.5-llvm-13-patch1.patch
Normal file
91
Mesa-21.2.5-llvm-13-patch1.patch
Normal file
@ -0,0 +1,91 @@
|
|||||||
|
From a20dc1dd150a6c31153197ceda01827daab4203e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Vinson Lee <vlee@freedesktop.org>
|
||||||
|
Date: Wed, 23 Jun 2021 21:58:08 -0700
|
||||||
|
Subject: [PATCH] swr: Fix build with llvm-13.
|
||||||
|
|
||||||
|
Fix build after llvm-13 commit 3302af9d4c39 ("Support: Remove
|
||||||
|
F_{None,Text,Append} compatibility synonyms, NFC").
|
||||||
|
|
||||||
|
Signed-off-by: Vinson Lee <vlee@freedesktop.org>
|
||||||
|
---
|
||||||
|
.../swr/rasterizer/jitter/JitManager.cpp | 24 +++++++++++++++++++
|
||||||
|
1 file changed, 24 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/gallium/drivers/swr/rasterizer/jitter/JitManager.cpp b/src/gallium/drivers/swr/rasterizer/jitter/JitManager.cpp
|
||||||
|
index 44482939c76..2487f754dc1 100644
|
||||||
|
--- a/src/gallium/drivers/swr/rasterizer/jitter/JitManager.cpp
|
||||||
|
+++ b/src/gallium/drivers/swr/rasterizer/jitter/JitManager.cpp
|
||||||
|
@@ -437,7 +437,11 @@ void JitManager::DumpAsm(Function* pFunction, const char* fileName)
|
||||||
|
sprintf(fName, "%s.%s.asm", funcName, fileName);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ raw_fd_ostream filestream(fName, EC, llvm::sys::fs::OF_None);
|
||||||
|
+#else
|
||||||
|
raw_fd_ostream filestream(fName, EC, llvm::sys::fs::F_None);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
legacy::PassManager* pMPasses = new legacy::PassManager();
|
||||||
|
auto* pTarget = mpExec->getTargetMachine();
|
||||||
|
@@ -490,7 +494,11 @@ void JitManager::DumpToFile(Module* M,
|
||||||
|
#else
|
||||||
|
sprintf(fName, "%s.%s.ll", funcName, fileName);
|
||||||
|
#endif
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ raw_fd_ostream fd(fName, EC, llvm::sys::fs::OF_None);
|
||||||
|
+#else
|
||||||
|
raw_fd_ostream fd(fName, EC, llvm::sys::fs::F_None);
|
||||||
|
+#endif
|
||||||
|
M->print(fd, annotater);
|
||||||
|
fd.flush();
|
||||||
|
}
|
||||||
|
@@ -512,7 +520,11 @@ void JitManager::DumpToFile(Function* f, const char* fileName)
|
||||||
|
#else
|
||||||
|
sprintf(fName, "%s.%s.ll", funcName, fileName);
|
||||||
|
#endif
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ raw_fd_ostream fd(fName, EC, llvm::sys::fs::OF_None);
|
||||||
|
+#else
|
||||||
|
raw_fd_ostream fd(fName, EC, llvm::sys::fs::F_None);
|
||||||
|
+#endif
|
||||||
|
f->print(fd, nullptr);
|
||||||
|
|
||||||
|
#if defined(_WIN32)
|
||||||
|
@@ -522,7 +534,11 @@ void JitManager::DumpToFile(Function* f, const char* fileName)
|
||||||
|
#endif
|
||||||
|
fd.flush();
|
||||||
|
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ raw_fd_ostream fd_cfg(fName, EC, llvm::sys::fs::OF_Text);
|
||||||
|
+#else
|
||||||
|
raw_fd_ostream fd_cfg(fName, EC, llvm::sys::fs::F_Text);
|
||||||
|
+#endif
|
||||||
|
WriteGraph(fd_cfg, (const Function*)f);
|
||||||
|
|
||||||
|
fd_cfg.flush();
|
||||||
|
@@ -726,7 +742,11 @@ void JitCache::notifyObjectCompiled(const llvm::Module* M, llvm::MemoryBufferRef
|
||||||
|
|
||||||
|
{
|
||||||
|
std::error_code err;
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ llvm::raw_fd_ostream fileObj(objPath.c_str(), err, llvm::sys::fs::OF_None);
|
||||||
|
+#else
|
||||||
|
llvm::raw_fd_ostream fileObj(objPath.c_str(), err, llvm::sys::fs::F_None);
|
||||||
|
+#endif
|
||||||
|
fileObj << Obj.getBuffer();
|
||||||
|
fileObj.flush();
|
||||||
|
}
|
||||||
|
@@ -734,7 +754,11 @@ void JitCache::notifyObjectCompiled(const llvm::Module* M, llvm::MemoryBufferRef
|
||||||
|
|
||||||
|
{
|
||||||
|
std::error_code err;
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ llvm::raw_fd_ostream fileObj(filePath.c_str(), err, llvm::sys::fs::OF_None);
|
||||||
|
+#else
|
||||||
|
llvm::raw_fd_ostream fileObj(filePath.c_str(), err, llvm::sys::fs::F_None);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
uint32_t objcrc = ComputeCRC(0, Obj.getBufferStart(), Obj.getBufferSize());
|
||||||
|
|
||||||
|
--
|
||||||
|
GitLab
|
127
Mesa-21.2.5-llvm-13-patch2.patch
Normal file
127
Mesa-21.2.5-llvm-13-patch2.patch
Normal file
@ -0,0 +1,127 @@
|
|||||||
|
From 98859f67c3d54c9c6d8bbf55251717cbe3511f4e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Grigory Vasilyev <h0tc0d3@gmail.com>
|
||||||
|
Date: Fri, 8 Oct 2021 15:26:49 +0300
|
||||||
|
Subject: [PATCH] Fix swr build with LLVM 13
|
||||||
|
|
||||||
|
---
|
||||||
|
.../swr/rasterizer/jitter/builder_mem.cpp | 12 +++++++++++
|
||||||
|
.../swr/rasterizer/jitter/builder_mem.h | 4 ++++
|
||||||
|
src/gallium/drivers/swr/swr_shader.cpp | 20 ++++++++++++++-----
|
||||||
|
3 files changed, 31 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.cpp b/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.cpp
|
||||||
|
index b5eb0a782b1..ff0672cfd14 100644
|
||||||
|
--- a/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.cpp
|
||||||
|
+++ b/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.cpp
|
||||||
|
@@ -82,7 +82,11 @@ namespace SwrJit
|
||||||
|
std::vector<Value*> indices;
|
||||||
|
for (auto i : indexList)
|
||||||
|
indices.push_back(i);
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ return IN_BOUNDS_GEP(ptr->getType(), ptr, indices);
|
||||||
|
+#else
|
||||||
|
return IN_BOUNDS_GEP(ptr, indices);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
Value* Builder::IN_BOUNDS_GEP(Value* ptr, const std::initializer_list<uint32_t>& indexList)
|
||||||
|
@@ -90,7 +94,11 @@ namespace SwrJit
|
||||||
|
std::vector<Value*> indices;
|
||||||
|
for (auto i : indexList)
|
||||||
|
indices.push_back(C(i));
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ return IN_BOUNDS_GEP(ptr->getType(), ptr, indices);
|
||||||
|
+#else
|
||||||
|
return IN_BOUNDS_GEP(ptr, indices);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
LoadInst* Builder::LOAD(Value* Ptr, const char* Name, Type* Ty, MEM_CLIENT usage)
|
||||||
|
@@ -234,7 +242,11 @@ namespace SwrJit
|
||||||
|
/// @param pVecPassthru - SIMD wide vector of values to load when lane is inactive
|
||||||
|
Value* Builder::GATHER_PTR(Value* pVecSrcPtr, Value* pVecMask, Value* pVecPassthru)
|
||||||
|
{
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ return MASKED_GATHER(pVecSrcPtr->getType(), pVecSrcPtr, AlignType(4), pVecMask, pVecPassthru);
|
||||||
|
+#else
|
||||||
|
return MASKED_GATHER(pVecSrcPtr, AlignType(4), pVecMask, pVecPassthru);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
void Builder::SCATTER_PTR(Value* pVecDstPtr, Value* pVecSrc, Value* pVecMask)
|
||||||
|
diff --git a/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.h b/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.h
|
||||||
|
index 429d5779a4d..c6cfb812b81 100644
|
||||||
|
--- a/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.h
|
||||||
|
+++ b/src/gallium/drivers/swr/rasterizer/jitter/builder_mem.h
|
||||||
|
@@ -84,7 +84,11 @@ virtual CallInst* MASKED_LOAD(Value* Ptr,
|
||||||
|
Type* Ty = nullptr,
|
||||||
|
MEM_CLIENT usage = MEM_CLIENT::MEM_CLIENT_INTERNAL)
|
||||||
|
{
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ return IRB()->CreateMaskedLoad(Ptr->getType(), Ptr, AlignType(Align), Mask, PassThru, Name);
|
||||||
|
+#else
|
||||||
|
return IRB()->CreateMaskedLoad(Ptr, AlignType(Align), Mask, PassThru, Name);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
virtual StoreInst* STORE(Value *Val, Value *Ptr, bool isVolatile = false, Type* Ty = nullptr, MEM_CLIENT usage = MEM_CLIENT::MEM_CLIENT_INTERNAL)
|
||||||
|
diff --git a/src/gallium/drivers/swr/swr_shader.cpp b/src/gallium/drivers/swr/swr_shader.cpp
|
||||||
|
index 315036920fb..26e967759cd 100644
|
||||||
|
--- a/src/gallium/drivers/swr/swr_shader.cpp
|
||||||
|
+++ b/src/gallium/drivers/swr/swr_shader.cpp
|
||||||
|
@@ -1553,7 +1553,9 @@ BuilderSWR::CompileGS(struct swr_context *ctx, swr_jit_gs_key &key)
|
||||||
|
GlobalValue::ExternalLinkage,
|
||||||
|
"GS",
|
||||||
|
JM()->mpCurrentModule);
|
||||||
|
-#if LLVM_VERSION_MAJOR < 5
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ pFunction->addParamAttrs(AttributeList::FunctionIndex, attrBuilder);
|
||||||
|
+#elif LLVM_VERSION_MAJOR < 5
|
||||||
|
AttributeSet attrSet = AttributeSet::get(
|
||||||
|
JM()->mContext, AttributeSet::FunctionIndex, attrBuilder);
|
||||||
|
pFunction->addAttributes(AttributeSet::FunctionIndex, attrSet);
|
||||||
|
@@ -1781,7 +1783,9 @@ BuilderSWR::CompileTES(struct swr_context *ctx, swr_jit_tes_key &key)
|
||||||
|
"TES",
|
||||||
|
JM()->mpCurrentModule);
|
||||||
|
|
||||||
|
-#if LLVM_VERSION_MAJOR < 5
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ pFunction->addParamAttrs(AttributeList::FunctionIndex, attrBuilder);
|
||||||
|
+#elif LLVM_VERSION_MAJOR < 5
|
||||||
|
AttributeSet attrSet = AttributeSet::get(
|
||||||
|
JM()->mContext, AttributeSet::FunctionIndex, attrBuilder);
|
||||||
|
pFunction->addAttributes(AttributeSet::FunctionIndex, attrSet);
|
||||||
|
@@ -2082,7 +2086,9 @@ BuilderSWR::CompileTCS(struct swr_context *ctx, swr_jit_tcs_key &key)
|
||||||
|
"TCS",
|
||||||
|
JM()->mpCurrentModule);
|
||||||
|
|
||||||
|
-#if LLVM_VERSION_MAJOR < 5
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ pFunction->addParamAttrs(AttributeList::FunctionIndex, attrBuilder);
|
||||||
|
+#elif LLVM_VERSION_MAJOR < 5
|
||||||
|
AttributeSet attrSet = AttributeSet::get(
|
||||||
|
JM()->mContext, AttributeSet::FunctionIndex, attrBuilder);
|
||||||
|
pFunction->addAttributes(AttributeSet::FunctionIndex, attrSet);
|
||||||
|
@@ -2337,7 +2343,9 @@ BuilderSWR::CompileVS(struct swr_context *ctx, swr_jit_vs_key &key)
|
||||||
|
GlobalValue::ExternalLinkage,
|
||||||
|
"VS",
|
||||||
|
JM()->mpCurrentModule);
|
||||||
|
-#if LLVM_VERSION_MAJOR < 5
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ pFunction->addParamAttrs(AttributeList::FunctionIndex, attrBuilder);
|
||||||
|
+#elif LLVM_VERSION_MAJOR < 5
|
||||||
|
AttributeSet attrSet = AttributeSet::get(
|
||||||
|
JM()->mContext, AttributeSet::FunctionIndex, attrBuilder);
|
||||||
|
pFunction->addAttributes(AttributeSet::FunctionIndex, attrSet);
|
||||||
|
@@ -2642,7 +2650,9 @@ BuilderSWR::CompileFS(struct swr_context *ctx, swr_jit_fs_key &key)
|
||||||
|
GlobalValue::ExternalLinkage,
|
||||||
|
"FS",
|
||||||
|
JM()->mpCurrentModule);
|
||||||
|
-#if LLVM_VERSION_MAJOR < 5
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 13
|
||||||
|
+ pFunction->addParamAttrs(AttributeList::FunctionIndex, attrBuilder);
|
||||||
|
+#elif LLVM_VERSION_MAJOR < 5
|
||||||
|
AttributeSet attrSet = AttributeSet::get(
|
||||||
|
JM()->mContext, AttributeSet::FunctionIndex, attrBuilder);
|
||||||
|
pFunction->addAttributes(AttributeSet::FunctionIndex, attrSet);
|
||||||
|
--
|
25
Mesa.spec
25
Mesa.spec
@ -1,6 +1,6 @@
|
|||||||
Name: Mesa
|
Name: Mesa
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 21.2.4
|
Version: 21.2.5
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A 3-D graphics library with an API which is very similar to that of OpenGL
|
Summary: A 3-D graphics library with an API which is very similar to that of OpenGL
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -13,6 +13,9 @@ Patch0: Mesa-7.10.2-driproto-2.4.patch
|
|||||||
Patch1: Mesa-7.10.2-fix_nouveau_dri_includes.patch
|
Patch1: Mesa-7.10.2-fix_nouveau_dri_includes.patch
|
||||||
Patch2: Mesa-8.0.4-llvm-3.1-fixes-1.patch
|
Patch2: Mesa-8.0.4-llvm-3.1-fixes-1.patch
|
||||||
Patch3: Mesa-10.2.7-llvm-3.5.patch
|
Patch3: Mesa-10.2.7-llvm-3.5.patch
|
||||||
|
Patch4: Mesa-21.2.5-llvm-13-patch1.patch
|
||||||
|
Patch5: Mesa-21.2.5-llvm-13-patch2.patch
|
||||||
|
Patch6: Mesa-21.2.5-aarch64-rip-out-VC4-forced-NEON.patch
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -39,8 +42,8 @@ BuildRequires: libxshmfence-devel
|
|||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libllvm-devel >= 11.1.0
|
BuildRequires: libllvm-devel >= 13.0.0
|
||||||
BuildRequires: libclang-devel >= 11.1.0
|
BuildRequires: libclang-devel >= 13.0.0
|
||||||
BuildRequires: xproto-devel >= 7.1
|
BuildRequires: xproto-devel >= 7.1
|
||||||
BuildRequires: dri2proto-devel
|
BuildRequires: dri2proto-devel
|
||||||
BuildRequires: glproto-devel
|
BuildRequires: glproto-devel
|
||||||
@ -125,6 +128,12 @@ Common files and tools for the Mesa GL libraries.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n mesa-%{version}
|
%setup -q -n mesa-%{version}
|
||||||
#-D -T
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
%ifarch aarch64
|
||||||
|
#%patch6 -p1
|
||||||
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
@ -134,6 +143,7 @@ export CXX=clang++
|
|||||||
#%endif
|
#%endif
|
||||||
export PYTHON=%{__python3}
|
export PYTHON=%{__python3}
|
||||||
|
|
||||||
|
# FIXME: 21.2.5: disabling freedreno gallium driver due to llvm 13 build error
|
||||||
%meson \
|
%meson \
|
||||||
-Db_lto=false \
|
-Db_lto=false \
|
||||||
-Db_ndebug=true \
|
-Db_ndebug=true \
|
||||||
@ -144,15 +154,13 @@ export PYTHON=%{__python3}
|
|||||||
-Dgallium-drivers=r300,r600,radeonsi,freedreno,swrast,virgl,zink,etnaviv,kmsro,lima,panfrost,v3d,vc4 \
|
-Dgallium-drivers=r300,r600,radeonsi,freedreno,swrast,virgl,zink,etnaviv,kmsro,lima,panfrost,v3d,vc4 \
|
||||||
-Dlibunwind=disabled \
|
-Dlibunwind=disabled \
|
||||||
-Dvalgrind=disabled \
|
-Dvalgrind=disabled \
|
||||||
-Dasm=false \
|
|
||||||
%endif
|
%endif
|
||||||
%ifarch aarch64
|
%ifarch aarch64
|
||||||
-Dvulkan-drivers=amd,swrast,broadcom \
|
-Dvulkan-drivers=amd,swrast,broadcom \
|
||||||
-Ddri-drivers=r100,r200,nouveau \
|
-Ddri-drivers=r100,r200,nouveau \
|
||||||
-Dgallium-drivers=r300,r600,radeonsi,freedreno,nouveau,swrast,virgl,zink,etnaviv,kmsro,lima,panfrost,v3d,vc4 \
|
-Dgallium-drivers=r300,r600,radeonsi,nouveau,swrast,virgl,zink,etnaviv,kmsro,lima,panfrost,v3d,vc4 \
|
||||||
-Dlibunwind=disabled \
|
-Dlibunwind=disabled \
|
||||||
-Dvalgrind=disabled \
|
-Dvalgrind=disabled \
|
||||||
-Dasm=false \
|
|
||||||
%endif
|
%endif
|
||||||
%ifarch x86_64 %{ix86}
|
%ifarch x86_64 %{ix86}
|
||||||
-Dvulkan-drivers=amd,intel,swrast \
|
-Dvulkan-drivers=amd,intel,swrast \
|
||||||
@ -161,8 +169,6 @@ export PYTHON=%{__python3}
|
|||||||
-Dlibunwind=enabled \
|
-Dlibunwind=enabled \
|
||||||
-Dvalgrind=enabled \
|
-Dvalgrind=enabled \
|
||||||
%endif
|
%endif
|
||||||
-Dvulkan-overlay-layer=true \
|
|
||||||
-Dvulkan-device-select-layer=true \
|
|
||||||
-Ddri3=enabled \
|
-Ddri3=enabled \
|
||||||
-Degl=enabled \
|
-Degl=enabled \
|
||||||
-Dgallium-extra-hud=true \
|
-Dgallium-extra-hud=true \
|
||||||
@ -283,6 +289,9 @@ ln -s libGLX_mesa.so.0 %{buildroot}%{_libdir}/libGLX_indirect.so.0
|
|||||||
%{_libdir}/pkgconfig/xatracker.pc
|
%{_libdir}/pkgconfig/xatracker.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Nov 07 2021 Automatic Build System <autodist@mambasoft.it> 21.2.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Oct 15 2021 Automatic Build System <autodist@mambasoft.it> 21.2.4-1mamba
|
* Fri Oct 15 2021 Automatic Build System <autodist@mambasoft.it> 21.2.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user