automatic version update by autodist [release 10.1.2-1mamba;Wed May 07 2014]

This commit is contained in:
Automatic Build System 2024-01-05 17:47:37 +01:00
parent a2953ee37a
commit 0169e4a1d9
6 changed files with 1040 additions and 0 deletions

25
Mesa-7.0.3-libGL.la Normal file
View File

@ -0,0 +1,25 @@
# libGL.la - a libtool library file
# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
#
# Please DO NOT delete this file!
# It is necessary for linking the library.
# The name that we can dlopen(3).
dlname='libGL.so.1'
# Names of this library.
library_names='libGL.so.1 libGL.so'
# The name of the static archive.
#old_library='libGL.a'
# Is this an already installed library?
installed=yes
# Files to dlopen/dlpreopen
dlopen=''
dlpreopen=''
# Directory that this library needs to be installed in:
libdir='/usr/lib'

View File

@ -0,0 +1,12 @@
diff -Nru Mesa-7.10.2.orig//src/glx/dri2.c Mesa-7.10.2/src/glx/dri2.c
--- Mesa-7.10.2.orig//src/glx/dri2.c 2010-12-14 22:43:14.000000000 +0100
+++ Mesa-7.10.2/src/glx/dri2.c 2011-05-10 19:11:44.632223458 +0200
@@ -124,7 +124,7 @@
}
aevent->ust = ((CARD64)awire->ust_hi << 32) | awire->ust_lo;
aevent->msc = ((CARD64)awire->msc_hi << 32) | awire->msc_lo;
- aevent->sbc = ((CARD64)awire->sbc_hi << 32) | awire->sbc_lo;
+ aevent->sbc = awire->sbc;
return True;
}
#endif

View File

@ -0,0 +1,139 @@
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c.ark 2011-04-11 10:26:00.717291484 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c 2011-04-11 10:26:05.600624698 +0200
@@ -24,6 +24,8 @@
#include "pipe/p_defines.h"
#include "pipe/p_state.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
void
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c.ark 2011-04-11 10:25:55.913958268 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c 2011-04-11 10:26:00.663958154 +0200
@@ -23,6 +23,8 @@
#include "draw/draw_context.h"
#include "pipe/p_defines.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
#include "nv50_screen.h"
#include "nv50_resource.h"
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c.ark 2011-04-11 10:25:50.250625073 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c 2011-04-11 10:25:55.873958269 +0200
@@ -4,6 +4,8 @@
#include "util/u_format.h"
#include "util/u_split_prim.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
#include "nv50_resource.h"
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c.ark 2011-04-11 10:25:44.790625206 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c 2011-04-11 10:25:50.183958407 +0200
@@ -23,6 +23,8 @@
#include "pipe/p_context.h"
#include "util/u_inlines.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
struct nv50_query {
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c.ark 2011-04-11 10:25:32.790625497 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c 2011-04-11 10:25:38.633958688 +0200
@@ -23,6 +23,8 @@
#include "util/u_format_s3tc.h"
#include "pipe/p_screen.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
#include "nv50_screen.h"
#include "nv50_resource.h"
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c.ark 2011-04-11 10:25:38.710625354 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c 2011-04-11 10:25:44.713958540 +0200
@@ -26,6 +26,8 @@
#include "pipe/p_state.h"
#include "util/u_inlines.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
static void
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c.ark 2011-04-11 10:25:27.520625626 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c 2011-04-11 10:25:32.737292166 +0200
@@ -22,6 +22,7 @@
#include "util/u_format.h"
+#include <nouveau/nv04_pushbuf.h>
#include "nv50_context.h"
#include "nv50_resource.h"
#include "nouveau/nouveau_stateobj.h"
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c.ark 2011-04-11 10:25:22.407292417 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c 2011-04-11 10:25:27.450625628 +0200
@@ -22,6 +22,7 @@
#define __NOUVEAU_PUSH_H__
#include <stdint.h>
+#include <nouveau/nv04_pushbuf.h>
#include "nouveau/nouveau_pushbuf.h"
#include "nv50_context.h"
#include "nv50_resource.h"
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c.ark 2011-04-11 10:25:14.903959267 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c 2011-04-11 10:25:22.353959086 +0200
@@ -4,6 +4,8 @@
#include "util/u_format.h"
#include "util/u_math.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
#include "nv50_transfer.h"
#include "nv50_resource.h"
--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c.ark 2011-04-11 10:25:01.717292921 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c 2011-04-11 10:25:14.850625935 +0200
@@ -26,6 +26,8 @@
#include "util/u_format.h"
#include "util/u_split_prim.h"
+#include <nouveau/nv04_pushbuf.h>
+
#include "nv50_context.h"
#include "nv50_resource.h"
--- Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c.ark 2011-04-11 10:23:22.800628664 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c 2011-04-11 10:25:01.640626257 +0200
@@ -39,6 +39,7 @@
#include <nouveau/nouveau_bo.h>
#include <nouveau/nouveau_notifier.h>
#include <nouveau/nouveau_grobj.h>
+#include <nouveau/nv04_pushbuf.h>
#include "nv04_2d.h"
#include "nouveau/nv_object.xml.h"
--- Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c.ark 2011-04-11 10:27:59.380621927 +0200
+++ Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c 2011-04-11 10:28:02.833955176 +0200
@@ -3,6 +3,7 @@
#include "util/u_format_s3tc.h"
#include "util/u_simple_screen.h"
+#include <nouveau/nv04_pushbuf.h>
#include "nouveau/nouveau_screen.h"
#include "nouveau/nv_object.xml.h"
#include "nvfx_context.h"
--- Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c.ark 2011-04-11 10:27:27.220622711 +0200
+++ Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c 2011-04-11 11:09:24.147228063 +0200
@@ -24,6 +24,8 @@
*
*/
+#include <stdint.h>
+#include <nouveau/nv04_pushbuf.h>
#include "nouveau_driver.h"
#include "nouveau_context.h"
#include "nouveau_fbo.h"

View File

@ -0,0 +1,51 @@
Submitted By: Bruce Dubbs (bdubbs_AT_linuxfromscratch_DOT_org)
Date: 2012-06-04
Initial Package Version: 8.0.1
Origin: https://projects.archlinux.org/svntogit/packages.git/plain/trunk/mesa-8.0.3-llvm-3.1-fixes.patch?h=packages/mesa
Upstream Status: Not applicable
Description: Needed to build with LLVM 3.1
diff --git a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
index a50a51d..f1bb4d9 100644
--- a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
+++ b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
@@ -235,7 +235,24 @@ lp_disassemble(const void* func)
int AsmPrinterVariant = AsmInfo->getAssemblerDialect();
#endif
-#if HAVE_LLVM >= 0x0300
+#if HAVE_LLVM >= 0x0301
+ OwningPtr<const MCRegisterInfo> MRI(T->createMCRegInfo(Triple));
+ if (!MRI) {
+ debug_printf("error: no register info for target %s\n", Triple.c_str());
+ return;
+ }
+
+ OwningPtr<const MCInstrInfo> MII(T->createMCInstrInfo());
+ if (!MII) {
+ debug_printf("error: no instruction info for target %s\n", Triple.c_str());
+ return;
+ }
+#endif
+
+#if HAVE_LLVM >= 0x0301
+ OwningPtr<MCInstPrinter> Printer(
+ T->createMCInstPrinter(AsmPrinterVariant, *AsmInfo, *MII, *MRI, *STI));
+#elif HAVE_LLVM == 0x0300
OwningPtr<MCInstPrinter> Printer(
T->createMCInstPrinter(AsmPrinterVariant, *AsmInfo, *STI));
#elif HAVE_LLVM >= 0x0208
diff --git a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
index fe7616b..68f8808 100644
--- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
+++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
@@ -62,7 +62,11 @@
extern "C" void
lp_register_oprofile_jit_event_listener(LLVMExecutionEngineRef EE)
{
+#if HAVE_LLVM >= 0x0301
+ llvm::unwrap(EE)->RegisterJITEventListener(llvm::JITEventListener::createOProfileJITEventListener());
+#else
llvm::unwrap(EE)->RegisterJITEventListener(llvm::createOProfileJITEventListener());
+#endif
}

810
Mesa.spec Normal file
View File

@ -0,0 +1,810 @@
%define majver %(echo %version | cut -d. -f1-2)
%define libgl_majver %(echo %version | cut -d. -f 1)
%define libgl_minver %(echo %version | cut -d. -f 3)
%define pkgver %(echo %version | sed s/\.rc/-rc/)
#%ifarch arm
#%define dri_libglver 1.5.0800%libgl_minver
#%else
%define dri_libglver 1.2
#%endif
Name: Mesa
Epoch: 1
Version: 10.1.2
Release: 1mamba
Summary: A 3-D graphics library with an API which is very similar to that of OpenGL
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://mesa3d.sourceforge.net/
Source: ftp://freedesktop.org/pub/mesa/%{version}/MesaLib-%{version}.tar.bz2
#Source: http://www.mesa3d.org/beta/MesaLib-%{pkgver}.tar.gz
Source3: Mesa-7.0.3-libGL.la
Patch0: %{name}-7.10.2-driproto-2.4.patch
Patch1: %{name}-7.10.2-fix_nouveau_dri_includes.patch
Patch2: %{name}-8.0.4-llvm-3.1-fixes-1.patch
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libdrm
BuildRequires: libdrm-devel
BuildRequires: libexpat-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
BuildRequires: libtalloc-devel
BuildRequires: libX11-devel
BuildRequires: libxcb-devel
BuildRequires: libXdamage-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXi-devel
BuildRequires: libXmu-devel
BuildRequires: libXt-devel
BuildRequires: libXxf86vm-devel
BuildRequires: udev-devel
## AUTOBUILDREQ-END
BuildRequires: libdrm
BuildRequires: xproto-devel >= 7.1
BuildRequires: dri2proto-devel
BuildRequires: glproto-devel
BuildRequires: makedepend >= 1.0.0
BuildRequires: llvm-devel >= 3.1
BuildRequires: libudis86-devel
BuildRequires: liblesstif-devel
BuildRequires: libvdpau-devel
BuildRequires: dri3proto-devel
BuildRequires: libxshmfence-devel
BuildRequires: presentproto-devel
Provides: libgl
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Mesa is a 3-D graphics library with an API which is very similar to that of OpenGL.
To the extent that Mesa utilizes the OpenGL command syntax or state machine, it is being used with authorization from Silicon Graphics, Inc.(SGI). However, the author does not possess an OpenGL license from SGI, and makes no claim that Mesa is in any way a compatible replacement for OpenGL or associated with SGI. Those who want a licensed implementation of OpenGL should contact a licensed vendor.
%package -n libGL-Mesa-dri
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: System/Libraries
Provides: libGL.so.1
Obsoletes: libGL-Mesa-X11
Obsoletes: libGL-Mesa-fbdev
Provides: libGL-Mesa-X11
Provides: xorglibGL
Requires: libglapi == %{?epoch:%epoch:}%{version}-%{release}
%description -n libGL-Mesa-dri
Mesa implementation of the OpenGL 3-D graphics library.
%package -n libGL-Mesa-fbdev
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: System/Libraries
Provides: libGL.so.1
%description -n libGL-Mesa-fbdev
Mesa implementation of the OpenGL 3-D graphics library.
%package -n Mesa-tools
Summary: Utilities and demos for the Mesa GL libraries
Group: System/Tools
%description -n Mesa-tools
Utilities and demos for the Mesa GL libraries.
%package -n libGL-devel
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: Development/Libraries
Obsoletes: libGL-Mesa-X11-devel
Obsoletes: libGL-Mesa-indirect-devel
Requires: libGL-Mesa-dri == %{?epoch:%epoch:}%{version}-%{release}
%description -n libGL-devel
Mesa implementation of the OpenGL 3-D graphics library.
This package contains the headers and other files needed for development.
%package -n libGL-Mesa-indirect-devel
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: Development/Libraries
Obsoletes: libGL-Mesa-X11-devel
%description -n libGL-Mesa-indirect-devel
Mesa implementation of the OpenGL 3-D graphics library.
This package contains the headers and other files needed for development.
%package -n libGLU
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: System/Libraries
Obsoletes: libXorg
%description -n libGLU
Mesa implementation of the OpenGL 3-D graphics library.
%package -n libGLU-devel
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: Development/Libraries
Requires: libGLU == %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: libXorg-devel
%description -n libGLU-devel
An OpenGL 3-D graphics library using Linux Framebuffer device.
This package contains the headers and other files needed for development.
%package -n libGLw
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: System/Libraries
%description -n libGLw
Mesa implementation of the OpenGL 3-D graphics library.
%package -n libGLw-devel
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: Development/Libraries
Requires: libGLw == %{?epoch:%epoch:}%{version}-%{release}
%description -n libGLw-devel
Mesa implementation of the OpenGL 3-D graphics library.
This package contains the headers and other files needed for development.
%package -n libEGL
Summary: Mesa implementation of the EGL graphics library
Group: System/Libraries
Requires: libglapi == %{?epoch:%epoch:}%{version}-%{release}
%description -n libEGL
Mesa implementation of the OpenGL ES 1.0 graphics library.
%package -n libEGL-devel
Summary: Mesa implementation of the EGL graphics library
Group: Development/Libraries
Requires: libEGL == %{?epoch:%epoch:}%{version}-%{release}
%description -n libEGL-devel
Mesa implementation of the OpenGL EGL graphics library.
This package contains the headers and other files needed for development.
%package -n libGLESv1
Summary: Mesa implementation of the OpenGL ES 1.0 graphics library
Group: System/Libraries
Requires: libglapi == %{?epoch:%epoch:}%{version}-%{release}
%description -n libGLESv1
Mesa implementation of the OpenGL ES 1.0 graphics library.
%package -n libGLESv1-devel
Summary: Mesa implementation of the OpenGL ES 1.0 graphics library
Group: Development/Libraries
Requires: libGLESv1 == %{?epoch:%epoch:}%{version}-%{release}
%description -n libGLESv1-devel
Mesa implementation of the OpenGL ES 1.0 graphics library.
This package contains the headers and other files needed for development.
%package -n libGLESv2
Summary: Mesa implementation of the OpenGL ES 2.0 graphics library
Group: System/Libraries
Requires: libglapi == %{?epoch:%epoch:}%{version}-%{release}
%description -n libGLESv2
Mesa implementation of the OpenGL ES 2.0 graphics library.
%package -n libGLESv2-devel
Summary: Mesa implementation of the OpenGL ES 2.0 graphics library
Group: Development/Libraries
Requires: libGLESv2 == %{?epoch:%epoch:}%{version}-%{release}
%description -n libGLESv2-devel
Mesa implementation of the OpenGL ES 2.0 graphics library.
This package contains the headers and other files needed for development.
%package -n libglapi
Summary: The Mesa GL API module responsibile for dispatching all the gl* fuctions
Group: System/Libraries
%description -n libglapi
The Mesa GL API module is responsibile for dispatching all the gl* fuctions.
It is intended to be mainly used by both the libGLESv1 and libGLESv2 packages.
%package -n libOSMesa
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: System/Libraries
%description -n libOSMesa
Mesa implementation of the OpenGL 3-D graphics library.
%package -n libOSMesa-devel
Summary: Mesa implementation of the OpenGL 3-D graphics library
Group: Development/Libraries
Requires: libOSMesa == %{?epoch:%epoch:}%{version}-%{release}
%description -n libOSMesa-devel
Mesa implementation of the OpenGL 3-D graphics library.
This package contains the headers and other files needed for development.
%package -n libOpenVG
Summary: Mesa implementation of the OpenVG graphics library
Group: System/Libraries
%description -n libOpenVG
Mesa implementation of the OpenVG graphics library.
%package -n libOpenVG-devel
Summary: Development files for libOpenVG
Group: Development/Libraries
Requires: libOpenVG == %{?epoch:%epoch:}%{version}-%{release}
%description -n libOpenVG-devel
Mesa implementation of the OpenVG graphics library.
This package contains the headers and other files needed for development.
%package -n libgbm
Summary: Mesa generic buffer management library
Group: System/Libraries
%description -n libgbm
Mesa generic buffer management library.
%package -n libgbm-devel
Summary: Development files for libgbm
Group: Development/Libraries
Requires: libgbm == %{?epoch:%epoch:}%{version}-%{release}
%description -n libgbm-devel
Mesa generic buffer management library.
This package contains the headers and other files needed for development.
%package -n libvdpau-Mesa
Summary: Mesa plugins for libvdpau
Group: System/Libraries
Provides: vdpauplugins
%description -n libvdpau-Mesa
Mesa plugins for libvdpau.
%package -n libXvMC-Mesa
Summary: Mesa plugins for libXvMC
Group: System/Libraries
Provides: xvmcplugins
%description -n libXvMC-Mesa
Mesa plugins for libXvMC.
%debug_package
%prep
%setup -q
# -D -T
#:<< ___EOF
%ifarch arm
# Force libglx dri backend using swrast on non-DRI accelerated platforms
sed -i 's|default_driver="xlib"|default_driver="dri"|' configure
%endif
#%patch2 -p1
%build
#:<< ___EOF
./autogen.sh \
--with-dri-drivers=swrast \
--with-gallium-drivers=swrast
%configure \
--enable-osmesa \
--with-osmesa-bits=8 \
--enable-egl \
--enable-gles1 \
--enable-gles2 \
--with-egl-platforms=x11,drm \
--enable-driglx-direct \
--enable-dri \
--enable-shared-glapi \
--enable-glx \
--enable-glx-tls \
--enable-vdpau \
--enable-xvmc \
%ifnarch %{ix86} x86_64
--with-dri-drivers=swrast \
--with-gallium-drivers=swrast \
--enable-openvg \
--enable-gallium-egl \
--disable-gallium-llvm \
%else
--enable-openvg \
--enable-gallium-egl \
--enable-gallium-llvm \
--enable-gallium-g3dvl \
--with-gallium-drivers=nouveau,r300,r600,swrast \
%endif
# --with-driver=dri \
# --disable-gallium-egl \
%make
# -j1
#linux-dri-x86 DRI_DRIVER_INSTALL_DIR=%{_libdir}/dri/
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
#install -d %{buildroot}%{_libdir} %{buildroot}%{_bindir}
##cp -a lib/libOSMesa.* preserve/libGL.* %{buildroot}%{_libdir}
#install -m 755 \
# ../preserve/libGL-indirect.a ../preserve/libGLU-indirect.a \
# ../preserve/libglut-indirect.a ../preserve/libGLw-indirect.a \
# %{buildroot}%{_libdir}/
%makeinstall \
INSTALL_DIR=%{_prefix} \
DRI_DRIVER_INSTALL_DIR=%{_libdir}/dri/
#install -m 755 progs/xdemos/glxgears progs/xdemos/glxinfo %{buildroot}%{_bindir}
#mv %{buildroot}%{_libdir}/libGL.so.%{dri_libglver} \
# %{buildroot}%{_libdir}/libGL_so.%{dri_libglver}
ln -s libGL.so.1.2.0 %{buildroot}%{_libdir}/libGL_so.1.2
##remove the include that conflicts with liglew
#pushd %{buildroot}%{_includedir}/GL
#rm wglew.h glew.h glxew.h
#popd
#[ -L %{buildroot}%{_libdir}/libGL.so ] && rm -f %{buildroot}%{_libdir}/libGL.so
#ln -s libGL_so.%{dri_libglver} %{buildroot}%{_libdir}/libGL.so
## install libGL.la required for build
#install -m 0755 %{SOURCE3} %{buildroot}%{_libdir}/libGL.la
# remove libGL.so.1 symlink to manage it with alternatives
rm -f %{buildroot}%{_libdir}/libGL.so.1
rm -f %{buildroot}%{_libdir}/*.la
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n libGL-Mesa-dri
if [ $1 -ge 1 ]; then
/usr/sbin/update-alternatives \
--install %{_libdir}/libGL.so.1 libGL.so.1 \
%{_libdir}/libGL_so.%{dri_libglver} 50
fi
exit 0
%preun -n libGL-Mesa-dri
if [ $1 -eq 0 ]; then
/usr/sbin/update-alternatives --remove libGL.so.1 \
%{_libdir}/libGL_so.%{dri_libglver}
fi
exit 0
%post -n libGLU -p /sbin/ldconfig
%postun -n libGLU -p /sbin/ldconfig
%post -n libGLw -p /sbin/ldconfig
%postun -n libGLw -p /sbin/ldconfig
%post -n libGLESv1 -p /sbin/ldconfig
%postun -n libGLESv1 -p /sbin/ldconfig
%post -n libGLESv2 -p /sbin/ldconfig
%postun -n libGLESv2 -p /sbin/ldconfig
%post -n libOSMesa -p /sbin/ldconfig
%postun -n libOSMesa -p /sbin/ldconfig
%post -n libvdpau-Mesa -p /sbin/ldconfig
%postun -n libvdpau-Mesa -p /sbin/ldconfig
%post -n libXvMC-Mesa -p /sbin/ldconfig
%postun -n libXvMC-Mesa -p /sbin/ldconfig
%post -n libGL-devel
sed -i "s|%{_libdir}/libGL.la||" %{_libdir}/*.la
%ifarch x86_64
sed -i "s|%{_prefix}/lib/libGL.la||" %{_libdir}/*.la
%endif
:
%files -n libgbm
%defattr(-,root,root)
%{_libdir}/libgbm.so.*
%dir %{_libdir}/gbm
%{_libdir}/gbm/gbm_gallium_drm.so
%{_libdir}/gbm/gbm_gallium_drm.la
#%{_libdir}/gbm/pipe_swrast.so
#%ifarch %{ix86} x86_64
#%{_libdir}/gbm/pipe_nouveau.so
#%{_libdir}/gbm/pipe_r300.so
#%{_libdir}/gbm/pipe_r600.so
#%endif
%files -n libgbm-devel
%defattr(-,root,root)
%{_includedir}/gbm.h
%{_libdir}/libgbm.so
%{_libdir}/pkgconfig/gbm.pc
%files -n libEGL
%defattr(-,root,root)
%{_libdir}/libEGL.so.*
%dir %{_libdir}/egl
%{_libdir}/egl/egl_gallium.so
%dir %{_libdir}/gallium-pipe
%ifarch %{ix86} x86_64
%{_libdir}/gallium-pipe/pipe_nouveau.la
%{_libdir}/gallium-pipe/pipe_nouveau.so
%{_libdir}/gallium-pipe/pipe_r300.la
%{_libdir}/gallium-pipe/pipe_r300.so
%{_libdir}/gallium-pipe/pipe_r600.la
%{_libdir}/gallium-pipe/pipe_r600.so
%endif
%{_libdir}/gallium-pipe/pipe_swrast.la
%{_libdir}/gallium-pipe/pipe_swrast.so
%files -n libEGL-devel
%defattr(-,root,root)
%{_libdir}/egl/egl_gallium.la
%{_libdir}/pkgconfig/egl.pc
%files -n libGL-Mesa-dri
%defattr(-,root,root)
%{_sysconfdir}/drirc
%{_libdir}/libGL.so.1.2.0
%{_libdir}/libGL_so.*
#%{_libdir}/libdricore%{version}*.so.*
%dir %{_libdir}/dri
%{_libdir}/dri/*.so
%files -n libGL-devel
%defattr(-,root,root)
%dir %{_includedir}/EGL
%{_includedir}/EGL/*.h
%dir %{_includedir}/KHR
%{_includedir}/KHR/*.h
%dir %{_includedir}/GL
%{_includedir}/GL/gl.h
%{_includedir}/GL/gl_mangle.h
%{_includedir}/GL/glext.h
%{_includedir}/GL/glx.h
%{_includedir}/GL/glx_mangle.h
%{_includedir}/GL/glxext.h
#%{_includedir}/GL/vms_x_fix.h
%{_includedir}/GL/wmesa.h
%dir %{_includedir}/GL/internal
%{_includedir}/GL/internal/dri_interface.h
%{_includedir}/GL/wglext.h
#%{_libdir}/libGL.la
%{_libdir}/libGL.so
%{_libdir}/libEGL.so
%{_libdir}/libglapi.so
#%{_libdir}/libdricore%{version}*.so
%{_libdir}/dri/*.la
%{_libdir}/pkgconfig/dri.pc
%{_libdir}/pkgconfig/gl.pc
%files -n libvdpau-Mesa
%defattr(-,root,root)
%ifarch %{ix86} x86_64
%{_libdir}/vdpau/libvdpau_nouveau.la
%{_libdir}/vdpau/libvdpau_nouveau.so
%{_libdir}/vdpau/libvdpau_nouveau.so.*
#%{_libdir}/vdpau/libvdpau_r300.la
#%{_libdir}/vdpau/libvdpau_r300.so
#%{_libdir}/vdpau/libvdpau_r300.so.*
%{_libdir}/vdpau/libvdpau_r600.la
%{_libdir}/vdpau/libvdpau_r600.so
%{_libdir}/vdpau/libvdpau_r600.so.*
%endif
#%{_libdir}/vdpau/libvdpau_softpipe.la
#%{_libdir}/vdpau/libvdpau_softpipe.so
#%{_libdir}/vdpau/libvdpau_softpipe.so.*
%files -n libXvMC-Mesa
%defattr(-,root,root)
%ifarch %{ix86} x86_64
%{_libdir}/libXvMCnouveau.so
%{_libdir}/libXvMCnouveau.so.*
#%{_libdir}/libXvMCr300.so
#%{_libdir}/libXvMCr300.so.*
%{_libdir}/libXvMCr600.so
%{_libdir}/libXvMCr600.so.*
%endif
#%{_libdir}/libXvMCsoftpipe.so
#%{_libdir}/libXvMCsoftpipe.so.*
%files -n libGLESv1
%defattr(-,root,root)
%{_libdir}/libGLESv1_CM.so.*
%files -n libGLESv1-devel
%defattr(-,root,root)
%dir %{_includedir}/GLES
%{_includedir}/GLES/*.h
%{_libdir}/libGLESv1_CM.so
%{_libdir}/pkgconfig/glesv1_cm.pc
%files -n libGLESv2
%defattr(-,root,root)
%{_libdir}/libGLESv2.so.*
%files -n libGLESv2-devel
%defattr(-,root,root)
%dir %{_includedir}/GLES2
%{_includedir}/GLES2/*.h
%{_libdir}/libGLESv2.so
%{_libdir}/pkgconfig/glesv2.pc
# TODO: create subpackage
%dir %{_includedir}/GLES3
%{_includedir}/GLES3/gl3.h
%{_includedir}/GLES3/gl3ext.h
%{_includedir}/GLES3/gl3platform.h
%files -n libglapi
%defattr(-,root,root)
%{_libdir}/libglapi.so.*
%files -n libOSMesa
%defattr(-,root,root)
%{_libdir}/libOSMesa.so.*
%files -n libOSMesa-devel
%defattr(-,root,root)
%{_includedir}/GL/osmesa.h
%{_libdir}/libOSMesa.so
%{_libdir}/pkgconfig/osmesa.pc
%files -n libOpenVG
%defattr(-,root,root)
%{_libdir}/libOpenVG.so.*
%files -n libOpenVG-devel
%defattr(-,root,root)
%dir %{_includedir}/VG
%{_includedir}/VG/*.h
%{_libdir}/libOpenVG.so
%{_libdir}/pkgconfig/vg.pc
%changelog
* Wed May 07 2014 Automatic Build System <autodist@mambasoft.it> 10.1.2-1mamba
- automatic version update by autodist
* Mon Apr 21 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 10.1.1-1mamba
- update to 10.1.1
* Fri Mar 07 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 10.1.0-1mamba
- update to 10.1.0
* Tue Feb 04 2014 Automatic Build System <autodist@mambasoft.it> 10.0.3-1mamba
- automatic version update by autodist
* Fri Jan 10 2014 Automatic Build System <autodist@mambasoft.it> 10.0.2-1mamba
- automatic version update by autodist
* Sun Dec 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 10.0.1-1mamba
- update to 10.0.1
* Sat Dec 07 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 10.0.0-1mamba
- update to 10.0.0
* Thu Nov 28 2013 Automatic Build System <autodist@mambasoft.it> 9.2.4-1mamba
- automatic version update by autodist
* Thu Nov 14 2013 Automatic Build System <autodist@mambasoft.it> 9.2.3-2mamba
- rebuilt after fixing broken rpm
* Wed Nov 13 2013 Automatic Build System <autodist@mambasoft.it> 9.2.3-1mamba
- automatic version update by autodist
* Sat Oct 19 2013 Automatic Build System <autodist@mambasoft.it> 9.2.2-1mamba
- automatic version update by autodist
* Sat Oct 05 2013 Automatic Build System <autodist@mambasoft.it> 9.2.1-1mamba
- update to 9.2.1
* Fri Aug 30 2013 Automatic Build System <autodist@mambasoft.it> 9.2.0-1mamba
- update to 9.2.0
* Fri Aug 02 2013 Automatic Build System <autodist@mambasoft.it> 9.1.6-1mamba
- automatic version update by autodist
* Thu Jul 18 2013 Automatic Build System <autodist@mambasoft.it> 9.1.5-1mamba
- automatic version update by autodist
* Tue Jul 02 2013 Automatic Build System <autodist@mambasoft.it> 9.1.4-1mamba
- automatic version update by autodist
* Wed May 22 2013 Automatic Build System <autodist@mambasoft.it> 9.1.3-1mamba
- automatic version update by autodist
* Wed May 01 2013 Automatic Build System <autodist@mambasoft.it> 9.1.2-1mamba
- automatic version update by autodist
* Sun Mar 31 2013 Automatic Build System <autodist@mambasoft.it> 9.1.1-1mamba
- automatic version update by autodist
* Mon Feb 25 2013 Automatic Build System <autodist@mambasoft.it> 9.1-1mamba
- automatic version update by autodist
* Fri Feb 22 2013 Automatic Build System <autodist@mambasoft.it> 9.0.3-1mamba
- automatic version update by autodist
* Sat Jan 26 2013 Automatic Build System <autodist@mambasoft.it> 9.0.2-1mamba
- automatic version update by autodist
* Mon Nov 19 2012 Automatic Build System <autodist@mambasoft.it> 9.0.1-1mamba
- automatic version update by autodist
* Wed Oct 10 2012 Automatic Build System <autodist@mambasoft.it> 9.0-1mamba
- automatic version update by autodist
* Sun Jul 22 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.4-3mamba
- added --enable-xvmc and --enable-gallium-g3dvl
- (source edit / x86_64) don't install libGL.la
* Fri Jul 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.4-2mamba
- rebuilt with llvm 3.1
- add --enable-gallium-egl
- reenable openvg
* Wed Jul 11 2012 Automatic Build System <autodist@mambasoft.it> 8.0.4-1mamba
- automatic version update by autodist
* Mon Jun 25 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.3-2mamba
- added --enable-vdpau
* Sat May 19 2012 Automatic Build System <autodist@mambasoft.it> 8.0.3-1mamba
- automatic version update by autodist
* Tue Apr 10 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.2-2mamba
- added debug package
* Thu Mar 22 2012 Automatic Build System <autodist@mambasoft.it> 8.0.2-1mamba
- automatic version update by autodist
* Fri Feb 17 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0.1-1mamba
- update to 8.0.1
* Thu Feb 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 8.0-1mamba
- update to 8.0
* Tue Jan 24 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 7.11.2-2mamba
- rebuilt with --with-egl-platforms=x11,drm and --enable-shared-glapi; removed --disable-gallium-egl
* Mon Nov 28 2011 Automatic Build System <autodist@mambasoft.it> 7.11.2-1mamba
- automatic update by autodist
* Fri Nov 18 2011 Automatic Build System <autodist@mambasoft.it> 7.11.1-1mamba
- automatic version update by autodist
* Sat Oct 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.11-2mamba
- configure options reworked to new version; re-enabled built of Nouveau Gallium driver
* Fri Sep 09 2011 Automatic Build System <autodist@mambasoft.it> 7.11-1mamba
- automatic version update by autodist
* Sat Jul 16 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.10.3-1mamba
- update to 7.10.3
* Fri Jun 03 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.10.2-4mamba
- also add --disable-gallium-radeon (replacing disable-gallium-r300)
* Fri Jun 03 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.10.2-3mamba
- disable radeon Gallium build due to slower performance yet
* Mon May 16 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.10.2-2mamba
- reworked configure options to enable more new things
* Tue May 10 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.10.2-1mamba
- update to 7.10.2
* Sat Feb 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 7.10-1mamba
- update to 7.10
* Thu Nov 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 7.8.2-4mamba
- rebuilt with GLES overlay enabled; added libGLESv1 and libGLESv2 packages
* Tue Oct 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 7.8.2-3mamba
- rebuilt with --enable-gallium-nouveau
* Tue Aug 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 7.8.2-2mamba
- added patch to fix refresh issues with intel driver (see https://bugs.freedesktop.org/show_bug.cgi?id=27420)
* Sat Jul 03 2010 Automatic Build System <autodist@mambasoft.it> 7.8.2-1mamba
- automatic update to 7.8.2 by autodist
* Thu Apr 08 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 7.6.1-1mamba
- update to 7.6.1
* Fri Jan 01 2010 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 7.5.2-2mamba
- rebuild removing glew files that conflict with libglew package
* Sat Dec 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.5.2-1mamba
- update to 7.5.2
* Sat Jul 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.5-1mamba
- update to 7.5
* Sun Jun 21 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.5.rc3-1mamba
- update to 7.5.rc3
* Sat Jun 20 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.4.3-1mamba
- update to 7.4.3
* Wed Apr 15 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.4-1mamba
- update to 7.4
* Wed Apr 15 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.2-1mamba
- automatic update to 7.2 by autodist
* Tue Dec 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.4-1mamba
- update to 7.0.4
* Thu Nov 13 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.3-4mamba
- radeon: add a patch that fixes a white titlebar whit compiz and maximized windows
* Wed Jun 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.3-3mamba
- libGL.la: remove reference to missing libGL.a
* Fri Jun 06 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.3-2mamba
- libGL-devel: added /usr/lib/libGL.la
* Fri May 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.3-1mamba
- update to 7.0.3
* Thu Oct 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.1-4mamba
- reverted previous patch: it is not necessary, libGL.so linked to nvidia
library works if /usr/lib/libnvidia-tls.so.1 is present and correct
* Thu Oct 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.1-3mamba
- make libGL.so point to Mesa libGL and require the package too
* Mon Sep 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.1-2mamba
- remove .so extension from libGL to avoid ldconfig reconfiguration
* Thu Aug 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.1-1mamba
- update to 7.0.1
* Sun May 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.3-2mamba
- libGL-Mesa-dri: set alternatives for libGL.so.1
- libOSMesa: fix for 'libOSMesa.so.6 is not a symlink'
* Fri May 11 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.3-1mamba
- update to 6.5.3
* Fri Mar 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2.git20070315-2qilnx
- set DRI_DRIVER_INSTALL_DIR during make too
* Thu Mar 15 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2.git20070315-1qilnx
- update to version 6.5.2.git20070315 by autospec
- rename source and patches from libMesa to Mesa
- build with USING_EGL=1 to fix undefined symbols
* Fri Jan 05 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-8qilnx
- fix make realclean patch for .so symlinks
* Fri Jan 05 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-7qilnx
- rebuilt
* Sun Dec 31 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-6qilnx
- move dri drivers back to /usr/lib/dri
* Fri Dec 29 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-5qilnx
- rebuild with MesaGLUT
- add glxinfo and glxgears applications
* Thu Dec 28 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-4qilnx
- libGL-devel: obsolete libGL-Mesa-X11-devel
* Wed Dec 27 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-3qilnx
- libGL-Mesa-dri: provide xorglibGL and obsolete libGL-Mesa-X11
* Wed Dec 20 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-2qilnx
- rebuild and repackage for Xorg 7.1
* Mon Dec 18 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.2-1qilnx
- update to version 6.5.2 by autospec
* Wed Oct 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.1-1qilnx
- package created by autospec

View File

@ -1,2 +1,5 @@
# Mesa
Mesa is a 3-D graphics library with an API which is very similar to that of OpenGL.
To the extent that Mesa utilizes the OpenGL command syntax or state machine, it is being used with authorization from Silicon Graphics, Inc.(SGI). However, the author does not possess an OpenGL license from SGI, and makes no claim that Mesa is in any way a compatible replacement for OpenGL or associated with SGI. Those who want a licensed implementation of OpenGL should contact a licensed vendor.