update to 3.6.5 [release 3.6.5-1mamba;Sun Aug 04 2019]
This commit is contained in:
parent
28d6efffbe
commit
e9a8400406
45
Ice-3.6.5-openjdk-7.patch
Normal file
45
Ice-3.6.5-openjdk-7.patch
Normal file
@ -0,0 +1,45 @@
|
||||
From 9943871496ca85284ea0fac0a0c07100003a1855 Mon Sep 17 00:00:00 2001
|
||||
From: Jose <jose@zeroc.com>
|
||||
Date: Mon, 29 Jul 2019 18:56:23 +0200
|
||||
Subject: [PATCH] Fixes for building with JDK 7
|
||||
|
||||
---
|
||||
java/src/IceGridGUI/build.gradle | 3 ++-
|
||||
java/src/IceGridGUI/proguard-jar.gradle | 2 +-
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/java/src/IceGridGUI/build.gradle b/java/src/IceGridGUI/build.gradle
|
||||
index 8206e5e88f..04c830040e 100644
|
||||
--- a/java/src/IceGridGUI/build.gradle
|
||||
+++ b/java/src/IceGridGUI/build.gradle
|
||||
@@ -103,6 +103,7 @@ if(icegridguiProguard.toBoolean()) {
|
||||
if(hasJavaFx) {
|
||||
project.ext.libJars << "${System.properties['java.home']}/${javafxJar}"
|
||||
}
|
||||
+ project.ext.jarBuilder = "proguard-jar.gradle"
|
||||
}
|
||||
else{
|
||||
['java.base.jmod',
|
||||
@@ -118,8 +119,8 @@ if(icegridguiProguard.toBoolean()) {
|
||||
'java.logging.jmod'].each {
|
||||
project.ext.libJars << "${System.properties['java.home']}/jmods/${it}"
|
||||
}
|
||||
+ project.ext.jarBuilder = "plain-jar.gradle"
|
||||
}
|
||||
- project.ext.jarBuilder = "proguard-jar.gradle"
|
||||
}
|
||||
apply from: jarBuilder
|
||||
|
||||
diff --git a/java/src/IceGridGUI/proguard-jar.gradle b/java/src/IceGridGUI/proguard-jar.gradle
|
||||
index 20b61ea75b..fa75ed54e0 100644
|
||||
--- a/java/src/IceGridGUI/proguard-jar.gradle
|
||||
+++ b/java/src/IceGridGUI/proguard-jar.gradle
|
||||
@@ -13,7 +13,7 @@ buildscript {
|
||||
}
|
||||
|
||||
dependencies {
|
||||
- classpath "net.sf.proguard:proguard-gradle:6.1.1"
|
||||
+ classpath "net.sf.proguard:proguard-gradle:6.0.2"
|
||||
}
|
||||
}
|
||||
|
499
Ice.spec
499
Ice.spec
@ -5,20 +5,20 @@
|
||||
%define ruby_version %(ruby -rrbconfig -e 'puts Config::CONFIG["ruby_version"]')
|
||||
|
||||
Name: Ice
|
||||
Version: 3.4.0
|
||||
Release: 2mamba
|
||||
Version: 3.6.5
|
||||
Release: 1mamba
|
||||
Summary: The Internet Communications Engine (Ice)
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: gil <puntogil@libero.it>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.zeroc.com/
|
||||
Source0: http://zeroc.com/download/Ice/%{majversion}/Ice-%{version}.tar.gz
|
||||
# from http://www.zeroc.com/download/Ice/3.4/ice-%{version}-1.src.rpm
|
||||
Source1: Ice-rpmbuild-%{version}.tar.gz
|
||||
Source0: https://github.com/zeroc-ice/ice.git/v%{version}/ice-%{version}.tar.bz2
|
||||
#Source0: http://zeroc.com/download/Ice/%{majversion}/Ice-%{version}.tar.gz
|
||||
#Source1: http://www.zeroc.com/download/Ice/%{majversion}/ice-%{version}-1.src.rpm
|
||||
Source2: icegridgui
|
||||
Source3: IceGridAdmin.desktop
|
||||
Source4: Ice-3.3.0-man-pages.tar.gz
|
||||
#Source4: Ice-3.3.0-man-pages.tar.gz
|
||||
Patch0: Ice-3.3.0-dont-build-demo-test.patch
|
||||
Patch1: Ice-3.4.0-java-build.patch
|
||||
Patch2: Ice-3.3.1-jgoodies.patch
|
||||
@ -27,21 +27,13 @@ Patch4: Ice-3.3.1-rpmbuild-change-user.patch
|
||||
# http://www.zeroc.com/forums/attachments/patches/745d1268183564-patch-1-ice-3-4-0-slice2cpp-stream-issue-patch-stream.txt
|
||||
Patch5: patch-stream.txt
|
||||
Patch6: Ice-3.4.0-s390.patch
|
||||
|
||||
Patch7: Ice-3.6.5-openjdk-7.patch
|
||||
License: GPL
|
||||
BuildRequires: apache-ant
|
||||
BuildRequires: apache-ant-nodeps
|
||||
BuildRequires: ImageMagick
|
||||
BuildRequires: java-bdb48
|
||||
BuildRequires: java-openjdk
|
||||
BuildRequires: java-proguard
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: jgoodies-forms13
|
||||
BuildRequires: jgoodies-looks
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libdb-devel
|
||||
BuildRequires: libdb53-cxx
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libmcpp-devel
|
||||
@ -51,18 +43,22 @@ BuildRequires: libstdc++6-devel
|
||||
BuildRequires: mono-core
|
||||
BuildRequires: ruby-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: jgoodies-common
|
||||
BuildRequires: mono-devel
|
||||
BuildRequires: openssl
|
||||
BuildRequires: php-devel
|
||||
BuildRequires: ruby-devel
|
||||
BuildRequires: apache-ant
|
||||
BuildRequires: apache-ant-nodeps
|
||||
BuildRequires: ImageMagick
|
||||
BuildRequires: java-bdb48
|
||||
BuildRequires: java-openjdk
|
||||
BuildRequires: java-proguard
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The Internet Communications Engine (Ice) is a modern object-oriented middleware with support for C++, .NET, Java, Python, Objective-C, Ruby, and PHP. Ice is used in many mission-critical projects by companies all over the world.
|
||||
|
||||
Ice is easy to learn, yet provides a powerful network infrastructure and vast array of features for demanding technical applications.
|
||||
|
||||
Ice is free software, available with full source, and released under the terms of GNU General Public License (GPL). Commercial licenses are available for customers who wish to use Ice for closed-source software.
|
||||
|
||||
%package devel
|
||||
@ -72,7 +68,6 @@ Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The Internet Communications Engine (Ice).
|
||||
|
||||
This package contains tools for developing Ice applications in C++.
|
||||
|
||||
%package -n mono-Ice
|
||||
@ -163,189 +158,102 @@ The Internet Communications Engine (Ice).
|
||||
|
||||
This package contains Ice services to run through /etc/rc.d/init.d.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q
|
||||
for p in $(find . -name "*.py"); do
|
||||
# sed -i 's|#!/usr/bin/python|#!%{__python}|' $p
|
||||
sed -i 's|#!/usr/bin/env python|#!%{__python}|' $p
|
||||
# sed -i 's|#!python|#!%{__python}|' $p
|
||||
sed -i 's|#!/usr/local/bin/python2.1|#!%{__python}|' $p
|
||||
sed -i 's|#!/usr/local/bin/python|#!%{__python}|' $p
|
||||
done
|
||||
|
||||
sed -i 's|#!/usr/local/bin/python|#!%{__python}|' %{_builddir}/Ice-%{version}/cpp/src/ca/iceca
|
||||
|
||||
for r in $(find . -name "*.rb"); do
|
||||
sed -i 's|#!/usr/bin/env ruby|#!/usr/bin/ruby|' $r
|
||||
done
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
|
||||
%setup -q -n Ice-rpmbuild-%{version} -T -b 1
|
||||
%patch4 -p1
|
||||
|
||||
%setup -q -n Ice-3.3.0-man-pages -T -b 4
|
||||
rm -f slice2docbook.1
|
||||
%setup -q -n ice-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
sed -i "s| test$||" csharp/Makefile
|
||||
|
||||
%build
|
||||
unset JAVA_HOME
|
||||
export JAVA_HOME=%{_jvmdir}/java-openjdk
|
||||
unset QT_HOME || : ; source /etc/profile.d/libqt4.sh
|
||||
export PYTHON_VERSION=python2.6 CPPFLAGS=-I%{_qt4_headerdir} LIBS="-lQtCore -lQtSql"
|
||||
export CLASSPATH=""
|
||||
CLASSPATH=$CLASSPATH:$(build-classpath db ant/ant-nodeps jgoodies-forms13 jgoodies-looks proguard)
|
||||
cd %{_builddir}/Ice-%{version}
|
||||
make CXXFLAGS="%{optflags} -fPIC" CFLAGS="%{optflags} -fPIC" embedded_runpath_prefix="" DB_FLAGS="-I%{_includedir}/db4"
|
||||
#:<< _EOF
|
||||
#export CFLAGS="%{optflags} -fPIC -Wno-error -lpthread"
|
||||
|
||||
# rebuild the Java ImportKey class
|
||||
cd %{_builddir}/Ice-%{version}/cpp/src/ca
|
||||
rm -rf *.class
|
||||
$JAVA_HOME/bin/javac ImportKey.java
|
||||
%make \
|
||||
OPTIMIZE="yes" USR_DIR_INSTALL="yes" prefix=%{_prefix} \
|
||||
CONFIGS="shared cpp11-shared" \
|
||||
CXXFLAGS="%{optflags} -fPIC -fvisibility=hidden -Wall -Wno-error -pthread" \
|
||||
PYTHON="python3" cpp js python ruby php
|
||||
|
||||
cd %{_builddir}/Ice-%{version}/java
|
||||
cd resources/icons
|
||||
convert icegrid.ico temp.png
|
||||
mv temp-8.png icegrid.png
|
||||
rm -rf temp*.png
|
||||
%make -C csharp
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
cd %{_builddir}/Ice-%{version}/
|
||||
make prefix=%{buildroot} GACINSTALL=yes GAC_ROOT=%{buildroot}%{_libdir} embedded_runpath_prefix="" install
|
||||
%makeinstall \
|
||||
OPTIMIZE="yes" USR_DIR_INSTALL="yes" prefix=%{_prefix} \
|
||||
CONFIGS="shared cpp11-shared" SKIP=slice2py \
|
||||
PYTHON="python3"
|
||||
|
||||
# java
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
mv %{buildroot}/lib/ant-ice.jar %{buildroot}%{_javadir}/ant-ice-%{version}.jar
|
||||
mv %{buildroot}/lib/Ice.jar %{buildroot}%{_javadir}/Ice-%{version}.jar
|
||||
mv %{buildroot}/lib/Freeze.jar %{buildroot}%{_javadir}/Freeze-%{version}.jar
|
||||
%makeinstall -C csharp \
|
||||
OPTIMIZE="yes" USR_DIR_INSTALL="yes" \
|
||||
prefix=%{_prefix} \
|
||||
install_assembliesdir=%{_prefix}/lib/mono/Ice
|
||||
|
||||
(
|
||||
cd %{buildroot}%{_javadir}/
|
||||
for jar in *-%{version}*; do
|
||||
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||
done
|
||||
)
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/Ice-%{version}
|
||||
mv %{buildroot}/lib/IceGridGUI.jar %{buildroot}%{_datadir}/Ice-%{version}
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/
|
||||
install -pm 644 %{_builddir}/Ice-%{version}/java/resources/icons/icegrid.png %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/
|
||||
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||
ln -sf ../icons/hicolor/48x48/apps/icegrid.png \
|
||||
%{buildroot}%{_datadir}/pixmaps/icegrid.png
|
||||
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
install -pm 755 %{SOURCE2} %{buildroot}%{_bindir}
|
||||
sed -i -e "s#DIR#%{_datadir}/Ice-%{version}#" %{buildroot}%{_bindir}/icegridgui
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
desktop-file-install --mode=644 --dir=%{buildroot}%{_datadir}/applications %{SOURCE3}
|
||||
|
||||
mkdir -p %{buildroot}%{_defaultdocdir}/Ice-%{version}
|
||||
cp -p %{_builddir}/Ice-rpmbuild-%{version}/ice.ini %{buildroot}/ice.ini
|
||||
|
||||
# servers
|
||||
mkdir -p %{buildroot}%{_sysconfdir}
|
||||
cp -p %{_builddir}/Ice-rpmbuild-%{version}/*.conf %{buildroot}%{_sysconfdir}
|
||||
mkdir -p %{buildroot}%{_initrddir}
|
||||
for i in icegridregistry icegridnode glacier2router ; do
|
||||
cp -p %{_builddir}/Ice-rpmbuild-%{version}/$i.redhat %{buildroot}%{_initrddir}/$i
|
||||
done
|
||||
mkdir -p %{buildroot}%{_localstatedir}/lib/icegrid
|
||||
mkdir -p %{buildroot}%{_localstatedir}/lib/ice/icegrid/node1
|
||||
mkdir -p %{buildroot}%{_localstatedir}/lib/ice/icegrid/registry
|
||||
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
mv %{buildroot}/bin/* %{buildroot}%{_bindir}
|
||||
mkdir -p %{buildroot}%{_includedir}
|
||||
mv %{buildroot}/include/* %{buildroot}%{_includedir}
|
||||
mkdir -p %{buildroot}%{_libdir}
|
||||
|
||||
mv %{buildroot}/%{_lib}/* %{buildroot}%{_libdir} || true
|
||||
mv %{buildroot}/lib/* %{buildroot}%{_libdir} || true
|
||||
mkdir -p %{buildroot}%{_defaultdocdir}/Ice-%{version}
|
||||
mv %{buildroot}/help/IceGridAdmin %{buildroot}%{_defaultdocdir}/Ice-%{version}
|
||||
|
||||
|
||||
cd %{buildroot}%{_defaultdocdir}/Ice-%{version}/IceGridAdmin
|
||||
chmod a-x *
|
||||
for f in *.js *.css; do
|
||||
dos2unix $f
|
||||
done
|
||||
for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
|
||||
iconv -f ISO88591 -t UTF8 $f -o $f.tmp
|
||||
mv $f.tmp $f
|
||||
done
|
||||
|
||||
# csharp
|
||||
for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
|
||||
sed -i -e "s#/lib/#%{_libdir}/#" %{buildroot}%{_libdir}/pkgconfig/$f.pc
|
||||
sed -i -e "s#mono_root}/usr#mono_root}#" %{buildroot}%{_libdir}/pkgconfig/$f.pc
|
||||
mv %{buildroot}%{_bindir}/$f.xml %{buildroot}%{_libdir}/mono/gac/$f/%{version}.*/
|
||||
done
|
||||
|
||||
# php
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/php
|
||||
mv %{buildroot}/ice.ini %{buildroot}%{_sysconfdir}/php
|
||||
mkdir -p %{buildroot}%{php_extensiondir}
|
||||
mv %{buildroot}/php/IcePHP.so %{buildroot}%{php_extensiondir}
|
||||
mkdir -p %{buildroot}%{_libdir}/php
|
||||
mv %{buildroot}/php/* %{buildroot}%{_libdir}/php
|
||||
|
||||
for f in %{buildroot}/python/Ice.py %{buildroot}/ruby/*.rb; do
|
||||
grep -v '/usr/bin/env' $f > $f.tmp
|
||||
mv $f.tmp $f
|
||||
done
|
||||
|
||||
# ruby
|
||||
mkdir -p %{buildroot}%{ruby_sitearchdir}
|
||||
mv %{buildroot}/ruby/* %{buildroot}%{ruby_sitearchdir}
|
||||
|
||||
# python
|
||||
mkdir -p %{buildroot}%{python_sitearch}/Ice
|
||||
mv %{buildroot}/python/* %{buildroot}%{python_sitearch}/Ice
|
||||
cp -p %{_builddir}/Ice-rpmbuild-%{version}/ice.pth %{buildroot}%{python_sitearch}
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/Ice-%{version}
|
||||
|
||||
mv %{buildroot}/config/* %{buildroot}%{_datadir}/Ice-%{version}
|
||||
mv %{buildroot}/slice %{buildroot}%{_datadir}/Ice-%{version}
|
||||
|
||||
find %{buildroot}%{_datadir}/Ice-%{version} -name "*.ice" | xargs chmod a-x
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/Ice-%{version}
|
||||
mv %{buildroot}%{_libdir}/ImportKey.class %{buildroot}%{_datadir}/Ice-%{version}
|
||||
|
||||
mkdir -p %{buildroot}%{_defaultdocdir}/Ice-%{version}
|
||||
mv %{buildroot}/ICE_LICENSE %{buildroot}%{_defaultdocdir}/Ice-%{version}/ICE_LICENSE
|
||||
mv %{buildroot}/LICENSE %{buildroot}%{_defaultdocdir}/Ice-%{version}/LICENSE
|
||||
|
||||
cd %{_builddir}/Ice-%{version}
|
||||
cp CHANGES RELEASE_NOTES %{buildroot}%{_defaultdocdir}/Ice-%{version}/
|
||||
|
||||
mkdir -p %{buildroot}%{_mandir}/man1
|
||||
cp -p %{_builddir}/Ice-3.3.0-man-pages/*.1 %{buildroot}%{_mandir}/man1
|
||||
cp -a csharp/lib/pkgconfig %{buildroot}%{_libdir}/
|
||||
#make prefix=%{buildroot} GACINSTALL=yes GAC_ROOT=%{buildroot}%{_libdir} embedded_runpath_prefix="" install
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%post -n icegrid-gui
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
||||
fi
|
||||
:
|
||||
|
||||
%postun -n icegrid-gui
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
||||
fi
|
||||
:
|
||||
|
||||
%pre servers
|
||||
getent group iceuser > /dev/null || /usr/sbin/groupadd -r iceuser
|
||||
getent passwd iceuser > /dev/null || \
|
||||
/usr/sbin/groupadd -r -g iceuser -d %{_localstatedir}/lib/icegrid \
|
||||
-s /sbin/nologin -c "IceGrid server user" iceuser
|
||||
exit 0
|
||||
|
||||
%post servers
|
||||
/sbin/chkconfig --add icegridregistry
|
||||
/sbin/chkconfig --add icegridnode
|
||||
/sbin/chkconfig --add glacier2router
|
||||
:
|
||||
|
||||
%preun servers
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/service icegridregistry stop >/dev/null 2>&1 || :
|
||||
/sbin/chkconfig --del icegridregistry
|
||||
/sbin/service icegridnode stop >/dev/null 2>&1 || :
|
||||
/sbin/chkconfig --del icegridnode
|
||||
/sbin/service glacier2router stop >/dev/null 2>&1 || :
|
||||
/sbin/chkconfig --del glacier2router
|
||||
fi
|
||||
:
|
||||
|
||||
%postun servers
|
||||
if [ "$1" -ge "1" ]; then
|
||||
/sbin/service icegridregistry condrestart >/dev/null 2>&1 || :
|
||||
/sbin/service icegridnode condrestart >/dev/null 2>&1 || :
|
||||
/sbin/service glacier2router condrestart >/dev/null 2>&1 || :
|
||||
fi
|
||||
:
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/dumpdb
|
||||
%{_bindir}/glacier2router
|
||||
%ifarch x86_64
|
||||
%{_bindir}/icebox
|
||||
%endif
|
||||
%{_bindir}/iceboxadmin
|
||||
%{_bindir}/iceca
|
||||
#%{_bindir}/iceca
|
||||
%{_bindir}/icegridadmin
|
||||
%{_bindir}/icegridnode
|
||||
%{_bindir}/icegridregistry
|
||||
@ -360,39 +268,39 @@ cp -p %{_builddir}/Ice-3.3.0-man-pages/*.1 %{buildroot}%{_mandir}/man1
|
||||
%{_libdir}/libGlacier2.so.*
|
||||
%{_libdir}/libIce.so.*
|
||||
%{_libdir}/libIceBox.so.*
|
||||
%{_libdir}/libIceDB.so.*
|
||||
#%{_libdir}/libIceDB.so.*
|
||||
%{_libdir}/libIceGrid.so.*
|
||||
%{_libdir}/libIceGridFreezeDB.so.*
|
||||
#%{_libdir}/libIceGridFreezeDB.so.*
|
||||
%{_libdir}/libIcePatch2.so.*
|
||||
%{_libdir}/libIceSSL.so.*
|
||||
%{_libdir}/libIceStorm.so.*
|
||||
%{_libdir}/libIceStormFreezeDB.so.*
|
||||
#%{_libdir}/libIceStormFreezeDB.so.*
|
||||
%{_libdir}/libIceStormService.so.*
|
||||
%{_libdir}/libIceUtil.so.*
|
||||
%{_libdir}/libIceXML.so.*
|
||||
%{_libdir}/libSlice.so.*
|
||||
%{_datadir}/Ice-%{version}/*.class
|
||||
#%{_datadir}/Ice-%{version}/*.class
|
||||
%{_datadir}/Ice-%{version}/*.ice.gz
|
||||
%{_datadir}/Ice-%{version}/slice
|
||||
%{_datadir}/Ice-%{version}/*.xml
|
||||
%{_datadir}/Ice-%{version}/*.py
|
||||
%{_defaultdocdir}/Ice-%{version}/CHANGES
|
||||
%{_defaultdocdir}/Ice-%{version}/ICE_LICENSE
|
||||
%{_defaultdocdir}/Ice-%{version}/LICENSE
|
||||
%{_defaultdocdir}/Ice-%{version}/RELEASE_NOTES
|
||||
%{_mandir}/man1/dumpdb.1.gz
|
||||
%{_mandir}/man1/glacier2router.1.gz
|
||||
%{_mandir}/man1/icebox.1.gz
|
||||
%{_mandir}/man1/iceboxadmin.1.gz
|
||||
%{_mandir}/man1/icegridadmin.1.gz
|
||||
%{_mandir}/man1/icegridnode.1.gz
|
||||
%{_mandir}/man1/icegridregistry.1.gz
|
||||
%{_mandir}/man1/icepatch2calc.1.gz
|
||||
%{_mandir}/man1/icepatch2client.1.gz
|
||||
%{_mandir}/man1/icepatch2server.1.gz
|
||||
%{_mandir}/man1/icestormadmin.1.gz
|
||||
%{_mandir}/man1/slice2html.1.gz
|
||||
%{_mandir}/man1/transformdb.1.gz
|
||||
#%{_defaultdocdir}/Ice-%{version}/CHANGES
|
||||
#%{_defaultdocdir}/Ice-%{version}/ICE_LICENSE
|
||||
#%{_defaultdocdir}/Ice-%{version}/LICENSE
|
||||
#%{_defaultdocdir}/Ice-%{version}/RELEASE_NOTES
|
||||
%{_mandir}/man1/dumpdb.1*
|
||||
%{_mandir}/man1/glacier2router.1*
|
||||
%{_mandir}/man1/icebox.1*
|
||||
%{_mandir}/man1/iceboxadmin.1*
|
||||
%{_mandir}/man1/icegridadmin.1*
|
||||
%{_mandir}/man1/icegridnode.1*
|
||||
%{_mandir}/man1/icegridregistry.1*
|
||||
%{_mandir}/man1/icepatch2calc.1*
|
||||
%{_mandir}/man1/icepatch2client.1*
|
||||
%{_mandir}/man1/icepatch2server.1*
|
||||
%{_mandir}/man1/icestormadmin.1*
|
||||
%{_mandir}/man1/slice2html.1*
|
||||
%{_mandir}/man1/transformdb.1*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
@ -407,42 +315,32 @@ cp -p %{_builddir}/Ice-3.3.0-man-pages/*.1 %{buildroot}%{_mandir}/man1
|
||||
%{_includedir}/IceSSL
|
||||
%{_includedir}/IceStorm
|
||||
%{_includedir}/IceUtil
|
||||
%{_includedir}/IceXML
|
||||
#%{_includedir}/IceXML
|
||||
%{_includedir}/Slice
|
||||
%{_libdir}/libFreeze.so
|
||||
%{_libdir}/libGlacier2.so
|
||||
%{_libdir}/libIce.so
|
||||
%{_libdir}/libIceBox.so
|
||||
%{_libdir}/libIceDB.so
|
||||
#%{_libdir}/libIceDB.so
|
||||
%{_libdir}/libIceGrid.so
|
||||
%{_libdir}/libIceGridFreezeDB.so
|
||||
#%{_libdir}/libIceGridFreezeDB.so
|
||||
%{_libdir}/libIcePatch2.so
|
||||
%{_libdir}/libIceSSL.so
|
||||
%{_libdir}/libIceStorm.so
|
||||
%{_libdir}/libIceStormFreezeDB.so
|
||||
#%{_libdir}/libIceStormFreezeDB.so
|
||||
%{_libdir}/libIceStormService.so
|
||||
%{_libdir}/libIceUtil.so
|
||||
%{_libdir}/libIceXML.so
|
||||
%{_libdir}/libSlice.so
|
||||
%{_mandir}/man1/slice2cpp.1.gz
|
||||
%{_mandir}/man1/slice2freeze.1.gz
|
||||
%{_mandir}/man1/slice2cpp.1*
|
||||
%{_mandir}/man1/slice2freeze.1*
|
||||
|
||||
%files -n mono-Ice
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/mono/Glacier2/
|
||||
%{_libdir}/mono/Ice/
|
||||
%{_libdir}/mono/IceBox/
|
||||
%{_libdir}/mono/IceGrid/
|
||||
%{_libdir}/mono/IcePatch2/
|
||||
%{_libdir}/mono/IceStorm/
|
||||
%{_libdir}/mono/gac/Glacier2
|
||||
%{_libdir}/mono/gac/Ice
|
||||
%{_libdir}/mono/gac/IceBox
|
||||
%{_libdir}/mono/gac/IceGrid
|
||||
%{_libdir}/mono/gac/IcePatch2
|
||||
%{_libdir}/mono/gac/IceStorm
|
||||
%dir %{_prefix}/lib/mono/Ice
|
||||
%{_prefix}/lib/mono/Ice/*
|
||||
%{_bindir}/iceboxnet.exe
|
||||
%{_mandir}/man1/iceboxnet.exe.1.gz
|
||||
%{_mandir}/man1/iceboxnet.1*
|
||||
|
||||
%files -n mono-Ice-devel
|
||||
%defattr(-,root,root)
|
||||
@ -453,122 +351,89 @@ cp -p %{_builddir}/Ice-3.3.0-man-pages/*.1 %{buildroot}%{_mandir}/man1
|
||||
%{_libdir}/pkgconfig/IceGrid.pc
|
||||
%{_libdir}/pkgconfig/IcePatch2.pc
|
||||
%{_libdir}/pkgconfig/IceStorm.pc
|
||||
%{_mandir}/man1/slice2cs.1.gz
|
||||
%{_mandir}/man1/slice2cs.1*
|
||||
|
||||
%post -n icegrid-gui
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
||||
fi
|
||||
|
||||
%postun -n icegrid-gui
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
||||
fi
|
||||
|
||||
%files -n icegrid-gui
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/Ice-%{version}/IceGridGUI.jar
|
||||
%attr(755,root,root) %{_bindir}/icegridgui
|
||||
%{_datadir}/applications/*
|
||||
%{_datadir}/icons/hicolor/48x48/apps/icegrid.png
|
||||
%{_datadir}/pixmaps/icegrid.png
|
||||
%doc %{_defaultdocdir}/Ice-%{version}/IceGridAdmin
|
||||
%{_mandir}/man1/icegridgui.1.gz
|
||||
#%files -n icegrid-gui
|
||||
#%defattr(-,root,root)
|
||||
#%{_datadir}/Ice-%{version}/IceGridGUI.jar
|
||||
#%attr(755,root,root) %{_bindir}/icegridgui
|
||||
#%{_datadir}/applications/*
|
||||
#%{_datadir}/icons/hicolor/48x48/apps/icegrid.png
|
||||
#%{_datadir}/pixmaps/icegrid.png
|
||||
#%doc %{_defaultdocdir}/Ice-%{version}/IceGridAdmin
|
||||
#%{_mandir}/man1/icegridgui.1*
|
||||
|
||||
%files -n java-Ice
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/slice2java
|
||||
%{_bindir}/slice2freezej
|
||||
%{_javadir}/Ice-%{version}.jar
|
||||
%{_javadir}/Ice.jar
|
||||
%{_javadir}/ant-ice-%{version}.jar
|
||||
%{_javadir}/ant-ice.jar
|
||||
%{_javadir}/Freeze-%{version}.jar
|
||||
%{_javadir}/Freeze.jar
|
||||
%{_mandir}/man1/slice2freezej.1.gz
|
||||
%{_mandir}/man1/slice2java.1.gz
|
||||
%{_javadir}/ice-%{version}.jar
|
||||
#%{_javadir}/ice.jar
|
||||
#%{_javadir}/ant-ice-%{version}.jar
|
||||
#%{_javadir}/ant-ice.jar
|
||||
%{_javadir}/freeze-%{version}.jar
|
||||
#%{_javadir}/freeze.jar
|
||||
%{_mandir}/man1/slice2freezej.1*
|
||||
%{_mandir}/man1/slice2java.1*
|
||||
|
||||
%files -n php-Ice
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/slice2php
|
||||
%config(noreplace) %{_sysconfdir}/php/ice.ini
|
||||
#%config(noreplace) %{_sysconfdir}/php/ice.ini
|
||||
%{php_extensiondir}/IcePHP.so
|
||||
%{_libdir}/php/Glacier2.php
|
||||
%{_libdir}/php/Ice.php
|
||||
%{_libdir}/php/IceBox.php
|
||||
%{_libdir}/php/IceGrid.php
|
||||
%{_libdir}/php/IcePatch2.php
|
||||
%{_libdir}/php/IceStorm.php
|
||||
%dir %{_libdir}/php/Glacier2
|
||||
%{_libdir}/php/Glacier2/*.php
|
||||
%dir %{_libdir}/php/Ice
|
||||
%{_libdir}/php/Ice/*.php
|
||||
%dir %{_libdir}/php/IceBox
|
||||
%{_libdir}/php/IceBox/*.php
|
||||
%dir %{_libdir}/php/IceGrid
|
||||
%{_libdir}/php/IceGrid/*.php
|
||||
%dir %{_libdir}/php/IcePatch2
|
||||
%{_libdir}/php/IcePatch2/*.php
|
||||
%dir %{_libdir}/php/IceStorm
|
||||
%{_libdir}/php/IceStorm/*.php
|
||||
%{_datadir}/php/Glacier2.php
|
||||
%{_datadir}/php/Ice.php
|
||||
%{_datadir}/php/IceBox.php
|
||||
%{_datadir}/php/IceGrid.php
|
||||
%{_datadir}/php/IcePatch2.php
|
||||
%{_datadir}/php/IceStorm.php
|
||||
%dir %{_datadir}/php/Glacier2
|
||||
%{_datadir}/php/Glacier2/*.php
|
||||
%dir %{_datadir}/php/Ice
|
||||
%{_datadir}/php/Ice/*.php
|
||||
%dir %{_datadir}/php/IceBox
|
||||
%{_datadir}/php/IceBox/*.php
|
||||
%dir %{_datadir}/php/IceGrid
|
||||
%{_datadir}/php/IceGrid/*.php
|
||||
%dir %{_datadir}/php/IcePatch2
|
||||
%{_datadir}/php/IcePatch2/*.php
|
||||
%dir %{_datadir}/php/IceStorm
|
||||
%{_datadir}/php/IceStorm/*.php
|
||||
|
||||
%files -n python-Ice
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/slice2py
|
||||
%{python_sitearch}/Ice/
|
||||
%{python_sitearch}/ice.pth
|
||||
%{_mandir}/man1/slice2py.1.gz
|
||||
%{python3_sitelib}/*
|
||||
%{_mandir}/man1/slice2py.1*
|
||||
|
||||
%files -n ruby-Ice
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/slice2rb
|
||||
#%{_bindir}/slice2rb
|
||||
%{ruby_sitearchdir}/*
|
||||
%{_mandir}/man1/slice2rb.1.gz
|
||||
#%{_mandir}/man1/slice2rb.1*
|
||||
|
||||
%pre servers
|
||||
getent group iceuser > /dev/null || /usr/sbin/groupadd -r iceuser
|
||||
getent passwd iceuser > /dev/null || \
|
||||
/usr/sbin/groupadd -r -g iceuser -d %{_localstatedir}/lib/icegrid \
|
||||
-s /sbin/nologin -c "IceGrid server user" iceuser
|
||||
exit 0
|
||||
|
||||
%post servers
|
||||
/sbin/chkconfig --add icegridregistry
|
||||
/sbin/chkconfig --add icegridnode
|
||||
/sbin/chkconfig --add glacier2router
|
||||
|
||||
%preun servers
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/service icegridregistry stop >/dev/null 2>&1 || :
|
||||
/sbin/chkconfig --del icegridregistry
|
||||
/sbin/service icegridnode stop >/dev/null 2>&1 || :
|
||||
/sbin/chkconfig --del icegridnode
|
||||
/sbin/service glacier2router stop >/dev/null 2>&1 || :
|
||||
/sbin/chkconfig --del glacier2router
|
||||
fi
|
||||
|
||||
%postun servers
|
||||
if [ "$1" -ge "1" ]; then
|
||||
/sbin/service icegridregistry condrestart >/dev/null 2>&1 || :
|
||||
/sbin/service icegridnode condrestart >/dev/null 2>&1 || :
|
||||
/sbin/service glacier2router condrestart >/dev/null 2>&1 || :
|
||||
fi
|
||||
|
||||
%files servers
|
||||
%defattr(-,root,root)
|
||||
%{_initrddir}/icegridregistry
|
||||
%{_initrddir}/icegridnode
|
||||
%{_initrddir}/glacier2router
|
||||
%config(noreplace) %{_sysconfdir}/icegridregistry.conf
|
||||
%config(noreplace) %{_sysconfdir}/icegridnode.conf
|
||||
%config(noreplace) %{_sysconfdir}/glacier2router.conf
|
||||
%attr(0775,root,iceuser) %dir %{_localstatedir}/lib/icegrid
|
||||
%attr(0775,root,iceuser) %dir %{_localstatedir}/lib/ice/icegrid/node1
|
||||
%attr(0775,root,iceuser) %dir %{_localstatedir}/lib/ice/icegrid/registry
|
||||
#%files servers
|
||||
#%defattr(-,root,root)
|
||||
#%{_initrddir}/icegridregistry
|
||||
#%{_initrddir}/icegridnode
|
||||
#%{_initrddir}/glacier2router
|
||||
#%config(noreplace) %{_sysconfdir}/icegridregistry.conf
|
||||
#%config(noreplace) %{_sysconfdir}/icegridnode.conf
|
||||
#%config(noreplace) %{_sysconfdir}/glacier2router.conf
|
||||
#%attr(0775,root,iceuser) %dir %{_localstatedir}/lib/icegrid
|
||||
#%attr(0775,root,iceuser) %dir %{_localstatedir}/lib/ice/icegrid/node1
|
||||
#%attr(0775,root,iceuser) %dir %{_localstatedir}/lib/ice/icegrid/registry
|
||||
|
||||
%changelog
|
||||
* Sun Aug 04 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.5-1mamba
|
||||
- update to 3.6.5
|
||||
|
||||
* Wed Jun 12 2013 Automatic Build System <autodist@mambasoft.it> 3.5.0-1mamba
|
||||
- update to 3.5.0
|
||||
|
||||
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 3.4.2-1mamba
|
||||
- update to 3.4.2
|
||||
|
||||
* Sun Aug 14 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.0-3mamba
|
||||
- replace java-bdb requirement with java-bdb48 and add make include flag
|
||||
|
||||
@ -576,4 +441,4 @@ fi
|
||||
- rebuilt devel
|
||||
|
||||
* Sun Jun 20 2010 gil <puntogil@libero.it> 3.4.0-1mamba
|
||||
- First build
|
||||
- First build
|
||||
|
@ -1,8 +1,6 @@
|
||||
# Ice
|
||||
|
||||
The Internet Communications Engine (Ice) is a modern object-oriented middleware with support for C++, .NET, Java, Python, Objective-C, Ruby, and PHP. Ice is used in many mission-critical projects by companies all over the world.
|
||||
|
||||
Ice is easy to learn, yet provides a powerful network infrastructure and vast array of features for demanding technical applications.
|
||||
|
||||
Ice is free software, available with full source, and released under the terms of GNU General Public License (GPL). Commercial licenses are available for customers who wish to use Ice for closed-source software.
|
||||
|
||||
|
Reference in New Issue
Block a user