190 lines
6.0 KiB
RPMSpec
190 lines
6.0 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
Name: FlightGear
|
|
Version: 2016.1.1
|
|
Release: 1mamba
|
|
Summary: Flight Simulator
|
|
Group: Graphical Desktop/Applications/Games
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.flightgear.org/
|
|
Source0: http://heanet.dl.sourceforge.net/project/flightgear/release-%{majver}/flightgear-%{version}.tar.bz2
|
|
#Source0: http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/flightgear-%{version}.tar.bz2
|
|
Source1: http://netcologne.dl.sourceforge.net/project/flightgear/release-%{majver}/FlightGear-%{version}-data.tar.bz2
|
|
#Source1: http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/%{name}-data-%{majver}.0.tar.bz2
|
|
Source2: flight.png
|
|
Patch0: FlightGear-3.4.0-fgviewer-find-lX11.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: OpenSceneGraph
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libGL-devel
|
|
BuildRequires: libGLU-devel
|
|
BuildRequires: libICE-devel
|
|
BuildRequires: libSM-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXext-devel
|
|
BuildRequires: libXft-devel
|
|
BuildRequires: libXi-devel
|
|
BuildRequires: libXinerama-devel
|
|
BuildRequires: libXmu-devel
|
|
BuildRequires: libbzip2-devel
|
|
BuildRequires: libdbus-devel
|
|
BuildRequires: libfltk-devel
|
|
BuildRequires: libfreeglut-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libgsm-devel
|
|
BuildRequires: libopenal-devel
|
|
BuildRequires: libplib-devel
|
|
BuildRequires: libpng-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libspeex-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libudev-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libSimGear-devel >= %{version}
|
|
BuildRequires: libfltk-devel >= 1.3.3-2mamba
|
|
BuildRequires: OpenSceneGraph >= 3.4.0
|
|
Requires: %{name}-data
|
|
Requires: alsa-oss
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
The FlightGear flight simulator project is an open-source, multi-platform, cooperative flight simulator development project.
|
|
|
|
%package data
|
|
Group: Graphical Desktop/Applications/Games
|
|
Summary: Maps for %{name}
|
|
|
|
%description data
|
|
The FlightGear flight simulator project is an open-source, multi-platform, cooperative flight simulator development project.
|
|
This package contains maps and scenary for FlightGear.
|
|
|
|
%prep
|
|
%setup -q -a1 -n flightgear-%{version}
|
|
#% setup -q -n flightgear-%{version} -D -T
|
|
#:<< _EOF
|
|
#%patch0 -p1
|
|
|
|
%build
|
|
#:<< _EOF
|
|
%cmake -d build \
|
|
-DCMAKE_EXE_LINKER_FLAGS="-lX11"
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%makeinstall -C build
|
|
|
|
install -d 644 %{buildroot}%{_libdir}/%{name}
|
|
cp -r fgdata/* %{buildroot}%{_libdir}/%{name}
|
|
|
|
#install -D -m0755 ./build/src/Canvas/ShivaVG/src/libShivaVG.so %{buildroot}%{_libdir}/libShivaVG.so
|
|
install -D -m0755 ./build/utils/fgadmin/src/libFGAdminUI.so %{buildroot}%{_libdir}/libFGAdminUI.so
|
|
install -D -m0755 ./build/3rdparty/sqlite3/libfgsqlite3.so %{buildroot}%{_libdir}/libfgsqlite3.so
|
|
install -D -m0755 ./build/src/GUI/libfglauncher.so %{buildroot}%{_libdir}/libfglauncher.so
|
|
|
|
# fix wrong permissions
|
|
find %{buildroot}%{_libdir}/%{name} \
|
|
-type d -exec chmod 755 {} \;
|
|
|
|
#Icon
|
|
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
|
install -D -m 644 %{SOURCE2} %{buildroot}%{_datadir}/pixmaps/flight.png
|
|
|
|
# Create the system menu entry
|
|
mkdir -p %{buildroot}%{_datadir}/applications
|
|
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
|
[Desktop Entry]
|
|
Name=%{name}
|
|
GenericName=Flight Simulator
|
|
GenericName[it]=Simulatore di volo in 3D
|
|
Comment=Flight Simulator
|
|
Exec=fgfs
|
|
Icon=%{_datadir}/pixmaps/flight.png
|
|
Terminal=0
|
|
Type=Application
|
|
X-KDE-StartupNotify=false
|
|
Categories=Game;Simulation;
|
|
EOF
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/*
|
|
%{_libdir}/libFGAdminUI.so
|
|
%{_libdir}/libfgsqlite3.so
|
|
%{_libdir}/libfglauncher.so
|
|
%{_datadir}/applications/FlightGear.desktop
|
|
%{_datadir}/pixmaps/flight.png
|
|
#%dir %{_datadir}/flightgear
|
|
#%{_datadir}/flightgear/positions.txt
|
|
#%{_datadir}/flightgear/special_frequencies.txt
|
|
%{_mandir}/man1/*
|
|
%doc AUTHORS COPYING
|
|
#ChangeLog NEWS README
|
|
|
|
%files data
|
|
%defattr(-,root,root)
|
|
%dir %{_libdir}/%{name}
|
|
%{_libdir}/%{name}/*
|
|
|
|
%changelog
|
|
* Fri Mar 04 2016 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2016.1.1-1mamba
|
|
- update to 2016.1.1
|
|
|
|
* Sat Feb 13 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.0-2mamba
|
|
- install libfglauncher.so
|
|
|
|
* Sat Mar 21 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.0-1mamba
|
|
- update to 3.4.0
|
|
|
|
* Tue Mar 25 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.0-1mamba
|
|
- update to 3.0.0
|
|
|
|
* Fri May 24 2013 openmamba WebBuild System <webbuild@openmamba.org> 2.10.0-2mamba
|
|
- Rebuild with new libstdc++
|
|
|
|
* Tue Apr 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.0-1mamba
|
|
- update to 2.10.0
|
|
|
|
* Tue Apr 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.0-2mamba
|
|
- rebuilt with OpenScenGraph 3.1.5 and libSimGear 2.10
|
|
|
|
* Mon Dec 03 2012 Automatic Build System <autodist@mambasoft.it> 2.8.0-1mamba
|
|
- update to 2.8.0
|
|
|
|
* Thu Jun 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1mamba
|
|
- update to 2.0.0
|
|
|
|
* Sat May 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-4mamba
|
|
- rebuilt with OpenSceneGraph 2.9.4
|
|
|
|
* Sat Apr 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Fri Apr 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Mar 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-1mamba
|
|
- update to 1.9.1
|
|
|
|
* Thu Jan 22 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Tue Jan 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-1mamba
|
|
- update to 1.9.0
|
|
|
|
* Mon Jan 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.0-1mamba
|
|
- update to 1.0.0
|
|
|
|
* Tue Sep 06 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.9.8-2qilnx
|
|
- rebuild and moved from devel-contrib repository to devel repository
|
|
|
|
* Sat Sep 03 2005 Tiziano Pratellesi <tiziano.pratellesi@email.it> 0.9.8-1qilnx
|
|
- package created by autospec
|