automatic version update by autodist [release 2.2.12-1mamba;Mon Jun 17 2013]

This commit is contained in:
Automatic Build System 2024-01-05 17:42:46 +01:00
parent 66e4fea85e
commit 843d4f5e3a
4 changed files with 179 additions and 0 deletions

View File

@ -0,0 +1,22 @@
$NetBSD$
--- libAfterImage/import.c.orig 2010-09-23 20:57:57.000000000 +0000
+++ libAfterImage/import.c
@@ -1251,7 +1251,7 @@ png2ASImage_int( void *data, png_rw_ptr
* the normal method of doing things with libpng). REQUIRED unless you
* set up your own error handlers in the png_create_read_struct() earlier.
*/
- if ( !setjmp (png_ptr->jmpbuf))
+ if ( !setjmp (png_jmpbuf(png_ptr)))
{
ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
@@ -1468,7 +1468,7 @@ typedef struct ASImPNGReadBuffer
static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
{
- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
+ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
memcpy(data, buf->buffer, length);
buf->buffer += length;
}

View File

@ -0,0 +1,15 @@
$NetBSD$
Fix build with png-1.5.
--- libAfterImage/export.c.orig 2010-09-23 20:52:15.000000000 +0000
+++ libAfterImage/export.c
@@ -496,7 +496,7 @@ ASImage2png_int ( ASImage *im, void *dat
png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
if ( png_ptr != NULL )
if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
- if( setjmp(png_ptr->jmpbuf) )
+ if( setjmp(png_jmpbuf(png_ptr)) )
{
png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
info_ptr = NULL ;

140
AfterStep.spec Normal file
View File

@ -0,0 +1,140 @@
Name: AfterStep
Version: 2.2.12
Release: 1mamba
Summary: AfterStep is a window manager for the Unix X Window System
Group: Graphical Desktop/Applications/Environment
Vendor: openmamba
Distribution: openmamba
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
URL: http://www.afterstep.org
Source: ftp://ftp.afterstep.org/stable/AfterStep-%{version}.tar.bz2
Patch1: AfterStep-2.2.11-libpng-1.5-1.patch
Patch2: AfterStep-2.2.11-libpng-1.5-2.patch
License: GPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libglib-devel
BuildRequires: libgtk-devel
BuildRequires: libICE-devel
BuildRequires: libjpeg-devel
BuildRequires: libpango-devel
BuildRequires: libpng-devel
BuildRequires: librsvg-devel
BuildRequires: libSM-devel
BuildRequires: libtiff-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libz-devel
BuildRequires: perl
## AUTOBUILDREQ-END
%description
AfterStep is a window manager for the Unix X Window System. Originally based on the look and feel of the NeXTStep interface, it provides end users with a consistent, clean, and elegant desktop. The goal of AfterStep development is to provide for flexibility of desktop configuration, improving aestetics, and efficient use of system resources.
%package devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Development files for %{name}.
%prep
%setup -q -n afterstep-devel-%{version}
#%patch1 -p0
#%patch2 -p0
%build
./configure \
--prefix=%{_prefix} \
--mandir=%{_mandir}
%make -j1
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/ascheckttf
%{_bindir}/ASFileBrowser
%{_bindir}/ASMount
%{_bindir}/ASRun
%{_bindir}/ASWallpaper
%{_bindir}/Animate
%{_bindir}/Arrange
%{_bindir}/Banner
%{_bindir}/GWCommand
%{_bindir}/Ident
%{_bindir}/MonitorWharf
%{_bindir}/Pager
%{_bindir}/PrintDesktopEntries
%{_bindir}/Wharf
%{_bindir}/WinCommand
%{_bindir}/WinList
%{_bindir}/WinTabs
%{_bindir}/Xpm2Jpg
%{_bindir}/afterimage-libs
%{_bindir}/afterstep
%{_bindir}/afterstepdoc
%{_bindir}/ascolor
%{_bindir}/ascommand.pl
%{_bindir}/ascompose
%{_bindir}/asflip
%{_bindir}/asgrad
%{_bindir}/asgtk-config
%{_bindir}/asi18n
%{_bindir}/asmerge
%{_bindir}/asscale
%{_bindir}/astext
%{_bindir}/astile
%{_bindir}/asvector
%{_bindir}/asview
%{_bindir}/importasmenu
%{_bindir}/installastheme.pl
%{_bindir}/makeastheme.pl
%{_bindir}/postcard.sh
%dir %{_datadir}/afterstep
%{_datadir}/afterstep/*
%{_datadir}/man/man1/*.1x*
%{_datadir}/man/man3/*.3x*
#%{_datadir}/xsessions/AfterStep.desktop
%files devel
%defattr(-,root,root)
%{_bindir}/afterimage-config
%{_bindir}/afterstep-config
%dir %{_includedir}/libASGTK
%{_includedir}/libASGTK/asgtk*.h
%dir %{_includedir}/libAfterBase
%{_includedir}/libAfterBase/*.h
%dir %{_includedir}/libAfterConf
%{_includedir}/libAfterConf/afterconf.h
%dir %{_includedir}/libAfterImage
%{_includedir}/libAfterImage/*.h
%dir %{_includedir}/libAfterStep
%{_includedir}/libAfterStep/*.h
%{_libdir}/libASGTK.a
%{_libdir}/libAfterBase.a
%{_libdir}/libAfterConf.a
%{_libdir}/libAfterImage.a
%{_libdir}/libAfterStep.a
%changelog
* Mon Jun 17 2013 Automatic Build System <autodist@mambasoft.it> 2.2.12-1mamba
- automatic version update by autodist
* Mon Mar 18 2013 Automatic Build System <autodist@mambasoft.it> 2.2.11-1mamba
- automatic version update by autodist
* Tue Oct 28 2008 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.2.8-1mamba
- package created by autospec

View File

@ -1,2 +1,4 @@
# AfterStep
AfterStep is a window manager for the Unix X Window System. Originally based on the look and feel of the NeXTStep interface, it provides end users with a consistent, clean, and elegant desktop. The goal of AfterStep development is to provide for flexibility of desktop configuration, improving aestetics, and efficient use of system resources.