rebuilt with libpng 1.4 [release 1.0.2001.11.16-3mamba;Thu Dec 16 2010]

This commit is contained in:
Silvan Calarco 2024-01-05 17:42:38 +01:00
parent 1dc952b57e
commit 961060d02b
5 changed files with 110 additions and 0 deletions

26
54321-1.0-SDL.patch Normal file
View File

@ -0,0 +1,26 @@
diff -purN 54321.orig/archs/Linux/variables.GNU 54321/archs/Linux/variables.GNU
--- 54321.orig/archs/Linux/variables.GNU 2001-11-08 16:54:01.000000000 +0100
+++ 54321/archs/Linux/variables.GNU 2005-08-23 11:44:30.000000000 +0200
@@ -5,8 +5,8 @@ STRIP := strip
MKDIR_CMD = test -d $(@D) || mkdir -p $(@D)
############################################################
-SDL := /usr/local
-SDL_IMAGE := /usr/local
+SDL := /usr
+SDL_IMAGE := /usr
CPPFLAGS += -I${SDL}/include/SDL -I${SDL_IMAGE}/include/SDL
LDFLAGS += \
diff -purN 54321.orig/code/main.cpp 54321/code/main.cpp
--- 54321.orig/code/main.cpp 2001-11-16 05:14:04.000000000 +0100
+++ 54321/code/main.cpp 2005-08-23 11:45:50.000000000 +0200
@@ -29,7 +29,7 @@
#include "life.h"
#include "lifeController.h"
extern "C" int
- SDL_main( int argc, char** argv )
+ main( int argc, char** argv )
{
unsigned int initFlags = 0;
initFlags |= SDL_INIT_VIDEO;

13
54321-desktop Normal file
View File

@ -0,0 +1,13 @@
[Desktop Entry]
Exec=/usr/bin/54321
Name=54321
GenericNamePuzzle game
GenericName[it]=Gioco a puzzle
Icon=tux
Terminal=false
Type=Application
Comment=Puzzle game
Comment[it]=Gioco a puzzle
Encoding=UTF-8
Categories=KDE;Game;LogicGame;

3
54321-exec Normal file
View File

@ -0,0 +1,3 @@
#!/bin/bash
cd /usr/share/games/54321 && ./54321-Linux -window

66
54321.spec Normal file
View File

@ -0,0 +1,66 @@
Name: 54321
Version: 1.0.2001.11.16
Release: 3mamba
Summary: 54321 is five games in four-, three-, or two-dimensions for one player.
Group: Graphical Desktop/Applications/Educational
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.nklein.com/products/54321/
Source0: http://www.nklein.com/products/54321/1.0.2001.11.16/%{name}.tgz
Source1: %{name}-exec
Source2: %{name}-desktop
Patch0: %{name}-1.0-SDL.patch
License: Freeware
BuildRequires: libSDL-devel >= 1.2.8
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
54321 is five games in four-, three-, or two-dimensions for one player. 54321 takes five classic two-dimensional puzzle games and extends them into three and four dimensions.
%prep
%setup -q -n %{name}
%patch0 -p1
%build
%make -f GNUmakefile CXXFLAGS="%{optflags} -DNDEBUG=1"
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
install -d %{buildroot}%{_datadir}/games/%{name}
cp -r Release/* %{buildroot}%{_datadir}/games/%{name}
install -d %{buildroot}%{_bindir}
install -m755 -D %{SOURCE1} %{buildroot}%{_bindir}/%{name}
install -d %{buildroot}%{_datadir}/applications
install -m755 -D %{SOURCE2} %{buildroot}%{_datadir}/applications/%{name}.desktop
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%dir %{_datadir}/games/%{name}
%{_datadir}/games/%{name}/*
%doc README
%changelog
* Thu Dec 16 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2001.11.16-3mamba
- rebuilt with libpng 1.4
* Tue Apr 06 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2001.11.16-2mamba
- updated maintainer
* Mon Sep 29 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2001.11.16-1mamba
- automatic update by autodist
* Thu May 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0-3mamba
- rebuilt
* Tue Aug 23 2005 Massimo Pintore <massimo.pintore@qilinux.it> 1.0-2qilnx
- License field corrected
* Mon Aug 22 2005 Massimo Pintore <massimo.pintore@qilinux.it> 1.0-1qilnx
- package created by autospec

View File

@ -1,2 +1,4 @@
# 54321 # 54321
54321 is five games in four-, three-, or two-dimensions for one player. 54321 takes five classic two-dimensional puzzle games and extends them into three and four dimensions.